Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
LXDE - Lightweight X11 Desktop Environment (Live Ebuilds)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Wed Sep 03, 2008 9:37 am    Post subject: Reply with quote

duckz wrote:
Now I am confused, which layman should user use?


There's only one layman, but there are many overlays, and at present there are lxde ebuilds in several (gentoo-taiwan, zen-overlay and the new lxde overlay). What you want to do is install layman if you don\'t already have it installed (emerge -a layman).

Then grab a list of the available overlays. Given there is now a dedicated lxde overlay thanks to yngwin you\'d be best to go with that so as above...

Code:

layman -a lxde


...to add the lxde overlay, you then need to copy the contents of /usr/portage/local/layman/lxde/Documentation/portage/package.keywords/lxde.svn to your /etc/portage/packge.keywords...

Code:

cat /usr/portage/local/layman/lxde/Documentation/portage/package.keywords/lxde.svn >> /etc/portage/package.keywords


and your set to emerge.

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth


Last edited by slackline on Sun Sep 07, 2008 9:54 am; edited 1 time in total
Back to top
View user's profile Send private message
duckz
Apprentice
Apprentice


Joined: 26 Jun 2007
Posts: 158

PostPosted: Wed Sep 03, 2008 10:29 am    Post subject: Reply with quote

I got it installed from lxde layman.

I got it by:

Code:
 emerge mercurial
emerge layman
echo source /usr/local/portage/layman/make.conf >> /etc/make.conf
layman -f
layman -a lxde
cat /usr/local/portage/layman/lxde/Documentation/portage/package.keywords/lxde.svn >> /etc/portage/package.keywords
for z in `cat /usr/local/portage/layman/lxde/sets/lxde-full` ; do emerge "$z"; done


cheers!
_________________
emerge -va techygadget.com <- install my blog in gentoo
./configure anime wallpaper
make install premium drupal theme
Back to top
View user's profile Send private message
duckz
Apprentice
Apprentice


Joined: 26 Jun 2007
Posts: 158

PostPosted: Wed Sep 03, 2008 10:44 am    Post subject: Reply with quote

I think LXDE deserve a page in the gentoo wiki, any brave soul with enough time to spare wiling to create them?
_________________
emerge -va techygadget.com <- install my blog in gentoo
./configure anime wallpaper
make install premium drupal theme
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Wed Sep 03, 2008 12:52 pm    Post subject: Reply with quote

[quote=\"yngwin\"]you can pull in the packages with emerge -av @lxde-full or emerge -av @lxde-lite for the light variant.[/quote]

Portage doesn\'t seem to be picking up the sets defined in the overlay...
Code:

# eix -e sys-apps/portage
[I] sys-apps/portage
     Available versions:  [P]2.0.51.22-r3 [P]2.1.1-r2 2.1.4.4 (~)2.1.5.6 (~)2.2_rc8 {build doc elibc
_FreeBSD elibc_glibc elibc_uclibc epydoc linguas_pl selinux userland_GNU}
     Installed versions:  2.2_rc8(08:00:12 08/13/08)(-build -doc -epydoc -linguas_pl -selinux)
     Homepage:            http://www.gentoo.org/proj/en/portage/index.xml
     Description:         Portage is the package management and distribution system for Gentoo

fisher neil # emerge -av @lxde-full
emerge: There are no sets to satisfy \'lxde-full\'. The following sets exist:

    downgrade
    installed
    live-rebuild
    module-rebuild
    preserved-rebuild
    security
    system
    world


Tried looking up how to get sets recognised in the developers handbook, but it seems it no longer exists (http://devmanual.gentoo.org/)

How do I get the two lxde sets recognised by portage?

Cheers

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Wed Sep 03, 2008 2:56 pm    Post subject: Reply with quote

they dont work for me either... im new to set support so I cant fix it atm, but Ijust wanted to confirm that the lxde sets are not working
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Wed Sep 03, 2008 2:57 pm    Post subject: Reply with quote

for all those who are trying out lxde, the network tools for lxde are all works in progress and incomplete. wicd complements lxde nicely if u are looking for a networkmanager like tool
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Wed Sep 03, 2008 4:57 pm    Post subject: Reply with quote

Hmm, strange that the sets don't work for you. Thinking about what might be possible differences between our setups: I have my overlays defined in /etc/make.conf, and let layman edit that. So you might want to try adding the overlay to PORTDIR_OVERLAY in /etc/make.conf instead of in layman's configuration.

Alternatively, you could make a directory /etc/portage/sets/ and symlink the set files from the overlay. (Symlinking would be better tham copying, as I'm still tweaking the sets, so they might be changed.)
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Wed Sep 03, 2008 6:53 pm    Post subject: Reply with quote

My /etc/make.conf look like...

/etc/make.conf:

## Local overlays
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/hugin"

## Layman
source /usr/portage/local/layman/make.conf


and

/usr/portage/local/layman/make.conf:

PORTDIR_OVERLAY="
/usr/local/portage/layman/perl-experimental
/usr/local/portage/layman/science
/usr/local/portage/layman/sunrise
/usr/local/portage/layman/lxde
$PORTDIR_OVERLAY
"


...but its not being picked up since...

emerge --info | grep OVERLAY:

# emerge --info | grep OVERLAY
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/lxde'
PORTDIR_OVERLAY="/usr/portage/local/layman/perl-experimental /usr/portage/local/layman/science /usr/portage/local/layman/sunrise /usr/local/portage /usr/portage/local/hugin"



...which is strange, and this is even stranger...

Code:

# layman -d lxde
* Successfully deleted overlay "lxde".
fisher ~ # layman -a lxde
* Running command "/usr/bin/hg clone "http://bitbucket.org/yngwin/lxde-overlay//" "/usr/local/portage/layman/lxde""...
requesting all changes
adding changesets
adding manifests
adding file changes
added 13 changesets with 127 changes to 101 files
updating working directory
50 files updated, 0 files merged, 0 files removed, 0 files unresolved
* Successfully added overlay "lxde".
fisher ~ # ls -l /usr/portage/local/layman/
total 63
-rw-r--r--  1 portage portage 50244 Mar 25 13:15 cache_65bd38402ac8431067b54904bd2ed2d1.xml
-rw-r--r--  1 portage portage   300 Mar 25 13:15 cache_75abb983c9988e297fe74639cccf9f52.xml
drwxr-xr-x 22 portage portage  1024 Sep 30  2007 java-experimental
-rw-r--r--  1 portage portage   180 Sep  3 18:10 make.conf
-rw-r--r--  1 portage portage   149 Apr  9 07:21 make.conf~
-rw-r--r--  1 portage portage  1668 Apr  9 07:21 overlays.xml
drwxr-xr-x  7 portage portage  1024 Jun 22 11:51 perl-experimental
drwxr-xr-x 27 portage portage  1024 Apr  9 07:17 science
drwxr-xr-x 98 portage portage  4096 Apr  9 07:19 sunrise


It appears that the overlay isn't actually being downloaded properly by mercurial (at least here it isn't).

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Wed Sep 03, 2008 11:12 pm    Post subject: Reply with quote

That is really strange, because it works fine here:
Code:
hummingbird ~ # layman -a lxde
* Running command "/usr/bin/hg clone "http://bitbucket.org/yngwin/lxde-overlay//" "/var/repos/lxde""...
requesting all changes
adding changesets
adding manifests
adding file changes
added 13 changesets with 127 changes to 101 files
updating working directory
50 files updated, 0 files merged, 0 files removed, 0 files unresolved
* Successfully added overlay "lxde".
hummingbird ~ # ll /var/repos
total 9
drwxrwxr-x   5 ben  portage   5 2008-09-04 01:06 .
drwxr-xr-x  15 root root     18 2008-06-11 14:16 ..
drwxrwxr-x  19 ben  portage  19 2008-09-03 04:02 local
drwxr-xr-x  11 root root     13 2008-09-04 01:06 lxde
drwxrwxr-x 106 ben  portage 109 2008-09-03 13:31 sunrise
hummingbird ~ # ll /var/repos/lxde 
total 8
drwxr-xr-x 11 root root     13 2008-09-04 01:06 .
drwxrwxr-x  5 ben  portage   5 2008-09-04 01:06 ..
drwxr-xr-x  3 root root      3 2008-09-04 01:06 Documentation
drwxr-xr-x  3 root root     11 2008-09-04 01:06 .hg
drwxr-xr-x 15 root root     15 2008-09-04 01:06 lxde-base
-rw-r--r--  1 root root      0 2008-09-04 01:06 manifest1_obsolete
drwxr-xr-x  3 root root      3 2008-09-04 01:06 media-gfx
drwxr-xr-x  3 root root      3 2008-09-04 01:06 net-analyzer
drwxr-xr-x  2 root root      4 2008-09-04 01:06 profiles
drwxr-xr-x  2 root root      4 2008-09-04 01:06 sets
-rw-r--r--  1 root root    106 2008-09-04 01:06 sets.conf
drwxr-xr-x  3 root root      3 2008-09-04 01:06 virtual
drwxr-xr-x  3 root root      3 2008-09-04 01:06 x11-misc

(ll being my alias for ls -al)
Which version of layman are you using? Or could it be a permissions thing?
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1311
Location: Netherlands

PostPosted: Thu Sep 04, 2008 12:43 am    Post subject: Reply with quote

slack---line wrote:
My /etc/make.conf look like...

/etc/make.conf:

## Local overlays
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/hugin"

## Layman
source /usr/portage/local/layman/make.conf


and

/usr/portage/local/layman/make.conf:

PORTDIR_OVERLAY="
/usr/local/portage/layman/perl-experimental
/usr/local/portage/layman/science
/usr/local/portage/layman/sunrise
/usr/local/portage/layman/lxde
$PORTDIR_OVERLAY
"


...but its not being picked up since...
[...]

Dude get your paths right - it seems that you mix the path settings from what you picked up in the forums and what your installed layman gives you ;-)

There was a change with layman-1.2.0 from '/usr/portage/local/layman/' to '/usr/local/portage/layman/' ... check which paths are correct ;-)

HTH
swimmer

PS: I apologize in advance if my guess was wront ;-)
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Thu Sep 04, 2008 6:31 am    Post subject: Reply with quote

swimmer wrote:

Dude get your paths right - it seems that you mix the path settings from what you picked up in the forums and what your installed layman gives you ;-)

There was a change with layman-1.2.0 from '/usr/portage/local/layman/' to '/usr/local/portage/layman/' ... check which paths are correct ;-)

HTH
swimmer

PS: I apologize in advance if my guess was wront ;-)


I don't remember ever manually editing /usr/portage/local/layman/make.conf until yesterday when I added the lxde line after adding the overlay and finding it wasn't where I was expecting it.

Must have missed the switch over in layman's locatin, but have modified the layman entry in /etc/make.conf and have emerged the @lxde-full set sucesfully.

Thanks for the work on the ebuilds yngwin, and thanks for pointing out the obvious mistake I'd made swimmer.

Apologies for being a muppet :oops:

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1311
Location: Netherlands

PostPosted: Thu Sep 04, 2008 8:16 am    Post subject: Reply with quote

Good to hear that I was not "wront" and glad to hear that I could be a little help ;-)

Greetz
swimmer
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1311
Location: Netherlands

PostPosted: Thu Sep 04, 2008 8:22 am    Post subject: Reply with quote

And for my own problem I start my own reply ;-)

I got curious yesterday night and started to install the overlay as well and everything went very well until it started to emerge pcmanfm :-/
Code:
checking for HAL... no
configure: error: To use HAL support, you must have developing packages of dbus-glib-1 (>=0.31), hal(>=0.5.0), and hal-storage, or you can use --disable-hal to disable HAL support.

I'm using '-hal' since I didn't need it and don't want it unless really necessary. So it seems that hal is mandatory for pcmanfm?
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Thu Sep 04, 2008 11:13 am    Post subject: Reply with quote

No, I just hadn't tested it with -hal. It's fixed now. :)
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Thu Sep 04, 2008 12:02 pm    Post subject: Reply with quote

swimmer wrote:
And for my own problem I start my own reply ;-)

I got curious yesterday night and started to install the overlay as well and everything went very well until it started to emerge pcmanfm :-/
Code:
checking for HAL... no
configure: error: To use HAL support, you must have developing packages of dbus-glib-1 (>=0.31), hal(>=0.5.0), and hal-storage, or you can use --disable-hal to disable HAL support.

I\'m using \'-hal\' since I didn\'t need it and don\'t want it unless really necessary. So it seems that hal is mandatory for pcmanfm?


Doesn\'t sound like its essential, since the Makefile is suggesting you can disable hal support, potential flag for the ebuild?

Also, although the default WM for LXDE is Openbox, the wiki indicates you can use any window manager, how about having flags to allow users to choose their WM? For example I use fluxbox and would rather use that than install openbox too?

Looking through the overlay I can only find openbox being pulled in by the sets, is it possible to give sets USE-flags? Where can I find more documentation on sets?

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth


Last edited by slackline on Sun Sep 07, 2008 9:54 am; edited 1 time in total
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Thu Sep 04, 2008 12:58 pm    Post subject: Reply with quote

slack---line wrote:
swimmer wrote:
So it seems that hal is mandatory for pcmanfm?

Doesn't sound like its essential, since the Makefile is suggesting you can disable hal support, potential flag for the ebuild?

It already has that flag, the ebuild just had a bug in its implementation. Which is fixed now.

slack---line wrote:
Also, although the default WM for LXDE is Openbox, the wiki indicates you can use any window manager, how about having flags to allow users to choose their WM? For example I use fluxbox and would rather use that than install openbox too?

You don't have to use the sets. LXDE is very modular and therefore flexible. You could just do an emerge -pv @lxde-full and then pick and choose which packages you want. As the project is very young the documentation is on the slim side. I suggest you consult the lxde wiki, which you already found, and the help channel #lxde on irc.oftc.net.

slack---line wrote:
Looking through the overlay I can only find openbox being pulled in by the sets, is it possible to give sets USE-flags? Where can I find more documentation on sets?

In the portage documentation, on my machine: file:///usr/share/doc/portage-2.2_rc8/html/index.html
It says:
Quote:
All atoms from configured file are used to form the set, and currently only simple and versioned atoms are supported (no use conditionals or any-of constructs).

So we cannot (yet) use useflags in sets. But you can even define your own sets in /etc/portage/sets/ if you want to use a set with a different content than what we provide. If you use a different WM, you will have to edit the startup script /etc/xdg/lxsession/LXDE/config.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 642

PostPosted: Sat Sep 06, 2008 1:31 pm    Post subject: Reply with quote

I can't emerge lxde-full, I get
Hawaiian portage # emerge -pv lxde-full

These are the packages that would be merged, in order:

Calculating dependencies \
emerge: there are no ebuilds to satisfy "lxde-full".

I've done this
cat /usr/local/portage/layman/lxde/Documentation/portage/package.keywords/lxde-svn >> /etc/portage/package.keywords

my layman is in /usr/local/portage
Hawaiian portage # ls /usr/local/portage/layman
cache_65bd38402ac8431067b54904bd2ed2d1.xml lxde make.conf overlays.xml

my /etc/make.conf contains
source /usr/local/portage/layman/make.conf
PORTDIR_OVERLAY="/usr/local/portage/layman"

I'm out of ideas, anyone?
Jim
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Sat Sep 06, 2008 1:52 pm    Post subject: Reply with quote

u need to make a symlink like this ln -s /usr/local/portage/lxde-overlay/Documentation/portage/sets/lxde-full /etc/portage/sets/lxde-full
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Sat Sep 06, 2008 2:01 pm    Post subject: Reply with quote

No, you should not link the sets to your local /etc/portage/sets. The sets are automatically made available to portage because of the sets.conf in the overlay's root. You should make sure you have the latest portage (at this moment version 2.2_rc8) and use the @ sign in front of the set name: emerge -av @lxde-full
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 642

PostPosted: Sat Sep 06, 2008 2:03 pm    Post subject: Reply with quote

I had to alter the paths a bit to make your command valid, but it still doesn't work.Hawaiian ja # ln -s /usr/local/portage/layman/lxde/sets/lxde-full /etc/portage/sets/lxde-full
Hawaiian ja # emerge -pv lxde-full

These are the packages that would be merged, in order:

Calculating dependencies -
emerge: there are no ebuilds to satisfy "lxde-full".

Hawaiian ja # ls /etc/portage/sets/lxde-full
/etc/portage/sets/lxde-full
Hawaiian ja # ls -l /etc/portage/sets/lxde-full
lrwxrwxrwx 1 root root 45 2008-09-06 15:01 /etc/portage/sets/lxde-full -> /usr/local/portage/layman/lxde/sets/lxde-full
Hawaiian ja # ls /usr/local/portage/layman/lxde/sets/lxde-full
Display all 127 possibilities? (y or n)
Hawaiian ja # ls /usr/local/portage/layman/lxde/sets/lxde-full
/usr/local/portage/layman/lxde/sets/lxde-full
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Sun Sep 07, 2008 10:12 am    Post subject: Reply with quote

BrummieJim wrote:
I had to alter the paths a bit to make your command valid, but it still doesn't work.

Code:
Hawaiian ja # ln -s  /usr/local/portage/layman/lxde/sets/lxde-full /etc/portage/sets/lxde-full
Hawaiian ja # emerge -pv lxde-full

These are the packages that would be merged, in order:

Calculating dependencies -
emerge: there are no ebuilds to satisfy "lxde-full".

Hawaiian ja # ls /etc/portage/sets/lxde-full
/etc/portage/sets/lxde-full
Hawaiian ja # ls -l /etc/portage/sets/lxde-full
lrwxrwxrwx 1 root root 45 2008-09-06 15:01 /etc/portage/sets/lxde-full -> /usr/local/portage/layman/lxde/sets/lxde-full
Hawaiian ja # ls /usr/local/portage/layman/lxde/sets/lxde-full
Display all 127 possibilities? (y or n)
Hawaiian ja # ls /usr/local/portage/layman/lxde/sets/lxde-full
/usr/local/portage/layman/lxde/sets/lxde-full


Start by removing the symlink /etc/portage/sets/lxde-full as yngwin says its not needed.

I think you've got your PORTDIR_OVERLAY messed up a bit, check the output of..

Code:

emerge --info | grep -i overlay


If your /etc/make.conf has the commands in the order you've listed....

Code:

source /usr/local/portage/layman/make.conf
PORTDIR_OVERLAY="/usr/local/portage/layman"


.. I suspect what you'll find is that you only have /usr/local/portage/layman defined as your only overlay directory which would explain why portage isn't picking up the @lxde-full set as it resides in /usr/local/portage/layman/lxde

The line

Code:

PORTDIR_OVERLAY="/usr/local/portage/layman"


is redundant since /usr/local/portage/layman isn't an overlay per-se, but contains the overlays that you add via layman and these are defined in /usr/local/portage/layman/make.conf also it wipes out any overlays that you've defined and sourced from /usr/local/portage/layman/make.conf, if the order is as you wrote it above then your /etc/make.conf should look like...

Code:

source /usr/local/portage/layman/make.conf
PORTDIR_OVERLAY="$PORTDIR_OVERLAY"


Personally I define my own local overlay first and then source layman..

/etc/make.conf:

PORTDIR_OVERLAY="/usr/local/portage"
source /usr/local/portage/layman/make.conf


...and my layman make.conf adds the layman overlays I have, but ALSO retains the previously defined overlays...

/usr/local/portage/layman/make.conf:

PORTDIR_OVERLAY="
/usr/local/portage/layman/perl-experimental
/usr/local/portage/layman/science
/usr/local/portage/layman/sunrise
/usr/local/portage/layman/lxde
$PORTDIR_OVERLAY
"


Either way, you'll likely find that its down to PORTDIR_OVERLAY not being defined as your expecting.

slack

P.S. - Use BBcode, makes it a lot easier to read posts :roll:
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 642

PostPosted: Sun Sep 07, 2008 7:52 pm    Post subject: Reply with quote

Hi Slack,
Agree with you about the PORTDIR_OVERLAY. When I open a terminal window, I get the following.

Code:

Hawaiian ja # echo $PORTDIR_OVERLAY

Hawaiian ja #

My /etc/make.conf now reads
Code:

PORTDIR_OVERLAY="/usr/local/portage"
source /usr/local/portage/layman/make.conf

If I check the paths I get
Code:

Hawaiian ja # ls /usr/local/portage
layman
Hawaiian ja # cat  /usr/local/portage/layman/make.conf
PORTDIR_OVERLAY="
/usr/local/portage/layman/lxde
$PORTDIR_OVERLAY
"


I can run source /usr/local/portage/layman/make.conf manually
Code:

Hawaiian ja # source   /usr/local/portage/layman/make.conf
Hawaiian ja # echo $PORTDIR_OVERLAY
/usr/local/portage/layman/lxde

Which then sets everything up, but still can't get anything to emerge, either the full set, or piece by piece.

Any ideas, I'm stumped.
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Sun Sep 07, 2008 8:19 pm    Post subject: Reply with quote

Is $PORTDIR_OVERLAY defined in a fresh terminal/login? Check the output of...

Code:

# emerge --info | grep -i overlay


Defining $PORTDIR_OVERLAY from the prompt may not be working as expected as the subsequent scripts may be starting new instances of your shell and therefore not picking up the environment variables correctly (a la 'source /etc/profile' ).

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth


Last edited by slackline on Sun Sep 07, 2008 9:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 642

PostPosted: Sun Sep 07, 2008 8:54 pm    Post subject: Reply with quote

Yeah, I was wondering about that, but after opening a new terminal, su'ing and running
Quote:

Hawaiian ja # emerge --info | grep -i overlay
PORTDIR_OVERLAY="/usr/local/portage/layman/lxde /usr/local/portage"


So no idea! I think I've checked most of it, bound to be the thing I haven't, but can't think what it is,
Jim
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Mon Sep 08, 2008 12:36 am    Post subject: Reply with quote

I think it's not working because you use /usr/local/portage as an overlay, and then some subdir in there as the lxde overlay. Overlays controlled by layman should be in a separate directory from your local overlay.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum