Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
git xorg server craps out during build
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Thu Aug 28, 2008 10:26 pm    Post subject: git xorg server craps out during build Reply with quote

Hey guys. I didnt know whether I should file a bug report or not, so I decided to post this question here first and get a second opinion. Please if you guys can give me any help... Any help at all, I'd be glad to take it.

Anyway let me explain what I'm trying to do....

I want to get the open source radeon driver xf86-video-radeon to build with R500 3d support for my 1950pro. More info here... Also this is the install guide I used to get it all set up. Of course I had to change it quite a bit in order to resolve dependencies, and to get everything to compile, but so far I've had no luck getting xorg-server to compile...

Here is all the information that you guys may need.

package.unmask wrote:
=x11-base/xorg-server-9999
=x11-proto/glproto-9999
=x11-proto/randrproto-9999
=x11-libs/libXxf86vm-9999
=x11-libs/libXtst-9999
=x11-libs/libXfont-9999
=x11-libs/pixman-9999
=x11-libs/libpciaccess-9999
=x11-proto/dri2proto-9999
=x11-base/x11-drm-99999999
=x11-libs/xtrans-9999
=x11-proto/renderproto-9999
=x11-libs/libXrender-9999
=x11-proto/xcb-proto-9999
=x11-libs/libxcb-9999
=x11-drivers/xf86-video-ati-9999
=x11-libs/libdrm-9999
=media-libs/mesa-9999
=x11-drivers/xf86-input-keyboard-9999
=x11-proto/xproto-9999
=x11-libs/libXext-9999
=x11-libs/libXi-9999
=x11-proto/xextproto-9999
=x11-libs/libX11-9999
=x11-libs/libXft-9999
=media-libs/fontconfig-9999
=x11-proto/inputproto-9999
=x11-proto/xf86driproto-9999


package.keywords wrote:

=x11-drivers/xf86-video-vesa-2.0.0
=x11-drivers/xf86-input-mouse-1.3.0
=x11-drivers/xf86-input-joystick-1.3.2
=x11-apps/rgb-1.0.3
=x11-apps/xinit-1.0.8-r3
=x11-misc/xkeyboard-config-1.3
=x11-apps/xauth-1.0.3
=x11-base/xorg-server-1.4.99.906
=x11-base/xorg-x11-7.3

=x11-proto/glproto-9999
=x11-proto/randrproto-9999
=x11-libs/libXxf86vm-9999
=x11-libs/libXtst-9999
=x11-libs/libXfont-9999
=x11-libs/pixman-9999
=x11-libs/libpciaccess-9999
=x11-base/xorg-server-9999
=x11-proto/dri2proto-9999
=x11-base/x11-drm-99999999
=x11-libs/xtrans-9999
=x11-proto/renderproto-9999
=x11-libs/libXrender-9999
=x11-proto/inputproto-9999
=x11-libs/libX11-9999
=x11-proto/xproto-9999
=media-libs/mesa-9999
=x11-libs/libXext-9999
=x11-proto/xextproto-9999
=x11-libs/libXi-9999
=x11-drivers/xf86-video-ati-9999
=x11-drivers/xf86-input-mouse-9999
=x11-drivers/xf86-input-keyboard-9999
=x11-drivers/xf86-input-evdev-9999
=x11-proto/xf86driproto-9999
=x11-libs/libxcb-9999
=x11-proto/xcb-proto-9999


OK, so these are the packages that I had to unmask in package.unmask, and package.keywords in order to meet all of the dependencies, and to get everything to compile cleanly. So far so good, but I still cant get xorg-server to compile. To give you a better idea let me paste the output from the xorg-server output....

Quote:

Making all in glx
make[1]: Entering directory `/var/tmp/portage/x11-base/xorg-server-9999/work/xorg-server-9999/glx'
../doltcompile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include -I../hw/xfree86/os-support -I../hw/xfree86/os-support/bus -I../hw/xfree86/common -I../hw/xfree86/dri -I../hw/xfree86/dri2 -I../mi -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/freetype2 -I/usr/include/pixman-1 -I/usr/include/hal -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I../include -I../include -I../Xext -I../composite -I../damageext -I../xfixes -I../Xi -I../mi -I../miext/shadow -I../miext/damage -I../render -I../randr -I../fb -I/usr/include/drm -I/usr/include/X11/dri -DXFree86Server -D__GLX_ALIGN64 -O2 -pipe -march=k8 -MT indirect_dispatch.lo -MD -MP -MF .deps/indirect_dispatch.Tpo -c -o indirect_dispatch.lo indirect_dispatch.c
../doltcompile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include -I../hw/xfree86/os-support -I../hw/xfree86/os-support/bus -I../hw/xfree86/common -I../hw/xfree86/dri -I../hw/xfree86/dri2 -I../mi -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/freetype2 -I/usr/include/pixman-1 -I/usr/include/hal -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I../include -I../include -I../Xext -I../composite -I../damageext -I../xfixes -I../Xi -I../mi -I../miext/shadow -I../miext/damage -I../render -I../randr -I../fb -I/usr/include/drm -I/usr/include/X11/dri -DXFree86Server -D__GLX_ALIGN64 -O2 -pipe -march=k8 -MT indirect_dispatch_swap.lo -MD -MP -MF .deps/indirect_dispatch_swap.Tpo -c -o indirect_dispatch_swap.lo indirect_dispatch_swap.c
../doltcompile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include -I../hw/xfree86/os-support -I../hw/xfree86/os-support/bus -I../hw/xfree86/common -I../hw/xfree86/dri -I../hw/xfree86/dri2 -I../mi -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/freetype2 -I/usr/include/pixman-1 -I/usr/include/hal -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I../include -I../include -I../Xext -I../composite -I../damageext -I../xfixes -I../Xi -I../mi -I../miext/shadow -I../miext/damage -I../render -I../randr -I../fb -I/usr/include/drm -I/usr/include/X11/dri -DXFree86Server -D__GLX_ALIGN64 -O2 -pipe -march=k8 -MT indirect_reqsize.lo -MD -MP -MF .deps/indirect_reqsize.Tpo -c -o indirect_reqsize.lo indirect_reqsize.c
mv -f .deps/indirect_reqsize.Tpo .deps/indirect_reqsize.Plo
../doltcompile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../include -I../hw/xfree86/os-support -I../hw/xfree86/os-support/bus -I../hw/xfree86/common -I../hw/xfree86/dri -I../hw/xfree86/dri2 -I../mi -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -DDBUS_API_SUBJECT_TO_CHANGE -I/usr/include/freetype2 -I/usr/include/pixman-1 -I/usr/include/hal -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I../include -I../include -I../Xext -I../composite -I../damageext -I../xfixes -I../Xi -I../mi -I../miext/shadow -I../miext/damage -I../render -I../randr -I../fb -I/usr/include/drm -I/usr/include/X11/dri -DXFree86Server -D__GLX_ALIGN64 -O2 -pipe -march=k8 -MT indirect_size_get.lo -MD -MP -MF .deps/indirect_size_get.Tpo -c -o indirect_size_get.lo indirect_size_get.c
In file included from indirect_dispatch.c:40:
glapitable.h:812: error: expected declaration specifiers or '...' before 'GLint64EXT'
glapitable.h:813: error: expected declaration specifiers or '...' before 'GLuint64EXT'
indirect_dispatch.c: In function '__glXDisp_TexSubImage1D':
indirect_dispatch.c:2976: warning: cast to pointer from integer of different size
indirect_dispatch.c: In function '__glXDisp_TexSubImage2D':
indirect_dispatch.c:3000: warning: cast to pointer from integer of different size
indirect_dispatch.c: In function '__glXDisp_TexImage3D':
indirect_dispatch.c:3748: warning: cast to pointer from integer of different size
indirect_dispatch.c: In function '__glXDisp_TexSubImage3D':
indirect_dispatch.c:3777: warning: cast to pointer from integer of different size
make[1]: *** [indirect_dispatch.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
In file included from indirect_dispatch_swap.c:40:
glapitable.h:812: error: expected declaration specifiers or '...' before 'GLint64EXT'
glapitable.h:813: error: expected declaration specifiers or '...' before 'GLuint64EXT'
indirect_dispatch_swap.c: In function '__glXDispSwap_TexSubImage1D':
indirect_dispatch_swap.c:3096: warning: cast to pointer from integer of different size
indirect_dispatch_swap.c: In function '__glXDispSwap_TexSubImage2D':
indirect_dispatch_swap.c:3120: warning: cast to pointer from integer of different size
indirect_dispatch_swap.c: In function '__glXDispSwap_TexImage3D':
indirect_dispatch_swap.c:3884: warning: cast to pointer from integer of different size
indirect_dispatch_swap.c: In function '__glXDispSwap_TexSubImage3D':
indirect_dispatch_swap.c:3913: warning: cast to pointer from integer of different size
make[1]: *** [indirect_dispatch_swap.lo] Error 1
indirect_size_get.c: In function '__glGetBooleanv_size':
indirect_size_get.c:709: error: 'GL_COMPARE_REF_DEPTH_TO_TEXTURE_EXT' undeclared (first use in this function)
indirect_size_get.c:709: error: (Each undeclared identifier is reported only once
indirect_size_get.c:709: error: for each function it appears in.)
indirect_size_get.c:733: error: 'GL_DRAW_FRAMEBUFFER_BINDING_EXT' undeclared (first use in this function)
indirect_size_get.c:735: error: 'GL_READ_FRAMEBUFFER_BINDING_EXT' undeclared (first use in this function)
make[1]: *** [indirect_size_get.lo] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-9999/work/xorg-server-9999/glx'
make: *** [all-recursive] Error 1
*
* ERROR: x11-base/xorg-server-9999 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3221: Called x-modular_src_compile
* environment, line 4011: Called x-modular_src_make
* environment, line 4047: Called die
* The specific snippet of code:
* emake || die "emake failed"
* The die message:
* emake failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/x11-base/xorg-server-9999/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-base/xorg-server-9999/temp/environment'.
*

* Messages for package x11-base/xorg-server-9999:

*
* ERROR: x11-base/xorg-server-9999 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3221: Called x-modular_src_compile
* environment, line 4011: Called x-modular_src_make
* environment, line 4047: Called die
* The specific snippet of code:
* emake || die "emake failed"
* The die message:
* emake failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/x11-base/xorg-server-9999/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-base/xorg-server-9999/temp/environment'.
*


Hopefully this makes sense to someone out there, becouse it looks like gibberish to me. The way I'm reading it there are three problems, one with indirect_dispatch.c, and another with indirect_dispatch_swap.c as well as a third with indirect_size_get.c Problem is I have no idea whjat all this means or how to resolve it...

I feel like I'm in the last mile running the home stretch of a marathon, but with no chance in hell of finishing.
Back to top
View user's profile Send private message
Sadako
Advocate
Advocate


Joined: 05 Aug 2004
Posts: 3789
Location: sleeping in the bathtub

PostPosted: Thu Aug 28, 2008 10:41 pm    Post subject: Reply with quote

I have a 1950 pro too, and the 1.4.99.906 xorg-server ebuild in portage, which is a fairly recent 1.5 release candidate, works fine for me along with mesa 7.1_rc3.

In fact, the only related git ebuild I'm using is x11-drm, and direct rendering is working excellently.

Mesa 7.1 was just released, so xorg-server 1.5 should be shortly behind it, my advice is to go with the rc's in portage for the moment.

As for why this is failing, git ebuilds typically pull the master branch, but xorg-server 1.5 has it's own branch now, so changes they made in the current master could easily have broken it, so if you have to use a git xorg-server try pulling the 1.5 branch instead (just don't ask me how to do that in an ebuild :P ).
_________________
"You have to invite me in"
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Thu Aug 28, 2008 10:47 pm    Post subject: Reply with quote

Awesome I'm glad you responded so quickly... Well, as to why I'm using git...

I was initially using x11-base/xorg-server-1.4.99.906 But then I ran right smack dab in the middle of this bugger. And the fix is only available in git. In order to get around this bug I have to use the git build. You can find more information on this thread at phoronix.
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Fri Aug 29, 2008 8:15 pm    Post subject: Reply with quote

Hopeless wrote:
so if you have to use a git xorg-server try pulling the 1.5 branch instead (just don't ask me how to do that in an ebuild :P ).


I'll jump in here
add
EGIT_BRANCH="master" (or any other branch here)

before inherit in ebuild to fetch specified branch instead of master (which is the default)

@duby2291
Make sure you switch to xorg opengl provider prior to building mesa or xorg-server if you're using ati proprietary driver. Git ebuils does not do that, but it's necessary (it replaces /usr/include/GL links with xorg ones)

Code:
eselect opengl set xorg-x11


cheers
_________________
Maciek
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Sun Aug 31, 2008 5:17 pm    Post subject: Reply with quote

Tried running eselect as per your suggestion but it didnt help. I never installed the closed drivers before, so I didnt think it would make a difference, but at the same time I never ran eselect before either so it was worth a try. But I still get the same error in the same spot.
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Sun Aug 31, 2008 10:00 pm    Post subject: Reply with quote

Have you tried running emerge recently? A few days ago some new DRI2 code has been merged to master and xorg-server compiled cleanly on my box (and it refused to do so before).
Running eselect is necessary for mixed installations (ati OS mixed with proprietary) - ati proprietary comes with it's own GL and GLX headers and it could cause problems with building mesa/xorg-server (so that those ebuilds usually make sure to do eselect opengl set xorg-x11 for the compilation time and I don't remember whether -9999 ebuild do so as well).

good luck
_________________
Maciek
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Mon Sep 01, 2008 3:03 pm    Post subject: Reply with quote

Tried it again, but it still craps out in exactly the same spot. Same exact error on the same exact line.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Sep 01, 2008 3:05 pm    Post subject: Reply with quote

Are you actually still running 2006.1?

If yes, you'll need to update to the current profile before trying this stuff. Some of the settings may be a problem from years ago...
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum