Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
e17 from svn
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon Nov 17, 2008 10:45 am    Post subject: Reply with quote

Thanks nitm and GroMeZ! Added.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
GroMeZ
n00b
n00b


Joined: 21 Apr 2007
Posts: 10

PostPosted: Mon Nov 17, 2008 8:03 pm    Post subject: Reply with quote

Thanks to you gimpel ! :)

EDIT: just a little fix, modules should be added in DEPEND of e_modules and added to package.keywords.livecvs
Back to top
View user's profile Send private message
thom_raindog
Guru
Guru


Joined: 16 May 2008
Posts: 400

PostPosted: Tue Nov 18, 2008 7:12 am    Post subject: removing E Reply with quote

Howdie

I tried to install E using makism's guid in this thread
https://forums.gentoo.org/viewtopic-t-705835-start-25.html

Now it didn't work out and I find I need the diskspace. How can I remove it again? A simply
Code:

emerge -c e
does nothing..
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9290

PostPosted: Tue Nov 18, 2008 7:39 am    Post subject: Reply with quote

Are you using -c (--clean) or -C (--unmerge)? The former will only remove old versions, not the most recent installed version.

Merged the above post.
Back to top
View user's profile Send private message
thom_raindog
Guru
Guru


Joined: 16 May 2008
Posts: 400

PostPosted: Tue Nov 18, 2008 3:57 pm    Post subject: Reply with quote

Capital C or lowercase makes no difference in my case..

Code:

emerge -C e

--- Couldn't find 'e' to unmerge.

>>> No packages selected for removal by unmerge
black_beauty thom # emerge -C e17

--- Couldn't find 'e17' to unmerge.

>>> No packages selected for removal by unmerge
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9290

PostPosted: Wed Nov 19, 2008 12:15 am    Post subject: Reply with quote

Code:
emerge -av --depclean
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Thu Nov 20, 2008 3:31 pm    Post subject: Reply with quote

I have a problem installing some e17 apps, such epeg.
the output is the following:
Code:
>>> Emerging (1 of 1) media-libs/epeg-9999
 * checking ebuild checksums ;-) ...                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                       [ ok ]
 * Using user server for live sources: http://svn.enlightenment.org/svn/e/trunk
 * This is a LIVE SOURCES ebuild.
 * That means there are NO promises it will work.
 * If it fails to build, FIX THE CODE YOURSELF
 * before reporting any issues.
>>> Unpacking source...
 * subversion switch start -->
 *      old repository: http://svn.enlightenment.org/svn/e/trunk/OLD/epeg@37561
 *      new repository: http://svn.enlightenment.org/svn/e/trunk/epeg
svn: Target path does not exist
 *
 * ERROR: media-libs/epeg-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2636:  Called enlightenment_src_unpack
 *             environment, line 1499:  Called subversion_src_unpack
 *             environment, line 2876:  Called subversion_fetch
 *             environment, line 2837:  Called die
 * The specific snippet of code:
 *                       ${ESVN_SWITCH_CMD} ${options} ${repo_uri} || die "${ESVN}: can't update ${wc_path} from ${repo_uri}";
 *  The die message:
 *   subversion: can't update /usr/portage/distfiles/svn-src/enlightenment/epeg from http://svn.enlightenment.org/svn/e/trunk/epeg


on the svn, epeg is not in "http://svn.enlightenment.org/svn/e/trunk/epe", but it is in the OLD folder.
do I need to manually edit some ebuilds?


Last edited by ckx3009 on Thu Nov 20, 2008 4:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Thu Nov 20, 2008 3:42 pm    Post subject: Reply with quote

Which overlay?
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Thu Nov 20, 2008 3:44 pm    Post subject: Reply with quote

sorry, I forgot to mention it: it is the official enlightenment overlay

Last edited by ckx3009 on Thu Nov 20, 2008 4:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Thu Nov 20, 2008 3:47 pm    Post subject: Reply with quote

ckx3009 wrote:
sorry, i forgot to mention it: it is the official enlightenment overlay

Yeah that one misses eina and checkout only works for stuff in trunk directly.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Thu Nov 20, 2008 4:01 pm    Post subject: Reply with quote

still misses eina? it is months it do that.
is it still maintained actively?
or it is better I migrate to enlightenment-svn overlay (that, I suppose, it is maintained by you)?

you answer seems to be obvious :P

edit: with your overlay, I need some strange things to compile all the packages, such as one exact version of gcc or some CFLAGS or LDFLAGS?
with official overlay I saw I can't use aggressive flags or it does not compile anything.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Thu Nov 20, 2008 5:54 pm    Post subject: Reply with quote

ckx3009 wrote:
edit: with your overlay, I need some strange things to compile all the packages, such as one exact version of gcc or some CFLAGS or LDFLAGS?
with official overlay I saw I can't use aggressive flags or it does not compile anything.

Uhm, there is no difference regarding compilation, just the paths are fixed for SVN, and eina got added.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Thu Nov 20, 2008 9:56 pm    Post subject: Reply with quote

in fact still remain some errors, such as:
Code:
checking for evas-config... no
configure: error: evas-config is not in your $PATH. Please ensure it is.
emerging retina-9999

and for epdf-9999:
Code:
* subversion check out start -->
 *      repository: http://svn.enlightenment.org/svn/e/trunk/epdf
svn: L'URL 'http://svn.enlightenment.org/svn/e/trunk/epdf' non esiste
 *
 * ERROR: app-text/epdf-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2636:  Called enlightenment_src_unpack
 *             environment, line 1499:  Called subversion_src_unpack
 *             environment, line 2876:  Called subversion_fetch
 *             environment, line 2808:  Called die
 * The specific snippet of code:
 *           ${ESVN_FETCH_CMD} ${options} "${repo_uri}" || die "${ESVN}: can't fetch to ${wc_path} from ${repo_uri}.";
 *  The die message:
 *   subversion: can't fetch to /usr/portage/distfiles/svn-src/enlightenment/epdf from http://svn.enlightenment.org/svn/e/trunk/epdf.

same message for express-9999 and enterminus-9999

entropy instead gives a strange error: http://pastebin.com/m2b06b73
strange because evas and eina are both installed.

all is compiled on a centrino duo T2250 using:
- gcc 4.3.2
- CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
- no LDFLAGS
- MAKEOPTS="-j3"
- portage 2.2
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Fri Nov 21, 2008 6:27 am    Post subject: Reply with quote

retina is most probably unmaintained. I think the maintained packages were converted to use pkg-config instead of evas-config many months ago.
epdf and enterminus are in PROTO, so you need to add that information to the ebuilds.
express is also unmaintained and in fact resides in the BROKEN directory.
I have no idea what is the problem with entropy. I haven't noticed any recent commits to entropy though.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Fri Nov 21, 2008 9:37 am    Post subject: Reply with quote

thank you for the explanation!
I'm not very interested in most of that packages, but entropy, instead, is very interesting and I would like to have it installed.
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5413

PostPosted: Sat Dec 06, 2008 7:23 am    Post subject: Reply with quote

ebpp results in the same error has epdf.
ebpp is located under the MISC subdirectory and epdf is located under the PROTO subdirectory
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Sat Dec 06, 2008 10:55 am    Post subject: Reply with quote

Please use the official overlay again. It has been updated.

Note that e has been renamed to enlightenment.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
lowang_19
n00b
n00b


Joined: 28 Oct 2005
Posts: 66

PostPosted: Sun Dec 07, 2008 11:13 am    Post subject: Reply with quote

gimpel wrote:
Please use the official overlay again. It has been updated.

Note that e has been renamed to enlightenment.


Does not work for me. enlightenment fails to build with this error :
Code:

/usr/bin/eet -e \
        ../../config/default/e.cfg config \
        e.src 1
/usr/bin/eet: symbol lookup error: /usr/bin/eet: undefined symbol: eet_data_undump_ciphe


If I install enlightenment directly from SVN it works... Something wrong in the ebuilds or use flags ?
_________________
lowang
Back to top
View user's profile Send private message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 325
Location: Sweden

PostPosted: Sun Dec 07, 2008 11:22 am    Post subject: Reply with quote

lowang_19 wrote:
gimpel wrote:
Please use the official overlay again. It has been updated.

Note that e has been renamed to enlightenment.


Does not work for me. enlightenment fails to build with this error :
Code:

/usr/bin/eet -e \
        ../../config/default/e.cfg config \
        e.src 1
/usr/bin/eet: symbol lookup error: /usr/bin/eet: undefined symbol: eet_data_undump_ciphe


If I install enlightenment directly from SVN it works... Something wrong in the ebuilds or use flags ?


I've build eet successfully using the ebuilds from vapiers overlay. (That's the one we're referring to here as "official", right?) It's only got two use-flags, of which I've enabled nls.

Have you built eina as well? I don't know if that's needed before eet or not, but maybe?

So far I've gotten eina, eet and embryo (oh, and imlib2) installed, but the rest fails due to dependency on evas which I haven't gotten to build yet. (See this post in the current E17 is coming? -thread.)
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5413

PostPosted: Mon Dec 08, 2008 3:58 pm    Post subject: Reply with quote

just my luck, e17 from gimpel's overlay compiled well, I've switched to vapier's overlay and evas fails :(
Code:
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../../../.. -I. -I../../../../src/lib -I../../../../src/lib/include -I../../../../src/modules/engines/cairo_common -I/usr/include/freetype2 -I/usr/include/cairo -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/eina-0 -I/usr/include/eina-0/eina -march=core2 -O2 -pipe -D_GNU_SOURCE -MT module_la-evas_engine.lo -MD -MP -MF .deps/module_la-evas_engine.Tpo -c evas_engine.c  -fPIC -DPIC -o .libs/module_la-evas_engine.o
evas_engine.c:144: warning: initialization from incompatible pointer type
evas_engine.c:145: warning: initialization from incompatible pointer type
evas_engine.c:146: warning: initialization from incompatible pointer type
evas_engine.c:148: warning: initialization from incompatible pointer type
evas_engine.c:149: warning: initialization from incompatible pointer type
evas_engine.c:150: warning: initialization from incompatible pointer type
evas_engine.c:151: warning: initialization from incompatible pointer type
evas_engine.c:152: warning: initialization from incompatible pointer type
evas_engine.c:153: warning: initialization from incompatible pointer type
evas_engine.c:154: warning: initialization from incompatible pointer type
evas_engine.c:155: warning: initialization from incompatible pointer type
evas_engine.c:156: warning: initialization from incompatible pointer type
evas_engine.c:157: warning: initialization from incompatible pointer type
evas_engine.c:158: warning: initialization from incompatible pointer type
evas_engine.c:159: warning: initialization from incompatible pointer type
evas_engine.c:160: warning: initialization from incompatible pointer type
evas_engine.c:161: warning: initialization from incompatible pointer type
evas_engine.c:162: warning: initialization from incompatible pointer type
evas_engine.c:164: warning: initialization from incompatible pointer type
evas_engine.c:168: warning: initialization from incompatible pointer type
evas_engine.c:169: warning: initialization from incompatible pointer type
evas_engine.c:170: warning: initialization from incompatible pointer type
evas_engine.c:172: warning: initialization from incompatible pointer type
evas_engine.c:173: warning: initialization from incompatible pointer type
evas_engine.c:174: warning: initialization from incompatible pointer type
evas_engine.c:175: warning: initialization from incompatible pointer type
evas_engine.c:176: warning: initialization from incompatible pointer type
evas_engine.c:177: warning: initialization from incompatible pointer type
evas_engine.c:179: warning: initialization from incompatible pointer type
evas_engine.c:180: warning: initialization from incompatible pointer type
evas_engine.c:181: warning: initialization from incompatible pointer type
evas_engine.c:182: warning: initialization from incompatible pointer type
evas_engine.c:183: warning: initialization from incompatible pointer type
evas_engine.c:184: warning: initialization from incompatible pointer type
evas_engine.c:185: warning: initialization from incompatible pointer type
evas_engine.c:186: warning: initialization from incompatible pointer type
evas_engine.c:187: warning: initialization from incompatible pointer type
evas_engine.c:188: warning: initialization from incompatible pointer type
evas_engine.c:189: warning: initialization from incompatible pointer type
evas_engine.c:190: warning: initialization from incompatible pointer type
evas_engine.c:192: warning: initialization from incompatible pointer type
evas_engine.c:193: warning: initialization from incompatible pointer type
evas_engine.c:194: warning: initialization from incompatible pointer type
evas_engine.c:196: warning: initialization from incompatible pointer type
evas_engine.c:197: warning: initialization from incompatible pointer type
evas_engine.c:199: warning: initialization from incompatible pointer type
evas_engine.c:200: warning: initialization from incompatible pointer type
evas_engine.c:201: warning: initialization from incompatible pointer type
evas_engine.c:202: warning: initialization from incompatible pointer type
evas_engine.c:203: warning: initialization from incompatible pointer type
evas_engine.c:204: warning: initialization from incompatible pointer type
evas_engine.c:205: warning: initialization from incompatible pointer type
evas_engine.c:206: warning: initialization from incompatible pointer type
evas_engine.c:207: warning: initialization from incompatible pointer type
evas_engine.c:208: warning: initialization from incompatible pointer type
evas_engine.c:209: warning: initialization from incompatible pointer type
evas_engine.c:210: warning: initialization from incompatible pointer type
evas_engine.c:211: warning: initialization from incompatible pointer type
evas_engine.c:212: warning: initialization from incompatible pointer type
evas_engine.c:213: warning: initialization from incompatible pointer type
evas_engine.c:214: warning: initialization from incompatible pointer type
evas_engine.c:216: warning: initialization from incompatible pointer type
evas_engine.c:217: warning: initialization from incompatible pointer type
evas_engine.c:218: warning: initialization from incompatible pointer type
evas_engine.c:220: warning: initialization from incompatible pointer type
evas_engine.c:221: warning: initialization from incompatible pointer type
evas_engine.c:222: warning: initialization from incompatible pointer type
evas_engine.c:223: warning: initialization from incompatible pointer type
evas_engine.c:224: warning: initialization from incompatible pointer type
evas_engine.c:225: warning: initialization from incompatible pointer type
evas_engine.c:226: warning: initialization from incompatible pointer type
evas_engine.c:227: warning: initialization from incompatible pointer type
evas_engine.c:229: warning: initialization from incompatible pointer type
evas_engine.c:230: warning: initialization from incompatible pointer type
evas_engine.c:231: warning: initialization from incompatible pointer type
evas_engine.c:232: warning: initialization from incompatible pointer type
evas_engine.c:233: warning: initialization from incompatible pointer type
evas_engine.c:234: warning: initialization from incompatible pointer type
evas_engine.c:235: warning: initialization from incompatible pointer type
evas_engine.c:237: warning: initialization from incompatible pointer type
evas_engine.c:238: warning: initialization from incompatible pointer type
evas_engine.c:239: warning: initialization from incompatible pointer type
evas_engine.c:241: warning: initialization from incompatible pointer type
evas_engine.c:243: warning: initialization from incompatible pointer type
evas_engine.c: In function 'eng_output_setup':
evas_engine.c:300: warning: assignment makes pointer from integer without a cast
evas_engine.c: In function 'eng_image_new_from_data':
evas_engine.c:934: error: incompatible types in assignment
evas_engine.c:935: error: wrong type argument to unary exclamation mark
evas_engine.c:942: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:943: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:944: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:945: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c: In function 'eng_image_new_from_copied_data':
evas_engine.c:962: warning: assignment makes pointer from integer without a cast
evas_engine.c:969: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c: In function 'eng_image_size_get':
evas_engine.c:1003: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:1004: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c: In function 'eng_image_data_preload_request':
evas_engine.c:1056: warning: 'return' with a value, in function returning void
evas_engine.c: In function 'eng_image_data_preload_cancel':
evas_engine.c:1066: warning: 'return' with a value, in function returning void
evas_engine.c: In function 'eng_image_draw':
evas_engine.c:1125: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:1130: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:1130: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:1136: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:1136: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:1152: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:1153: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:1154: warning: passing argument 1 of 'cairo_image_surface_create_for_data' from incompatible pointer type
evas_engine.c:1177: error: invalid type argument of '->' (have 'struct <anonymous>')
evas_engine.c:1178: error: invalid type argument of '->' (have 'struct <anonymous>')
make[5]: *** [module_la-evas_engine.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
 x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../../../.. -I. -I../../../../src/lib -I../../../../src/lib/include -I../../../../src/modules/engines/cairo_common -I/usr/include/freetype2 -I/usr/include/cairo -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/eina-0 -I/usr/include/eina-0/eina -march=core2 -O2 -pipe -D_GNU_SOURCE -MT module_la-evas_x_main.lo -MD -MP -MF .deps/module_la-evas_x_main.Tpo -c evas_x_main.c  -fPIC -DPIC -o .libs/module_la-evas_x_main.o
mv -f .deps/module_la-evas_x_main.Tpo .deps/module_la-evas_x_main.Plo
make[5]: Leaving directory `/var/tmp/portage/x11-libs/evas-9999/work/evas/src/modules/engines/cairo_x11'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/x11-libs/evas-9999/work/evas/src/modules/engines'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/x11-libs/evas-9999/work/evas/src/modules'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-libs/evas-9999/work/evas/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/evas-9999/work/evas'
make: *** [all] Error 2
 * Using user server for live sources: http://svn.enlightenment.org/svn/e/trunk
 * This is a LIVE SOURCES ebuild.
 * That means there are NO promises it will work.
 * If it fails to build, FIX THE CODE YOURSELF
 * before reporting any issues.
 *
 * ERROR: x11-libs/evas-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2718:  Called enlightenment_src_compile
 *             environment, line 1525:  Called enlightenment_die 'emake failed'
 *             environment, line 1495:  Called die
 * The specific snippet of code:
 *   '"!!! SEND BUG REPORTS TO e17@gentoo.org NOT THE E TEAM"
 *  The die message:
 *   emake failed
 * !!! SEND BUG REPORTS TO e17@gentoo.org NOT THE E TEAM
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-libs/evas-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/evas-9999/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/enlightment/'
 *

_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon Dec 08, 2008 4:23 pm    Post subject: Reply with quote

DaggyStyle, disable cairo useflag for evas. That engine is broken and pretty much unmaintained anyway.

Before vapier's update, cairo useflag was there in evas, but useless as it was missing in econf, and so it was disabled by default anyway.
The fix to the ebuild now uncovers the brokeness of the engine :)
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5413

PostPosted: Mon Dec 08, 2008 5:47 pm    Post subject: Reply with quote

gimpel wrote:
DaggyStyle, disable cairo useflag for evas. That engine is broken and pretty much unmaintained anyway.

Before vapier's update, cairo useflag was there in evas, but useless as it was missing in econf, and so it was disabled by default anyway.
The fix to the ebuild now uncovers the brokeness of the engine :)


evas is unmaintained or cairo within evas?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Mon Dec 08, 2008 6:02 pm    Post subject: Reply with quote

cairo within evas:
http://marc.info/?l=enlightenment-devel&m=122826231611995&w=2
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
sian
Apprentice
Apprentice


Joined: 26 Jan 2004
Posts: 288

PostPosted: Fri Dec 26, 2008 8:41 am    Post subject: Reply with quote

Hi all,

I tried to update e17 and compiles failed in x11-wm/enlightenment. Here is the end of the log.

Code:

/usr/bin/edje_cc -v -id ../../data/themes/images -fd ../../data/themes/fonts -DLOWRES_PDA=1 -DMEDIUMRES_PDA=2 -DHIRES_PDA=3 -DSLOW_PC=4 -DMEDIUM_PC=5 -DFAST_PC=6 -DE17_PROFILE=SLOW_PC \
        ../../data/themes/illume.edc \
        ../../data/themes/illume.edj
/usr/bin/edje_cc: Opening "/tmp/edje_cc.edc-tmp-m50LpG" for input
/usr/bin/edje_cc: Parsing input file
/usr/bin/edje_cc: Parsing done
/usr/bin/edje_cc: Opening "/tmp/edje_cc.edc-tmp-rYXxIJ" for input
/usr/bin/edje_cc: Parsing input file
/usr/bin/edje_cc: Wrote       511 bytes (   0Kb) for "edje_file" header
/usr/bin/edje_cc: Parsing done
/usr/bin/edje_cc: Wrote      4611 bytes (   5Kb) for "edje_file" header


Do you have the same problem ?

I used sets to emerge e17.

Quote:
dev-libs/eina
dev-libs/eet
x11-libs/evas
x11-libs/ecore
dev-libs/efreet
dev-libs/embryo
media-libs/edje
x11-libs/e_dbus
x11-wm/enlightenment
x11-libs/esmart
x11-misc/entrance
media-libs/epsilon
media-libs/imlib2


before updating I unmerged this sets and cleaned the svn-src directory. Then I did emerge -1 @enlightement-svn.
I am using the official svn overlay.

Thanks in advance for your help.
_________________
Kernel : 2.6.32 - E17 - OpenRC-0.61 - gcc-4.4.3
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Fri Dec 26, 2008 5:20 pm    Post subject: Reply with quote

I would suggest that you wait for some time for this to get fixed. There is already a bug report regarding this.

For future emerges, try to keep a backup of the current installation, so that you can roll back easily. I usually backup my current installation with quickpkg --include-config=y and use emerge -K to restore the old installation.
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum