Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
e17 from svn
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5387

PostPosted: Fri Dec 26, 2008 5:23 pm    Post subject: Reply with quote

sian wrote:
Hi all,

I tried to update e17 and compiles failed in x11-wm/enlightenment. Here is the end of the log.

Code:

/usr/bin/edje_cc -v -id ../../data/themes/images -fd ../../data/themes/fonts -DLOWRES_PDA=1 -DMEDIUMRES_PDA=2 -DHIRES_PDA=3 -DSLOW_PC=4 -DMEDIUM_PC=5 -DFAST_PC=6 -DE17_PROFILE=SLOW_PC \
        ../../data/themes/illume.edc \
        ../../data/themes/illume.edj
/usr/bin/edje_cc: Opening "/tmp/edje_cc.edc-tmp-m50LpG" for input
/usr/bin/edje_cc: Parsing input file
/usr/bin/edje_cc: Parsing done
/usr/bin/edje_cc: Opening "/tmp/edje_cc.edc-tmp-rYXxIJ" for input
/usr/bin/edje_cc: Parsing input file
/usr/bin/edje_cc: Wrote       511 bytes (   0Kb) for "edje_file" header
/usr/bin/edje_cc: Parsing done
/usr/bin/edje_cc: Wrote      4611 bytes (   5Kb) for "edje_file" header


Do you have the same problem ?

I used sets to emerge e17.

Quote:
dev-libs/eina
dev-libs/eet
x11-libs/evas
x11-libs/ecore
dev-libs/efreet
dev-libs/embryo
media-libs/edje
x11-libs/e_dbus
x11-wm/enlightenment
x11-libs/esmart
x11-misc/entrance
media-libs/epsilon
media-libs/imlib2


before updating I unmerged this sets and cleaned the svn-src directory. Then I did emerge -1 @enlightement-svn.
I am using the official svn overlay.

Thanks in advance for your help.


strange, I've reemerged E17 today, the only package that failed was x11-plugins/e_modules-screenshot, everything else complied ok.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
sian
Apprentice
Apprentice


Joined: 26 Jan 2004
Posts: 288

PostPosted: Sat Dec 27, 2008 8:37 am    Post subject: Reply with quote

@DaggyStyle : do you use all the softwares in SVN live version ?
_________________
Kernel : 2.6.32 - E17 - OpenRC-0.61 - gcc-4.4.3
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5387

PostPosted: Sat Dec 27, 2008 8:43 am    Post subject: Reply with quote

sian wrote:
@DaggyStyle : do you use all the softwares in SVN live version ?


when did you synced against the overlay last?

maybe it is a ebuild issue
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
sian
Apprentice
Apprentice


Joined: 26 Jan 2004
Posts: 288

PostPosted: Sat Dec 27, 2008 11:20 am    Post subject: Reply with quote

@DaggyStyle : I have the same error except the 2 red lines (compared to yesterday). I used the gimple overlay and the official overlay.

Quote:
/usr/bin/edje_cc -v -id ../../data/themes/images -fd ../../data/themes/fonts -DLOWRES_PDA=1 -DMEDIUMRES_PDA=2 -DHIRES_PDA=3 -DSLOW_PC=4 -DMEDIUM_PC=5 -DFAST_PC=6 -DE17_PROFILE=SLOW_PC \
../../data/themes/illume.edc \
../../data/themes/illume.edj
[eina_module.c:367] eina_module_list_get() safety check failed: path == NULL
[eina_module.c:367] eina_module_list_get() safety check failed: path == NULL

/usr/bin/edje_cc: Opening "/tmp/edje_cc.edc-tmp-RJomKd" for input
/usr/bin/edje_cc: Parsing input file
/usr/bin/edje_cc: Parsing done
/usr/bin/edje_cc: Wrote 511 bytes ( 0Kb) for "edje_file" header
/usr/bin/edje_cc: Opening "/tmp/edje_cc.edc-tmp-akpMlh" for input
/usr/bin/edje_cc: Parsing input file
/usr/bin/edje_cc: Parsing done
/usr/bin/edje_cc: Wrote 4611 bytes ( 5Kb) for "edje_file" header


so this should not be an ebuild problem. As ppurka said, I will have to wait a little bit. Unitl then I am stuck with an ugly wm... :evil:
_________________
Kernel : 2.6.32 - E17 - OpenRC-0.61 - gcc-4.4.3
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5387

PostPosted: Sat Dec 27, 2008 11:48 am    Post subject: Reply with quote

have no idea, here are genlop output and the actual ebuild, can't seem to remember from where is it.
Code:
 * x11-wm/enlightenment

     Mon Dec  8 19:23:14 2008 >>> x11-wm/enlightenment-9999
     Fri Dec 26 12:19:21 2008 >>> x11-wm/enlightenment-9999

   Total builds: 2
   Global build time: 16 minutes and 48 seconds.
   Average merge time: 8 minutes and 24 seconds.

   Info about currently installed ebuild:

   * x11-wm/enlightenment-9999
   Install date: Fri Dec 26 12:19:21 2008
   USE="pam"
   CFLAGS="-march=core2 -O2 -pipe"


Code:
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-wm/e/e-9999.ebuild,v 1.7 2006/10/22 05:44:35 vapier Exp $

ESVN_URI_APPEND="e"
inherit enlightenment

DESCRIPTION="the e17 window manager"

IUSE="pam"

RDEPEND=">=x11-libs/ecore-9999
        >=media-libs/edje-9999
        >=dev-libs/eet-9999
        >=dev-libs/efreet-9999
        >=dev-libs/embryo-9999
        >=dev-libs/eina-9999
        >=x11-libs/evas-9999
        >=x11-libs/e_dbus-9999
        pam? ( sys-libs/pam )"
DEPEND="${RDEPEND}
        x11-proto/xproto
        sys-devel/libtool"

pkg_setup() {
        if ! built_with_use x11-libs/evas png ; then
                eerror "Re-emerge evas with USE=png"
                die "Re-emerge evas with USE=png"
        fi
        enlightenment_pkg_setup
}


you decide
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
sian
Apprentice
Apprentice


Joined: 26 Jan 2004
Posts: 288

PostPosted: Sat Dec 27, 2008 10:39 pm    Post subject: Reply with quote

@DaggyStyle : thank you.
I tried the 2 overlays (vapier, gimpel), I removed ccache to check if this could help, erased the source to get them back again. Still the same error. I hope I will not have to wait too long...
_________________
Kernel : 2.6.32 - E17 - OpenRC-0.61 - gcc-4.4.3
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3256

PostPosted: Sat Dec 27, 2008 10:56 pm    Post subject: Reply with quote

I updated e yesterday. And I too am getting the warnings in red. But other than that the packages compiled fine. But, for now, I am using the enlightenment snapshot from itask-ng git. So, that may be one reason why it worked.

On second thoughts, the problem is with compiling edje files, and all the edje files are working properly for me. For example I compiled e_modules from svn yesterday and it worked perfectly fine. Similarly, I updated detour theme and it also compiled fine (except for that eina warning in red).
_________________
emerge --quiet redefined | E17 vids: I, II | Now using kde5 | e is unstable :-/
Back to top
View user's profile Send private message
sian
Apprentice
Apprentice


Joined: 26 Jan 2004
Posts: 288

PostPosted: Mon Dec 29, 2008 7:28 pm    Post subject: Reply with quote

Hi all,
Fianlly, I got e17 emerged. I don't really know why it worked for you and not for me but I am happy to use e17 again.
So thanks ppurka and daggyStyle.
_________________
Kernel : 2.6.32 - E17 - OpenRC-0.61 - gcc-4.4.3
Back to top
View user's profile Send private message
nitm
n00b
n00b


Joined: 27 Dec 2004
Posts: 61

PostPosted: Tue Jan 13, 2009 11:54 pm    Post subject: Reply with quote

Hello,

Does someone knows why when building libs I get:
Code:

libtool: link: warning: `/usr/lib/libefreet.la' seems to be moved
libtool: link: warning: `/usr/lib/libefreet_mime.la' seems to be moved
libtool: link: warning: `/usr/lib/libedje.la' seems to be moved
libtool: link: warning: `/usr/lib/libembryo.la' seems to be moved
libtool: link: warning: `/usr/lib/libecore_job.la' seems to be moved
libtool: link: warning: `/usr/lib/libeet.la' seems to be moved
libtool: link: warning: `/usr/lib/libecore_txt.la' seems to be moved
libtool: link: warning: `/usr/lib/libecore_file.la' seems to be moved
libtool: link: warning: `/usr/lib/libecore.la' seems to be moved
libtool: link: warning: `/usr/lib/libgnutls.la' seems to be moved
libtool: link: warning: `/usr/lib/libevas.la' seems to be moved
libtool: link: warning: `/usr/lib/libeina.la' seems to be moved


I'm playing (modifying) with ewl and this warnings slow down the linking (causing relinking I think) phaze, which is a bit annoying.
I get this errors no matter what overlay I use (it might be broken something in the eclass) and I get it for all the libs.

Any help will be highly appreciated.
Best regards,
Teodor
Back to top
View user's profile Send private message
yoshi314
l33t
l33t


Joined: 30 Dec 2004
Posts: 848
Location: PL

PostPosted: Sun Jan 18, 2009 11:26 am    Post subject: Reply with quote

i think it happens all the time for me with various packages. i guess it's safe to ignore
_________________
~amd64
shrink your /usr/portage with squashfs+aufs
Back to top
View user's profile Send private message
nitm
n00b
n00b


Joined: 27 Dec 2004
Posts: 61

PostPosted: Sun Jan 18, 2009 5:28 pm    Post subject: Reply with quote

Yes, everything works fine, just the compilation is slow. And that is a problem if you recompile some of the libs very often (for example when you've made some changes to it and want to test them).
Back to top
View user's profile Send private message
milomak
Apprentice
Apprentice


Joined: 10 Apr 2008
Posts: 255

PostPosted: Sun Jan 18, 2009 6:52 pm    Post subject: Reply with quote

makism wrote:
thom_raindog wrote:
Alright, there is a lot of technicality in this post so I will just ask:
How do I install E17? :)

Can someone point me to a decent (and up-to-date, i.e. SVN) howto or wiki?
Sorry for barging into this thread like this :)


something like this (based on my setup, preference and http://overlays.gentoo.org/dev/vapier/wiki/enlightenment):
Code:
svn co http://gimpel.ath.cx/svn/enlightenment-svn /usr/portage/local/enlightenment-svn

Code:
echo 'PORTDIR_OVERLAY="${PORTDIR_OVERLAY} /usr/portage/local/enlightenment-svn"' >> /etc/make.conf

Code:
ln -sfn /usr/portage/local/enlightenment-svn/scripts/package.keywords.livecvs /etc/portage/package.keywords/e_live

Code:
emerge -va e


1) if "/usr/portage/local/" does not exist, create it
2) it is assumed that you do not use a monolithic package.keywords file but a directory with the name "package.keywords"

if not sure for a thing, do not proceed, instead ask :-)


I get the following error

Code:

root portage # ln -sfn /usr/portage/local/enlightenment-svn/scripts/package.keywords.livecvs /etc/portage/package.keywords/e_live
root portage # emerge -va e

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "e".


EDIT: emerge enlightenment got the ball rolling. will see if it completes


Last edited by milomak on Sun Jan 18, 2009 7:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Sun Jan 18, 2009 6:56 pm    Post subject: Reply with quote

It's called x11-wm/enlightenment now.

And don't use my overlay, it's outdated - and deleted now.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
milomak
Apprentice
Apprentice


Joined: 10 Apr 2008
Posts: 255

PostPosted: Sun Jan 18, 2009 7:09 pm    Post subject: Reply with quote

yeah used this - http://overlays.gentoo.org/dev/vapier/wiki/enlightenment
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum