Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error emerging scilab, gtkhtml, and libGL.so
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Maat Ghandi
n00b
n00b


Joined: 07 Jan 2008
Posts: 11
Location: Santa Cruz, CA

PostPosted: Tue Sep 02, 2008 5:36 pm    Post subject: Error emerging scilab, gtkhtml, and libGL.so Reply with quote

I'm trying to emerge the masked package scilab. The installation exits when installing gtkhtml-2.11.1. It seems to exit on an error with libGL.so. Here is the emerge error

Quote:

x86_64-pc-linux-gnu-gcc -shared .libs/gtkhtmlcontext.o -Wl,--whole-archive ../libgtkhtml/css/.libs/libhtmlcss.a ../libgtkhtml/document/.libs/libhtmldocument.a ../libgtkhtml/dom/.libs/libdom.a ../libgtkhtml/graphics/.libs/libhtmlgraphics.a ../libgtkhtml/layout/.libs/libhtmllayout.a ../libgtkhtml/util/.libs/libhtmlutil.a ../libgtkhtml/view/.libs/libhtmlview.a -Wl,--no-whole-archive -L/usr/lib64 /usr/lib64/libpangoft2-1.0.so /usr/lib64/libfontconfig.so /usr/lib64/libfreetype.so /usr/lib64/libglitz-glx.so /usr/lib64/libglitz.so /usr/lib64/libGL.so /usr/lib64/libXmu.so /usr/lib64/libXt.so /usr/lib64/libSM.so /usr/lib64/libICE.so /usr/lib64/libXi.so /usr/lib64/libXext.so -lpthread /usr/lib64/libpng12.so /usr/lib64/libXrender.so /usr/lib64/libX11.so /usr/lib64/libXau.so /usr/lib64/libXdmcp.so /usr/lib64/libpixman-1.so -lz -lm /usr/lib64/libgtk-x11-2.0.so /usr/lib64/libgdk-x11-2.0.so /usr/lib64/libatk-1.0.so /usr/lib64/libgdk_pixbuf-2.0.so /usr/lib64/libpangocairo-1.0.so /usr/lib64/libpango-1.0.so /usr/lib64/libcairo.so /usr/lib64/libgobject-2.0.so /usr/lib64/libgmodule-2.0.so -ldl /usr/lib64/libglib-2.0.so /usr/lib64/libxml2.so -march=nocona -Wl,-soname -Wl,libgtkhtml-2.so.0 -o .libs/libgtkhtml-2.so.0.0.0
/usr/lib64/libGL.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[3]: *** [libgtkhtml-2.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/gnome-extra/gtkhtml-2.11.1/work/libgtkhtml-2.11.1/libgtkhtml'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-extra/gtkhtml-2.11.1/work/libgtkhtml-2.11.1/libgtkhtml'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-extra/gtkhtml-2.11.1/work/libgtkhtml-2.11.1'
make: *** [all] Error 2
*
* ERROR: gnome-extra/gtkhtml-2.11.1 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3072: Called gnome2_src_compile
* environment, line 2409: Called die
* The specific snippet of code:
* emake || die "compile failure"
* The die message:
* compile failure
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/gnome-extra/gtkhtml-2.11.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/gnome-extra/gtkhtml-2.11.1/temp/environment'.


It seems to not like libGL.so which is symbolically linked as shown below

/usr/lib64/libGL.so -> /usr/lib32/opengl/xorg-x11/lib/libGL.so

It seems odd that the 64 bit library is pointing to a 32 bit version. All the forum threads I've read about this issue are related to Nvidia graphics issues. However I have a thinkpad with an integrated Intel 945GM graphics card. All the Nvidia solutions involve emerging Nvidia drivers, yet I don't want to do that. I can't figure out a way to re-emerge the ligGL.so library. I tried revdep-rebuild -X and it claimed there was nothing to fix.

Any help with this issue would be much appreciated.

Jerome
_________________
Lenovo T60
Processor: Intel Core 2 Duo T7200
Graphics: Intel Mobile 945GM
Wireless: Atheros AR5212 NIC
Kernel: 2.6.25-gentoo-rc6 64-bit
Back to top
View user's profile Send private message
kevstar31
Guru
Guru


Joined: 22 Nov 2006
Posts: 449
Location: Ohio

PostPosted: Tue Sep 02, 2008 8:04 pm    Post subject: Reply with quote

Post a bug report at bugs.gentoo.org and besure to post the output of emerge --info as part of your report.
try remerging nvidia-glx and masking that particular version by:
Code:
echo "=gnome-extra/gtkhtml-2.11.1" >> /etc/portage/package.mask

and also masking the latest version of nvidia-glx that emerges may help also.
_________________
while(true) std::cout << "Jesus I trust in you." << std::endl;
My Political Compass
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Tue Sep 02, 2008 8:19 pm    Post subject: Reply with quote

Try doing eselect opengl xorg-x11 and then back to nvidia and see if it fixes the problem.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Maat Ghandi
n00b
n00b


Joined: 07 Jan 2008
Posts: 11
Location: Santa Cruz, CA

PostPosted: Wed Sep 03, 2008 2:35 pm    Post subject: Reply with quote

The only thing I'm confused about is that I don't have nvidia installed in the first place. I don't have an nvidia card. The only option I have for opengl is xorg-x11

Quote:

# eselect opengl list
Available OpenGL implementations:
[1] xorg-x11 *


When I search for packages with the keyword nvidia, I don't see an nvidia-glx package. But I don't want to install nvidia drivers. Even if there was one, I don't want to install it. Any other suggestions would be appreciated.

Jerome
_________________
Lenovo T60
Processor: Intel Core 2 Duo T7200
Graphics: Intel Mobile 945GM
Wireless: Atheros AR5212 NIC
Kernel: 2.6.25-gentoo-rc6 64-bit
Back to top
View user's profile Send private message
Maat Ghandi
n00b
n00b


Joined: 07 Jan 2008
Posts: 11
Location: Santa Cruz, CA

PostPosted: Fri Sep 05, 2008 5:21 pm    Post subject: Reply with quote

I posted a bug report here

https://bugs.gentoo.org/show_bug.cgi?id=236577
_________________
Lenovo T60
Processor: Intel Core 2 Duo T7200
Graphics: Intel Mobile 945GM
Wireless: Atheros AR5212 NIC
Kernel: 2.6.25-gentoo-rc6 64-bit
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum