Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.30.*) - Part 5
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Fri Jan 30, 2009 7:05 pm    Post subject: Reply with quote

I just made the jump to Paludis and I must admit I am not even sure where to start to fix the errors it throws. Can someone point me in the right direction to fix this?

I have an odd feeling it is one of those 'it's the ebuilds fault' you cant do anything about it.

Code:
cosmo2 ~ # paludis -pi everything --dl-reinstall always
paludis@1233342008: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/local/profiles/', falling back to generated name 'x-local' (ignore this message if you have yet to sync this repository).
paludis@1233342008: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/the-overlay/profiles/', falling back to generated name 'x-the-overlay' (ignore this message if you have yet to sync this repository).
paludis@1233342008: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/local/profiles/', falling back to generated name 'x-local' (ignore this message if you have yet to sync this repository).
paludis@1233342008: [QA e.repo_name.unusable] Couldn't open repo_name file in '/var/paludis/repositories/the-overlay/profiles/', falling back to generated name 'x-the-overlay' (ignore this message if you have yet to sync this repository).
Building target list...
Building dependency list...paludis@1233342028: [WARNING e.cache.save.failure] Not writing cache file to '/var/cache/paludis/metadata/dev-jokey/app-emulation/virtualbox-bin-2.1.2' due to exception 'Empty slot dependency specified' (paludis::PackageDepSpecError)

Unhandled exception:
  * In program paludis -pi everything --dl-reinstall always:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding NamedSetDepSpec 'everything':
  * When adding PackageDepSpec 'app-emulation/virtualbox-bin':
  * When adding package 'app-emulation/virtualbox-bin-2.1.2:0::dev-jokey':
  * When parsing metadata key 'RDEPEND' from 'app-emulation/virtualbox-bin-2.1.2:0::dev-jokey':
  * When parsing '!!app-emulation/virtualbox-ose !app-emulation/virtualbox-ose-additions ~app-emulation/virtualbox-modules-2.1.2 !headless? ( x11-libs/libXcursor media-libs/libsdl:[X] x11-libs/libXrender x11-libs/libXfixes media-libs/libmng media-libs/jpeg media-libs/libpng x11-libs/libXi x11-libs/libXrandr x11-libs/libXinerama x11-libs/libXft media-libs/freetype media-libs/fontconfig x11-libs/libXext dev-libs/glib chm? ( dev-libs/expat ) ) x11-libs/libXt dev-libs/libxml2 x11-libs/libXau x11-libs/libX11 x11-libs/libSM x11-libs/libICE x11-libs/libXdmcp sys-apps/usermode-utilities net-misc/bridge-utils x86? ( sys-libs/libstdc++-v3 ) ':
  * When parsing from offset '111':
  * When parsing from offset '144':
  * When parsing elike package dep spec 'media-libs/libsdl:[X]':
  * When parsing generic package dep spec 'media-libs/libsdl:[X]':
  * Empty slot dependency specified (paludis::PackageDepSpecError)


The repo_name messages I can handle when I paludis -s. But the messages about the virtaulbox-bin and RDEPEND mean nothing to me. I tried this, paludis -pi libsdl to see if there was a missing 'X' use flag but it looks fine to me.
Code:

These packages will be installed:

* media-libs/libsdl [R 1.2.13-r1] <target>
    X -aalib alsa -arts audio -custom-cflags -dga -directfb -esd -fbcon -ggi joystick -libcaca -nas -opengl -oss -pulseaudio (-svga) video -xinerama -xv build_options: -optional_tests split strip

Thanks for any assistance.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Sat Jan 31, 2009 3:32 pm    Post subject: Reply with quote

Hm, paludis just fucked up itself.

gcc update 4.3.2 -> 4.3.3:

Code:
<<<         /usr/lib64/gcc/x86_64-pc-linux-gnu/4.3.2/32/crtend.o                                                   
<<<         /usr/lib64/gcc/x86_64-pc-linux-gnu/4.3.2/32/crtbeginTS.o                                               
<<<         /usr/lib64/gcc/x86_64-pc-linux-gnu/4.3.2/32/crtbeginT.o                                                 
<<<         /usr/lib64/gcc/x86_64-pc-linux-gnu/4.3.2/32/crtbeginS.o                                                 
<<<         /usr/lib64/gcc/x86_64-pc-linux-gnu/4.3.2/32/crtbegin.o                                                 
--- [!empt] /usr/lib64/gcc/x86_64-pc-linux-gnu/4.3.2/32                                                             
--- [!empt] /usr/lib64/gcc/x86_64-pc-linux-gnu/4.3.2                                                               
--- [!empt] /usr/lib64/gcc/x86_64-pc-linux-gnu                                                                     
--- [!empt] /usr/lib64/gcc                                                                                         
--- [!type] /usr/lib                                                                                               
--- [!time] /usr/bin/x86_64-pc-linux-gnu-gcc-4.3.2                                                                 
--- [!time] /usr/bin/x86_64-pc-linux-gnu-g++-4.3.2                                                                 
--- [!time] /usr/bin/x86_64-pc-linux-gnu-cpp-4.3.2                                                                 
--- [!time] /usr/bin/x86_64-pc-linux-gnu-c++-4.3.2                                                                 
--- [!time] /usr/bin/gcc-4.3.2                                                                                     
--- [!time] /usr/bin/g++-4.3.2                                                                                     
--- [!time] /usr/bin/cpp-4.3.2                                                                                     
--- [!time] /usr/bin/c++-4.3.2                                                                                     
--- [!empt] /usr/bin                                                                                               
--- [!empt] /usr                                                                                                   
--- [cfgpr] /etc/eselect/compiler/x86_64-pc-linux-gnu-4.3.2.conf                                                   
--- [!empt] /etc/eselect/compiler                                                                                   
--- [!empt] /etc/eselect                                                                                           
--- [!md5 ] /etc/env.d/gcc/x86_64-pc-linux-gnu-4.3.2                                                               
--- [!empt] /etc/env.d/gcc                                                                                         
--- [!empt] /etc/env.d                                                                                             
--- [!empt] /etc                                                                                                   
locked_pipe_command: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Code:
# paludis -i1 gcc
/usr/bin/paludis: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Nice one!

env-update && source /etc/profile helps here. (If others stumble over this one)
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Tue Feb 03, 2009 8:30 pm    Post subject: Reply with quote

Is there somewhere I can learn how to make a set? I was thinking of making a toolchain set that I could use to rebuild the toolchain easily. Thanks for the help.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Tue Feb 03, 2009 10:19 pm    Post subject: Reply with quote

Basic paludis sets are easy

use * at the beginning of a line for a set
use ? for an package without a slot (foo/bar)
use ?: for a package with a slot (foo/bar:4.2)

There's the basics.

The file needs to have a .conf extension.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
kimrhh
n00b
n00b


Joined: 04 Feb 2009
Posts: 2

PostPosted: Wed Feb 04, 2009 11:35 am    Post subject: Paludis sets Reply with quote

Quote:

use * at the beginning of a line for a set
use ? for an package without a slot (foo/bar)
use ?: for a package with a slot (foo/bar:4.2)

There's the basics.


That is incorrect. Instead of posting misinformation you should point others to the relevant documentation:

http://paludis.pioto.org/configuration/sets.html
Back to top
View user's profile Send private message
pigeon768
l33t
l33t


Joined: 02 Jan 2006
Posts: 675

PostPosted: Mon Feb 09, 2009 2:56 pm    Post subject: Reply with quote

Error with paludis -i world --dl-reinstall always --continue-on-failure if-satisfied:
Code:
moamp ~ # grep -a '(unsatisfied' build.log
(558 of 946, 30 skipped, 3 failed) Skipping gnome-base/gdm-2.20.9:0::gentoo (unsatisfied 'virtual/pam')
(559 of 946, 31 skipped, 3 failed) Skipping x11-misc/xscreensaver-5.08:0::gentoo (unsatisfied 'virtual/pam')
(586 of 946, 32 skipped, 3 failed) Skipping kde-base/kdebase-kioslaves-4.2.0:4.2::gentoo (unsatisfied 'virtual/ssh')
(603 of 946, 33 skipped, 3 failed) Skipping dev-python/PyQt4-4.4.4-r2:0::gentoo (unsatisfied 'virtual/python')
(667 of 946, 34 skipped, 3 failed) Skipping sci-geosciences/gpsd-2.37:0::gentoo (unsatisfied 'virtual/dev-manager')
It happens occasionally without --dl-reinstall always, but I *believe* it only starts happening after a package fails - IOW I believe it's an error specific to --continue-on-failure if-satisfied.

There are threads on the paludis mailing list about it, but the complaints are somewhat non-specific. (no error messages, no analysis, no background)

edit: there are more skipped packages - at least 29 more, obviously - but build.log seems to be corrupted.
Back to top
View user's profile Send private message
Mr. Tao
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2007
Posts: 147

PostPosted: Tue Feb 10, 2009 1:05 am    Post subject: Reply with quote

I do use paludis for clean installation on new HD and I'm repeatedly facing the same problem. Some ebuilds (e.g. net-dns/avahi) in some parts (pkg_preinst in avahi's case) include instructions for adding new user/group in the system.

Unlike emerge, paludis doesn't seem to honor these instruction what is cause of nasty problems. Usually I have to run something like ebuild /usr/portage/net-dns/avahi/avahi-0.6.24.ebuild preinst to fix it. This is very annoying.

I wonder if I'm just missing something in configuration or the problem is in paludis itself.
Back to top
View user's profile Send private message
shazeal
Apprentice
Apprentice


Joined: 03 May 2006
Posts: 197
Location: New Zealand

PostPosted: Fri Feb 13, 2009 12:42 pm    Post subject: Reply with quote

I dont get this, portage had slotted phpmyadmin-3.1.1 and 3.1.2, I switched to paludis. And now when I try and do paludis -i -p world I get this...
Code:
 * In program paludis -i -p world:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding NamedSetDepSpec 'world':
  * When adding PackageDepSpec 'dev-db/phpmyadmin:3.1.1':
  * No versions of 'dev-db/phpmyadmin:3.1.1' are available.


So I uninstalled phpmyadmin:3.1.1 but the error still comes back, so I removed 3.1.2 as well same thing. I can install other stuff fine, but I cant run the update. Any ideas why its doing this?[/code]
Back to top
View user's profile Send private message
slangdaddy
n00b
n00b


Joined: 17 Jul 2007
Posts: 73
Location: Braunschweig

PostPosted: Fri Feb 13, 2009 2:49 pm    Post subject: Reply with quote

@shazeal You could check your world file for occurences of phpmyadmin.
Back to top
View user's profile Send private message
shazeal
Apprentice
Apprentice


Joined: 03 May 2006
Posts: 197
Location: New Zealand

PostPosted: Fri Feb 13, 2009 8:52 pm    Post subject: Reply with quote

Yup it was in there, backed it up and deleted the line. It all works great now thank you :)
Back to top
View user's profile Send private message
sternklang
Veteran
Veteran


Joined: 10 Sep 2005
Posts: 1641
Location: Somewhere in time and space

PostPosted: Sat Feb 14, 2009 4:33 pm    Post subject: Reply with quote

Current paludis now includes a manifest-creation utility, appareo. I've been eagerly awaiting this as my only use of the "ebuild" command is to generate manifests.

There is as yet nothing on the Paludis web site describing this in detail, and so far using the man page info I have not been able to get it to work. Trying to generate a manifest for an ebuild in my local repository fails:
Code:
$ sudo appareo --manifest tomboy-0.12.1.ebuild

Unhandled exception:
  * In program appareo --manifest tomboy-0.12.1.ebuild:
  * When loading profiles.desc:
  * E Repository configuration error: No profiles.desc found (maybe this repository is not synced, or maybe you need to specify its master (paludis::ERepositoryConfigurationError)

This repository doesn't sync and doesn't have it's own profiles.desc, so I tried this:
Code:
$ sudo appareo --manifest tomboy-0.12.1.ebuild --master-repository-name gentoo

Unhandled exception:
  * In program appareo --manifest tomboy-0.12.1.ebuild --master-repository-name gentoo:
  * When initialising NoConfigEnvironment at '/usr/local/overlays/myoverlay':
  * Repository 'myoverlay' depends upon 'gentoo', which is not configured (paludis::ConfigurationError)


There is indeed a gentoo.conf in /etc/paludis/repositories so I'm not sure what the issue is:
Code:
$ cat /etc/paludis/repositories/gentoo.conf
location = ${ROOT}/usr/portage
sync = rsync://rsync.us.gentoo.org/gentoo-portage
distdir = /usr/portage/distfiles
format = ebuild
names_cache = ${location}/.cache/names
write_cache = /var/cache/paludis/metadata

$ cat /etc/paludis/repositories/myportage.conf
location = ${ROOT}/usr/local/overlays/myoverlay
sync =
master_repository = gentoo
format = ebuild
names_cache = ${location}/.cache/names
write_cache = /var/cache/paludis/metadata
cache=/var/empty
importance = 10

Every other aspect of paludis usage works as expected so I believe my configuration is correct. Any help would be appreciated.
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Sat Feb 14, 2009 5:58 pm    Post subject: Reply with quote

sternklang wrote:
Current paludis now includes a manifest-creation utility, appareo. I've been eagerly awaiting this as my only use of the "ebuild" command is to generate manifests.

There is as yet nothing on the Paludis web site describing this in detail, and so far using the man page info I have not been able to get it to work. Trying to generate a manifest for an ebuild in my local repository fails:


Run:
Code:
# appareo --master-repository-name gentoo --extra-repository-dir /usr/portage BLAH


You can put this stuff in metadata/layout.conf too in the repository in question.
I like it a lot, since you can create all the manifests from the base directory instead of the ebuild directories, just -P name
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
sternklang
Veteran
Veteran


Joined: 10 Sep 2005
Posts: 1641
Location: Somewhere in time and space

PostPosted: Sat Feb 14, 2009 6:13 pm    Post subject: Reply with quote

cheater1034 wrote:
Run:
Code:
# appareo --master-repository-name gentoo --extra-repository-dir /usr/portage BLAH

Works perfectly, thanks!

cheater1034 wrote:
You can put this stuff in metadata/layout.conf too in the repository in question.

I'm not familiar with that config file, other than the entry in the appareo man page. Can you point me to further documentation on that? Also, neither gentoo portage nor any of the overlays I manage with playman seem to have such a file, so am I correct in assuming this is something new with appareo?
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Sat Feb 14, 2009 6:28 pm    Post subject: Reply with quote

It's used in exheres repositories too. I don't believe portage has any use for the layout.conf file like paludis does, anyway you can put masters = in layout.conf:
Code:
# cat layout.conf
masters = gentoo


I do not know if it exists or what the variable is for the location of the master, but I'm sure it's written somewhere i just haven't really looked.
(I don't understand why it doesn't use the repositories/conf file because it specifies location in there)

I would think masters = gentoo would make it look at repositories/gentoo.conf file but it doesnt work that way yet apparently.
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
kimrhh
n00b
n00b


Joined: 04 Feb 2009
Posts: 2

PostPosted: Sat Feb 14, 2009 8:11 pm    Post subject: Reply with quote

guys, you should really ask these question on the paludis user mailing list, you are not right about layout and configs
Back to top
View user's profile Send private message
taipan67
l33t
l33t


Joined: 04 Dec 2004
Posts: 866
Location: England (i'm told...)

PostPosted: Tue Feb 17, 2009 8:50 am    Post subject: Reply with quote

Please excuse what i'm sure will be a repeat question, but i'm buggered if i can find the answer anywhere i've looked... :oops:

Is there a Paludis equivalent to 'PORT_LOGDIR'? I'm using paludis for the first time, and one particular package, tango-icon-theme, installed successfully, but my file-manager, thunar, displays it's hideous fallback-icon far more frequently than it ought to, and i suspect that the icon-theme failed to install a lot of icons (there were countless messages highlighted in red which flashed by on the console too fast to read), but without a log of the installation i can't check what those highlighted messages said.

Thanks in advance. :wink:
_________________
"Anyone who goes to see a psychiatrist should have their head examined!"
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Tue Feb 17, 2009 2:13 pm    Post subject: Reply with quote

In program paludis -i world -p:
* When performing install action from command line:
* When executing install task:
* When building dependency list:
* When adding NamedSetDepSpec 'world':
* When adding PackageDepSpec 'app-mobilephone/obex-data-server':
* When adding package 'app-mobilephone/obex-data-server-0.3.4:0::gentoo':
* When adding build dependencies as pre dependencies:
* When adding PackageDepSpec '>=net-wireless/bluez-libs-3.13':
* When adding package 'net-wireless/bluez-libs-3.36:0::gentoo':
* When adding build dependencies as pre dependencies:
* When checking BlockDepSpec '!net-wireless/bluez':
* Block: net-wireless/bluez (paludis::BlockError)


any help?
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2843

PostPosted: Tue Feb 17, 2009 2:16 pm    Post subject: Reply with quote

You can only have bluez or bluez-libs + bluez-utils in system..
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Tue Feb 17, 2009 2:27 pm    Post subject: Reply with quote

SlashBeast wrote:
You can only have bluez or bluez-libs + bluez-utils in system..


so do i have to uninstall bluez-libs + bluez-utils? and i don't have both installed
bluez is a dependency of kde4 from kde-testing.

another question please.
how can i keyword the qt-live-all-kde from qting-edge?
paludis wants to downgrade to the portage version.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Tue Feb 17, 2009 3:45 pm    Post subject: Reply with quote

tranquilcool wrote:
SlashBeast wrote:
You can only have bluez or bluez-libs + bluez-utils in system..


so do i have to uninstall bluez-libs + bluez-utils? and i don't have both installed
bluez is a dependency of kde4 from kde-testing.

another question please.
how can i keyword the qt-live-all-kde from qting-edge?
paludis wants to downgrade to the portage version.



EDIT: SOLVED
unmasked;
app-mobilephone/obex-data-server

masked;
echo "x11-libs/qt" >> /etc/paludis/package_mask.conf
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
uvok
n00b
n00b


Joined: 14 Oct 2008
Posts: 26

PostPosted: Wed Feb 25, 2009 4:28 pm    Post subject: Reply with quote

I have a similar error like mikkoc had, but for me, it says
Code:
Ignoring run dependencies due to exception 'Error searching for 'virtual/xft': no available versions' (paludis::AllMaskedError)

Unfortunately, I cannot unnstall it, as there is no version available...

Full log is here btw:
http://dpaste.com/1002/
These
Code:
paludis@1235500715: [QA e.profile.no_match] (same context) No match for '->=gnome-base/gnome-desktop-2.24.0'. This usually indicates a bug in your profile.

errors are very annoying, too. How can I get rid off them?

paludis-info:
Code:

 # paludis --info
paludis 0.34.4
Paludis build information:
    Compiler:
        CXX:                   i686-pc-linux-gnu-g++ 4.3.3
        CXXFLAGS:               -O2 -march=i686 -pipe
        LDFLAGS:               -Wl,-O1
        DATE:                  2009-02-24T18:29:27+0100

    Libraries:
        C++ Library:           GNU libstdc++ 20090124

    Reduced Privs:
        reduced_uid:           115
        reduced_uid->name:     paludisbuild
        reduced_uid->dir:      /var/tmp/paludis
        reduced_gid:           1020
        reduced_gid->name:     paludisbuild

    Paths:
        DATADIR:               /usr/share
        LIBDIR:                /usr/lib
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc
        PYTHONINSTALLDIR:     
        RUBYINSTALLDIR:        /usr/lib/ruby/site_ruby/1.8/i686-linux

Environment:
    Format:                    paludis
    Config dir:                /etc/paludis
    World file:                /var/db/pkg/world

Repository installed-virtuals:
    format:                    installed_virtuals
    root:                      /

Repository virtuals:
    format:                    virtuals

Repository gentoo:
    format:                    ebuild
    location:                  /usr/portage
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /usr/portage/metadata/cache
    distdir:                   /var/portage/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/portage/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    names_cache:               /usr/portage/.cache/names
    newsdir:                   /usr/portage/metadata/news
    profile_eapi_when_unspecified: 0
    profiles:                  /usr/portage/profiles/default/linux/x86/2008.0/desktop
    securitydir:               /usr/portage/metadata/glsa
    setsdir:                   /usr/portage/sets
    sync:                      rsync://rsync.europe.gentoo.org/gentoo-portage
    sync_options:             
    use_manifest:              use
    write_cache:               /var/empty

Repository installed:
    format:                    vdb
    location:                  /var/db/pkg
    builddir:                  /var/tmp/paludis
    names_cache:               /var/db/pkg/.cache/names
    provides_cache:            /var/db/pkg/.cache/provides
    root:                      /
...


edit:
Okay, The xft message disappeared after I reinstalled qt-3; but still thereare these strange profile.no_match errors...


Last edited by uvok on Wed Feb 25, 2009 6:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Wed Feb 25, 2009 5:41 pm    Post subject: Reply with quote

uvok wrote:
I have a similar error like mikkoc had, but for me, it says
Code:
Ignoring run dependencies due to exception 'Error searching for 'virtual/xft': no available versions' (paludis::AllMaskedError)

Unfortunately, I cannot unnstall it, as there is no version available...

Full log is here btw:
http://dpaste.com/1002/
These
Code:
paludis@1235500715: [QA e.profile.no_match] (same context) No match for '->=gnome-base/gnome-desktop-2.24.0'. This usually indicates a bug in your profile.

errors are very annoying, too. How can I get rid off them?

paludis-info:
Code:

 # paludis --info
paludis 0.34.4
Paludis build information:
    Compiler:
        CXX:                   i686-pc-linux-gnu-g++ 4.3.3
        CXXFLAGS:               -O2 -march=i686 -pipe
        LDFLAGS:               -Wl,-O1
        DATE:                  2009-02-24T18:29:27+0100

    Libraries:
        C++ Library:           GNU libstdc++ 20090124

    Reduced Privs:
        reduced_uid:           115
        reduced_uid->name:     paludisbuild
        reduced_uid->dir:      /var/tmp/paludis
        reduced_gid:           1020
        reduced_gid->name:     paludisbuild

    Paths:
        DATADIR:               /usr/share
        LIBDIR:                /usr/lib
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc
        PYTHONINSTALLDIR:     
        RUBYINSTALLDIR:        /usr/lib/ruby/site_ruby/1.8/i686-linux

Environment:
    Format:                    paludis
    Config dir:                /etc/paludis
    World file:                /var/db/pkg/world

Repository installed-virtuals:
    format:                    installed_virtuals
    root:                      /

Repository virtuals:
    format:                    virtuals

Repository gentoo:
    format:                    ebuild
    location:                  /usr/portage
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /usr/portage/metadata/cache
    distdir:                   /var/portage/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/portage/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    names_cache:               /usr/portage/.cache/names
    newsdir:                   /usr/portage/metadata/news
    profile_eapi_when_unspecified: 0
    profiles:                  /usr/portage/profiles/default/linux/x86/2008.0/desktop
    securitydir:               /usr/portage/metadata/glsa
    setsdir:                   /usr/portage/sets
    sync:                      rsync://rsync.europe.gentoo.org/gentoo-portage
    sync_options:             
    use_manifest:              use
    write_cache:               /var/empty

Repository installed:
    format:                    vdb
    location:                  /var/db/pkg
    builddir:                  /var/tmp/paludis
    names_cache:               /var/db/pkg/.cache/names
    provides_cache:            /var/db/pkg/.cache/provides
    root:                      /
...


Would you be trying to install a virtualbox ebuild? If so yo have to delete that dep in the ebuild and appareo it.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Fri Feb 27, 2009 6:20 pm    Post subject: Reply with quote

/var/tmp/portage/sys-apps/paludis-0.34.5/work/paludis-0.34.5/paludis/selinux/.libs/libpaludisselinux_0.34.so.34)
make[5]: *** [inquisitio.1] Error 1
make[5]: *** Waiting for unfinished jobs....
mv -f .deps/inquisitio-key_extractor.Tpo .deps/inquisitio-key_extractor.Po
make[5]: Leaving directory `/var/tmp/portage/sys-apps/paludis-0.34.5/work/paludis-0.34.5/src/clients/inquisitio'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/portage/sys-apps/paludis-0.34.5/work/paludis-0.34.5/src/clients/inquisitio'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/sys-apps/paludis-0.34.5/work/paludis-0.34.5/src/clients'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-apps/paludis-0.34.5/work/paludis-0.34.5/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-apps/paludis-0.34.5/work/paludis-0.34.5'
make: *** [all] Error 2
*
* ERROR: sys-apps/paludis-0.34.5 failed.


errors with latest paludis.
any help?
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
uvok
n00b
n00b


Joined: 14 Oct 2008
Posts: 26

PostPosted: Sat Feb 28, 2009 12:00 pm    Post subject: Reply with quote

tranquilcool wrote:
...
errors with latest paludis.
any help?


Try Paludis 0.36
Furthermore, you can't see the error, try to paste more of the buildlog (maybe to a pastebin)
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Sat Feb 28, 2009 1:53 pm    Post subject: Reply with quote

uvok wrote:
tranquilcool wrote:
...
errors with latest paludis.
any help?


Try Paludis 0.36
Furthermore, you can't see the error, try to paste more of the buildlog (maybe to a pastebin)


paludis 0.36 compiles.
thanks!
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 5 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum