Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.30.*) - Part 5
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Fri Jan 08, 2010 7:09 am    Post subject: Reply with quote

i am using +kdeprefix. how do i tell paludis to use it?

thanks.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
justinkb
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 160

PostPosted: Fri Jan 08, 2010 7:32 am    Post subject: Reply with quote

i would just grep -F 'dev-python/' from "paludis -q installed-packages::installed"'s output (using paludis from git, otherwise use everything::installed)... surely you have grep installed ? ;)
_________________
~amd64 | gcc 4.4.2 | linux 2.6.33-git w/ alsa 1.0.22.1 and drm-radeon-testing | gnome(-light) 2.28.2 | xorg-x11 and xf86-video-ati from git
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Sun Jan 10, 2010 1:43 pm    Post subject: Reply with quote

tranquilcool wrote:
i am using +kdeprefix. how do i tell paludis to use it?

thanks.


nobody?
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sun Jan 10, 2010 1:49 pm    Post subject: Reply with quote

tranquilcool wrote:
tranquilcool wrote:
i am using +kdeprefix. how do i tell paludis to use it?

thanks.


nobody?


The same way you do every use flag. In use.conf.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Sun Jan 10, 2010 2:25 pm    Post subject: Reply with quote

loftwyr wrote:
tranquilcool wrote:
tranquilcool wrote:
i am using +kdeprefix. how do i tell paludis to use it?

thanks.


nobody?


The same way you do every use flag. In use.conf.


doesn't work because -kdeprefix is hardcoded in kde4.
in portage i obtain +kdeprefix editing /etc/portage/profile/use.mask.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
slangdaddy
n00b
n00b


Joined: 17 Jul 2007
Posts: 73
Location: Braunschweig

PostPosted: Sun Jan 10, 2010 3:01 pm    Post subject: Reply with quote

@tranquilcool

You need to create your own profile, e.g.:

in /etc/paludis/repositories/gentoo.conf
Code:
...
profiles = /usr/portage/profiles/default/linux/amd64/2008.0/desktop /etc/paludis/myProfile
...


The settings in /etc/paludis/myProfile will override those of /usr/portage/profiles/default/linux/amd64/2008.0/desktop.

Now create the folder /etc/paludis/myProfile and put the file use.mask in it, containing
Code:
-kdeprefix


Paths shoud be customized to your needs, of course.
Now you should be able to set kdeprefix via use.conf. I didn't actually try this on kdeprefix, though.
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sun Jan 10, 2010 3:23 pm    Post subject: Reply with quote

Maybe you should consider not using kdeprefix any longer? It will be unsupported soon I guess.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Sun Jan 10, 2010 3:34 pm    Post subject: Reply with quote

slangdaddy wrote:
@tranquilcool

You need to create your own profile, e.g.:

in /etc/paludis/repositories/gentoo.conf
Code:
...
profiles = /usr/portage/profiles/default/linux/amd64/2008.0/desktop /etc/paludis/myProfile
...


The settings in /etc/paludis/myProfile will override those of /usr/portage/profiles/default/linux/amd64/2008.0/desktop.

Now create the folder /etc/paludis/myProfile and put the file use.mask in it, containing
Code:
-kdeprefix


Paths shoud be customized to your needs, of course.
Now you should be able to set kdeprefix via use.conf. I didn't actually try this on kdeprefix, though.



thanks. that did it.

as a matter of fact i prefer using kdeprefix. i guess i'll continue to use it as long as it's supported.
i really don't see any good reason not to use it.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Tue Mar 09, 2010 7:21 pm    Post subject: Reply with quote

Anyone has an idea how to fix this:
Code:

paludis -u rdesktop
Building unmerge list... paludis@1268162273: [WARNING e.vdb.provides.no_package] In thread ID '25593':
  ... In program paludis (--show-reasons summary --show-use-descriptions new --continue-on-failure if-satisfied --dl-downgrade warning --log-level warning) -u rdesktop:
  ... When performing uninstall action from command line:
  ... When executing uninstall task:
  ... When looking for target 'net-misc/rdesktop':
  ... When adding 'net-misc/rdesktop-1.6.0-r4::installed' to the uninstall list:
  ... When adding things that depend upon 'net-misc/rdesktop-1.6.0-r4::installed':
  ... When collecting all installed packages:
  ... When finding provided packages for 'installed':
  ... No package available for 'sys-kernel/zen-sources 2.6.33_rc5_p1'


I get it on every paludis command. I guess its some orphan in pkg db, but i grepped for zen-sources and didn't find anything....

Thanks in advance.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Tue Mar 09, 2010 7:57 pm    Post subject: Reply with quote

Phlogiston wrote:
Anyone has an idea how to fix this:
Code:

  ... No package available for 'sys-kernel/zen-sources 2.6.33_rc5_p1'


I get it on every paludis command. I guess its some orphan in pkg db, but i grepped for zen-sources and didn't find anything....

Thanks in advance.


Have you tried uninstalling the package?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Tue Mar 09, 2010 9:46 pm    Post subject: Reply with quote

loftwyr wrote:
Phlogiston wrote:
Anyone has an idea how to fix this:
Code:

  ... No package available for 'sys-kernel/zen-sources 2.6.33_rc5_p1'


I get it on every paludis command. I guess its some orphan in pkg db, but i grepped for zen-sources and didn't find anything....

Thanks in advance.


Have you tried uninstalling the package?


Yes, its not installed at all, at least not that version.

The thing I remember is that I installed the new package while uninstalling this version.
Code:
 paludis -q zen-sources
paludis@1268171231: [WARNING e.vdb.provides.no_package] In thread ID '2415':
  ... In program paludis (--show-reasons summary --show-use-descriptions new --continue-on-failure if-satisfied --dl-downgrade warning --log-level warning) -q zen-sources:
  ... When performing query action from command line:
  ... When handling query 'zen-sources':
  ... When parsing user package dep spec 'zen-sources':
  ... When parsing generic package dep spec 'zen-sources':
  ... When disambiguating package name 'zen-sources':
  ... When finding all versions in some arbitrary order from packages matching */zen-sources with filter all matches filtered through all matches filtered through packages matching */*:
  ... When finding category names containing package 'zen-sources':
  ... When finding provided packages for 'installed':
  ... No package available for 'sys-kernel/zen-sources 2.6.33_rc5_p1'
* sys-kernel/zen-sources
    gentoo:                  2.6.30_p11(~) {:2.6.30_p11} 2.6.31_p8(~) {:2.6.31_p8} 2.6.31_p9(~) {:2.6.31_p9} 2.6.31_p10(~) {:2.6.31_p10} 2.6.31_p11(~) {:2.6.31_p11} 2.6.31_p12(~) {:2.6.31_p12} 2.6.32_p1(~) {:2.6.32_p1} 2.6.32_p2(~) {:2.6.32_p2} 2.6.32_p3(~) {:2.6.32_p3} 2.6.32_p4(~) {:2.6.32_p4} 2.6.32_p5(~) {:2.6.32_p5} 2.6.32_p6(~) {:2.6.32_p6} 2.6.32_p7(~) {:2.6.32_p7} (2.6.33_rc2_p1-r1)R(~) {:2.6.33_rc2_p1-r1} (2.6.33_rc4_p1)R(~) {:2.6.33_rc4_p1} 2.6.33_rc5_p1(~r) {:2.6.33_rc5_p1} (2.6.33_rc7_p1)R(~) {:2.6.33_rc7_p1} 2.6.33_p1(~) {:2.6.33_p1} (9999)K {:9999}                                                                                                                                           
    installed:               2.6.33_p1* {:2.6.33_p1}
    Description:             The Zen Kernel Sources v2.6
    Homepage:                http://zen-kernel.org
    License:                 GPL-2
    Installed time:          Mon Mar 08 18:06:40 CET 2010
    Use flags:               (-build) (symlink) Build Options: -trace
    From repositories:       gentoo
    Installed using:         paludis-0.44.1

Key to mask reasons:

* K: keyword
* R: repository
* r: repository (overridden)
* ~: keyword (unstable accepted)

_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Tue Mar 09, 2010 9:55 pm    Post subject: Reply with quote

Strange, the package is there according to the listing. Perhaps it's masked.

What happens if you specifically try to install it ( -p )?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Tue Mar 09, 2010 10:06 pm    Post subject: Reply with quote

loftwyr wrote:
Strange, the package is there according to the listing. Perhaps it's masked.

What happens if you specifically try to install it ( -p )?


I'm trying this now:
Code:
paludis -i =zen-sources-2.6.33_rc5_p1 && paludis -u =zen-sources-2.6.33_rc5_p1
Building target list... paludis@1268172325: [WARNING e.vdb.provides.no_package] In thread ID '2715':
  ... In program paludis (--show-reasons summary --show-use-descriptions new --continue-on-failure if-satisfied --dl-downgrade warning --log-level warning) -i =zen-sources-2.6.33_rc5_p1:
  ... When performing install action from command line:
  ... When adding install target '=zen-sources-2.6.33_rc5_p1':
  ... When parsing user package dep spec '=zen-sources-2.6.33_rc5_p1':
  ... When parsing generic package dep spec '=zen-sources-2.6.33_rc5_p1':
  ... When disambiguating package name 'zen-sources':
  ... When finding all versions in some arbitrary order from packages matching */zen-sources with filter all matches filtered through supports action install filtered through packages matching =*/*-2.6.33_rc5_p1:
  ... When finding category names containing package 'zen-sources':
  ... When loading names for virtuals repository:
  ... When finding provided packages for 'installed':
  ... No package available for 'sys-kernel/zen-sources 2.6.33_rc5_p1'

Building dependency list: ... 108 steps

These packages will be installed:

* sys-kernel/zen-sources :2.6.33_rc5_p1 [S 2.6.33_rc5_p1] <target>
    -build symlink build_options: -optional_tests -trace -preserve_work
    72.39 MBytes to download

Total: 1 package (1 in new slot), 72.39 MBytes to download

Checking for possible errors......


But there is something wrong with virtuals for installed as the messages says... but where is this?

/edit:

This fixed it!

However this error is weird:
Code:
>^> [obj] /usr/src/linux-2.6.33_rc5-zen1/crypto/zlib.c
>-> [dir] /usr/src/linux-2.6.33_rc5-zen1
>>> Running ebuild phases loadenv postinst saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting pkg_postinst

/var/tmp/paludis/sys-kernel-zen-sources-2.6.33_rc5_p1/temp/loadsaveenv: line 4463: cd: /var/tmp/paludis/sys-kernel-zen-sources-2.6.33_rc5_p1/work/linux-2.6.33_rc5-zen1: No such file or directory
 * If you are upgrading from a previous kernel, you may be interested
 * in the following document:
 *   - General upgrade guide: http://www.gentoo.org/doc/en/kernel-upgrade.xml

_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
pdfan
n00b
n00b


Joined: 03 May 2010
Posts: 6

PostPosted: Mon May 03, 2010 9:16 am    Post subject: what does [ignor] ,[obj], etc mean when paludis installs Reply with quote

what does [ignor] ,[obj], etc mean when paludis installs ?

the paludis man page does not show the meaning of those symbols, only let user to guess blindly.
Back to top
View user's profile Send private message
jmdennis
n00b
n00b


Joined: 15 May 2010
Posts: 4

PostPosted: Sun May 16, 2010 5:13 am    Post subject: Paludis permission problem Reply with quote

I am using the 0.46 version. This may have been answered in one of the parts but I get this error when I run the above command. I forgot to mention that I used portage2paludis and it created every folder correctly. I even followed the wiki on this to make sure that every thing was created and had the rights to it. I followed the guide on the link below. I was not able to get chown paludisbuild to work as I had to change it to chown paludisbuild:paludisbuild /var/db/pkg/.cache. I can install one application at a time but can not do any thing other then this. I love the idea of Paludis but I am unable to get it to work so far.

http://en.gentoo-wiki.com/wiki/Paludis/Installation

paludis@1273962131: [WARNING e.ebuild.userpriv_disabled] In thread ID '21609':
... In program paludis --install world:
... When performing install action from command line:
... When executing install task:
... When performing pretend actions:
... When fetching 'media-video/nvidia-settings-195.36.24:0::gentoo':
... When checking permissions on '/usr/portage/distfiles' for userpriv:
... Directory '/usr/portage/distfiles' owned by group 'portage', not 'paludisbuild', so cannot enable userpriv
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sun May 16, 2010 12:25 pm    Post subject: Reply with quote

just go into /usr/portage and run the following as root:
Code:

chown -r paludisbuild:paludisbuild *


and all will be well.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
jmdennis
n00b
n00b


Joined: 15 May 2010
Posts: 4

PostPosted: Mon May 17, 2010 5:47 am    Post subject: Thanks Reply with quote

Thanks for the command. I found out that I need to use an upper case r but other then that the command works great. I am still having problems but those are gentoo problems and not this commands fault. I look forward to using it more.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7
Page 7 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum