Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.30.*) - Part 5
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Thu Jan 01, 2009 11:22 am    Post subject: Reply with quote

H E L L O to everybody in New 2009 Year :).

I have a problem with upgrading paludis
Code:
sys-apps/paludis [U 0.32.3 -> 0.32.4]

paludis on configure stage complains about a boost.python
Code:
checking whether to build the python interface... yes
checking for a Python interpreter with version >= 2.3... python
checking for python... /usr/bin/python
checking for python version... 2.5
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.5/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.5/site-packages
checking whether your gcc is new enough to enable Python... yes
checking for headers required to compile python extensions... /usr/include/python2.5
checking for Python.h... yes
checking for Python installation dir... ${exec_prefix}/lib/python2.5/site-packages
checking for boost.python... no
configure: error: boost.python (http://www.boost.org/libs/python/doc/) is required. If you think you have boost.python, you may need to reinstall it if you have upgraded Python since installing Boost.                                                                                                         

!!! ERROR in sys-apps/paludis-0.32.4:
!!! In econf at line 1617           
!!! econf failed                     

!!! Call stack:
!!!    * econf (/var/tmp/paludis/sys-apps-paludis-0.32.4/temp/loadsaveenv:1617)
!!!    * src_compile (/var/tmp/paludis/sys-apps-paludis-0.32.4/temp/loadsaveenv:3665)
!!!    * ebuild_f_compile (/usr/libexec/paludis/0/src_compile.bash:49)               
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:482)                         
!!!    * main (/usr/libexec/paludis/ebuild.bash:498)                                 

diefunc: making ebuild PID 9005 exit with error
die trap: exiting with error.                 

In my system dev-libs/boost is installed in version 1.37
Code:
paludis --query boost
paludis@1230808545: [WARNING repository.blacklisted] Repository 'paludis-extras' is blacklisted with reason 'Repeatedly broken, full of highly buggy code and all round harmful. Do not use.'.
paludis@1230808545: [WARNING e.vdb.provides.no_package] In program paludis --query boost:
  ... When performing query action from command line:
  ... When handling query 'boost':
  ... When parsing user package dep spec 'boost':
  ... When parsing generic package dep spec 'boost':
  ... When disambiguating package name 'boost':
  ... When finding all versions in some arbitrary order from packages matching */boost with filter all matches filtered through all matches:
  ... When finding category names containing package 'boost':
  ... When finding provided packages for 'installed':
  ... No package available for 'app-cdr/cdrtools 2.01.01_alpha42'
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/gentoo-sources 2.6.25-r5'
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/gentoo-sources 2.6.25-r6'
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/gentoo-sources 2.6.27'
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/gentoo-sources 2.6.27-r1'
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/linux-headers 2.6.25-r4'
* dev-libs/boost
    gentoo:                  1.33.1-r1 1.34.1-r2 1.35.0-r1 1.35.0-r2 1.35.0-r3 {:0} 1.36.0 {:1.36} 1.37.0 {:1.37}
    installed:               1.37.0* {:1.37}
    Description:             Boost Libraries for C++
    Homepage:                http://www.boost.org/
    License:                 freedist Boost-1.0
    Installed time:          Tue Dec 30 13:14:01 2008
    Use flags:               (-debug) (-doc) (-expat) (-icu) (-mpi) (-tools)
    From repositories:       gentoo
    Installed using:         paludis-0.32.3

So I am confused, paludis complain about something which is installed, I have even reinstalled both python and boost but it doesn't help.

BTW as you can see paludis is showing me something like:
Code:
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/linux-headers 2.6.25-r4'

How can I remove this message, or rather the reason of this message.
_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Tue Jan 06, 2009 5:03 pm    Post subject: Reply with quote

Anyone has an idea about this:
Code:

/usr/bin/libtool: line 1170: /usr/libexec/paludis/utils/sed: No such file or directory                                         
: compile: cannot determine name of library object from `'                                                                     
make[1]: *** [strings/apr_cpystrn.lo] Error 1                                                                                 
make[1]: *** Waiting for unfinished jobs....                                                                                   
/usr/bin/libtool: line 1170: /usr/libexec/paludis/utils/sed: No such file or directory                                         
/usr/bin/libtool: line 1170: /usr/libexec/paludis/utils/sed: No such file or directory                                         
/usr/bin/libtool: line 1117: /usr/libexec/paludis/utils/sed: No such file or directory                                         
: compile: cannot determine name of library object from `'                                                                     
make[1]: *** [strings/apr_strnatcmp.lo] Error 1                                                                               
: compile: cannot determine name of library object from `'                                                                     
make[1]: *** [passwd/apr_getpass.lo] Error 1                                                                                   
/usr/bin/libtool: line 1117: /usr/libexec/paludis/utils/sed: No such file or directory                                         
/usr/bin/libtool: line 1170: /usr/libexec/paludis/utils/sed: No such file or directory                                         
: compile: cannot determine name of library object from `'                                                                     
make[1]: *** [strings/apr_strings.lo] Error 1                                                                                 
make[1]: Leaving directory `/tmp/PALUDIS/var_tmp/dev-libs-apr-1.3.3/work/apr-1.3.3'                                           
make: *** [all-recursive] Error 1                                                                                             
/usr/libexec/paludis/utils/emake: emake returned error 2 


It seems to only happen on that package...
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
alligator421
Apprentice
Apprentice


Joined: 30 Jul 2003
Posts: 191

PostPosted: Thu Jan 08, 2009 2:26 pm    Post subject: Reply with quote

Phlogiston wrote:
Anyone has an idea about this:
...


I stepped on this stuff too.
Re-emerge (well re-paludis) libtool and it is fine after.
Back to top
View user's profile Send private message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 325
Location: Sweden

PostPosted: Thu Jan 08, 2009 2:36 pm    Post subject: Reply with quote

alligator421 wrote:
Re-emerge (well re-paludis)
Re-palude? :lol:
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Sun Jan 11, 2009 10:11 am    Post subject: Reply with quote

phoenix_me wrote:
H E L L O to everybody in New 2009 Year :).

I have a problem with upgrading paludis
Code:
sys-apps/paludis [U 0.32.3 -> 0.32.4]

paludis on configure stage complains about a boost.python
Code:
checking whether to build the python interface... yes
checking for a Python interpreter with version >= 2.3... python
checking for python... /usr/bin/python
checking for python version... 2.5
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.5/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.5/site-packages
checking whether your gcc is new enough to enable Python... yes
checking for headers required to compile python extensions... /usr/include/python2.5
checking for Python.h... yes
checking for Python installation dir... ${exec_prefix}/lib/python2.5/site-packages
checking for boost.python... no
configure: error: boost.python (http://www.boost.org/libs/python/doc/) is required. If you think you have boost.python, you may need to reinstall it if you have upgraded Python since installing Boost.                                                                                                         

!!! ERROR in sys-apps/paludis-0.32.4:
!!! In econf at line 1617           
!!! econf failed                     

!!! Call stack:
!!!    * econf (/var/tmp/paludis/sys-apps-paludis-0.32.4/temp/loadsaveenv:1617)
!!!    * src_compile (/var/tmp/paludis/sys-apps-paludis-0.32.4/temp/loadsaveenv:3665)
!!!    * ebuild_f_compile (/usr/libexec/paludis/0/src_compile.bash:49)               
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:482)                         
!!!    * main (/usr/libexec/paludis/ebuild.bash:498)                                 

diefunc: making ebuild PID 9005 exit with error
die trap: exiting with error.                 

In my system dev-libs/boost is installed in version 1.37
Code:
paludis --query boost
paludis@1230808545: [WARNING repository.blacklisted] Repository 'paludis-extras' is blacklisted with reason 'Repeatedly broken, full of highly buggy code and all round harmful. Do not use.'.
paludis@1230808545: [WARNING e.vdb.provides.no_package] In program paludis --query boost:
  ... When performing query action from command line:
  ... When handling query 'boost':
  ... When parsing user package dep spec 'boost':
  ... When parsing generic package dep spec 'boost':
  ... When disambiguating package name 'boost':
  ... When finding all versions in some arbitrary order from packages matching */boost with filter all matches filtered through all matches:
  ... When finding category names containing package 'boost':
  ... When finding provided packages for 'installed':
  ... No package available for 'app-cdr/cdrtools 2.01.01_alpha42'
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/gentoo-sources 2.6.25-r5'
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/gentoo-sources 2.6.25-r6'
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/gentoo-sources 2.6.27'
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/gentoo-sources 2.6.27-r1'
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/linux-headers 2.6.25-r4'
* dev-libs/boost
    gentoo:                  1.33.1-r1 1.34.1-r2 1.35.0-r1 1.35.0-r2 1.35.0-r3 {:0} 1.36.0 {:1.36} 1.37.0 {:1.37}
    installed:               1.37.0* {:1.37}
    Description:             Boost Libraries for C++
    Homepage:                http://www.boost.org/
    License:                 freedist Boost-1.0
    Installed time:          Tue Dec 30 13:14:01 2008
    Use flags:               (-debug) (-doc) (-expat) (-icu) (-mpi) (-tools)
    From repositories:       gentoo
    Installed using:         paludis-0.32.3

So I am confused, paludis complain about something which is installed, I have even reinstalled both python and boost but it doesn't help.

BTW as you can see paludis is showing me something like:
Code:
paludis@1230808545: [WARNING e.vdb.provides.no_package] (same context) No package available for 'sys-kernel/linux-headers 2.6.25-r4'

How can I remove this message, or rather the reason of this message.


if you have gcc-4.4.... you have to revert to earlier gcc version
to compile without the boost errors.


you remove the no available in /var/cache/paludis/provides or wherever you have
provides (check your repositories configurations)
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
Paapaa
l33t
l33t


Joined: 14 Aug 2005
Posts: 955
Location: Finland

PostPosted: Mon Jan 12, 2009 11:37 am    Post subject: Reply with quote

Trying to install gvim-7.2 for amd64. I get this:

Code:
  * File 'vim-7.2.tar.bz2': failed integrity checks: Incorrect file size


Can I file a bug report or could this ever be Paludis issue?
_________________
Paludis, the way packages are meant to be managed.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Jan 12, 2009 12:43 pm    Post subject: Reply with quote

Have you tried deleting the file out of /usr/portage/distfiles and re-downloading it? If yes, then I usually just delete the Manifest file out of the repository for that package and install it anyway.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Paapaa
l33t
l33t


Joined: 14 Aug 2005
Posts: 955
Location: Finland

PostPosted: Mon Jan 12, 2009 6:51 pm    Post subject: Reply with quote

Thanks. Deleting the file and reinstalling fixed this. But is this a situation which should NOT occur if everything is done properly. Ie. if the source package size is changed, should Paludis detect the case and operate accordingly? Or is this caused by ebuild developer or what?
_________________
Paludis, the way packages are meant to be managed.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Jan 12, 2009 10:19 pm    Post subject: Reply with quote

The manifest is generated by the ebuild dev and if it changes, they usually only fix it if there's a bug listed. Paludis can do nothing.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Phobos666
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2006
Posts: 76
Location: Germany

PostPosted: Sun Jan 18, 2009 2:28 pm    Post subject: Reply with quote

since paludis-extra is closed
Quote:
NOTE: Paludis-extras is in the trasformation period atm. It probably wont be available as a repository any more. The collection of scripts will still be available for view, so you will be able to use it as you wish, if you wish. Changes will be done shortly. Rsync server is down now.
... how can I update eix WITH the overlays configured by paludis?
Back to top
View user's profile Send private message
mikkoc
Apprentice
Apprentice


Joined: 24 May 2007
Posts: 231

PostPosted: Sun Jan 18, 2009 2:49 pm    Post subject: Reply with quote

How to get rid of this warning?

Code:

  ... When adding PackageDepSpec '>=x11-libs/gtk+-2':                                             
  ... When adding installed package 'x11-libs/gtk+-2.14.7:2::installed':                         
  ... When adding run dependencies as post dependencies:                                         
  ... When adding PackageDepSpec '>=x11-libs/pango-1.20':                                         
  ... When adding installed package 'x11-libs/pango-1.20.5:0::installed':                         
  ... When adding run dependencies as post dependencies:                                         
  ... When adding PackageDepSpec '>=x11-libs/cairo-1.2.6':                                       
  ... When adding installed package 'x11-libs/cairo-1.6.4-r1:0::installed':                       
  ... When adding run dependencies as post dependencies:                                         
  ... When adding PackageDepSpec 'virtual/xft':                                                   
  ... No visible packages matching 'virtual/xft', falling back to installed package 'virtual/xft-7.0::installed
Back to top
View user's profile Send private message
slangdaddy
n00b
n00b


Joined: 17 Jul 2007
Posts: 73
Location: Braunschweig

PostPosted: Sun Jan 18, 2009 3:38 pm    Post subject: Reply with quote

mikkoc, please see http://lists.pioto.org/pipermail/paludis-user/2009-January/000777.html

btw. the paludis mailing list are very helpful in general ...
Back to top
View user's profile Send private message
mikkoc
Apprentice
Apprentice


Joined: 24 May 2007
Posts: 231

PostPosted: Sun Jan 18, 2009 4:20 pm    Post subject: Reply with quote

Thanks, that worked :)
Back to top
View user's profile Send private message
Phobos666
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2006
Posts: 76
Location: Germany

PostPosted: Mon Jan 19, 2009 10:49 pm    Post subject: Reply with quote

I think I found a bug in latest paludis.
When I compiled xine-lib with following useflags:
Code:
These packages will be installed:

* media-libs/xine-lib :1 [N 1.1.16.1] <target>
    X a52 -aac -aalib alsa (-altivec) -arts -debug -directfb dts dvd -dxr3 -esd -fbcon flac -gnome gtk imagemagick -ipv6 -jack -libcaca mad -mmap mng modplug musepack nls opengl -oss -pulseaudio (-real) samba sdl -speex theora truetype v4l vcd (-vidix) (-vis) vorbis -wavpack (-win32codecs) xcb xinerama xv xvmc build_options: -optional_tests split strip
    "Core libraries for Xine movie player"


It ends up with an error. When I emerge it with portage (using it after 2 years the first time again and have added the same useflags as paludis) it compiles fine. The error in paludis:
Code:
 gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils -I../../../src/input -I../../../src/input -I../../../lib -I../../../lib -fvisibility=hidden -fomit-frame-pointer -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -march=native -O2 -pipe -msse3 -frename-registers -ffunction-sections -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -c boxblur.c  -fPIC -DPIC -o .libs/xineplug_post_planar_la-boxblur.o
 gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils -I../../../src/input -I../../../src/input -I../../../lib -I../../../lib -fvisibility=hidden -fomit-frame-pointer -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -march=native -O2 -pipe -msse3 -frename-registers -ffunction-sections -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -c denoise3d.c  -fPIC -DPIC -o .libs/xineplug_post_planar_la-denoise3d.o
/bin/sh ../../../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils  -I../../../src/input -I../../../src/input  -I../../../lib -I../../../lib   -fvisibility=hidden   -fomit-frame-pointer `echo -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE  -march=native -O2 -pipe -msse3 -frename-registers -ffunction-sections -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG | sed -e 's/-O0\?\s/-Os /g'` -c -o xineplug_post_planar_la-eq2.lo `test -f 'eq2.c' || echo './'`eq2.c
/bin/sh ../../../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils  -I../../../src/input -I../../../src/input  -I../../../lib -I../../../lib   -fvisibility=hidden   -fomit-frame-pointer -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE  -march=native -O2 -pipe -msse3 -frename-registers -ffunction-sections -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -c -o xineplug_post_planar_la-unsharp.lo `test -f 'unsharp.c' || echo './'`unsharp.c
 gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils -I../../../src/input -I../../../src/input -I../../../lib -I../../../lib -fvisibility=hidden -fomit-frame-pointer -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -march=native -O2 -pipe -msse3 -frename-registers -ffunction-sections -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -c eq.c  -fPIC -DPIC -o .libs/xineplug_post_planar_la-eq.o
/bin/sh ../../../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils  -I../../../src/input -I../../../src/input  -I../../../lib -I../../../lib   -fvisibility=hidden   -fomit-frame-pointer -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE  -march=native -O2 -pipe -msse3 -frename-registers -ffunction-sections -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -c -o xineplug_post_planar_la-pp.lo `test -f 'pp.c' || echo './'`pp.c
 gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils -I../../../src/input -I../../../src/input -I../../../lib -I../../../lib -fvisibility=hidden -fomit-frame-pointer -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -march=native -O2 -pipe -msse3 -frename-registers -ffunction-sections -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -c eq2.c  -fPIC -DPIC -o .libs/xineplug_post_planar_la-eq2.o
 gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils -I../../../src/input -I../../../src/input -I../../../lib -I../../../lib -fvisibility=hidden -fomit-frame-pointer -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -march=native -O2 -pipe -msse3 -frename-registers -ffunction-sections -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -c unsharp.c  -fPIC -DPIC -o .libs/xineplug_post_planar_la-unsharp.o
/bin/sh ../../../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils  -I../../../src/input -I../../../src/input  -I../../../lib -I../../../lib   -fvisibility=hidden   -fomit-frame-pointer `echo -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE  -march=native -O2 -pipe -msse3 -frename-registers -ffunction-sections -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG | sed -e 's/-O0\?\s/-Os /g'` -c -o xineplug_post_planar_la-noise.lo `test -f 'noise.c' || echo './'`noise.c
 gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils -I../../../src/input -I../../../src/input -I../../../lib -I../../../lib -fvisibility=hidden -fomit-frame-pointer -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -march=native -O2 -pipe -msse3 -frename-registers -ffunction-sections -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -c pp.c  -fPIC -DPIC -o .libs/xineplug_post_planar_la-pp.o
 gcc -DHAVE_CONFIG_H -I. -I../../../include -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils -I../../../src/input -I../../../src/input -I../../../lib -I../../../lib -fvisibility=hidden -fomit-frame-pointer -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -march=native -O2 -pipe -msse3 -frename-registers -ffunction-sections -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -c noise.c  -fPIC -DPIC -o .libs/xineplug_post_planar_la-noise.o
pp.c: In function 'pp_draw':
pp.c:336: warning: passing argument 1 of 'pp_postprocess' from incompatible pointer type
noise.c: Assembler messages:
noise.c:155: Error: suffix or operands invalid for `mov'
noise.c:161: Error: `(%rsi,%eax)' is not a valid base/index expression
noise.c:162: Error: `(%r10,%eax)' is not a valid base/index expression
noise.c:166: Error: `(%rdi,%eax)' is not a valid base/index expression
noise.c:182: Error: suffix or operands invalid for `mov'
noise.c:188: Error: `(%rsi,%eax)' is not a valid base/index expression
noise.c:189: Error: `(%r10,%eax)' is not a valid base/index expression
noise.c:193: Error: `(%rdi,%eax)' is not a valid base/index expression
noise.c:224: Error: suffix or operands invalid for `mov'
noise.c:227: Error: `(%rsi,%eax)' is not a valid base/index expression
noise.c:228: Error: `(%rbx,%eax)' is not a valid base/index expression
noise.c:229: Error: `(%r11,%eax)' is not a valid base/index expression
noise.c:230: Error: `(%r10,%eax)' is not a valid base/index expression
noise.c:246: Error: `(%rdi,%eax)' is not a valid base/index expression
make[3]: *** [xineplug_post_planar_la-noise.lo] Error 1
make[3]: Leaving directory `/var/tmp/paludis/media-libs-xine-lib-1.1.16.1/work/xine-lib-1.1.16.1/src/post/planar'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/paludis/media-libs-xine-lib-1.1.16.1/work/xine-lib-1.1.16.1/src/post'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/paludis/media-libs-xine-lib-1.1.16.1/work/xine-lib-1.1.16.1/src'
make: *** [all-recursive] Error 1
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in media-libs/xine-lib-1.1.16.1:
!!! In src_compile at line 3941
!!! emake failed.


Paludis info:
Code:
root@nukebox ~ # paludis --info                                                                                                                                                                          18:03:26
paludis 0.34.0_alpha2
Paludis build information:
    Compiler:
        CXX:                   x86_64-pc-linux-gnu-g++ 4.3.2
        CXXFLAGS:               -march=athlon64 -O2 -pipe -msse3
        LDFLAGS:               -Wl,-O1
        DATE:                  2009-01-17T16:32:27+0100

    Libraries:
        C++ Library:           GNU libstdc++ 20080827

    Reduced Privs:
        reduced_uid:           102
        reduced_uid->name:     paludisbuild
        reduced_uid->dir:      /var/tmp/paludis
        reduced_gid:           440
        reduced_gid->name:     paludisbuild

    Paths:
        DATADIR:               /usr/share
        LIBDIR:                /usr/lib64
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc
        PYTHONINSTALLDIR:     
        RUBYINSTALLDIR:        /usr/lib64/ruby/site_ruby/1.8/x86_64-linux

Environment:
    Format:                    paludis
    Config dir:                /etc/paludis
    World file:                /var/db/pkg/world

Repository layman:
    format:                    unavailable
    location:                  /var/db/paludis/repositories/layman
    sync:                      tar+http://git.exherbo.org/layman_repositories.tar.bz2
    sync_options:             

Repository installed-virtuals:
    format:                    installed_virtuals
    root:                      /

Repository virtuals:
    format:                    virtuals

Repository gentoo:
    format:                    ebuild
    location:                  /usr/portage
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /usr/portage/metadata/cache
    distdir:                   /usr/portage/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/portage/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    names_cache:               /var/cache/paludis/names
    newsdir:                   /usr/portage/metadata/news
    profile_eapi_when_unspecified: 0
    profiles:                  /usr/portage/profiles/default/linux/amd64/2008.0/desktop
    securitydir:               /usr/portage/metadata/glsa
    setsdir:                   /usr/portage/sets
    sync:                      rsync://rsync.gentoo.org/gentoo-portage
    sync_options:             
    use_manifest:              use
    write_cache:               /var/cache/paludis/metadata

    Package information:
        app-admin/eselect-compiler: (none)
        app-shells/bash:       3.2_p39
        dev-java/java-config:  1.3.7-r1 2.1.6-r1
        dev-lang/python:       2.4.4-r13 2.5.2-r7
        dev-python/pycrypto:   2.0.1-r6
        dev-util/ccache:       2.4-r7
        dev-util/cmake:        2.6.2-r1
        dev-util/confcache:    (none)
        sys-apps/baselayout:   2.0.0
        sys-apps/openrc:       0.4.2
        sys-apps/sandbox:      1.2.18.1-r2
        sys-devel/autoconf:    2.13 2.63
        sys-devel/automake:    1.10.2 1.4_p6 1.5 1.7.9-r1 1.8.5-r3 1.9.6-r2
        sys-devel/binutils:    2.19
        sys-devel/gcc-config:  1.4.0-r4
        sys-devel/libtool:     1.5.26
        virtual/os-headers:    2.6.27-r2 (for sys-kernel/linux-headers::installed)

Repository installed:
    format:                    vdb
    location:                  /var/db/pkg
    builddir:                  /var/tmp/paludis
    names_cache:               /var/db/pkg/.cache/names
    provides_cache:            /var/db/pkg/.cache/provides
    root:                      /

Repository berkano:
    format:                    ebuild
    location:                  /var/paludis/repositories/berkano
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /var/empty
    distdir:                   /usr/portage/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/portage/eclass /var/paludis/repositories/berkano/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    master_repository:         gentoo
    names_cache:               /var/cache/paludis/names
    newsdir:                   /var/paludis/repositories/berkano/metadata/news
    profile_eapi_when_unspecified: 0
    profiles:                  /usr/portage/profiles/default/linux/amd64/2008.0/desktop
    securitydir:               /var/paludis/repositories/berkano/metadata/glsa
    setsdir:                   /var/paludis/repositories/berkano/sets
    sync:                      svn+http://svn.liveforge.org/berkano/trunk
    sync_options:             
    use_manifest:              use
    write_cache:               /var/cache/paludis/metadata

Repository kde:
    format:                    ebuild
    location:                  /var/paludis/repositories/kde-testing
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /var/empty
    distdir:                   /usr/portage/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/portage/eclass /var/paludis/repositories/kde-testing/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    master_repository:         gentoo
    names_cache:               /var/cache/paludis/names
    newsdir:                   /var/paludis/repositories/kde-testing/metadata/news
    profile_eapi_when_unspecified: 0
    profiles:                  /usr/portage/profiles/default/linux/amd64/2008.0/desktop
    securitydir:               /var/paludis/repositories/kde-testing/metadata/glsa
    setsdir:                   /var/paludis/repositories/kde-testing/sets
    sync:                      git://git.overlays.gentoo.org/proj/kde.git
    sync_options:             
    use_manifest:              use
    write_cache:               /var/cache/paludis/metadata

Repository portage-disturbed:
    format:                    ebuild
    location:                  /usr/portage-disturbed
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /var/empty
    distdir:                   /usr/portage/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/portage/eclass /usr/portage-disturbed/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    master_repository:         gentoo
    names_cache:               /var/cache/paludis/names
    newsdir:                   /usr/portage-disturbed/metadata/news
    profile_eapi_when_unspecified: 0
    profiles:                  /usr/portage/profiles/default/linux/amd64/2008.0/desktop
    securitydir:               /usr/portage-disturbed/metadata/glsa
    setsdir:                   /usr/portage-disturbed/sets
    sync:                     
    sync_options:             
    use_manifest:              use
    write_cache:               /var/cache/paludis/metadata

Repository proaudio:
    format:                    ebuild
    location:                  /var/paludis/repositories/pro-audio
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /var/empty
    distdir:                   /usr/portage/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/portage/eclass /var/paludis/repositories/pro-audio/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    master_repository:         gentoo
    names_cache:               /var/cache/paludis/names
    newsdir:                   /var/paludis/repositories/pro-audio/metadata/news
    profile_eapi_when_unspecified: 0
    profiles:                  /usr/portage/profiles/default/linux/amd64/2008.0/desktop
    securitydir:               /var/paludis/repositories/pro-audio/metadata/glsa
    setsdir:                   /var/paludis/repositories/pro-audio/sets
    sync:                      svn://svn.tuxfamily.org/svnroot/proaudio/proaudio/trunk/overlays/proaudio
    sync_options:             
    use_manifest:              use
    write_cache:               /var/cache/paludis/metadata

Repository secondlife:
    format:                    ebuild
    location:                  /var/paludis/repositories/secondlife
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /var/empty
    distdir:                   /usr/portage/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/portage/eclass /var/paludis/repositories/secondlife/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    master_repository:         gentoo
    names_cache:               /var/paludis/repositories/secondlife/.cache/names
    newsdir:                   /var/paludis/repositories/secondlife/metadata/news
    profile_eapi_when_unspecified: 0
    profiles:                  /usr/portage/profiles/default/linux/amd64/2008.0/desktop
    securitydir:               /var/paludis/repositories/secondlife/metadata/glsa
    setsdir:                   /var/paludis/repositories/secondlife/sets
    sync:                      svn+http://overlays.gentoo.org/svn/dev/matsuu/secondlife/
    sync_options:             
    use_manifest:              use
    write_cache:               /var/cache/paludis/metadata

No packages were specified on the command line, so detailed information is not
available (Paludis can display detailed information for both installed and
installable packages).


Please correct me if its not a bug but I ended up with it.
Back to top
View user's profile Send private message
netshade
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2004
Posts: 84
Location: Sweden

PostPosted: Sun Jan 25, 2009 9:52 am    Post subject: Reply with quote

I'm sorry if this question has been answered elsewhere, but I seem to be unable to find it.
Whatever happened to
Code:
playman
? I'm pretty sure it used to ship with paludis since they removed it from portage, but I can't find it. Is it replaced? Disbanded? Is my system b0rked? (That's the usual answer... :oops: ) Or is it me lacking a few grey ones? :roll:

Thanks for your patience with me. :)
_________________
From where the shadows turn into nightmare, netshade greets you...
Back to top
View user's profile Send private message
mikkoc
Apprentice
Apprentice


Joined: 24 May 2007
Posts: 231

PostPosted: Sun Jan 25, 2009 10:37 am    Post subject: Reply with quote

you need to compile paludis with ruby use flag
Back to top
View user's profile Send private message
netshade
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2004
Posts: 84
Location: Sweden

PostPosted: Sun Jan 25, 2009 10:58 am    Post subject: Reply with quote

Ow, flagname change.. :) I had ruby set, but it seems to be called ruby-bindings now... Thanks!
_________________
From where the shadows turn into nightmare, netshade greets you...
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2843

PostPosted: Tue Jan 27, 2009 9:34 am    Post subject: Reply with quote

Can someone tar and upload somewhere paludis-extras overlay? I need paludis-supported portage-utils.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Jan 28, 2009 8:52 am    Post subject: Reply with quote

Code:
# paludis -i kdebase-meta:4.2 kmail:4.2 gwenview:4.2                                                                         
Building target list...                                                                                                                       
Unhandled exception:                                                                                                                         
  * In program paludis (--log-level warning) -i kdebase-meta:4.2 kmail:4.2 gwenview:4.2:                                                     
  * When performing install action from command line:                                                                                         
  * When adding install target 'gwenview:4.2':                                                                                               
  * When parsing user package dep spec 'gwenview:4.2':                                                                                       
  * When parsing generic package dep spec 'gwenview:4.2':                                                                                     
  * When disambiguating package name 'gwenview':                                                                                             
  * Ambiguous package name 'gwenview' (candidates are kde-base/gwenview, media-gfx/gwenview) (paludis::AmbiguousPackageNameError)

There is no 4.2-SLOT for gwenview, so the package is not ambigious.
So please could the SLOT be considered while disambiguating the package?
Back to top
View user's profile Send private message
numerodix
l33t
l33t


Joined: 18 Jul 2002
Posts: 743
Location: nl.eu

PostPosted: Wed Jan 28, 2009 11:07 pm    Post subject: Reply with quote

Hello understanding paludis gurus (hopefully),

Could you tell me how to install kde 4.2? It's my understanding the ebuilds are in the tree, masked. And the thing is I want the ebuilds in the tree, not an overlay (personal preference).

Right now I have kde 3.5.10.

This guide: http://www.gentoo.org/proj/en/desktop/kde/kde4-guide.xml
says to do stuff like "emerge @kde". Now I'm sure paludis has sets too but I don't know how they work and I've never used them.

If you could just tell me the simplest thing that works, and I don't mind if it means installing all of kde 4.2.

(The reason I ask is because I've tried messing with kde4 through overlays before and that never got me anywhere so I just want to know the path of least resistance.)

Now for unmasking. Would something like
Code:
*/*:4.2

work?

Lastly, how do I do "layman -d" with playman?
_________________
undvd - ripping dvds should be as simple as unzip
Back to top
View user's profile Send private message
Ampheus
l33t
l33t


Joined: 19 Oct 2005
Posts: 814
Location: Rheine, NRW, Germany

PostPosted: Thu Jan 29, 2009 12:06 am    Post subject: Reply with quote

numerodix wrote:
Hello understanding paludis gurus (hopefully),

Could you tell me how to install kde 4.2? It's my understanding the ebuilds are in the tree, masked. And the thing is I want the ebuilds in the tree, not an overlay (personal preference).

Right now I have kde 3.5.10.

This guide: http://www.gentoo.org/proj/en/desktop/kde/kde4-guide.xml
says to do stuff like "emerge @kde". Now I'm sure paludis has sets too but I don't know how they work and I've never used them.

If you could just tell me the simplest thing that works, and I don't mind if it means installing all of kde 4.2.

(The reason I ask is because I've tried messing with kde4 through overlays before and that never got me anywhere so I just want to know the path of least resistance.)

Now for unmasking. Would something like
Code:
*/*:4.2

work?

Lastly, how do I do "layman -d" with playman?


I posted a little guide to do this in Desktop Environments -> Kde 4.2
_________________
Für alle doubleposter ;)
Back to top
View user's profile Send private message
numerodix
l33t
l33t


Joined: 18 Jul 2002
Posts: 743
Location: nl.eu

PostPosted: Thu Jan 29, 2009 12:24 am    Post subject: Reply with quote

Ampheus wrote:
I posted a little guide to do this in Desktop Environments -> Kde 4.2


Uh, in reference to your post there, what does the arrow "->" in
Code:
*/*::kde->

mean?
_________________
undvd - ripping dvds should be as simple as unzip
Back to top
View user's profile Send private message
Ampheus
l33t
l33t


Joined: 19 Oct 2005
Posts: 814
Location: Rheine, NRW, Germany

PostPosted: Thu Jan 29, 2009 12:46 am    Post subject: Reply with quote

That's a really good question. I just found out that you have to use it when uninstalling things this way. Try the expression with 'paludis -q' and then try 'paludis -u' without the '->'. You will see what I mean, but I can't tell you why you have to add it.
_________________
Für alle doubleposter ;)
Back to top
View user's profile Send private message
Ingmarv
Retired Dev
Retired Dev


Joined: 27 Feb 2007
Posts: 188
Location: Belgium

PostPosted: Thu Jan 29, 2009 2:12 pm    Post subject: Reply with quote

numerodix wrote:
Ampheus wrote:
I posted a little guide to do this in Desktop Environments -> Kde 4.2


Uh, in reference to your post there, what does the arrow "->" in
Code:
*/*::kde->

mean?


Code:
*/*::kde


Means all packages in a repository named "kde"

Code:
*/*::kde->


Means all _installed_ packages from a repository named "kde"

So the first depspec expands to installable packages, while the second expands to uninstallable packages.
Back to top
View user's profile Send private message
numerodix
l33t
l33t


Joined: 18 Jul 2002
Posts: 743
Location: nl.eu

PostPosted: Fri Jan 30, 2009 12:04 am    Post subject: Reply with quote

I'm having a snag with debug data being installed that I don't use. I vaguely recall there used to be a cli option for this (shouldn't it be off by default anyway?) but now there isn't and I've set -debug and strip globally hoping that would do it but it hasn't.

For example:

Code:
These packages will be installed:

* kde-base/kdemultimedia-kioslaves :4.2 [R 4.2.0] <target>
    -debug encode flac kdeprefix vorbis build_options: -optional_tests split strip

_________________
undvd - ripping dvds should be as simple as unzip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 4 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum