Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] bloquer un paquet à une version précise
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Thu Sep 04, 2008 8:29 pm    Post subject: [emerge] bloquer un paquet à une version précise Reply with quote

bonjours a tous,

je me demandait comment bloquer un package a une version donnée ?

exemple : je veux rester sur la version x de vmware et ne pas avoir les maj ...

une idée ?

(évidament je pourrai virer l'ebuild mais c'est pas tres propre ...)
_________________
Pourquoi faire simple quand on peut faire compliqué ?


Last edited by sd44 on Fri Sep 05, 2008 7:08 am; edited 1 time in total
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Thu Sep 04, 2008 9:01 pm    Post subject: Reply with quote

Code:
emacs /etc/portage/packages.mask
(ou tout autre éditeur de texte (pas de troll please...)

et tu rajoutes:

Code:
>app-emulation/vmware-version_max
Back to top
View user's profile Send private message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Thu Sep 04, 2008 9:07 pm    Post subject: Reply with quote

merci YetiBarBar mais ce fichier n'est t'il pas mis a jour avec emerge --sync ? (ou alors je confond)
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
Gronono
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2007
Posts: 99
Location: Noumea, NC

PostPosted: Fri Sep 05, 2008 2:14 am    Post subject: Reply with quote

sd44 wrote:
merci YetiBarBar mais ce fichier n'est t'il pas mis a jour avec emerge --sync ? (ou alors je confond)


Sans être un grand expert Gentoo, je dirais que non (je n'ai jamais eu aucun soucis). emerge --sync met à jour l'équivalent mais au niveau du profile dans /usr/portage.
Celui qui est dans /etc/portage est spécifique ton système.

A+
Gornono
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Fri Sep 05, 2008 3:46 am    Post subject: Reply with quote

Gronono +1 !
Les fichiers situés dans /etc/portage visent précisément à configurer le comportement de la commande emerge.

@sd44 : n'y a-t-il vraiment pas moyen de trouver un autre titre : "petite question", c'est vraiment agaçant, on se fiche que la question soit petite, grande, large, étroite, rouge ou noire. L'essentiel, c'est d'avoir une synthèse du problème!
En l'occurence, "[portage] bloquer un paquet à une version précise" aurait été plus adéquat.
;)

Variations sur le même thème
Back to top
View user's profile Send private message
Gronono
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2007
Posts: 99
Location: Noumea, NC

PostPosted: Fri Sep 05, 2008 5:06 am    Post subject: Reply with quote

ghoti wrote:

En l'occurence, "[portage] bloquer un paquet à une version précise" aurait été plus adéquat.
;)

Variations sur le même thème

Merci Ghoti de ta confirmation.

C'est marrant je viens de taper sous google "portage bloquer un paquet à une version précise" et on tombe sur Fonctionnement de Portage qui explique le fonctionnement du masquage d'un ebuild dans portage.
Ghoti serait-il un expert en recherche google ?
Back to top
View user's profile Send private message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Fri Sep 05, 2008 7:07 am    Post subject: Reply with quote

merci de vos reponse, je change le titre (sorry)
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum