Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Using Skype with Gentoo/Sabayon
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
hashbangslashbinslashbash
n00b
n00b


Joined: 13 Mar 2008
Posts: 17

PostPosted: Fri Sep 05, 2008 4:16 pm    Post subject: Using Skype with Gentoo/Sabayon Reply with quote

I looked on the Skype site but the installs for linux don't include anything for gentoo.

I tried this:

Quote:
# emerge -p skype

These are the packages that would be merged, in order:

Calculating dependencies |
!!! All ebuilds that could satisfy ">=sys-libs/glibc-2.4" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-libs/glibc-2.8_p20080602 (masked by: package.mask, ~x86 keyword)
- sys-libs/glibc-2.7-r2 (masked by: package.mask, ~x86 keyword)
- sys-libs/glibc-2.6.1 (masked by: package.mask)
- sys-libs/glibc-2.6 (masked by: package.mask, ~x86 keyword)
- sys-libs/glibc-2.5.1 (masked by: package.mask, missing keyword)
- sys-libs/glibc-2.5-r4 (masked by: package.mask)
- sys-libs/glibc-2.5-r3 (masked by: package.mask)
- sys-libs/glibc-2.5-r2 (masked by: package.mask)
- sys-libs/glibc-2.4-r4 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "net-im/skype-2.0.0.63" [ebuild])


How can I get around this "masked" issue? Am I emerging the right thing?
Back to top
View user's profile Send private message
defenderBG
l33t
l33t


Joined: 20 Jun 2006
Posts: 817

PostPosted: Fri Sep 05, 2008 4:50 pm    Post subject: Reply with quote

apperantly you are new to gentoo and portage. (and what is with sabayon? it is not gentoo)
You are emerging the right package.
Now apperantly you have not set the profile... redo this step:
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=6#doc_chap2
Once you have done it installing skype should work somewhat smooth. You will see other messages like: package-x (masked by: ~x86 keyword) Please refer to this manual on how to unmask them properly.
http://gentoo-wiki.com/HOWTO_Use_Portage_Correctly#Forcing_Unstable_Packages It will help you a lot!
If you have any problems or question please write again.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Fri Sep 05, 2008 5:08 pm    Post subject: Reply with quote

I don't know what you installed, but it doesn't seem to be any recent version of gentoo. What is the output of emerge --info?
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
defenderBG
l33t
l33t


Joined: 20 Jun 2006
Posts: 817

PostPosted: Fri Sep 05, 2008 5:50 pm    Post subject: Reply with quote

the portage seams to be synced:
http://gentoo-portage.com/sys-libs/glibc

I think the problem is that he/she didnt choose a profile and thus the output.
Back to top
View user's profile Send private message
abaelinor
n00b
n00b


Joined: 27 Aug 2005
Posts: 51

PostPosted: Sat Sep 06, 2008 4:56 am    Post subject: Reply with quote

defenderBG wrote:
(and what is with sabayon? it is not gentoo)

yes it is. it's a pre-packaged version of gentoo. it's for those who want the sourcing power of gentoo but the ease of use of ubuntu.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sat Sep 06, 2008 5:39 am    Post subject: Reply with quote

djlosch wrote:
defenderBG wrote:
(and what is with sabayon? it is not gentoo)

yes it is. it's a pre-packaged version of gentoo. it's for those who want the sourcing power of gentoo but the ease of use of ubuntu.


No. It's not. It forked from Gentoo just like Fedora forked from Red Hat, but the Gentoo project doesn't support Sabayon in any way. It's a different distro which shares some common elements with Gentoo.

Unless you can replicate this same problem on Gentoo installation, we assume it's a Sabayon specific problem.

I know nothing about Sabayon, so I will not recommend to manually touch profiles or something, because maybe Sabayon has a different way to do the things, and I might even screw it more. The ideal place to ask is the Sabayon forum.

Moved from Multimedia to Unsupported Software since it's not related to Gentoo.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum