Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4.1++ and keyboard
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
obsrv
Apprentice
Apprentice


Joined: 19 Aug 2005
Posts: 167
Location: Panevėžys, Lithuania

PostPosted: Wed Sep 10, 2008 8:13 am    Post subject: KDE 4.1++ and keyboard Reply with quote

I have KDE 4.1++ (SVN) and Keyboard Logitech G15, and all keys are scrambled if it is a correct word. My english is poor. When I press up arrow, I get a screenshot, on numpat enter doesnt work, other arrow keys do nothing, in xOrg configuration it is set generic 101 key keyboard, I cahnged it to kbd, in KDE i use Logitech G15 layout with G15daemon, I tried other variants but I get the same result. What infomation should i provide you folks to help me solve this problem?
_________________
SKA punk
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Wed Sep 10, 2008 8:33 am    Post subject: Reply with quote

First of all, if you haven't already, set
Code:
INPUT_DEVICES="evdev"

in your make.conf. After that, do an 'emerge -1Nva xorg-server', plus make sure that '>=x11-drivers/xf86-input-evdev-2.0.0' gets pulled in.

Assuming you have recently updated your system, hal-0.5.11-something should already be installed. Configuration of keyboard and mouse has moved out from xorg.conf since then. Comment those sections out for the time being.

Defaults are set in /usr/share/hal/fdi/policy/10osvendor/ and for custom configuration, copy over 10-x11-input.fdi to /etc/hal/fdi/policy/ - e.g. simply setting the German keyboard layout would look like that:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keys">
      <merge key="input.x11_driver" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">de</merge>
    </match>
  </device>
</deviceinfo>


In KDE, set your keyboard layout (systemsettings --> regional & language) to 'evdev-managed keyboard' and your language of choice.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum