Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KTorrent SVN
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
obsrv
Apprentice
Apprentice


Joined: 19 Aug 2005
Posts: 167
Location: Panevėžys, Lithuania

PostPosted: Sun Sep 14, 2008 3:40 pm    Post subject: KTorrent SVN Reply with quote

When I try to compile KTorrent SVN version (9999 build) from laymans kde-svn overlay I get this error (full log)

Code:
pirate obsrv # emerge -av ktorrent 

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] net-p2p/ktorrent-9999  USE="bitfinder bwscheduler infowidget ipfilter logviewer mediaplayer scanfolder search stats upnp webinterface" 0 kB [1]

Total: 1 package (1 new), Size of downloads: 0 kB
Portage tree and overlays:                       
 [0] /usr/portage                               
 [1] /usr/local/portage/layman/kdesvn-portage   

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) net-p2p/ktorrent-9999
 * checking ebuild checksums ;-) ...                                                                                                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                       [ ok ]

 * WARNING! This is an experimental ebuild of the extragear/network KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because           
 * of this ebuild!                                                               

>>> Unpacking source...
 * subversion update start -->
 *      repository: svn://anonsvn.kde.org/home/kde/trunk/extragear/network
At revision 860905.                                                       
 *    working copy: /usr/portage/distfiles/svn-src/KDE/extragear/network/network

 * Exporting parts of working copy to /var/tmp/portage/net-p2p/ktorrent-9999/work/ktorrent
>>> Source unpacked.                                                                     
>>> Compiling source in /var/tmp/portage/net-p2p/ktorrent-9999/work/ktorrent ...         
-- The C compiler identification is GNU                                                   
-- The CXX compiler identification is GNU                                                 
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc                         
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works               
-- Detecting C compiler ABI info                                                         
-- Detecting C compiler ABI info - done                                                   
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++                       
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works             
-- Detecting CXX compiler ABI info                                                       
-- Detecting CXX compiler ABI info - done                                                 
-- Looking for Q_WS_X11                                                                   
-- Looking for Q_WS_X11 - found                                                           
-- Looking for Q_WS_WIN                                                                   
-- Looking for Q_WS_WIN - not found.                                                     
-- Looking for Q_WS_QWS                                                                   
-- Looking for Q_WS_QWS - not found.                                                     
-- Looking for Q_WS_MAC                                                                   
-- Looking for Q_WS_MAC - not found.                                                     
-- Found Qt-Version 4.4.1 (using /usr/bin/qmake)                                         
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname                                                                                                                                           
-- Looking for gethostbyname - found                                                                                                                                   
-- Looking for connect                                                                                                                                                 
-- Looking for connect - found                                                                                                                                         
-- Looking for remove                                                                                                                                                 
-- Looking for remove - found                                                                                                                                         
-- Looking for shmat                                                                                                                                                   
-- Looking for shmat - found                                                                                                                                           
-- Looking for IceConnectionNumber in ICE                                                                                                                             
-- Looking for IceConnectionNumber in ICE - found                                                                                                                     
-- Found X11: /usr/lib64/libX11.so                                                                                                                                     
-- Looking for include files CMAKE_HAVE_PTHREAD_H                                                                                                                     
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found                                                                                                             
-- Looking for pthread_create in pthreads                                                                                                                             
-- Looking for pthread_create in pthreads - not found                                                                                                                 
-- Looking for pthread_create in pthread                                                                                                                               
-- Looking for pthread_create in pthread - found                                                                                                                       
-- Found Automoc4: /usr/bin/automoc4                                                                                                                                   
-- Found Perl: /usr/bin/perl                                                                                                                                           
-- Performing Test _OFFT_IS_64BIT                                                                                                                                     
-- Performing Test _OFFT_IS_64BIT - Success                                                                                                                           
-- Performing Test HAVE_FPIE_SUPPORT                                                                                                                                   
-- Performing Test HAVE_FPIE_SUPPORT - Success                                                                                                                         
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL                                                                                                                     
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success                                                                                                           
-- Performing Test __KDE_HAVE_GCC_VISIBILITY                                                                                                                           
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success                                                                                                                 
-- Found Phonon: /usr/lib64/libphonon.so                                                                                                                               
-- Found Phonon Includes: /usr/include/KDE;/usr/include                                                                                                               
-- Found KDE 4.2 include dir: /usr/kde/svn/include                                                                                                                     
-- Found KDE 4.2 library dir: /usr/kde/svn/lib64                                                                                                                       
-- Found KDE4 kconfig_compiler preprocessor: /usr/kde/svn/bin/kconfig_compiler                                                                                         
-- Found automoc4: /usr/bin/automoc4                                                                                                                                   
-- Found IW: /usr/include                                                                                                                                             
-- Could not find Kopete includes.                                                                                                                                     
-- Could not find Kopete library.                                                                                                                                     
-- Could NOT find Kdepim  (missing:  KDEPIM_LIBRARIES KDEPIM_INCLUDE_DIR)                                                                                             
-- Found KDE PIM libraries                                                                                                                                             
-- Found gpgme-config at /usr/bin/gpgme-config                                                                                                                         
-- Found gpgme v1.1.6, checking for flavours...                                                                                                                       
--  Found flavour 'vanilla', checking whether it's usable...yes                                                                                                       
--  Found flavour 'pthread', checking whether it's usable...yes                                                                                                       
-- Usable gpgme flavours found:  vanilla pthread                                                                                                                       
-- Found qgpgme: libraries: qgpgme;gpgme++-pthread;/usr/lib64/libgpgme-pthread.so;/usr/lib64/libpthread.so;/usr/lib64/libgpg-error.so                                 
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig                                                                                             
-- Could NOT find QCA2 includes                                                                                                                                       
-- Could NOT find QCA2 libraries                                                                                                                                       
--                                                                                                                                                                     
-----------------------------------------------------------------------------                                                                                         
-- The following external packages were located on your system.                                                                                                       
-- This installation will have the extra features provided by these packages.                                                                                         
+ gpgme                                                                                                                                                               
+ KDE PIM Libraries                                                                                                                                                   
-----------------------------------------------------------------------------                                                                                         
-- The following OPTIONAL packages could NOT be located on your system.                                                                                               
-- Consider installing them to enable more features from this software.                                                                                               
+ Kopete: Kopete headers required to build Kopete plugins <kopete.kde.org>                                                                                             
+ KDE PIM: KDE PIM headers and libraries, needed to build Kopete Cryptography plugin <http://pim.kde.org/>                                                             
-----------------------------------------------------------------------------                                                                                         

-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/portage/net-p2p/ktorrent-9999/work/ktorrent_build
>>> Source compiled.                                                                           
>>> Test phase [not enabled]: net-p2p/ktorrent-9999                                           

>>> Install ktorrent-9999 into /var/tmp/portage/net-p2p/ktorrent-9999/image/ category net-p2p
make: *** No rule to make target `install'.  Stop.                                           
 *                                                                                           
 * ERROR: net-p2p/ktorrent-9999 failed.                                                     
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 3085:  Called kde4overlay-meta_src_install
 *             environment, line 2387:  Called cmake-utils_src_install
 *             environment, line  743:  Called die
 * The specific snippet of code:
 *       emake install DESTDIR="${D}" || die "Make install failed";
 *  The die message:
 *   Make install failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-p2p/ktorrent-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-p2p/ktorrent-9999/temp/environment'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/local/portage/layman/kdesvn-portage/eclass/kde4svn-meta.eclass
 *   /usr/local/portage/layman/kdesvn-portage/eclass/kde4svn.eclass
 *   /usr/local/portage/layman/kdesvn-portage/eclass/kde4overlay-base.eclass
 *   /usr/local/portage/layman/kdesvn-portage/eclass/kde4overlay-functions.eclass
 *   /usr/local/portage/layman/kdesvn-portage/eclass/kde4overlay-meta.eclass
 * This ebuild is from an overlay: '/usr/local/portage/layman/kdesvn-portage/'
 *

 * Messages for package net-p2p/ktorrent-9999:

 * WARNING! This is an experimental ebuild of the extragear/network KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!
 *
 * ERROR: net-p2p/ktorrent-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 3085:  Called kde4overlay-meta_src_install
 *             environment, line 2387:  Called cmake-utils_src_install
 *             environment, line  743:  Called die
 * The specific snippet of code:
 *       emake install DESTDIR="${D}" || die "Make install failed";
 *  The die message:
 *   Make install failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-p2p/ktorrent-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-p2p/ktorrent-9999/temp/environment'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/local/portage/layman/kdesvn-portage/eclass/kde4svn-meta.eclass
 *   /usr/local/portage/layman/kdesvn-portage/eclass/kde4svn.eclass
 *   /usr/local/portage/layman/kdesvn-portage/eclass/kde4overlay-base.eclass
 *   /usr/local/portage/layman/kdesvn-portage/eclass/kde4overlay-functions.eclass
 *   /usr/local/portage/layman/kdesvn-portage/eclass/kde4overlay-meta.eclass
 * This ebuild is from an overlay: '/usr/local/portage/layman/kdesvn-portage/'
 *
pirate obsrv #

_________________
SKA punk
Back to top
View user's profile Send private message
ukavi
Apprentice
Apprentice


Joined: 09 Feb 2007
Posts: 181
Location: The Netherlands

PostPosted: Sun Sep 14, 2008 3:46 pm    Post subject: Reply with quote

seems like it's not completely an autoconfiscated package. contact the maintainers (of the ebuild).
_________________
English is not my native language, please notify me of any mistakes.
Back to top
View user's profile Send private message
obsrv
Apprentice
Apprentice


Joined: 19 Aug 2005
Posts: 167
Location: Panevėžys, Lithuania

PostPosted: Sun Sep 14, 2008 3:55 pm    Post subject: Reply with quote

I want to try other version but I'm unable to unmask it:

pirate obsrv # emerge -av =ktorrent-3.1.2

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "=net-p2p/ktorrent-3.1.2" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-p2p/ktorrent-3.1.2 (masked by: missing keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I write net-p2p/ktorrent -* to /etc/portage/package.keywords/kdesvn/ktorrent.keywords but no go...
_________________
SKA punk
Back to top
View user's profile Send private message
ukavi
Apprentice
Apprentice


Joined: 09 Feb 2007
Posts: 181
Location: The Netherlands

PostPosted: Sun Sep 14, 2008 4:01 pm    Post subject: Reply with quote

try without the -*
_________________
English is not my native language, please notify me of any mistakes.
Back to top
View user's profile Send private message
Benni123
Tux's lil' helper
Tux's lil' helper


Joined: 13 Mar 2005
Posts: 110

PostPosted: Sun Sep 14, 2008 4:15 pm    Post subject: Reply with quote

same problem here, ktorrent won't compile with the svn-overlay
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Mon Sep 15, 2008 3:31 pm    Post subject: Reply with quote

Benni123 wrote:
same problem here, ktorrent won't compile with the svn-overlay


Ktorrent is compiling with no problem. I don't remember the exact revision of svn, but I just finished process of compilation.

phoenix
_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
Benni123
Tux's lil' helper
Tux's lil' helper


Joined: 13 Mar 2005
Posts: 110

PostPosted: Mon Sep 15, 2008 4:57 pm    Post subject: Reply with quote

yes, today it compiles.
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Tue Sep 16, 2008 5:43 am    Post subject: Reply with quote

Benni123 wrote:
yes, today it compiles.


Ktorrent compiles and runs without problem... but I have problem with plasma-workspace from svn... compiles ok but it crashes each time I am trying to running it.
_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum