Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
how to enable compiz-fusion on gnome at startup?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
cvega
n00b
n00b


Joined: 03 Sep 2008
Posts: 34
Location: Santiago, Chile

PostPosted: Mon Sep 15, 2008 11:05 pm    Post subject: how to enable compiz-fusion on gnome at startup? Reply with quote

I've installed CF and is working flawlessly with the following command:

Code:
LIBGL_ALWAYS_INDIRECT=1 compiz --replace ccp & emerald --enable


Then I wanted to enable it at startup, so I made a script:

/etc/X11/xinit/xinitrc.d/01-compiz

Code:
#!/bin/sh
sleep 5
LIBGL_ALWAYS_INDIRECT=1 compiz --replace ccp &
sleep 1
emerald --enable


And then placed the file under System->Preferences->Sesions->Startup Programs

It's not working.

¿Any ideas?
_________________
Intel Core 2 Duo T5200 (1.6 GHz, 533 MHz FSB, 2MB L2 cache)
Intel Graphics Media Accelerator 950
1GB DDR2
Back to top
View user's profile Send private message
deno
Guru
Guru


Joined: 13 Sep 2006
Posts: 406

PostPosted: Tue Sep 16, 2008 12:13 am    Post subject: Reply with quote

Have you made it executable? chmod +x /etc/X11/xinit/xinitrc.d/01-compiz.
Back to top
View user's profile Send private message
cvega
n00b
n00b


Joined: 03 Sep 2008
Posts: 34
Location: Santiago, Chile

PostPosted: Tue Sep 16, 2008 12:34 am    Post subject: Reply with quote

Ooops!

I did

chmod -x /etc/X11/xinit

instead of

chmod +x /etc/X11/xinit

Thanks deno. Anyway, now there is another problem. When logging in gnome, the screen becomes totally black, I can only see the mouse pointer.
_________________
Intel Core 2 Duo T5200 (1.6 GHz, 533 MHz FSB, 2MB L2 cache)
Intel Graphics Media Accelerator 950
1GB DDR2
Back to top
View user's profile Send private message
cvega
n00b
n00b


Joined: 03 Sep 2008
Posts: 34
Location: Santiago, Chile

PostPosted: Tue Sep 16, 2008 4:41 am    Post subject: Reply with quote

Ok, I fixed the black screen at gnome login. I forgot to put a & at the end of the script:

Code:
#!/bin/sh
sleep 5
LIBGL_ALWAYS_INDIRECT=1 compiz --replace ccp &
sleep 1
emerald --enable &


Now I'm facing a little but yet annoying problem:

After logging in, the desktop effects are not the ones I had. For instance, when changing workspace, the "Desktop Cube" appears but I don't use it. Then, when trying to use "Scale Windows Effect", everything is fixed and my old setting is back.

It's very weird. How can I solve that?

EDIT: Nevermid, now is fixed for good.
_________________
Intel Core 2 Duo T5200 (1.6 GHz, 533 MHz FSB, 2MB L2 cache)
Intel Graphics Media Accelerator 950
1GB DDR2
Back to top
View user's profile Send private message
m_gustafsson
Apprentice
Apprentice


Joined: 18 Mar 2007
Posts: 243
Location: Sweden

PostPosted: Fri Oct 10, 2008 5:59 am    Post subject: Reply with quote

Hi cvega,

I think that I might be experiencing the same problem as the last one you mention, i.e. nothing happens when I change my effects in CompizConfig Settings Manager.
If I for example disable the desktop cube it is still there when I switch window.
How did you solve your problem?

/Mats
Back to top
View user's profile Send private message
m_gustafsson
Apprentice
Apprentice


Joined: 18 Mar 2007
Posts: 243
Location: Sweden

PostPosted: Fri Oct 10, 2008 7:12 am    Post subject: Reply with quote

I think that my problem is now solved.
Instead of starting Compiz Fusion with a script in /etc/X11/xinit/xinitrc.d/ I am now starting it with the same script but triggered from Preferences->Sessions.

/Mats
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum