Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(Compiz-Fusion through Layman) ccsm segfaults [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Xanadu
Guru
Guru


Joined: 10 Oct 2002
Posts: 335
Location: Hour West of Philly (USA)

PostPosted: Tue Sep 23, 2008 1:59 am    Post subject: (Compiz-Fusion through Layman) ccsm segfaults [SOLVED] Reply with quote

Hey!

I really don't know what changed on my system, but ccsm just segfaults now. It's the ONLY part of compiz-fusion that doesn't work. I still have all effects (configured prior to ccsm breaking), Emerald WM, etc.

Code:
$ ccsm
Segmentation fault


That's it. No output what-so-ever. I can't honestly say that I've changed anything. I'm just looking for some ideas of what to re-merge. I've already completely ripped out compiz-fusion (emerge -C @compiz-fusion) and remerged it. ccsm still doesn't work.

Any ideas?

Thanx!
_________________
I'm not a prophet or a stone-age man
I'm just a mortal with potential of a super man

-David Bowie


Last edited by Xanadu on Wed Oct 15, 2008 1:13 am; edited 1 time in total
Back to top
View user's profile Send private message
Xanadu
Guru
Guru


Joined: 10 Oct 2002
Posts: 335
Location: Hour West of Philly (USA)

PostPosted: Thu Sep 25, 2008 9:56 am    Post subject: Reply with quote

Anyone have even a small direction for me to go?
_________________
I'm not a prophet or a stone-age man
I'm just a mortal with potential of a super man

-David Bowie
Back to top
View user's profile Send private message
Xanadu
Guru
Guru


Joined: 10 Oct 2002
Posts: 335
Location: Hour West of Philly (USA)

PostPosted: Thu Sep 25, 2008 6:07 pm    Post subject: Reply with quote

Also, I've already done:
Code:
emerge -1 `qlist -IC python` ccsm


In the hopes that that would help, but no go... :(
_________________
I'm not a prophet or a stone-age man
I'm just a mortal with potential of a super man

-David Bowie
Back to top
View user's profile Send private message
s0be
Apprentice
Apprentice


Joined: 23 Nov 2002
Posts: 239

PostPosted: Sat Sep 27, 2008 4:39 am    Post subject: Reply with quote

you could do:
Code:
strace ccsm

to see what's causing it to fail. This may require you to emerge strace. The output of that might be able to give you (or others, but it's quite verbose) a hint at what's causing it.
Back to top
View user's profile Send private message
Xanadu
Guru
Guru


Joined: 10 Oct 2002
Posts: 335
Location: Hour West of Philly (USA)

PostPosted: Wed Oct 15, 2008 1:13 am    Post subject: Reply with quote

I decided to rebuild world. I wanted to test out some different flags that I found at http://gentoo-wiki.com/CFLAGS_matrix anyway.

This is what I use now (after some broken packages and what not, everything builds on my system):

Code:
CHOST="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer -w"
CXXFLAGS="-O2 -march=prescott -pipe -ftracer -fomit-frame-pointer -w"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--hash-style=gnu -Wl,--enable-new-dtags -Wl,--warn-once"


My Gentoo machines SOAR. They are just stupid fast now. I think it's the linking that's doing it since I'm not really doing anything aggressive with my C*FLAGS.

At anyrate, somewhere in there ccsm started working again. I really don't know what it was. I wish I did so I could report it here, but...
_________________
I'm not a prophet or a stone-age man
I'm just a mortal with potential of a super man

-David Bowie
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum