Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Ethernet] Connexion impossible..
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Silvering
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2008
Posts: 85

PostPosted: Mon Sep 29, 2008 11:44 am    Post subject: [Ethernet] Connexion impossible.. Reply with quote

Bonjour à tous!! Je viens de terminer mon installation (après plusieurs problèmes.. :roll: merci à tout ceux qui m'ont aidé). Maintenant je voudrais bien sûr avoir internet par ethernet pour commencer et je configurerai le wifi plus tard..bref j'ai suivis le tuto du handbook et après un /etc/init.d/net.eth0 start j'obtiens:
Quote:
err,eth0:socket: Adress family not supported by protocol
warning: no inet socket available: Bad file descriptor
eth0: unknown ineterface: Bad file descriptor
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7935
Location: ~Brussels - Belgique

PostPosted: Mon Sep 29, 2008 11:51 am    Post subject: Reply with quote

Ok, mais peut-on avoir plus d'infos ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Silvering
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2008
Posts: 85

PostPosted: Mon Sep 29, 2008 11:59 am    Post subject: Reply with quote

Un ifconfig -a me renvoie un eth0, lo, wlan0 et wmaster0-00 après que voulez vous savoir de précis? Merci
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Mon Sep 29, 2008 1:16 pm    Post subject: Re: [Ethernet] Connexion impossible.. Reply with quote

Silvering wrote:
après un /etc/init.d/net.eth0 start j'obtiens:
Quote:
err,eth0:socket: Adress family not supported by protocol
warning: no inet socket available: Bad file descriptor
eth0: unknown ineterface: Bad file descriptor

Normal : si on se réfère à la dernière config de noyau que tu as postée dans ton autre sujet, tu n'as pas activé le support tcp/ip :
Code:
# CONFIG_INET is not set
Back to top
View user's profile Send private message
Silvering
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2008
Posts: 85

PostPosted: Mon Sep 29, 2008 5:17 pm    Post subject: Reply with quote

Oh non ça ne vas pas recommencé..j'ai activé TCP/IP dans Networking Support et tjs pareil..
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Mon Sep 29, 2008 7:15 pm    Post subject: Reply with quote

/etc/conf.d/net ?
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Mon Sep 29, 2008 9:44 pm    Post subject: Reply with quote

Allez, on prend les mêmes et on recommence :lol:

Tu peux vérifier également s'il y a bien Unix domain socket et packet socket ?
Ou alors p'tet un conflit IPv4/IPv6 ?
Y-a-t'il une erreur du genre /proc/net/route dans les logs ?

Bref, faut nous donner des infos claire depuis les logs parce que sinon on va encore repartir dans tous les sens :lol:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7935
Location: ~Brussels - Belgique

PostPosted: Tue Sep 30, 2008 5:38 am    Post subject: Reply with quote

on donnerait pas le lien vers le forum d'alpha_one_x86 ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Silvering
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2008
Posts: 85

PostPosted: Tue Sep 30, 2008 10:44 am    Post subject: Reply with quote

Je vous posterai mon /etc/conf.d/net ce soir et oui par contre j'ai une erreur du genre /proc/net/route quand je lance le /etc/init.d/net.eth0 start
Back to top
View user's profile Send private message
Silvering
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2008
Posts: 85

PostPosted: Tue Sep 30, 2008 7:30 pm    Post subject: Reply with quote

Bon j'ai vérifié et Unix domain socket ainsi que packet socket sont bien installés.
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Tue Sep 30, 2008 7:43 pm    Post subject: Reply with quote

Poster le reste des infos se serait bien aussi :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7935
Location: ~Brussels - Belgique

PostPosted: Tue Sep 30, 2008 7:58 pm    Post subject: Reply with quote

Et éventuellement repartir d'un kernel qui fonctionne, et ne pas tout supprimer à la hache ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Silvering
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2008
Posts: 85

PostPosted: Wed Oct 01, 2008 10:49 am    Post subject: Reply with quote

alors voici mon fichier /etc/conf.d/net:
Quote:
config_eth0=("dhcp")


un ifconfig eth0 m'affiche:
Quote:
Link encap:Ethernet HWaddr 00:
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 b) TX bytes:O (0.0 b)

ensuite /etc/init.d/net.eth0 start:
Quote:
err, eth0: Socket: Address family notsupported by protocol
warning: no inet socket available; No such file or directory
eth0: unknown interface: Bad file description


Et dernière chose je n'ai pas de fichier route dans /proc/net..
Back to top
View user's profile Send private message
freezby
Tux's lil' helper
Tux's lil' helper


Joined: 07 Sep 2006
Posts: 103
Location: Angers, France

PostPosted: Wed Oct 01, 2008 11:50 am    Post subject: Reply with quote

Salut,

As tu bien installer dhcp ?

Code:
emerge -av dhcp
Back to top
View user's profile Send private message
Silvering
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2008
Posts: 85

PostPosted: Wed Oct 01, 2008 4:47 pm    Post subject: Reply with quote

Ca m'affiche:
Quote:

Fetch failed for 'net-misc/dhcp-3.1.1'
!!! can't process invalid log file: merge.ERROR
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Wed Oct 01, 2008 6:33 pm    Post subject: Reply with quote

@Silvering: De façon générale, il faut que tu nous colles le retour complet des commandes ! Cela évitera des erreurs/oublis lors de la copie sur le forum :
Silvering wrote:
Un ifconfig -a me renvoie un eth0, lo, wlan0 et wmaster0-00 après que voulez vous savoir de précis? Merci

Je persiste, c'est l'output complet de #ifconfig -a qu'il faut voir ; de même, par exemple pour un :
Code:
$zgrep -e "NET" -e "UNIX" -e "SOCKET" -e "IPV6" /proc/config.gz | grep -v \#


BTW: pour avoir juste un client dhcp c'est généralement net-misc/dhcpcd qu'on préfère
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Silvering
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2008
Posts: 85

PostPosted: Thu Oct 02, 2008 5:07 pm    Post subject: Reply with quote

Bon alors plusieurs choses:
- j'ai était voir si je possèdé dhcpcd dans /net-misc. Effectivement je l'ai et voici les fichiers qu'il y a à l'intérieur:
-ChangeLog, files, metadata.xml, dhcpcd-2.0.5-r1.ebuild, dhcpcd-3.0.16-r1.ebuild et bcp d'autre .ebuild

- mon ifconfig -a

Quote:

eth0
Link encap:Ethernet HWaddr 00::13:a9:83:7e:d9
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 b) TX bytes:O (0.0 b)

lo Link encap: Local Loopback
LOOPBACK MTU:16436 Metric:1
RX packets: 0 errors:0 dropped;0
overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wlan0 Link encap:Ethenet HWaddr 00:19:D2:6E:B6:E9
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:à errors:0 dropped:0
overrruns:0 frame:0
collisions: 0 txqueuelen:1000
RX bytes: 0 (0.0 b) TX bytes (0.0 b)

wmaster0 Link encap:UNSPEC HWaddr 00-19-D2-6E-B6-E9-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)



- enfin
Code:
$zgrep -e "NET" -e "UNIX" -e "SOCKET" -e "IPV6" /proc/config.gz | grep -v \#

je ne peux pas vous le donner je ne vois que la fin du résultat (je suis tjs en version console) donc pas possible de monter voir le début..
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Oct 02, 2008 5:28 pm    Post subject: Reply with quote

8O j'ai pas tout compris là... m'enfin bon - Tu peux toujours spliter la cmdline i.e. :
Code:
$zgrep -e "NET" /proc/config.gz | grep -v \#

Code:
$zgrep -e "UNIX" /proc/config.gz | grep -v \#

Code:
$zgrep -e "SOCKET" /proc/config.gz | grep -v \#

Code:
$zgrep -e "IPV6" /proc/config.gz | grep -v \#


Par ailleurs, ce n'est pas parce que tu as les ebuilds de dhcpcd dans l'arbre portage (jusque là c'est normal heureusement) que le package est installé !
regarde la sortie de #qlist dhcpcd par exemple ; voir si ti as un binaire et un fichier de conf i.e.
Code:

# qlist dhcpcd
/sbin/dhcpcd
/lib/dhcpcd/dhcpcd-run-hooks
/lib/dhcpcd/dhcpcd-hooks/01-test
/lib/dhcpcd/dhcpcd-hooks/10-mtu
/lib/dhcpcd/dhcpcd-hooks/20-resolv.conf
/lib/dhcpcd/dhcpcd-hooks/30-hostname
/lib/dhcpcd/dhcpcd-hooks/50-ntp.conf
/lib/dhcpcd/dhcpcd-hooks/50-yp.conf
/etc/dhcpcd.conf
/usr/share/man/man5/dhcpcd.conf.5.bz2
/usr/share/man/man8/dhcpcd.8.bz2
/usr/share/man/man8/dhcpcd-run-hooks.8.bz2

_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Silvering
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2008
Posts: 85

PostPosted: Thu Oct 02, 2008 6:17 pm    Post subject: Reply with quote

Quote:
$zgrep -e "UNIX" /proc/config.gz | grep -v \#

Me renvoie:
Quote:
CONFIG_UNIX=y
CONFIG_UNIX98_PTYS=y


Quote:

$zgrep -e "SOCKET" /proc/config.gz | grep -v \#

Ne me renvoi rien

Quote:
$zgrep -e "IPV6" /proc/config.gz | grep -v \#

Ne me renvoi rien

Quote:
$zgrep -e "NET" /proc/config.gz | grep -v \#

Me renvoi:
Quote:

#config_pata_netcell is not set
config_netdevices=y
config_netdevices_multiqueue=y
#config_net_SB1000 is not set
#config_arcnet is not set
config_net_ethernet=y
config_net_vender_3COM=y
config_net_pci=y
#config_pcnet32 is not set
config_netdev_1000=y
config_netdev_10000=y
#config_netxen_nic is not set
config_pcmcia_netwave=y
#config_usb_net_rmdis_wla is not set
#config_usb__usbnet is not set
#config_net_pcmcia is not set
#config_net_fc is not set
config_net_console=y
#config_netconsole_dynamic is not set
config_netpool=y
#config_netpool_trap is not set
config_netpool_controler=y
config_network_filesystems is not set


et enfin pour le qlist il me mets qlist: command not found on dirait qu'il n'est pas installé
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Oct 02, 2008 8:16 pm    Post subject: Reply with quote

    <noise>Haaaaaaaaaaaaaaaaaaaa................ BLAM !</noise>

Silvering wrote:
Code:
$zgrep -e "NET" /proc/config.gz | grep -v \#

Me renvoi:
Code:
#config_pata_netcell is not set
config_netdevices=y
config_netdevices_multiqueue=y
#config_net_SB1000 is not set
#config_arcnet is not set
config_net_ethernet=y
config_net_vender_3COM=y
config_net_pci=y
#config_pcnet32 is not set
config_netdev_1000=y
config_netdev_10000=y
#config_netxen_nic is not set
config_pcmcia_netwave=y
#config_usb_net_rmdis_wla is not set
#config_usb__usbnet is not set
#config_net_pcmcia is not set
#config_net_fc is not set
config_net_console=y
#config_netconsole_dynamic is not set
config_netpool=y
#config_netpool_trap is not set
config_netpool_controler=y
config_network_filesystems is not set


<!-- :evil: :evil: Où est CONFIG_INET ??? --> (cf.)

Par ailleurs, même si je me suis trompé sur la dénomination pour packet socket - c'est CONFIG_PACKET (et pas SOCKET), ça change pas grand choses vue que tu passes par make menuconfig pour le cocher et pourtant... (cf.) m'est avis que si tu changes SOCKET par PACKET dans la commande, m'étonnerais pas qu'elle ne te renvois rien

En revanche, pour le qfile, mille excuses, je croyais que le package portage-utils était installé de base. Alors dis nous ce que te donne : #emerge -s dhcpcd stp


Edit :... plus j'y rempense... alors en résumé "défoisque" :
tu refais un kernel en cochant depuis le menuconfig (tappe "/" dans l'interface de menuconfig pour activer la fonction de recherche - elle te donnera le chemin si tu ne sais pas)
CONFIG_INET=y
CONFIG_PACKET=y
Tu recompiles et tu installes ton nouveau noyau dans /boot
Tu verifies que dhcpcd soit installé et tu reboot
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Thu Oct 02, 2008 9:03 pm    Post subject: Reply with quote

boozo wrote:
<!-- :evil: :evil: Où est CONFIG_INET ??? --> (cf.)

Trop facile avec des couleurs ! :lol:
Ploum ploum ploum ->[]
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Oct 02, 2008 10:02 pm    Post subject: Reply with quote

@ghoti : Allez, à 3 contre 1 - soit la recompilation est passé à la trappe ; soit c'est la copie du bzImage ; soit c'est le symlink linux qui pointe dans les choux ^^

Mais tu perds rien pour attendre, n'aie crainte... on t'en garde un au chaud : en 4 lettres avec 2 voyelles ? :mrgreen:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7935
Location: ~Brussels - Belgique

PostPosted: Fri Oct 03, 2008 6:55 am    Post subject: Reply with quote

boozo wrote:
@ghotiMais tu perds rien pour attendre, n'aie crainte... on t'en garde un au chaud : en 4 lettres avec 2 voyelles ? :mrgreen:


RTFM ? TROLL ? heu je sai pô...
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Silvering
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2008
Posts: 85

PostPosted: Fri Oct 03, 2008 6:59 am    Post subject: Reply with quote

Dhcpcd à l'air d'être bien installé:

Quote:

Latest versionavailable: 3.2.3
Latest version installed: 3.2.3
Size offiles: 43kB
Homepage: http:/roy.marples.name/dhcpcd
Description: A DHCP client
License: BSD-2


Ensuite j'ai fais comme tu m'a dis pour le menuconfig puis un cp arch/i386/boot/bzImage /boot/
J'ai rebooter et tjs pareil quand je fais /etc/init.d/net.eth0 start:
Quote:

Bringing up eth0
dhcp
warning: no inet socket available: No such fileordirectory
Running dhcpcd...
err, eth0: socket: Adresss family notsupported by protocol

warning: no inet socket available: no suchfile or directory
eth0: unknown interface:Bad file descriptor
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7935
Location: ~Brussels - Belgique

PostPosted: Fri Oct 03, 2008 7:42 am    Post subject: Reply with quote

et si tu partais de genkernel sans toucher aux options ? ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum