Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 2)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Thu Oct 30, 2008 11:22 am    Post subject: Reply with quote

UPDATE:
With kde-crazy I got kdebase, kdeadmin, kdeartwork, + gwenview ark kdf okular kamera kalgebra to compile/install, but marble failed. Also had problems with various other packages from different live sets.

I'm thinking I should have removed all of the kdesvn-portage 9999 packages first, and also removed ALL of svn-src source files, and reinstalled from scratch.
On the other hand, I'm also concerned my questionable plasma-worksapce hack involving python mentioned in my post above has caused some if not most of these other compile failures.

Also, my panel is black (can't install the complete desktop settings glassified theme), but still has all the functions working OK
UPDATE on panel: A reboot and re-apply of glassified theme worked. I guess this one had nothing to do with my plasma-workspace hack, which I had suspected.

Tried koffice-live, and can't get past file collisions yet. The usual method(s) don't seem to work.
Code:
package app-office/koffice-data-9999 NOT merged
 *
 * Detected file collision(s):
 *
 *    /usr/share/icons/oxygen/16x16/actions/format-justify-left.png
 *    /usr/share/icons/oxygen/16x16/actions/object-group.png
 *    /usr/share/icons/oxygen/16x16/actions/format-justify-fill.png
 *    /usr/share/icons/oxygen/16x16/actions/format-text-italic.png
 *    /usr/share/icons/oxygen/16x16/actions/object-ungroup.png
 *    /usr/share/icons/oxygen/16x16/actions/object-order-raise.png
 *    /usr/share/icons/oxygen/16x16/actions/format-text-bold.png
 *    /usr/share/icons/oxygen/16x16/actions/object-order-lower.png
 *    /usr/share/icons/oxygen/16x16/actions/format-justify-center.png
 *    /usr/share/icons/oxygen/16x16/actions/object-order-front.png
 *    /usr/share/icons/oxygen/16x16/actions/object-order-back.png
 *    /usr/share/icons/oxygen/16x16/actions/format-justify-right.png
 *    /usr/share/icons/oxygen/16x16/actions/format-text-underline.png

portageq owners / <filename>` (to identify the installed package that owns a file) returns nothing- very confusing. :?

UPDATE on koffice. OK- I got around the file collisions by using the entire path (forgot it was needed :oops: ) . Here it is if anyone has this problem:
Code:
COLLISION_IGNORE="/usr/share/icons/oxygen/16x16/actions/format-justify-left.png /usr/share/icons/oxygen/16x16/actions/object-group.png /usr/share/icons/oxygen/16x16/actions/format-justify-fill.png /usr/share/icons/oxygen/16x16/actions/format-text-italic.png /usr/share/icons/oxygen/16x16/actions/object-ungroup.png /usr/share/icons/oxygen/16x16/actions/object-order-raise.png /usr/share/icons/oxygen/16x16/actions/format-text-bold.png /usr/share/icons/oxygen/16x16/actions/object-order-lower.png /usr/share/icons/oxygen/16x16/actions/format-justify-center.png /usr/share/icons/oxygen/16x16/actions/object-order-front.png /usr/share/icons/oxygen/16x16/actions/object-order-back.png /usr/share/icons/oxygen/16x16/actions/format-justify-right.png /usr/share/icons/oxygen/16x16/actions/format-text-underline.png" emerge @koffice-live

Comment: Well- All the koffice-live packages compiled and installed, and launch, but kword apparently only has filters for ODT and Kword documents. All my stuff is in .rtf format, so it's useless for me. Kword-1.6.x works great, and is currently my main Office app on other kde boxes. Am I just missing something here- are there any additional koffice-live plugins for more file formats, or is koffice-live jjust very incomplete right now? :roll:
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Thu Oct 30, 2008 2:58 pm    Post subject: Reply with quote

uraes wrote:
drescherjm wrote:
kdepimlibs-4.1.71 is failing for me right before the merge:

It seesms to me, that now all kde-crazy packages are failing when ">>> Installing" phaze begins, for example I get:

Code:

...
>>> Installing kde-base/kate-4.1.71
* checking 90 files for package collisions
 *
 * ERROR: kde-base/kate-4.1.71 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called pkg_preinst
 * environment, line 3245:  Called subversion_pkg_preinst
 * environment, line 3784:  Called subversion_wc_info ''
 * environment, line 3805:  Called subversion__get_repository_uri ''
 * environment, line 3621:  Called die
 * The specific snippet of code:
 * die "${ESVN}: ESVN_REPO_URI (or specified URI) is empty.";
 * The die message:
 * subversion: ESVN_REPO_URI (or specified URI) is empty.
...


For some reason is emerge trying to do smth with subversion. I found also one older thread ([SOLVED] mythtv-themes-0.20.2_p14301 fails to emerge), but really no solution...[/url]


This now appears to be fixed. I believe this is the fix:

http://git.overlays.gentoo.org/gitweb/?p=proj/kde-crazy.git;a=commitdiff;h=a885e284ce46bb90e44e024ace46104290bf7638
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Thu Oct 30, 2008 3:23 pm    Post subject: Reply with quote

On the koffice "no kword text format filters" problem. Can we add stuff from here http://websvn.kde.org/trunk/koffice/filters/
especially the kword set to the kde-libs-9999.ebuild, re-digest, and recompile koffice-libs? Or are they not there for a good reason?

Code:
KMEXTRA="
   doc/koffice/
   doc/thesaurus/
   filters/generic_wrapper/
   filters/libkowmf/
   filters/xsltfilter/
   interfaces/
   kounavail/
   plugins/
   tools/"

UPDATE:
OK- added filters/kword/ to the ebuild, redigested, but it failed because:
Code:
-- Configuring done
CMake Error in filters/kword/oowriter/CMakeLists.txt:
  Cannot find source file "ooutils.cc".  Tried extensions .c .C .c++ .cc .cpp
  .cxx .m .M .mm .h .hh .h++ .hm .hpp .hxx .in .txx                         


-- Build files have been written to: /var/tmp/portage/app-office/koffice-libs-9999/work/koffice-libs_build                                                                                             
 *                                                                                                 
 * ERROR: app-office/koffice-libs-9999 failed.


Had to comment out oowriter in /usr/portage/distfiles/svn-src/KDE/koffice/koffice/filters/kword/CMakeLists.txt
Code:
#add_subdirectory( oowriter )
Then I recompiled koffice-libs, and now all the text format import/export filters (except oowriter) show up in kword. :D However, trying to open/import an .rtf file in kword crashes it with "The application KWord (kword) crashed and caused the signal 11 (SIGSEGV." :( :?
Quote:
Details:
Thread 1 (Thread 0xa5474720 (LWP 6719)):
#0 0xffffe424 in __kernel_vsyscall ()
#1 0xa67deb80 in nanosleep () from /lib/libc.so.6
#2 0xa67de9bf in sleep () from /lib/libc.so.6
#3 0xa7044e8e in ?? () from /usr/lib/libkdeui.so.5
#4 0x00000000 in ?? ()

Maybe recompile ALL of koffice? :( Hmmm. Just tried an old MS Word '97 .doc file, and it works. Confusing. :?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
eusanpe
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2002
Posts: 107

PostPosted: Fri Oct 31, 2008 10:40 am    Post subject: Reply with quote

Here are the errors I get with kdnssd and kalgebra on kde-crazy. I will try later today and see if it continues.
Code:
>>> Emerging (1 of 1) kde-base/kalgebra-9999
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 *
 * WARNING! This is an experimental ebuild of the kdeedu KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!
>>> Unpacking source...
 * subversion update start -->
 * repository: svn://anonsvn.kde.org/home/kde/trunk/KDE/kdeedu
At revision 878053.
 * working copy: /usr/portage/distfiles/svn-src/KDE/kdeedu/kdeedu

 * Exporting parts of working copy to /var/tmp/portage/kde-base/kalgebra-9999/work/kalgebra
>>> Source unpacked.
>>> Configuring source in /var/tmp/portage/kde-base/kalgebra-9999/work/kalgebra ...
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.4.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found Phonon: /usr/lib64/libphonon.so
-- Found Phonon Includes: /usr/include/KDE;/usr/include
-- Found KDE 4.2 include dir: /usr/kde/live/include
-- Found KDE 4.2 library dir: /usr/kde/live/lib64
-- Found KDE4 kconfig_compiler preprocessor: /usr/kde/live/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found PythonInterp: /usr/bin/python2.5
-- Found Python executable: /usr/bin/python2.5
-- Found Python version: 2.5.2
-- Found Python library: /usr/lib64/libpython2.5.so
-- Found SIP version: 4.7.7
-- Found PyQt4 version: 4.4.3
-- Found PyKDE4 version 4.1.71 /usr/share/sip/PyKDE4
-- Found GMM: /usr/include
--
-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
+ Python
+ Gmm++
Congratulations! All external packages have been found.
-----------------------------------------------------------------------------

-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/portage/kde-base/kalgebra-9999/work/kalgebra_build
>>> Source configured.
>>> Compiling source in /var/tmp/portage/kde-base/kalgebra-9999/work/kalgebra ...
>>> Source compiled.
>>> Test phase [not enabled]: kde-base/kalgebra-9999

>>> Install kalgebra-9999 into /var/tmp/portage/kde-base/kalgebra-9999/image/ category kde-base
make: *** No rule to make target `install'.  Stop.
 *
 * ERROR: kde-base/kalgebra-9999 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_install
 * environment, line 3556:  Called kde4-meta_src_install
 * environment, line 2782:  Called cmake-utils_src_install
 * environment, line  840:  Called die
 * The specific snippet of code:
 * emake install DESTDIR="${D}" || die "Make install failed";
 * The die message:
 * Make install failed


Code:
>>> Emerging (1 of 4) kde-base/kdnssd-9999
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 *
 * WARNING! This is an experimental ebuild of the kdenetwork KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!
>>> Unpacking source...
 * subversion update start -->
 * repository: svn://anonsvn.kde.org/home/kde/trunk/KDE/kdenetwork

Fetching external item into 'kget/transfer-plugins/bittorrent/libbtcore'
External at revision 878053.

At revision 878053.
 * working copy: /usr/portage/distfiles/svn-src/KDE/kdenetwork/kdenetwork

 * Exporting parts of working copy to /var/tmp/portage/kde-base/kdnssd-9999/work/kdnssd
>>> Source unpacked.
>>> Configuring source in /var/tmp/portage/kde-base/kdnssd-9999/work/kdnssd ...
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.4.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found Phonon: /usr/lib64/libphonon.so
-- Found Phonon Includes: /usr/include/KDE;/usr/include
-- Found KDE 4.2 include dir: /usr/kde/live/include
-- Found KDE 4.2 library dir: /usr/kde/live/lib64
-- Found KDE4 kconfig_compiler preprocessor: /usr/kde/live/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found KDE PIM libraries
-- Looking for snd_seq_create_simple_port in asound
-- Looking for snd_seq_create_simple_port in asound - found
-- Found ALSA: /usr/lib64/libasound.so
-- Found speex library : /usr/lib64/libspeex.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found JPEG: /usr/lib64/libjpeg.so
-- Found X11VidMode: /usr/include
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found Decibel: /usr/include
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found IDN: /usr/include
-- Found Plasma: /usr/kde/live/lib64/libplasma.so
-- Performing Test LIBVNCSERVER_FOUND
-- Performing Test LIBVNCSERVER_FOUND - Success
-- Found LibVNCServer: /usr/lib64/libvncserver.so
-- Looking for DNSServiceRefDeallocate
-- Looking for DNSServiceRefDeallocate - not found
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found Soprano: /usr/lib64/libsoprano.so
-- Found Soprano includes: /usr/include
-- Found Soprano Index: /usr/lib64/libsopranoindex.so
-- Found Soprano Client: /usr/lib64/libsopranoclient.so
-- Found Soprano Plugins: nquadparser nquadserializer sesame2backend
-- Found NEPOMUK: /usr/kde/live/lib64/libnepomuk.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found Sqlite: /usr/include
--
-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
+ libvncserver
+ speex
+ libjpeg
+ QCA2
+ Decibel
+ IDN
+ Plasma
+ Soprano
+ Nepomuk
+ SQLite
-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
+ libnxcl, 1.0: NX X compression client library <http://svn.berlios.de/svnroot/repos/freenx/trunk/freenx-client/nxcl/>
Needed to build Krdc with NX support
+ libortp, 0.13: oRTP provides an API to send rtp packets <http://www.linphone.org/index.php/eng/code_review/ortp>
Needed to build Jingle support in Kopete.
+ mDNS: Zeroconf compatible runtime libraries <http://www.zeroconf.org>
Needed for KDE's service discovery feature Krfb and Krdc and the dnssd ioslave.
-----------------------------------------------------------------------------

-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/portage/kde-base/kdnssd-9999/work/kdnssd_build
>>> Source configured.
>>> Compiling source in /var/tmp/portage/kde-base/kdnssd-9999/work/kdnssd ...
>>> Source compiled.
>>> Test phase [not enabled]: kde-base/kdnssd-9999

>>> Install kdnssd-9999 into /var/tmp/portage/kde-base/kdnssd-9999/image/ category kde-base
make: *** No rule to make target `install'.  Stop.
 *
 * ERROR: kde-base/kdnssd-9999 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_install
 * environment, line 3551:  Called kde4-meta_src_install
 * environment, line 2780:  Called cmake-utils_src_install
 * environment, line  838:  Called die
 * The specific snippet of code:
 * emake install DESTDIR="${D}" || die "Make install failed";
 * The die message:
 * Make install failed
 


I am also getting this error and I have tried messing with package.keywords but to no avail:
Code:
!!! All ebuilds that could satisfy ">=kde-base/kdelibs-9999:live[-kdeprefix]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdelibs-9999 (masked by: missing keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "kde-base/kdegraphics-strigi-analyzer-9999" [installed])


Thanks,
Tony
Back to top
View user's profile Send private message
Nuitari
Apprentice
Apprentice


Joined: 15 May 2005
Posts: 245

PostPosted: Fri Oct 31, 2008 5:02 pm    Post subject: Reply with quote

Hi all!
i've a problem compiling kde-base/plasma-workspace-4.1.71:
http://rafb.net/p/FNAx7M66.html

anyone have this problem?
_________________
Da un discorso su #gentoo:

[15:10] <flowolf> pino: credo che se dovessi leggere ancora un punto interrogativo ed il tuo nick sulla stessa riga
[15:10] <flowolf> potrei andare fuori di testa
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Fri Oct 31, 2008 5:06 pm    Post subject: Reply with quote

The whole 4.1.71 compiled and installed fine for me yesterday but kdm no longer works on my system. I ended up switching to gdm and gnome-2.24 for the time being.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
mikedee
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 158

PostPosted: Fri Oct 31, 2008 7:13 pm    Post subject: Reply with quote

Nuitari: I had the same problem, you can fix it by removing python from the use flags for that package.

eg
Code:
USE=-python emerge plasma-workspace


I just added -python to make.conf

drescherjm: I also had that problem and I had to delete ~/.kde-4.2 to make it work again (its probably just 1 file, but I wasn't sure which and I'm starting new anyway)
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Fri Oct 31, 2008 8:39 pm    Post subject: Reply with quote

mikedee wrote:
Quote:
Nuitari: I had the same problem, you can fix it by removing python from the use flags for that package.

Are there any downsides to this? I'm not sure, but I would think python might be pretty important to plasma-workspace, as well as Gentoo in general, even if removing support support does allow plasma-workspace to compile. On the other hand, I did comment out the python subdirectory (macro_optional_add_subdirectory(python) as described in my updated post above, and haven't run into any problems yet.

I did find that without plasma-workspace compiled and installed, kdesvn can't even start.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
tog000
n00b
n00b


Joined: 01 Nov 2008
Posts: 1
Location: Mexico

PostPosted: Sat Nov 01, 2008 7:10 am    Post subject: Reply with quote

Hi, I'm having problems compiling konqueror-4.1.71 on my computer, it gives the following error:

http://pastebin.ca/1242190

I don't know if the KParts is somehow related to webkit and i have some problem with the Qt impl of webkit or if something else is out of place...
Any help will be greatly appreciated
Back to top
View user's profile Send private message
letchideslandes
Apprentice
Apprentice


Joined: 21 Nov 2004
Posts: 197
Location: Landes France

PostPosted: Sat Nov 01, 2008 9:51 am    Post subject: Reply with quote

Hello for people who wants localization in kde-4.1.71 ebuild, here's a solution :

get kdesvn-portage kde-l10n-9999 ebuild :
Code:
layman -a kdesvn-portage
cp -r /usr/local/portage/layman/kdesvn-portage/kde-base/kde-l10n YOUR_LOCAL_OVERLAY/kde-base/



get the eclass
Code:
cp -r /usr/local/portage/layman/kdesvn-portage/eclass YOUR_LOCAL_OVERLAY/


remove the kdesvn overlay
Code:
layman -d kdesvn-portage


provide the kdelibs-9999 package by injection
Code:
echo kde-base/kdelibs-9999 > /etc/portage/profile/package.provided


build kde-l10n
Code:
emerge -av =kde-base/kde-l10n-9999


append path to kde path
Code:
echo 'KDEDIRS="/usr/kde/svn"' > /etc/env.d/10monkde
env-update
source /etc/profile


now you can select your favorite language in systemsettings
Back to top
View user's profile Send private message
mikedee
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 158

PostPosted: Sat Nov 01, 2008 3:40 pm    Post subject: Reply with quote

wrc1944 wrote:
Are there any downsides to this?


None so far :)

AFAIK Plasma support is fairly new in plasma and all you miss are the plasmoids written in python (there are only a couple though). Anything which actually requires python would not have it as a use flag I assume. Portage and Gentoo in general are still working fine.
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Sat Nov 01, 2008 10:01 pm    Post subject: Reply with quote

drescherjm wrote:
The whole 4.1.71 compiled and installed fine for me yesterday but kdm no longer works on my system. I ended up switching to gdm and gnome-2.24 for the time being.


This seems to be fixed by setting xdm use

DISPLAYMANAGER="kdm"

instead of

DISPLAYMANAGER="kdm-4.2"

which worked with 4.1.69
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 152
Location: Czech Republic

PostPosted: Sat Nov 01, 2008 10:59 pm    Post subject: Reply with quote

letchideslandes wrote:
Hello for people who wants localization in kde-4.1.71 ebuild, here's a solution :
...


Thanks, it works :-)

I've made only one change. As I have kde4 installed without kdeprefix set, I did not set the KDEDIRS, but created a symlinks in the /usr/share/locale/<LANG>/LC_MESSAGES directory.
Back to top
View user's profile Send private message
Goshanecr
Apprentice
Apprentice


Joined: 17 Aug 2005
Posts: 158
Location: Russia

PostPosted: Sun Nov 02, 2008 6:21 am    Post subject: Reply with quote

Hi all!
I have a problem when try to install krdc from kdesvn-portage.
It tells that missing some patch file.. I'm try sync layman -S but this not helps.
Code:
Pantera-SMS-ka# emerge krdc
WARNING: repository at /usr/portage/local is missing a repo_name entry
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) kde-base/krdc-4.1.69
 * kdenetwork-4.1.69.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...             [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
>>> Unpacking source...
Unpacking parts of kdenetwork-4.1.69.tar.bz2 to /var/tmp/portage/kde-base/krdc-4.1.69/work

 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *
 * /usr/portage/local/layman/kdesvn-portage/kde-base/krdc/files/krdc-nxcl.patch
 * ( krdc-nxcl.patch )

 *
 * ERROR: kde-base/krdc-4.1.69 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_unpack
 * environment, line 3211:  Called kde4overlay-meta_src_unpack
 * environment, line 2549:  Called kde4overlay-meta_src_extract
 * environment, line 2515:  Called kde4overlay-base_src_unpack
 * environment, line 2275:  Called kde4overlay-base_apply_patches
 * environment, line 2131:  Called base_src_unpack 'autopatch'
 * environment, line  453:  Called epatch '/usr/portage/local/layman/kdesvn-portage/kde-base/krdc/files/krdc-nxcl.patch'
 * environment, line 1451:  Called die
 * The specific snippet of code:
 * die "Cannot find $EPATCH_SOURCE!";
 * The die message:
 * Cannot find $EPATCH_SOURCE!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/krdc-4.1.69/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/krdc-4.1.69/temp/environment'.
 *

>>> Failed to emerge kde-base/krdc-4.1.69, Log file:

>>>  '/var/tmp/portage/kde-base/krdc-4.1.69/temp/build.log'

 * Messages for package kde-base/krdc-4.1.69:

 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *
 * /usr/portage/local/layman/kdesvn-portage/kde-base/krdc/files/krdc-nxcl.patch
 * ( krdc-nxcl.patch )
 *
 * ERROR: kde-base/krdc-4.1.69 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_unpack
 * environment, line 3211:  Called kde4overlay-meta_src_unpack
 * environment, line 2549:  Called kde4overlay-meta_src_extract
 * environment, line 2515:  Called kde4overlay-base_src_unpack
 * environment, line 2275:  Called kde4overlay-base_apply_patches
 * environment, line 2131:  Called base_src_unpack 'autopatch'
 * environment, line  453:  Called epatch '/usr/portage/local/layman/kdesvn-portage/kde-base/krdc/files/krdc-nxcl.patch'
 * environment, line 1451:  Called die
 * The specific snippet of code:
 * die "Cannot find $EPATCH_SOURCE!";
 * The die message:
 * Cannot find $EPATCH_SOURCE!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/krdc-4.1.69/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/krdc-4.1.69/temp/environment'.
 *

 * GNU info directory index is up-to-date.
Back to top
View user's profile Send private message
sno35
Guru
Guru


Joined: 15 May 2004
Posts: 334
Location: Paris, France

PostPosted: Sun Nov 02, 2008 11:04 am    Post subject: Re: undefined reference to `jpeg_resync_to_restart' kdelibs- Reply with quote

frankOnPPC wrote:
I got a

jpegloader.cpp:(.text+0xb48): undefined reference to `jpeg_finish_output'
jpegloader.cpp:(.text+0xb50): undefined reference to `jpeg_input_complete'
CMakeFiles/khtml.dir/imload/decoders/jpegloader.o: (.got2+0xc): undefined reference to `jpeg_resync_to_restart'
collect2: ld returned 1 exit status
make[2]: *** [lib/libkhtml.so.5.1.0] Error 1
make[1]: *** [khtml/CMakeFiles/khtml.dir/all] Error 2

Which ends in
[... SNIP ...]


I think I guess where this comes from : libjpeg.so from inside a JDK. Had the problem many times.
You might remove the jdk/bin directory from your PATH while trying to build KDE.
Hth
Back to top
View user's profile Send private message
ebast
n00b
n00b


Joined: 02 Nov 2008
Posts: 11

PostPosted: Sun Nov 02, 2008 11:39 am    Post subject: Reply with quote

tog000 wrote:
Hi, I'm having problems compiling konqueror-4.1.71 on my computer, it gives the following error:

http://pastebin.ca/1242190

I don't know if the KParts is somehow related to webkit and i have some problem with the Qt impl of webkit or if something else is out of place...
Any help will be greatly appreciated


I had the same problem. Upgrading dev-util/cmake to 2.6.2, dev-libs/rasqal to 0.9.16 and dev-libs/redland to 1.0.8 solved the problem for me. Of course, it could be possible, that upgrading one of them is sufficient, but i don't now which.

Hope that helps.
Back to top
View user's profile Send private message
mikedee
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 158

PostPosted: Sun Nov 02, 2008 3:51 pm    Post subject: Reply with quote

Does anyone know the release schedule for the snapshots? Is it weekly, or just whenever the KDE team thinks its good?
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 152
Location: Czech Republic

PostPosted: Sun Nov 02, 2008 5:09 pm    Post subject: Reply with quote

mikedee wrote:
Does anyone know the release schedule for the snapshots? Is it weekly, or just whenever the KDE team thinks its good?


Well, according to schedule, there should be Alpha 1 now.
Back to top
View user's profile Send private message
.W.
n00b
n00b


Joined: 10 Nov 2004
Posts: 22
Location: Finland,Kangasala

PostPosted: Mon Nov 03, 2008 7:08 am    Post subject: Reply with quote

letchideslandes wrote:
Hello for people who wants localization in kde-4.1.71 ebuild, here's a solution :

get kdesvn-portage kde-l10n-9999 ebuild :
Code:
layman -a kdesvn-portage
cp -r /usr/local/portage/layman/kdesvn-portage/kde-base/kde-l10n YOUR_LOCAL_OVERLAY/kde-base/



get the eclass
Code:
cp -r /usr/local/portage/layman/kdesvn-portage/eclass YOUR_LOCAL_OVERLAY/


remove the kdesvn overlay
Code:
layman -d kdesvn-portage


provide the kdelibs-9999 package by injection
Code:
echo kde-base/kdelibs-9999 > /etc/portage/profile/package.provided


build kde-l10n
Code:
emerge -av =kde-base/kde-l10n-9999


append path to kde path
Code:
echo 'KDEDIRS="/usr/kde/svn"' > /etc/env.d/10monkde
env-update
source /etc/profile


now you can select your favorite language in systemsettings



I have another (better?) solution, that does not need any -9999 deps. Here's kde-l10n-4.1.9999.ebuild: http://pastebin.ca/1243825.
Back to top
View user's profile Send private message
airon
n00b
n00b


Joined: 30 Sep 2003
Posts: 21

PostPosted: Mon Nov 03, 2008 9:45 am    Post subject: Reply with quote

For all those that were unable to compile plasma-workspace.

I had the same problem. But finally I was able to compile it after emerging the following packages:

dev-python/sip-4.7.7
kde-base/automoc-0.9.87 (re emerged, I had it compiled before, so I re emerged it)

I don't know which one did the trick. But after that, I have my plasma-workspace with the python USE enabled.

I hope this helps to someone.
Back to top
View user's profile Send private message
airon
n00b
n00b


Joined: 30 Sep 2003
Posts: 21

PostPosted: Mon Nov 03, 2008 12:54 pm    Post subject: Reply with quote

Another note, after emerging sip, you may emerge (or reemerge):

dev-python/PyQt4-4.4.3
pykde4-4.1.71

Then give it a try.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Tue Nov 04, 2008 7:55 am    Post subject: Reply with quote

Just curious- anyone know what's going on in http://websvn.kde.org/trunk/KDE/kdelibs/plasma/
Seems pretty drastic. Has anyone rebuilt since all these updates?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 152
Location: Czech Republic

PostPosted: Tue Nov 04, 2008 8:38 am    Post subject: Reply with quote

.W. wrote:

I have another (better?) solution, that does not need any -9999 deps. Here's kde-l10n-4.1.9999.ebuild: http://pastebin.ca/1243825.

This solution has an advantage that there is not needed to have kdelibs in provided, but the translations are installed into the /usr/share/locale/ and there is an collision with e.g. amarok :-(

I have not time yet, to check if it is easy to change the ebuild to install into /urs/kde/4.2. But I'll try evening.
Back to top
View user's profile Send private message
d-fens
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2004
Posts: 92

PostPosted: Tue Nov 04, 2008 9:28 am    Post subject: Reply with quote

the plasma changes broke the ebuild

Code:

>>> Emerging (1 of 2) kde-base/libplasma-9999
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 *
 * WARNING! This is an experimental ebuild of the kdebase-workspace KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!
>>> Unpacking source...
 * Fetching disabled since 1 hours has not passed since last update.
 * Using existing repository copy at revision 879876.
 * working copy: /usr/portage/distfiles/svn-src/KDE/kdebase/kdebase

 * Exporting parts of working copy to /var/tmp/portage/kde-base/libplasma-9999/work/libplasma
rsync: link_stat "/usr/portage/distfiles/svn-src/KDE/kdebase/kdebase/workspace/libs/plasma" failed: No such file or directory (2)
rsync error: some files could not be transferred (code 23) at main.c(1031) [sender=3.0.2]
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Tue Nov 04, 2008 12:37 pm    Post subject: Reply with quote

I would imagine that's because plasma is moved and is no longer in /kdebase/workspace/libs/plasma. :wink:

I think I'll wait a couple of days before trying a rebuild.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 28, 29, 30  Next
Page 7 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum