Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 2)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Loibisch
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jan 2006
Posts: 89

PostPosted: Thu Nov 06, 2008 10:51 am    Post subject: Reply with quote

Ok, plasma-workspace just compiled with USE="-python"
Now the only package left with a problem (for me) is kde-base/systemsettings:

Code:
Linking CXX shared module ../../lib/kcm_clock.so                                                                                                                                                                   
[ 57%] Built target kcm_clock                                                                                                                                                                                       
Scanning dependencies of target kcmdatetimehelper                                                                                                                                                                   
[ 57%] Building CXX object kcontrol/dateandtime/CMakeFiles/kcmdatetimehelper.dir/kcmdatetimehelper_automoc.o                                                                                                       
[ 58%] Building CXX object kcontrol/dateandtime/CMakeFiles/kcmdatetimehelper.dir/helper.o                                                                                                                           
Linking CXX executable kcmdatetimehelper                                                                                                                                                                           
[ 58%] Built target kcmdatetimehelper                                                                                                                                                                               
make[2]: *** No rule to make target `/var/tmp/portage/kde-base/systemsettings-4.1.72/work/systemsettings-4.1.72/krunner/org.kde.krunner.App.xml', needed by `kcontrol/launch/krunner_interface.cpp'.  Stop.         
make[1]: *** [kcontrol/launch/CMakeFiles/kcm_launch.dir/all] Error 2                                                                                                                                               
make: *** [all] Error 2
..........
Back to top
View user's profile Send private message
cracki
n00b
n00b


Joined: 12 Oct 2005
Posts: 34

PostPosted: Thu Nov 06, 2008 12:29 pm    Post subject: Reply with quote

Hmm somehow PyKDE4 fails for me to compile successfully:

Code:
sip: /usr/share/sip/qt/versions.sip:34: Version is already defined
make[2]: *** [python/pykde4/sip/dnssd/sipdnssdpart0.cpp] Fehler 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_dnssd.dir/all] Fehler 2
make[1]: *** Warte auf noch nicht beendete Prozesse...
sip: /usr/share/sip/qt/versions.sip:34: Version is already defined
make[2]: *** [python/pykde4/sip/akonadi/sipakonadipart0.cpp] Fehler 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_akonadi.dir/all] Fehler 2


I wonder if these messages, appearing in configure have anything to do with that:
Code:
-- cmake package FindOkular.cmake was not found. The package Okular is needed to compile all part of this program.
-- cmake package FindKDevPlatform.cmake was not found. The package KDevPlatform is needed to compile all part of this program.
Back to top
View user's profile Send private message
fr4nk
n00b
n00b


Joined: 29 May 2004
Posts: 22
Location: Austria

PostPosted: Thu Nov 06, 2008 3:52 pm    Post subject: Reply with quote

I'm having problems compiling kdepimlibs for a few days now:

Code:
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/literal.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/resource.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/model.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/modelmaker.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/rdfvocab.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/sequence.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/statement.o
[ 32%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/resourcewrapper.o
[ 32%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/nodevisitor.o
[ 32%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/category.o
[ 32%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/constants.o
[ 32%] [ 32%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/content.o
Building CXX object syndication/CMakeFiles/syndication.dir/atom/document.o
[ 32%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/entry.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/generator.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/link.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/parser.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/person.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/source.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/atomtools.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/feedrss2impl.o
[ 35%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/itemrss2impl.o
[ 35%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/enclosurerss2impl.o
[ 35%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/categoryrss2impl.o
[ 35%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/imagerss2impl.o
[ 35%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/feedrdfimpl.o
[ 35%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/itemrdfimpl.o
[ 35%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/imagerdfimpl.o
[ 35%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/feedatomimpl.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/itematomimpl.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/enclosureatomimpl.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/categoryatomimpl.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/documentsource.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/documentvisitor.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/elementwrapper.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/constants.o
[ 38%] Building CXX object syndication/CMakeFiles/syndication.dir/feed.o
[ 38%] Building CXX object syndication/CMakeFiles/syndication.dir/item.o
[ 38%] Building CXX object syndication/CMakeFiles/syndication.dir/enclosure.o
[ 38%] [ 38%] Building CXX object syndication/CMakeFiles/syndication.dir/image.o
Building CXX object syndication/CMakeFiles/syndication.dir/category.o
[ 38%] Building CXX object syndication/CMakeFiles/syndication.dir/tools.o
[ 38%] Building CXX object syndication/CMakeFiles/syndication.dir/person.o
[ 39%] Building CXX object syndication/CMakeFiles/syndication.dir/personimpl.o
[ 39%] Building CXX object syndication/CMakeFiles/syndication.dir/loader.o
[ 39%] Building CXX object syndication/CMakeFiles/syndication.dir/global.o
[ 39%] Building CXX object syndication/CMakeFiles/syndication.dir/dataretriever.o
[ 39%] Building CXX object syndication/CMakeFiles/syndication.dir/specificitemvisitor.o
[ 39%] Building CXX object syndication/CMakeFiles/syndication.dir/specificitem.o
[ 39%] Building CXX object syndication/CMakeFiles/syndication.dir/specificdocument.o
[ 39%] Building CXX object syndication/CMakeFiles/syndication.dir/abstractparser.o
[ 39%] Building CXX object syndication/CMakeFiles/syndication.dir/syndication_automoc.o
Linking CXX shared library ../lib/libsyndication.so
[ 39%] Built target syndication
make: *** [all] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in kde-base/kdepimlibs-4.1.72:
!!! In cmake-utils_src_make at line 1209
!!! Make failed!

!!! Call stack:
!!!    * cmake-utils_src_make (/var/tmp/paludis/kde-base-kdepimlibs-4.1.72/temp/loadsaveenv:1209)
!!!    * kde4-base_src_make (/var/tmp/paludis/kde-base-kdepimlibs-4.1.72/temp/loadsaveenv:3400)
!!!    * kde4-base_src_compile (/var/tmp/paludis/kde-base-kdepimlibs-4.1.72/temp/loadsaveenv:3344)
!!!    * src_compile (/var/tmp/paludis/kde-base-kdepimlibs-4.1.72/temp/loadsaveenv:4365)
!!!    * ebuild_f_compile (/usr/libexec/paludis/2/src_compile.bash:54)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:477)
!!!    * main (/usr/libexec/paludis/ebuild.bash:492)

diefunc: making ebuild PID 5033 exit with error
die trap: exiting with error.


It happens with both 4.1.72 as well as -9999 (and the -scm version from the paludis KDE overlay). Version 4.1.2 compiles without problems.

I already tried deleting/resyncing the overlays and clearing svn-src.

Some data from paludis --info:

Code:
paludis 0.30.3         
Paludis build information:
    Compiler:             
        CXX:                   x86_64-pc-linux-gnu-g++ 4.3.2
        CXXFLAGS:              -march=core2 -O2 -pipe       
        LDFLAGS:                                           
        DATE:                  2008-10-11T16:22:36+0200     

    Libraries:
        C++ Library:           GNU libstdc++ 20080827

    Reduced Privs:
        reduced_uid:           109
        reduced_uid->name:     paludisbuild
        reduced_uid->dir:      /var/tmp/paludis
        reduced_gid:           1016           
        reduced_gid->name:     paludisbuild   

    Paths:
        DATADIR:               /usr/share
        LIBDIR:                /usr/lib64
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc       
        PYTHONINSTALLDIR:      /usr/lib64/python2.5/site-packages
        RUBYINSTALLDIR:        /usr/lib64/ruby/site_ruby/1.8/x86_64-linux

Environment:
    Format:                    paludis
    Config dir:                /etc/paludis
    World file:                /var/db/pkg/world

[...] Overlay list [....]

    Package information:
        app-admin/eselect-compiler: (none)                                                                                                                                                         
        app-shells/bash:       3.2_p39                                                                                                                                                             
        dev-java/java-config:  1.3.7 2.1.6-r1                                                                                                                                                     
        dev-lang/python:       2.5.2-r8                                                                                                                                                           
        dev-python/pycrypto:   (none)                                                                                                                                                             
        dev-util/ccache:       2.4-r8                                                                                                                                                             
        dev-util/cmake:        2.6.2                                                                                                                                                               
        dev-util/confcache:    (none)                                                                                                                                                             
        sys-apps/baselayout:   2.0.0                                                                                                                                                               
        sys-apps/openrc:       0.3.0-r1                                                                                                                                                           
        sys-apps/sandbox:      1.2.18.1-r3                                                                                                                                                         
        sys-devel/autoconf:    2.13 2.63                                                                                                                                                           
        sys-devel/automake:    1.10.1-r1 1.5 1.7.9-r1 1.8.5-r3 1.9.6-r2                                                                                                                           
        sys-devel/binutils:    2.19                                                                                                                                                               
        sys-devel/gcc-config:  1.4.0-r4                                                                                                                                                           
        sys-devel/libtool:     2.2.6a                                                                                                                                                             
        virtual/os-headers:    2.6.27-r2 (for sys-kernel/linux-headers::installed)


Global USE flags:

Code:
a52 aac avahi bash-completion bluetooth caps esd -gnome glitz -gtk kde kdeprefix lm_sensors mmx matroska mplayer pdf png pulseaudio qt-copy qt4 samba semantic-desktop smp sse sse2 svg threads usb x264 xine xinerama xcomposite xft xrandr xvid


Has anybody run into this problem and has a solution?
Back to top
View user's profile Send private message
ecroy
n00b
n00b


Joined: 08 Nov 2002
Posts: 59

PostPosted: Thu Nov 06, 2008 4:30 pm    Post subject: Reply with quote

fr4nk wrote:
Has anybody run into this problem and has a solution?

I think I have - check the beginning of the build log and you will probably notice something like:
Code:
-- Found KDE 4.1 include dir: /usr/include
-- Found KDE 4.1 library dir: /usr/lib

which seems to be the cause for this problem - I worked around it by simply unmerging kdelibs:4.1 before trying to build :4.2
As it seems to be only a build-time issue you can probably just emerge kdelibs:4.1 again afterwards.

Hope that helps!
Back to top
View user's profile Send private message
fr4nk
n00b
n00b


Joined: 29 May 2004
Posts: 22
Location: Austria

PostPosted: Thu Nov 06, 2008 4:39 pm    Post subject: Reply with quote

ecroy wrote:
I think I have - check the beginning of the build log and you will probably notice something like:
Code:
-- Found KDE 4.1 include dir: /usr/include
-- Found KDE 4.1 library dir: /usr/lib

which seems to be the cause for this problem - I worked around it by simply unmerging kdelibs:4.1 before trying to build :4.2
As it seems to be only a build-time issue you can probably just emerge kdelibs:4.1 again afterwards.

Hope that helps!


You're right, that's probably because I didn't (yet) compile KDE 4.1 with kdeprefix... the 4.2 ebuilds asked for it but paludis and portage both wanted to compile the 4.2 libs before recompiling 4.1 with kdeprefix.

So I'm now updating 4.1 with the new USE flag and then give kdepimlibs-4.1.72 a shot again.

Thanks very much, I'll report back if it worked. :)
Back to top
View user's profile Send private message
MemphisX
n00b
n00b


Joined: 17 Jul 2008
Posts: 5
Location: Greece

PostPosted: Thu Nov 06, 2008 6:16 pm    Post subject: Help Reply with quote

I've been using kdesvn-portage for a long time ago but I was unaware of the change and the removal of it...so on the last few syncs on layman kdesvn-portage couldnt sync... as I had some similar problems with enlightenment I followed the same route to solve oit and removed kdesvn-portage overlay with layman -d kdesvn-portage but when I tried to add it again I couldnt and I found the reason here as things have changed...

So I added kde-crazy overlay but whatever I do whatever I want to emerge I always get
.....emerge: There are no sets to satisfy 'kde-svn'. The following sets exist:.......

Im not using KDE 4 anymore other than when having serious problems with gnome but I want my system back to normal so I can atleast update... and it doesnt let me... how can I remove that set from my set now when the kdesvn-portage overlay doesnt exist?
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Thu Nov 06, 2008 6:23 pm    Post subject: Reply with quote

The set you want is

kde-4.2

To remove bad sets. You probably want to look in /etc/portage/sets
_________________
John

My gentoo overlay
Instructons for overlay


Last edited by drescherjm on Thu Nov 06, 2008 6:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Thu Nov 06, 2008 6:29 pm    Post subject: Reply with quote

Can I compile kde-4.1.3 from kde-testing?

How???

Thanks
Back to top
View user's profile Send private message
Shamus397
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 217
Location: Ur-th

PostPosted: Thu Nov 06, 2008 8:24 pm    Post subject: Reply with quote

Hmm, that's a good question. I wonder if that's still how you get stuff that's destined for the portage tree? :? Any devs care to chime in? :)
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Thu Nov 06, 2008 9:28 pm    Post subject: Reply with quote

Quote:
Can I compile kde-4.1.3 from kde-testing?

as kde-4.1.3 isn't actually in the kde-testing overlay, I don't think so. kdetesting doen't have a lot in it right now (no full kde contained in it).

With kde-4.1 in the main tree, kde-4.1.3 isn't going to get in overnight, and it came out yesturday.
you might just have to be a little more patient, or bump the ebuilds yourself.
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Thu Nov 06, 2008 9:41 pm    Post subject: Reply with quote

earendilion wrote:
I've the same problem...

Here the error with systemsettings :

Code:
[ 57%] Building CXX object kcontrol/dateandtime/CMakeFiles/kcm_clock.dir/kcm_clo
ck_automoc.o                                                                   
make[2]: *** Pas de règle pour fabriquer la cible « /var/tmp/portage/kde-base/sy
stemsettings-4.1.72/work/systemsettings-4.1.72/krunner/org.kde.krunner.App.xml »
Same problem here: I solved it suspending emerge after the unpacking and then extracting that file from kdebase-workspace and copying it to the right location.
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Thu Nov 06, 2008 9:45 pm    Post subject: Reply with quote

@dusdan, et al.
I did something similiar but I feel a tad easier,
I copied all the org.kde*.xml files from /usr/share/dbus-1/interfaces/.

As those are the ones it will probably be using. I'm not sure which is better, but I wanted my kde-4.2 back :(
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
fr4nk
n00b
n00b


Joined: 29 May 2004
Posts: 22
Location: Austria

PostPosted: Thu Nov 06, 2008 9:51 pm    Post subject: Reply with quote

fr4nk wrote:
I'll report back if it worked. :)


OK, that did the trick, thanks again, ecroy.
Back to top
View user's profile Send private message
earendilion
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2007
Posts: 115
Location: Meudon (92), France

PostPosted: Thu Nov 06, 2008 10:05 pm    Post subject: Reply with quote

Hi, I succeeded in launching kdm... but when i try to login I get an error saying that kstartupconfig4 couldn't be found. I know it's here (in /usr/kde/4.2/bin)... I tried to recompile it (thought it was a problem with the new kdeprefix use option), but it made nothing...

any idea ?

[EDIT] OK, I fixed this : the kdebase-startkde wasn't installed. I installed it and it worked ;)


Last edited by earendilion on Fri Nov 07, 2008 9:41 am; edited 1 time in total
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Fri Nov 07, 2008 8:49 am    Post subject: Reply with quote

How can I install Amarok for 4.2? I see ebuilds only for 4.1 and live.
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Fri Nov 07, 2008 9:55 am    Post subject: Reply with quote

kde-crazy has amarok-1.94, use that.
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
Loibisch
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jan 2006
Posts: 89

PostPosted: Fri Nov 07, 2008 10:19 am    Post subject: Reply with quote

coolsnowmen wrote:
kde-crazy has amarok-1.94, use that.

Well, the problem is that the amarok-1.94 ebuild still expects one of the libraries which has been merged into the main kdelibs in the 4.2 snapshots.
I had to copy the 1.94-ebuild to my local overlay, remove the dependency for that single library and compile amarok this way. Worked just fine.
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Fri Nov 07, 2008 10:59 am    Post subject: Reply with quote

coolsnowmen wrote:
kde-crazy has amarok-1.94, use that.


Did you try it? As I wrote it has ebuilds only for 4.1 (amarok-1.94:2) and live (amarok-9999:live).

EDIT: btw I'm trying to emerge amarok-9999 (local copy fixed fo 4.2, but still using slot live) and it says:
Code:
>>> Unpacking source...
 * subversion check out start -->
 * repository: svn://anonsvn.kde.org/home/kde/trunk/extragear/multimedia/amarok
svn: Can't connect to host 'anonsvn.kde.org': Connection refused
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Fri Nov 07, 2008 12:29 pm    Post subject: Reply with quote

One question:
Since 4.1.72 requires NetworkManager-0.7 how can I configure wireless access (essid, key and so on)?
I've been using knetworkmanager from kde 3.5 until 4.1.71, but it doesn't work with the new NM, and systemsetting network module complains that he cannot parse an XML file, but it doesn't say which one.
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Fri Nov 07, 2008 3:36 pm    Post subject: Reply with quote

aTan wrote:
coolsnowmen wrote:
kde-crazy has amarok-1.94, use that.

EDIT: btw I'm trying to emerge amarok-9999 (local copy fixed fo 4.2, but still using slot live) and it says:
Code:
>>> Unpacking source...
 * subversion check out start -->
 * repository: svn://anonsvn.kde.org/home/kde/trunk/extragear/multimedia/amarok
svn: Can't connect to host 'anonsvn.kde.org': Connection refused


Now it says (but I guess the reason is same):
Code:
 * Call stack:
 * ebuild.sh, line   49:  Called src_unpack
 * environment, line 3224:  Called kde4-base_src_unpack
 * environment, line 2426:  Called subversion_src_unpack
 * environment, line 3546:  Called subversion_fetch
 * environment, line 3478:  Called die
 * The specific snippet of code:
 * ${ESVN_FETCH_CMD} ${options} "${repo_uri}" || die "${ESVN}: can't fetch to ${wc_path} from ${repo_uri}.";
 * The die message:
 * subversion: can't fetch to /system/distfiles/svn-src/KDE/extragear/multimedia/amarok from svn://anonsvn.kde.org/home/kde/trunk/extragear/multimedia/amarok.
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Fri Nov 07, 2008 5:45 pm    Post subject: Reply with quote

I don't know what is going on, but all svn mirrors are offline (connection refused on svn port). I've tried all from http://techbase.kde.org/Getting_Started/Sources/Anonymous_SVN
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Fri Nov 07, 2008 6:25 pm    Post subject: Reply with quote

kweather error:

Code:
>>> Source configured.                                                                                   
>>> Compiling source in /var/tmp/portage/portage/kde-base/kweather-4.1.72/work/kweather-4.1.72 ...       
make -j6                                                                                                 
>>> Source compiled.                                                                                     
>>> Test phase [not enabled]: kde-base/kweather-4.1.72                                                   

>>> Install kweather-4.1.72 into /var/tmp/portage/portage/kde-base/kweather-4.1.72/image/ category kde-base
make -j6 install DESTDIR=/var/tmp/portage/portage/kde-base/kweather-4.1.72/image/                         
make: *** No rule to make target `install'.  Stop.                                                         
 *                                                                                                         
 * ERROR: kde-base/kweather-4.1.72 failed.                                                                 
 * Call stack:                                                                                             
 * ebuild.sh, line   49:  Called src_install                                                               
 * environment, line 3560:  Called kde4-meta_src_install                                                   
 * environment, line 2792:  Called cmake-utils_src_install                                                 
 * environment, line  841:  Called die                                                                     
 * The specific snippet of code:                                                                           
 * emake install DESTDIR="${D}" || die "Make install failed";                                             
 * The die message:                                                                                       
 * Make install failed
Back to top
View user's profile Send private message
sips
n00b
n00b


Joined: 08 Apr 2008
Posts: 31

PostPosted: Fri Nov 07, 2008 6:36 pm    Post subject: Reply with quote

Dusdan wrote:
One question:
Since 4.1.72 requires NetworkManager-0.7 how can I configure wireless access (essid, key and so on)?
I've been using knetworkmanager from kde 3.5 until 4.1.71, but it doesn't work with the new NM, and systemsetting network module complains that he cannot parse an XML file, but it doesn't say which one.

+1

EDIT: I just re-emerged solid with -networkmanager, downgraded networkmanager-0.7.0_rc1 to networkmanager-0.6.6 & happily using good old knetworkmanager:3.5


Last edited by sips on Fri Nov 07, 2008 7:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
martin.k
Guru
Guru


Joined: 28 Nov 2004
Posts: 493
Location: Wylatowo, Polska

PostPosted: Fri Nov 07, 2008 6:42 pm    Post subject: Reply with quote

aTan wrote:
I don't know what is going on, but all svn mirrors are offline (connection refused on svn port).

Thiago on #kde-devel said that anonsvn.kde.org is down :(
Just when I was trying to reemerge kde-krazy :P
Too bad :P
_________________
linux-2.6.17 +ck +R4 +lockless +genetic-as +... więcej nie pamiętam :)
LRU #299256
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Fri Nov 07, 2008 8:27 pm    Post subject: Reply with quote

aTan wrote:
coolsnowmen wrote:
kde-crazy has amarok-1.94, use that.


Did you try it? As I wrote it has ebuilds only for 4.1 (amarok-1.94:2) and live (amarok-9999:live).



"did you try it?"
I am using that version right now. I have a full kde 4.1.72 install (minus a couple broken packages). 1.94 is the latest tag in the amarok tree, it was tagged Oct-31, why do you think it is "only for 4.1".
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 28, 29, 30  Next
Page 9 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum