Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 2)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 14, 15, 16 ... 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Thu Nov 20, 2008 12:30 pm    Post subject: Reply with quote

d-fens wrote:
Code:
vi /usr/portage/local/layman/kde-crazy/kde-base/plasma-workspace/plasma-workspace-9999.ebuild

add ksysguard the file so KMEXTRACTONLY reads
Code:

KMEXTRACTONLY=" krunner/dbus/org.freedesktop.ScreenSaver.xml
        krunner/dbus/org.kde.krunner.App.xml
        ksmserver/org.kde.KSMServerInterface.xml
        libs/kworkspace/
        libs/taskmanager/
        ksysguard"


do a
Code:
ebuild /usr/portage/local/layman/kde-crazy/kde-base/plasma-workspace/plasma-workspace-9999.ebuild digest


and emerge it.



i couldn't log in so i had to start consolekit service (rc-update add consolekit default) and /etc/init.d/consolekit start



ok thanks!
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Thu Nov 20, 2008 2:28 pm    Post subject: Reply with quote

Give us 4.1.80!!!!! :twisted:
Back to top
View user's profile Send private message
angiest
n00b
n00b


Joined: 12 Nov 2008
Posts: 14

PostPosted: Thu Nov 20, 2008 2:45 pm    Post subject: Reply with quote

d-fens wrote:
Code:
vi /usr/portage/local/layman/kde-crazy/kde-base/plasma-workspace/plasma-workspace-9999.ebuild

add ksysguard the file so KMEXTRACTONLY reads
Code:

KMEXTRACTONLY=" krunner/dbus/org.freedesktop.ScreenSaver.xml
        krunner/dbus/org.kde.krunner.App.xml
        ksmserver/org.kde.KSMServerInterface.xml
        libs/kworkspace/
        libs/taskmanager/
        ksysguard"


do a
Code:
ebuild /usr/portage/local/layman/kde-crazy/kde-base/plasma-workspace/plasma-workspace-9999.ebuild digest


and emerge it.

i couldn't log in so i had to start consolekit service (rc-update add consolekit default) and /etc/init.d/consolekit start


That was in the ebuild when I sync'd this morning. Now I am receiving an error that it cannot find -lksysgrd. And I cannot emerge ksysguard because it has plasma-workspace as a dependency.
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Thu Nov 20, 2008 3:35 pm    Post subject: Reply with quote

aTan wrote:
Give us 4.1.80!!!!! :twisted:

lol it seems to be a drug this new release
the strange is that they have updated the overlay but not the svn...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7106
Location: Austria

PostPosted: Thu Nov 20, 2008 3:36 pm    Post subject: Reply with quote

True bleeding edge. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3251
Location: Gainesville, Florida

PostPosted: Thu Nov 20, 2008 5:46 pm    Post subject: Reply with quote

hunky,
Yes- you can't boot into kde because of what you said. It sounds like your kde versions are in conflict. Trying to run kde-3.5 and kde4 (or svn) with the same user with kdm as the display manager can be tricky. gdm sets it all up automatically, listing both kde versions, and works well (at least for me it's always done so).

Maybe you might try removing all of you current kde4 and trying to install using a dedicated user for kde4, using the USE flag kdeprefix in make.conf, and using gdm as display manager. Take a look at my posts on Page 11 of this thread https://forums.gentoo.org/viewtopic-p-5282016-highlight-.html#5282016 where I explain what I did (2nd post).
Keep in mind this is for kde-4.1.3, but the principle is the same for kdebase-live.
Basically, create a new user, install gdm, and then install kdebase when booted to the new dedicated user

There's a one line command by notHerbert to remove all kde packages for a specific version here, that is for 4.1*, but I guess you could modify it for kdebase-live. https://forums.gentoo.org/viewtopic-t-715210.html
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Thu Nov 20, 2008 5:47 pm    Post subject: Reply with quote

plasma-workspace still fails to compile here though I searched the build.log and it did not find any reference to lksysgrd. Looking through the pre-compile (configure?) part of the log I think the only failed lines are these:
Code:

-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Failed

-- Performing Test STRIGI_NEEDS_CHAR
-- Performing Test STRIGI_NEEDS_CHAR - Failed
-- Strigi API needs 'signed char'

there's a few "not found"s but I think that is pretty normal.
In the compile section I'm just seeing lines like this:
Code:
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/containments/                     panel/panel.cpp: In member function 'void Panel::updateBorders(const QRect&)':
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/containments/                     panel/panel.cpp:329: error: 'toolBoxItem' was not declared in this scope
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/containments/                     panel/panel.cpp: In member function 'void Panel::themeUpdated()':
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/containments/                     panel/panel.cpp:488: warning: passing 'qreal' for argument 1 to 'QSize::QSize(int, int)'
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/containments/                     panel/panel.cpp:488: warning: passing 'qreal' for argument 2 to 'QSize::QSize(int, int)'
make[2]: *** [plasma/containments/panel/CMakeFiles/plasma_containment_panel.dir/panel.o] E                     rror 1
make[1]: *** [plasma/containments/panel/CMakeFiles/plasma_containment_panel.dir/all] Error                      2


Sure appreciate the suggestions by d-fens.

[edit] Thanks wrc1944 for that. It may be a good suggestion - though fvwm doesn't bother me too much. I'll take a look at those posts you mentioned and give it some thought. I suspect I would still have these build problems though - but at least get my old kde back. cheers, jd
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Thu Nov 20, 2008 6:07 pm    Post subject: Reply with quote

took a look at that removal line:
Code:
emerge -uDN world
emerge -Ca $(qlist -ICv | grep "kde.*4.1" | sed 's/^/=/' | tr '\n' ' ')
emerge --depclean
revdep-rebuild
env-update && source /etc/profile

It lists about 9 packages of the 4.1.73 ilk to be removed and omits the 9999 packages. (I used --pretend with the command)
If I substitute 9999 for the 4.1, it lists about 10 packages to remove and a whole bunch of lines like this:
Code:
Not unmerging package kde-base/dolphin-9999 as it is
still referenced by the following package sets:
    kdebase-live

So I'm guessing I need to remove the set in the @world file? Then run the unmerge command for both versions (9999 and 4.1.73).

cheers, JD
Back to top
View user's profile Send private message
KejPi
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2004
Posts: 122
Location: Prague, Czech republic

PostPosted: Thu Nov 20, 2008 6:59 pm    Post subject: bespin Reply with quote

I prepared bespin live ebuild yesterday. It is probably very dirty solution, but it works so maybe somebody finds it useful ;-)

Code:

# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI="2"
inherit kde4-base

SLOT="live"

# Install to KDEDIR rather than /usr, to slot properly.
PREFIX="${KDEDIR}"

ESVN_REPO_URI="http://cloudcity.svn.sourceforge.net/svnroot/cloudcity"
DESCRIPTION="Bespin is a native style for QT/KDE4"
HOMEPAGE="http://cloudcity.sourceforge.net"

LICENSE="GPL-2"
KEYWORDS=""

DEPEND="kde-base/kwin:${SLOT}"
RDEPEND="${DEPEND}"


Create bespin-9999.ebuild and place it to your kde-crazy overlay directory/x11-themes/bespin/.
_________________
hidentity.org
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3251
Location: Gainesville, Florida

PostPosted: Thu Nov 20, 2008 7:26 pm    Post subject: Reply with quote

hunky,
You probably already did this, but did you resync kde-crazy with layman -s kde-crazy? Plasma was moved to kdelibs recently, and the overlay files have changed.

Seems like you should have a lot more that just 19 kde4/9999 packages installed.
What about running an emerge -ep @world just to see every package installed on your system. In any case, if you reinstall kdebase-live with a different user, you need to first get rid of all other kde4 and 9999 stuff.

When I removed my kde-4.1.3 on that other box, I got my kde-3.5.10 back, so you probably will too. Be careful not to remove any kde-3.5.xx, as I guess you want that retained with the original user.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental


Last edited by wrc1944 on Thu Nov 20, 2008 8:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Thu Nov 20, 2008 7:37 pm    Post subject: Announcement Reply with quote

Regarding Bespin - there are few unnecessary line in that ebuilds and it lack some as well - besides I've already posted my Bespin ebuild in #gentoo-kde few days ago and it may appear in kde-crazy in some time. But the most important:

ANNOUNCEMENT FOR THE ONES USING kde-crazy

Snapshots are now UNMASKED. They will stay ~arch masked, so everyone using them or intending to, is advised to remove kde4 entries from
/etc/portage/package.unmask.If you intend to use 4.1.3 - don't use overlay or place proper /etc/portage/package.mask entries.

Note that live ebuilds and snapshots that are NOT YET AVAILABLE wil stay HARD MASKED, so don't try to unmask them and then complain that tarballs can't be fetched please.

_________________
Maciek
Back to top
View user's profile Send private message
kaktyc
Tux's lil' helper
Tux's lil' helper


Joined: 14 Aug 2004
Posts: 100

PostPosted: Thu Nov 20, 2008 8:53 pm    Post subject: Reply with quote

angiest wrote:
d-fens wrote:
Code:
vi /usr/portage/local/layman/kde-crazy/kde-base/plasma-workspace/plasma-workspace-9999.ebuild

add ksysguard the file so KMEXTRACTONLY reads
Code:

KMEXTRACTONLY=" krunner/dbus/org.freedesktop.ScreenSaver.xml
        krunner/dbus/org.kde.krunner.App.xml
        ksmserver/org.kde.KSMServerInterface.xml
        libs/kworkspace/
        libs/taskmanager/
        ksysguard"


do a
Code:
ebuild /usr/portage/local/layman/kde-crazy/kde-base/plasma-workspace/plasma-workspace-9999.ebuild digest


and emerge it.

i couldn't log in so i had to start consolekit service (rc-update add consolekit default) and /etc/init.d/consolekit start


That was in the ebuild when I sync'd this morning. Now I am receiving an error that it cannot find -lksysgrd. And I cannot emerge ksysguard because it has plasma-workspace as a dependency.


Try
Code:
emerge --nodeps ksysguard && emerge plasma-workspace
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Nov 20, 2008 8:55 pm    Post subject: Reply with quote

Hi guys,

you know anything about including support for mac osx gadget in plasma-workspace (do the devs work on this one already) ?

many thanks in advance
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
angiest
n00b
n00b


Joined: 12 Nov 2008
Posts: 14

PostPosted: Thu Nov 20, 2008 9:01 pm    Post subject: Reply with quote

kaktyc wrote:

Try
Code:
emerge --nodeps ksysguard && emerge plasma-workspace


Trying it now. For the life of me I can't figure out why ksysguard would depend on plasma.
Back to top
View user's profile Send private message
angiest
n00b
n00b


Joined: 12 Nov 2008
Posts: 14

PostPosted: Thu Nov 20, 2008 9:31 pm    Post subject: Reply with quote

angiest wrote:
kaktyc wrote:

Try
Code:
emerge --nodeps ksysguard && emerge plasma-workspace


Trying it now. For the life of me I can't figure out why ksysguard would depend on plasma.


Yes that worked.
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Thu Nov 20, 2008 9:52 pm    Post subject: Reply with quote

I've thought about running kde-live as a different user and just don't really want to mess with it - I can always run a live-CD to play with kde4 but otherwise I would want easy access to all my original user files. I've got shares mapped out on a NAS that I don't want to mess with and issues like that. So for me, it would be best to try for a working KDE4 as my regular user - even if I have to can 3.5 (though I would probably not want to do that yet).

I've removed kde-live by running emerge -Ca @kdebase-live, then the
emerge -Ca $(qlist -ICv | grep "kde.*4.1" | sed 's/^/=/' | tr '\n' ' ') ,
emerge -Ca $(qlist -ICv | grep "kde.*9999" | sed 's/^/=/' | tr '\n' ' ') lines. Then depclean only manually so I don't remove a couple important packages in there. (my current kernel). That found some more 9999 packages, as well as other libraries and stuff. Revdep-rebuild found nothing.

So an emerge -auvD world still wants to pull in kde-live stuff, like kdepimlibs-9999 and kdepimlibs-4.1.80, both kdelibs (9999 and 4.1.80) and about a dozen other related files. I tried tree version and it didn't show anything pulling these in. Perhaps it is the world_sets file with @system in it. I figure I could un-keyword the files and re-mask certain ones - but wondering if there's something I'm missing.

Also - the compile errors I get on plasma-workspace seem related to qt but not sure. Wondering if I'm missing a USE flag on qt-core - right now I have qt3support and ssl. There's still -glib, -pch, -doc, and -debug. I have version 4.4.2 on both qt and qt-core. I think I tried recompiling them already. There were also a bunch of other new qt stuff like qt-dbus that I haven't played around with recompiling.

cheers / jd
Back to top
View user's profile Send private message
Behivor
n00b
n00b


Joined: 20 Oct 2005
Posts: 23
Location: Ukranian, Mariupol

PostPosted: Thu Nov 20, 2008 10:13 pm    Post subject: Reply with quote

Help :(
emerge @kde-live

Code:

>>> Emerging (9 of 227) kde-base/kode-9999
 * checking ebuild checksums ;-) ...                                                                      [ ok ]
 * checking auxfile checksums ;-) ...                                                                     [ ok ]
 * checking miscfile checksums ;-) ...                                                                    [ ok ]
 *                                                                                                             
 * WARNING! This is an experimental ebuild of the kdepim KDE4 SVN tree.                                         
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because                                         
 * of this ebuild!                                                                                             
>>> Unpacking source...                                                                                         
 * subversion update start -->                                                                                 
 *      repository: svn://anonsvn.kde.org/home/kde/trunk/KDE/kdepim                                             
At revision 887032.                                                                                             
 *    working copy: /usr/portage/distfiles/svn-src/KDE/kdepim/kdepim                                           

 * Exporting parts of working copy to /var/tmp/portage/kde-base/kode-9999/work/kode
>>> Source unpacked.                                                               
>>> Configuring source in /var/tmp/portage/kde-base/kode-9999/work/kode ...       
loading initial cache file /var/tmp/portage/kde-base/kode-9999/temp/gentoo_common_config.cmake
-- The C compiler identification is GNU                                                       
-- The CXX compiler identification is GNU                                                     
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc                             
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works                   
-- Detecting C compiler ABI info                                                             
-- Detecting C compiler ABI info - done                                                       
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++                           
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works                 
-- Detecting CXX compiler ABI info                                                           
-- Detecting CXX compiler ABI info - done                                                     
-- Looking for Q_WS_X11                                                                       
-- Looking for Q_WS_X11 - found                                                               
-- Looking for Q_WS_WIN                                                                       
-- Looking for Q_WS_WIN - not found.                                                         
-- Looking for Q_WS_QWS                                                                       
-- Looking for Q_WS_QWS - not found.                                                         
-- Looking for Q_WS_MAC                                                                       
-- Looking for Q_WS_MAC - not found.                                                         
-- Found Qt-Version 4.4.2 (using /usr/bin/qmake)                                             
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so                                                                   
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found                                                           
-- Looking for gethostbyname                                                                                     
-- Looking for gethostbyname - found                                                                             
-- Looking for connect                                                                                           
-- Looking for connect - found                                                                                   
-- Looking for remove                                                                                           
-- Looking for remove - found                                                                                   
-- Looking for shmat                                                                                             
-- Looking for shmat - found                                                                                     
-- Looking for IceConnectionNumber in ICE                                                                       
-- Looking for IceConnectionNumber in ICE - found                                                               
-- Found X11: /usr/lib64/libX11.so                                                                               
-- Looking for include files CMAKE_HAVE_PTHREAD_H                                                               
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found                                                       
-- Looking for pthread_create in pthreads                                                                       
-- Looking for pthread_create in pthreads - not found                                                           
-- Looking for pthread_create in pthread                                                                         
-- Looking for pthread_create in pthread - found                                                                 
-- Found Threads: TRUE                                                                                           
-- Found Perl: /usr/bin/perl                                                                                     
-- Performing Test _OFFT_IS_64BIT                                                                               
-- Performing Test _OFFT_IS_64BIT - Success                                                                     
-- Performing Test HAVE_FPIE_SUPPORT                                                                             
-- Performing Test HAVE_FPIE_SUPPORT - Success                                                                   
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL                                                               
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success                                                     
-- Performing Test __KDE_HAVE_GCC_VISIBILITY                                                                     
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success                                                           
-- Phonon Version:                                                                                               
-- Found Phonon: /usr/lib64/libphonon.so                                                                         
-- Found Phonon Includes: /usr/include/KDE;/usr/include                                                         
-- Found KDE 4.2 include dir: /usr/kde/live/include                                                             
-- Found KDE 4.2 library dir: /usr/kde/live/lib64                                                               
-- Found the KDE4 kconfig_compiler preprocessor: /usr/kde/live/bin/kconfig_compiler                             
-- Found automoc4: /usr/bin/automoc4                                                                             
-- Found KDE PIM libraries                                                                                       
-- Boost version: 1.35.0                                                                                         
-- Found the following Boost libraries:                                                                         
-- Found Akonadi: /usr/lib64/libakonadiprotocolinternals.so                                                     
-- Found Akonadi includes: /usr/include                                                                         
-- Found Akonadi common libraries: /usr/lib64/libakonadiprotocolinternals.so                                     
-- Found Akonadi dbus-interfaces: /usr/share/dbus-1/interfaces                                                   
-- Found ZLIB: /lib64/libz.so                                                                                   
-- Strigi API needs 'signed char'                                                                               
-- Found Strigi: /usr/lib64/libstreams.so                                                                       
-- Found gpgme-config at /usr/bin/gpgme-config                                                                   
-- Found gpgme v1.1.6, checking for flavours...                                                                 
--  Found flavour 'vanilla', checking whether it's usable...yes                                                 
--  Found flavour 'pthread', checking whether it's usable...yes                                                 
-- Usable gpgme flavours found:  vanilla pthread                                                                 
-- Found qgpgme: libraries: qgpgme;gpgme++-pthread;/usr/lib64/libgpgme-pthread.so;/usr/lib64/libpthread.so;/usr/lib64/libgpg-error.so                                                                                             
-- checking for one of the modules 'libopensync;>=0.38'                                                         
--   found libopensync, version 0.39-r3725                                                                       
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig                                       
-- Found GLIB2: /usr/lib64/libglib-2.0.so                                                                       
-- Could NOT find GNOKII  (missing:  GNOKII_INCLUDE_DIR GNOKII_LIBRARIES)                                       
-- Found Soprano: /usr/lib64/libsoprano.so                                                                       
-- Found Soprano includes: /usr/include                                                                         
-- Found Soprano Index: /usr/lib64/libsopranoindex.so                                                           
-- Found Soprano Client: /usr/lib64/libsopranoclient.so                                                         
-- Found Soprano Plugin Dir: /usr/share/soprano/plugins                                                         
-- Found Soprano Plugins: nquadparser nquadserializer                                                           
-- Found NEPOMUK: /usr/kde/live/lib64/libnepomuk.so                                                             
-- Found libassuan-config at /usr/bin/libassuan-config                                                           
-- Found assuan v1.0.5, checking for flavours...                                                                 
--  Found flavour 'vanilla', checking whether it's usable...yes                                                 
--  Found flavour 'pthread', checking whether it's usable...yes                                                 
--  Found flavour 'pth', checking whether it's usable...yes                                                     
-- Usable assuan flavours found:  vanilla pthread pth                                                           
-- Performing Test HAVE_ASSUAN_FD_T                                                                             
-- Performing Test HAVE_ASSUAN_FD_T - Success                                                                   
-- Looking for assuan_inquire_ext                                                                               
-- Looking for assuan_inquire_ext - found                                                                       
-- Performing Test HAVE_NEW_STYLE_ASSUAN_INQUIRE_EXT                                                             
-- Performing Test HAVE_NEW_STYLE_ASSUAN_INQUIRE_EXT - Success                                                   
-- Performing Test HAVE_GPG_ERR_SOURCE_KLEO                                                                     
-- Performing Test HAVE_GPG_ERR_SOURCE_KLEO - Success                                                           
-- Performing Test HAVE_ASSUAN_SOCK_GET_NONCE                                                                   
terminate called after throwing an instance of 'std::out_of_range'                                               
  what():  basic_string::erase                                                                                   
/var/tmp/portage/kde-base/kode-9999/temp/environment: line 896:  6236 Аварийный останов         cmake -C "${TMPDIR}/gentoo_common_config.cmake" ${cmakeargs} "${S}"                                                               
 *                                                                                                               
 * ERROR: kde-base/kode-9999 failed.                                                                             
 * Call stack:                                                                                                   
 *               ebuild.sh, line   49:  Called src_configure                                                     
 *             environment, line 3595:  Called kde4-meta_src_configure                                           
 *             environment, line 2756:  Called kde4-base_src_configure                                           
 *             environment, line 2468:  Called cmake-utils_src_configure                                         
 *             environment, line  884:  Called cmake-utils_src_configureout                                     
 *             environment, line  903:  Called die                                                               
 * The specific snippet of code:                                                                                 
 *       cmake -C "${TMPDIR}/gentoo_common_config.cmake" ${cmakeargs} "${S}" || die "Cmake failed";             
 *  The die message:                                                                                             
 *   Cmake failed                                                                                               
 *                                                                                                               
 * If you need support, post the topmost build error, and the call stack if relevant.                           
 * A complete build log is located at '/var/tmp/portage/kde-base/kode-9999/temp/build.log'.                     
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kode-9999/temp/environment'.             
 *                                                                                                   
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Nov 20, 2008 11:14 pm    Post subject: Reply with quote

Hi :)

the answer might be obvious,

but where does strigi / nepomuk safe it's file-index ?

many thanks in advance
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
d-fens
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2004
Posts: 92

PostPosted: Fri Nov 21, 2008 12:04 am    Post subject: Reply with quote

anyone got kdevelop-9999 to find it's plugins and work?
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Fri Nov 21, 2008 5:47 am    Post subject: Reply with quote

kernelOfTruth wrote:
Hi guys,

you know anything about including support for mac osx gadget in plasma-workspace (do the devs work on this one already) ?

many thanks in advance


I dunno, is there a difference between a gadget and a dashboard widget? because i've used the latter in kde4 to varying degrees.

PS new amarok out (1.98 )
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Fri Nov 21, 2008 6:53 am    Post subject: Reply with quote

Exporting parts of working copy to /var/tmp/portage/kde-base/kdepim-kresources-9999/work/kdepim-kresources
rsync: link_stat "/usr/portage/distfiles/svn-src/KDE/kdepim/kdepim/groupwise" failed: No such file or directory (2)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1040) [sender=3.0.4]
*
* ERROR: kde-base/kdepim-kresources-9999 failed.


am stucked here.
any help?
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3251
Location: Gainesville, Florida

PostPosted: Fri Nov 21, 2008 8:35 am    Post subject: Reply with quote

Check this out. http://websvn.kde.org/trunk/KDE/kdepim/kresources/CMakeLists.txt?view=log

Maybe remove kdepim in distfiles, and try a fresh checkout- they might have fixed it at svn.

Hmm. Just noticed -No work on that since May 20, so maybe this link is not relevant. :roll: Still, a fresh checkout can't hurt. :wink:
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Fri Nov 21, 2008 10:15 am    Post subject: Reply with quote

wrc1944 wrote:
Check this out. http://websvn.kde.org/trunk/KDE/kdepim/kresources/CMakeLists.txt?view=log

Maybe remove kdepim in distfiles, and try a fresh checkout- they might have fixed it at svn.

Hmm. Just noticed -No work on that since May 20, so maybe this link is not relevant. :roll: Still, a fresh checkout can't hurt. :wink:



have tried but still same thing.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Nov 21, 2008 10:22 am    Post subject: Reply with quote

kernelOfTruth wrote:
Hi :)

the answer might be obvious,

but where does strigi / nepomuk safe it's file-index ?

many thanks in advance


got it: in .kde4 (if prefix is disabled during compilation of kde-live)

does anyone actually use nepomuk / strigi's search index ? can it be searched through like with recoll, tracker, beagle, etc. ?

many thanks in advance
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Fri Nov 21, 2008 3:55 pm    Post subject: Reply with quote

Naive question:

Did somebody realize to download kde-4.1.80? And if so, which server is the lucky one?
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 14, 15, 16 ... 28, 29, 30  Next
Page 15 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum