Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 2)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 20, 21, 22 ... 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
rolis
n00b
n00b


Joined: 24 Apr 2008
Posts: 12

PostPosted: Mon Dec 08, 2008 5:45 am    Post subject: Reply with quote

marcus84 wrote:
anybody has compiled koffice beta2 (1.9.98.2)?

I get an error compiling Kchart

Code:

Linking CXX shared library ../../lib/libchartshapelib.so                                                         
CMakeFiles/chartshapelib.dir/Axis.o: In function `KChart::Axis::saveOdfGrid(KoShapeSavingContext&, KChart::OdfGridClass)':                                                                                                         
Axis.cpp:(.text+0x2c01): undefined reference to `KoGenStyle::KoGenStyle(KoGenStyle::Type, char const*, QString const&)'                                                                                                             
Axis.cpp:(.text+0x2ccd): undefined reference to `KoGenStyles::lookup(KoGenStyle const&, QString const&, int)'     
Axis.cpp:(.text+0x2d51): undefined reference to `KoGenStyle::~KoGenStyle()'                                       
CMakeFiles/chartshapelib.dir/Axis.o: In function `KChart::Axis::saveOdf(KoShapeSavingContext&)':                 
Axis.cpp:(.text+0x4100): undefined reference to `KoGenStyle::KoGenStyle(KoGenStyle::Type, char const*, QString const&)'                                                                                                             
Axis.cpp:(.text+0x4200): undefined reference to `KoGenStyles::lookup(KoGenStyle const&, QString const&, int)'     
Axis.cpp:(.text+0x45fb): undefined reference to `KoGenStyle::~KoGenStyle()'                                       
CMakeFiles/chartshapelib.dir/Axis.o: In function `KChart::Axis::loadOdf(KoXmlElement const&, KoShapeLoadingContext&)':                                                                                                             
Axis.cpp:(.text+0x499c): undefined reference to `KoStyleStack::save()'       


i'm getting the same problem.
the problem seems to be that koodf library is not included in the list of dependent libraries to link chartshapelib library.

the following patch files/1.9.98.2-cmake.patch
and updated ebuild kchart-1.9.98.2-r1.ebuild fixed the problem.

similar patches for kspread:
files/1.9.98.2-cmake.patch and kspread-1.9.98.2-r1.ebuild

i wonder if anybody else successfully build kchart-1.9.98.2 and this problem is just related to specific gentoo config?
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Mon Dec 08, 2008 10:29 am    Post subject: Reply with quote

applying this patch I get the following error:

Code:

***** 1.9.98.2-cmake.patch *****

================================

PATCH COMMAND:   patch -p0 -g0 -E --no-backup-if-mismatch < /usr/portage/local/layman/kde-crazy/app-office/kchart/files/1.9.98.2-cmake.patch

================================
patch: **** Only garbage was found in the patch input.
================================

PATCH COMMAND:   patch -p1 -g0 -E --no-backup-if-mismatch < /usr/portage/local/layman/kde-crazy/app-office/kchart/files/1.9.98.2-cmake.patch

================================
patch: **** Only garbage was found in the patch input.
================================

PATCH COMMAND:   patch -p2 -g0 -E --no-backup-if-mismatch < /usr/portage/local/layman/kde-crazy/app-office/kchart/files/1.9.98.2-cmake.patch

================================
patch: **** Only garbage was found in the patch input.
================================

PATCH COMMAND:   patch -p3 -g0 -E --no-backup-if-mismatch < /usr/portage/local/layman/kde-crazy/app-office/kchart/files/1.9.98.2-cmake.patch

================================
patch: **** Only garbage was found in the patch input.
================================

PATCH COMMAND:   patch -p4 -g0 -E --no-backup-if-mismatch < /usr/portage/local/layman/kde-crazy/app-office/kchart/files/1.9.98.2-cmake.patch

================================
patch: **** Only garbage was found in the patch input.



Any Idea?
Back to top
View user's profile Send private message
m1k0
Apprentice
Apprentice


Joined: 27 Dec 2006
Posts: 180
Location: Radom/Poland

PostPosted: Mon Dec 08, 2008 5:11 pm    Post subject: Reply with quote

I can't install nepomuk
Code:
-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/portage/kde-base/nepomuk-4.1.80/work/nepomuk_build
>>> Source configured.
>>> Compiling source in /var/tmp/portage/kde-base/nepomuk-4.1.80/work/nepomuk-4.1.80 ...
make -j1
>>> Source compiled.
>>> Test phase [not enabled]: kde-base/nepomuk-4.1.80

>>> Install nepomuk-4.1.80 into /var/tmp/portage/kde-base/nepomuk-4.1.80/image/ category kde-base
make -j1 install DESTDIR=/var/tmp/portage/kde-base/nepomuk-4.1.80/image/
make: *** Brak reguł do wykonania obiektu `install'. Stop.
 *
 * ERROR: kde-base/nepomuk-4.1.80 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 3500:  Called kde4-meta_src_install
 *             environment, line 2744:  Called cmake-utils_src_install
 *             environment, line  860:  Called die
 * The specific snippet of code:
 *       emake install DESTDIR="${D}" || die "Make install failed";
 *  The die message:
 *   Make install failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/nepomuk-4.1.80/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/nepomuk-4.1.80/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/layman/kde-crazy/'
 *

make: *** Brak reguł do wykonania obiektu `install'. Stop.
||
\/
make: *** There aren't ruls to meka object `install'. Stop.
_________________
MSI GX-70
Back to top
View user's profile Send private message
m1k0
Apprentice
Apprentice


Joined: 27 Dec 2006
Posts: 180
Location: Radom/Poland

PostPosted: Mon Dec 08, 2008 6:58 pm    Post subject: Reply with quote

This is a Makefile form working directory. There isn't `install'
Code:
desktop nepomuk-4.1.80 # cat Makefile
# CMAKE generated file: DO NOT EDIT! 
# Generated by "Unix Makefiles" Generator, CMake Version 2.6

# Default target executed when no arguments are given to make.
default_target: all                                           
.PHONY : default_target                                       

#=============================================================================
# Special targets provided by cmake.                                         

# Disable implicit rules so canoncical targets will work.
.SUFFIXES:                                               

# Remove some rules from gmake that .SUFFIXES does not remove.
SUFFIXES =                                                   

.SUFFIXES: .hpux_make_needs_suffix_list

# Suppress display of executed commands.
$(VERBOSE).SILENT:                     

# A target that is always out of date.
cmake_force:                         
.PHONY : cmake_force                 

#=============================================================================
# Set environment variables for the build.                                   

# The shell in which to execute make rules.
SHELL = /bin/sh                           

# The CMake executable.
CMAKE_COMMAND = /usr/bin/cmake

# The command to remove a file.
RM = /usr/bin/cmake -E remove -f

# The program to use to edit the cache.
CMAKE_EDIT_COMMAND = /usr/bin/ccmake   

# The top-level source directory on which CMake was run.
CMAKE_SOURCE_DIR = /var/tmp/portage/kde-base/nepomuk-4.1.80/work/nepomuk-4.1.80

# The top-level build directory on which CMake was run.
CMAKE_BINARY_DIR = /var/tmp/portage/kde-base/nepomuk-4.1.80/work/nepomuk-4.1.80

#=============================================================================
# Targets provided globally by CMake.                                         

# Special rule for the target edit_cache
edit_cache:                             
        @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running CMake cache editor..."
        /usr/bin/ccmake -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR)                                   
.PHONY : edit_cache                                                                                   

# Special rule for the target edit_cache
edit_cache/fast: edit_cache             
.PHONY : edit_cache/fast               

# Special rule for the target rebuild_cache
rebuild_cache:                             
        @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running CMake to regenerate build system..."
        /usr/bin/cmake -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR)                                                 
.PHONY : rebuild_cache                                                                                             

# Special rule for the target rebuild_cache
rebuild_cache/fast: rebuild_cache         
.PHONY : rebuild_cache/fast               

# Special rule for the target test
test:                             
        @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running tests..."
        /usr/bin/ctest --force-new-ctest-process $(ARGS)                                 
.PHONY : test                                                                           

# Special rule for the target test
test/fast: test                   
.PHONY : test/fast               

# The main all target
all: cmake_check_build_system
        $(CMAKE_COMMAND) -E cmake_progress_start /var/tmp/portage/kde-base/nepomuk-4.1.80/work/nepomuk-4.1.80/CMakeFiles /var/tmp/portage/kde-base/nepomuk-4.1.80/work/nepomuk-4.1.80/CMakeFiles/progress.make                                                                                                                                         
        $(MAKE) -f CMakeFiles/Makefile2 all                                                                                                                                 
        $(CMAKE_COMMAND) -E cmake_progress_start /var/tmp/portage/kde-base/nepomuk-4.1.80/work/nepomuk-4.1.80/CMakeFiles 0                                                 
.PHONY : all                                                                                                                                                               

# The main clean target
clean:                 
        $(MAKE) -f CMakeFiles/Makefile2 clean
.PHONY : clean                               

# The main clean target
clean/fast: clean     
.PHONY : clean/fast   

# Prepare targets for installation.
preinstall: all                   
        $(MAKE) -f CMakeFiles/Makefile2 preinstall
.PHONY : preinstall                               

# Prepare targets for installation.
preinstall/fast:                   
        $(MAKE) -f CMakeFiles/Makefile2 preinstall
.PHONY : preinstall/fast                         

# clear depends
depend:       
        $(CMAKE_COMMAND) -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR) --check-build-system CMakeFiles/Makefile.cmake 1
.PHONY : depend                                                                                                     

#=============================================================================
# Target rules for targets named uninstall                                   

# Build rule for target.
uninstall: cmake_check_build_system
        $(MAKE) -f CMakeFiles/Makefile2 uninstall
.PHONY : uninstall                               

# fast build rule for target.
uninstall/fast:
        $(MAKE) -f CMakeFiles/uninstall.dir/build.make CMakeFiles/uninstall.dir/build
.PHONY : uninstall/fast

# Help Target
help:
        @echo "The following are some of the valid targets for this Makefile:"
        @echo "... all (the default if no target is provided)"
        @echo "... clean"
        @echo "... depend"
        @echo "... edit_cache"
        @echo "... rebuild_cache"
        @echo "... test"
        @echo "... uninstall"
.PHONY : help



#=============================================================================
# Special targets to cleanup operation of make.

# Special rule to run CMake to check the build system integrity.
# No rule that depends on this can have commands that come from listfiles
# because they might be regenerated.
cmake_check_build_system:
        $(CMAKE_COMMAND) -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR) --check-build-system CMakeFiles/Makefile.cmake 0
.PHONY : cmake_check_build_system

_________________
MSI GX-70
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Mon Dec 08, 2008 7:55 pm    Post subject: Reply with quote

i have tried every syntax to mask the qt-svn (9999) packages in package.mask
without success.
any help?
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Mon Dec 08, 2008 8:18 pm    Post subject: Reply with quote

tranquilcool wrote:
i have tried every syntax to mask the qt-svn (9999) packages in package.mask
without success.
any help?



have you tried to deleted from package.keywords and package.unmask?
Back to top
View user's profile Send private message
rolis
n00b
n00b


Joined: 24 Apr 2008
Posts: 12

PostPosted: Tue Dec 09, 2008 6:00 am    Post subject: Reply with quote

marcus84 wrote:
applying this patch I get the following error:

Code:

***** 1.9.98.2-cmake.patch *****

================================

PATCH COMMAND:   patch -p0 -g0 -E --no-backup-if-mismatch < /usr/portage/local/layman/kde-crazy/app-office/kchart/files/1.9.98.2-cmake.patch

================================
patch: **** Only garbage was found in the patch input.
================================

PATCH COMMAND:   patch -p1 -g0 -E --no-backup-if-mismatch < /usr/portage/local/layman/kde-crazy/app-office/kchart/files/1.9.98.2-cmake.patch

================================
patch: **** Only garbage was found in the patch input.
================================

PATCH COMMAND:   patch -p2 -g0 -E --no-backup-if-mismatch < /usr/portage/local/layman/kde-crazy/app-office/kchart/files/1.9.98.2-cmake.patch

================================
patch: **** Only garbage was found in the patch input.
================================

PATCH COMMAND:   patch -p3 -g0 -E --no-backup-if-mismatch < /usr/portage/local/layman/kde-crazy/app-office/kchart/files/1.9.98.2-cmake.patch

================================
patch: **** Only garbage was found in the patch input.
================================

PATCH COMMAND:   patch -p4 -g0 -E --no-backup-if-mismatch < /usr/portage/local/layman/kde-crazy/app-office/kchart/files/1.9.98.2-cmake.patch

================================
patch: **** Only garbage was found in the patch input.



Any Idea?


that's weird. i've tried to download both patches from pastebin and they came out ok.
kde-crazy/app-office/kchart/files/1.9.98.2-cmake.patch should be:
Code:
--- kchart/shape/CMakeLists.txt.orig   2008-12-07 23:46:42.412214991 -0500
+++ kchart/shape/CMakeLists.txt   2008-12-07 23:47:24.435964971 -0500
@@ -49,6 +49,7 @@
     flake
     kotext
     kostore
+    koodf
     komain
     ${KDE4_KDEUI_LIBS}
     ${KDE4_KPARTS_LIBS}


and kde-crazy/app-office/kspread/files/1.9.98.2-cmake.patch:
Code:
--- kspread/CMakeLists.txt.orig   2008-12-08 00:58:49.979962638 -0500
+++ kspread/CMakeLists.txt   2008-12-08 01:00:49.130214585 -0500
@@ -225,6 +225,7 @@
    ${KDE4_KNOTIFYCONFIG_LIBS} ${KDE4_KPARTS_LIBS}
    koguiutils
    kutils flake
+   komain pigmentcms kostore koodf
    ${KDE4_KDE3SUPPORT_LIBS} )
 
 set_target_properties(kspreadcommon PROPERTIES
Back to top
View user's profile Send private message
bers
n00b
n00b


Joined: 28 Nov 2008
Posts: 49

PostPosted: Tue Dec 09, 2008 11:46 am    Post subject: oops Reply with quote

[ 70%] Building CXX object apps/dolphin/src/CMakeFiles/dolphin.dir/dolphindirlister.o
[ 71%] Building CXX object apps/dolphin/src/CMakeFiles/dolphin.dir/dolphincontextmenu.o
In file included from /var/tmp/portage/kde-base/dolphin-4.1.82/work/dolphin-4.1.82/apps/dolphin/src/dolphinviewcontainer.cpp:56:
/var/tmp/portage/kde-base/dolphin-4.1.82/work/dolphin-4.1.82/apps/dolphin/src/dolphincontextmenu.h:27:29: error: konq_copytomenu.h: Нет такого файла или каталога
In file included from /var/tmp/portage/kde-base/dolphin-4.1.82/work/dolphin-4.1.82/apps/dolphin/src/dolphincontextmenu.cpp:21:
/var/tmp/portage/kde-base/dolphin-4.1.82/work/dolphin-4.1.82/apps/dolphin/src/dolphincontextmenu.h:27:29: error: konq_copytomenu.h: Нет такого файла или каталога
[ 72%] Building CXX object apps/dolphin/src/CMakeFiles/dolphin.dir/dolphinfileplacesview.o
In file included from /var/tmp/portage/kde-base/dolphin-4.1.82/work/dolphin-4.1.82/apps/dolphin/src/dolphincontextmenu.cpp:21:
/var/tmp/portage/kde-base/dolphin-4.1.82/work/dolphin-4.1.82/apps/dolphin/src/dolphincontextmenu.h:123: ошибка: ‘KonqCopyToMenu’ не является именем типа
/var/tmp/portage/kde-base/dolphin-4.1.82/work/dolphin-4.1.82/apps/dolphin/src/dolphincontextmenu.cpp: In member function ‘void DolphinContextMenu::openItemContextMenu()’:
/var/tmp/portage/kde-base/dolphin-4.1.82/work/dolphin-4.1.82/apps/dolphin/src/dolphincontextmenu.cpp:222: ошибка: нет декларации ‘m_copyToMenu’ в этой области видимости
make[2]: *** [apps/dolphin/src/CMakeFiles/dolphin.dir/dolphincontextmenu.o] Ошибка 1
make[2]: *** Ожидание завершения заданий...
In file included from /var/tmp/portage/kde-base/dolphin-4.1.82/work/dolphin-4.1.82/apps/dolphin/src/dolphinviewcontainer.cpp:56:
/var/tmp/portage/kde-base/dolphin-4.1.82/work/dolphin-4.1.82/apps/dolphin/src/dolphincontextmenu.h:123: ошибка: ‘KonqCopyToMenu’ не является именем типа
make[2]: *** [apps/dolphin/src/CMakeFiles/dolphin.dir/dolphinviewcontainer.o] Ошибка 1
make[1]: *** [apps/dolphin/src/CMakeFiles/dolphin.dir/all] Ошибка 2
make: *** [all] Ошибка 2
*
* ERROR: kde-base/dolphin-4.1.82 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3557: Called kde4-meta_src_compile
* environment, line 2721: Called kde4-meta_src_make
* environment, line 2814: Called kde4-base_src_make
* environment, line 2452: Called cmake-utils_src_make
* environment, line 894: Called die
* The specific snippet of code:
* emake "$@" || die "Make failed!";
* The die message:
* Make failed!
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Dec 09, 2008 7:47 pm    Post subject: Reply with quote

Hi,

I'm getting a lot of those while I try to compile @kde-live:

Quote:
-- Configuring done
CMake Error: INSTALL(EXPORT) given unknown export "kdeworkspaceLibraryTargets"


until now for:
* plasma-workspace (?)
* ksplash
* libkcddb
* kcminit
* ksmserver
* ...

all of them fail and have to be skipped

any idea how to "fix" them ?

isn't everything supposed to compile fine today (beta2) ?

many thanks in advance
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Dec 09, 2008 8:02 pm    Post subject: Reply with quote

kernelOfTruth wrote:
Hi,

I'm getting a lot of those while I try to compile @kde-live:

Quote:
-- Configuring done
CMake Error: INSTALL(EXPORT) given unknown export "kdeworkspaceLibraryTargets"

I had to revert this patch to get behind that cmake error.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Dec 09, 2008 8:33 pm    Post subject: Reply with quote

gimpel wrote:
kernelOfTruth wrote:
Hi,

I'm getting a lot of those while I try to compile @kde-live:

Quote:
-- Configuring done
CMake Error: INSTALL(EXPORT) given unknown export "kdeworkspaceLibraryTargets"

I had to revert this patch to get behind that cmake error.


thanks, gimpel,

this might sound dumb but where and how to revert it ? :P (is it for plasma-workspace only ?)

do I have to do the ebuild combo ? (unpack, compile install qmerge)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Dec 09, 2008 8:48 pm    Post subject: Reply with quote

kernelOfTruth wrote:
thanks, gimpel,

this might sound dumb but where and how to revert it ? :P (is it for plasma-workspace only ?)

do I have to do the ebuild combo ? (unpack, compile install qmerge)

Ah no, it's for everything in kdebase/workspace, see the path in the patch. I applied it directly in svn-src
patch -p2 -R < ..patch, or -p3? can't remeber... :)
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6948
Location: Austria

PostPosted: Tue Dec 09, 2008 9:11 pm    Post subject: Reply with quote

Just got through a whole 4.1.82 build without errors.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Tue Dec 09, 2008 9:20 pm    Post subject: Reply with quote

genstorm wrote:
Just got through a whole 4.1.82 build without errors.


Great to hear that - let me test it a bit and I'll unmask them.
Still trunk to "fix" though... Alex Neundorf has been messing with buildsystem again and I don't like it at all...
_________________
Maciek
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Dec 09, 2008 10:19 pm    Post subject: Reply with quote

reavertm wrote:
Still trunk to "fix" though... Alex Neundorf has been messing with buildsystem again and I don't like it at all...

Heh, I really wasn't (and still ain't) sure if the svn ebuilds/eclass need a fix to work with his commit(s), or if he just messed up.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
valczir
n00b
n00b


Joined: 23 Nov 2005
Posts: 35
Location: Minnesota

PostPosted: Wed Dec 10, 2008 8:47 am    Post subject: Reply with quote

Dont Panic wrote:
Has anybody figured out the issue with kde-base/pykde4-4.1.80?

I still can't build that package. I am still getting a sip error: "sip: /usr/share/sip/qt/versions.sip:34: Version is already defined".

My workaround has been to add "kde-base/plasma-workspace -python" to my /etc/portage/package.use file. It appears that kde-base/pykde4-4.1.80 is no longer a dependency when kde-base/plasma-workspace is built -python.

I also have noticed that there isn't even an ebuild in the main portage tree for kde-base/pykde4-4.1.3.

Is pykde4 being depricated?


I found out that the error has something to do with PyQt 3.17.4 (in my case, at least). I ran equery b /usr/share/sip/qt/versions.sip and it said the file was owned by PyQt 3.17.4.

When I removed that version of PyQt, pykde complained about a missing qt/qtmod.sip file. I had a /usr/share/sip/Qt/Qtmod.sip, but linking that to /usr/share/sip/qt/qtmod.sip created errors, too.

So I just tried installing PyQt 3.17.6 to see if an updated version would be better, and it's also a no-go - I'm back to the original "Version is already defined" error. I even tried just deleting /usr/share/sip/qt/versions.sip, and it just gave more errors.

So I guess I'll just use your workaround. Seems like that's as good as it's going to get for a little while.
Back to top
View user's profile Send private message
pehop
n00b
n00b


Joined: 16 Oct 2005
Posts: 50
Location: Oxford, UK

PostPosted: Wed Dec 10, 2008 11:56 am    Post subject: Reply with quote

genstorm wrote:
Just got through a whole 4.1.82 build without errors.

Me too, but it's to early to say "hurray", because plasma crashes at start and I can see neither panel nor workspace :(
Back to top
View user's profile Send private message
robnotts
Guru
Guru


Joined: 15 Mar 2004
Posts: 405
Location: Nottingham, UK

PostPosted: Wed Dec 10, 2008 12:18 pm    Post subject: Reply with quote

Quote:
Me too, but it's to early to say "hurray", because plasma crashes at start and I can see neither panel nor workspace


had the same problem, had to delete my ~/.kde* directories, and then it work... eventually tracked it down to the fact i hadn't recompiled the networkmanager-applet plasmoid.


Now if only I could get kdepim-kresources and kdepim-wizards to compile I'd be fully up to date!
_________________
---

Gentoo Phenom][ X4 955 on AMD790 + Geforce 220GT 8GB/1.75TB (Desktop)
+ MythTV (3xFreeview,1xFreesat HD) on 1080p
Gentoo Turion64 X2 Geforce 6150 2GB/120GB (Laptop)
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Wed Dec 10, 2008 2:16 pm    Post subject: Reply with quote

Code:
[blocks B     ] media-sound/phonon ("media-sound/phonon" is blocking x11-libs/qt-phonon-4.4.9999)                                                               
[blocks B     ] x11-libs/qt-phonon ("x11-libs/qt-phonon" is blocking kde-base/kxsldbg-9999, kde-base/kde


is all what I get when trying to install kde-live...

How can I solve this block?

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
solshark
n00b
n00b


Joined: 24 Mar 2007
Posts: 17

PostPosted: Wed Dec 10, 2008 2:26 pm    Post subject: Reply with quote

Finswimmer wrote:
Code:
[blocks B     ] media-sound/phonon ("media-sound/phonon" is blocking x11-libs/qt-phonon-4.4.9999)                                                               
[blocks B     ] x11-libs/qt-phonon ("x11-libs/qt-phonon" is blocking kde-base/kxsldbg-9999, kde-base/kde


is all what I get when trying to install kde-live...

How can I solve this block?

Tobi


Hello.

1. Don't use qt-copy (are you sure you really need it?)
2. Unmerge qt-phonon
_________________
my russian blog: http://solshark.i-seo.biz
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6948
Location: Austria

PostPosted: Wed Dec 10, 2008 2:45 pm    Post subject: Reply with quote

pehop wrote:
genstorm wrote:
Just got through a whole 4.1.82 build without errors.

Me too, but it's to early to say "hurray", because plasma crashes at start and I can see neither panel nor workspace :(

I didn't have that. Generally it's a good idea to just rm ~/.kde* if you experience any issues after an upgrade.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pehop
n00b
n00b


Joined: 16 Oct 2005
Posts: 50
Location: Oxford, UK

PostPosted: Wed Dec 10, 2008 3:38 pm    Post subject: Reply with quote

I removed it and plasma has started to work until I add Comic Strip plasmoid :(
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 248

PostPosted: Wed Dec 10, 2008 4:33 pm    Post subject: Reply with quote

I have the same problem as above with plasma. I remove ~.kde an even tryed with an empty user acount but no luck. In my .xsession-error I have

Code:

lasma(27670)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Applet"  not found
plasma(27670)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Containment"  not found                                                                                                                         
plasma(27670)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Wallpaper"  not found                                                                                                                           
plasma(27670)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Wallpaper"  not found                                                                                                                           
plasma(27670)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Applet"  not found
plasma(27670)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Containment"  not found                                                                                                                         
plasma(27670)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Wallpaper"  not found                                                                                                                           
plasma(27670)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Wallpaper"  not found                                   
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6948
Location: Austria

PostPosted: Wed Dec 10, 2008 4:38 pm    Post subject: Reply with quote

pehop wrote:
I removed it and plasma has started to work until I add Comic Strip plasmoid :(

Confirmed. Adding the comic strip crashes plasma, but then it comes back again and it works. I didn't get it at first because my .kde settings worked from the start with the comic strip and everything already there.

Plus: No data sources for the LCD Weather plasmoid.

Also: Just successfully built and already running Amarok 2.0!

PS: I played around with random other plasmoids and couldn't reproduce the error. Also, adding the comic strip now worked.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2322
Location: Konradsreuth (Germany)

PostPosted: Wed Dec 10, 2008 6:34 pm    Post subject: Reply with quote

l3u wrote:
Hi :-)
kde-base/pykde4-4.1.80 fails here with:
Code:
[  1%] Built target compile_python_files
[  2%] Generating sip/dnssd/sipdnssdpart0.cpp, sip/dnssd/sipdnssdpart1.cpp, sip/dnssd/sipdnssdpart2.cpp, sip/dnssd/sipdnssdpart3.cpp, sip/dnssd/sipdnssdpart4.cpp, sip/dnssd/sipdnssdpart5.cpp, sip/dnssd/sipdnssdpart6.cpp, sip/dnssd/sipdnssdpart7.cpp

sip: /usr/share/sip/qt/versions.sip:34: Version is already defined
make[2]: *** [python/pykde4/sip/dnssd/sipdnssdpart0.cpp] Fehler 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_dnssd.dir/all] Fehler 2
make[1]: *** Warte auf noch nicht beendete Prozesse...
sip: /usr/share/sip/qt/versions.sip:34: Version is already defined
make[2]: *** [python/pykde4/sip/akonadi/sipakonadipart0.cpp] Fehler 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_akonadi.dir/all] Fehler 2
make: *** [all] Fehler 2
 *
 * ERROR: kde-base/pykde4-4.1.80 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3501:  Called kde4-meta_src_compile
 *             environment, line 2674:  Called kde4-meta_src_make
 *             environment, line 2767:  Called kde4-base_src_make
 *             environment, line 2405:  Called cmake-utils_src_make
 *             environment, line  887:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *  The die message:
 *   Make failed!

Any ideas?

Not reproducible with KDE 4.1.82 after unmerging cmake and sip and unmasking the latest testing versions.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 20, 21, 22 ... 28, 29, 30  Next
Page 21 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum