Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 2)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 26, 27, 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Sat Dec 20, 2008 10:30 am    Post subject: pykde4 Reply with quote

Code:
[ 95%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_soprano.dir/sip/soprano/sipsopranopart3.o                                     
In file included from /usr/include/python2.5/Python.h:13,                                                                                             
                 from /usr/include/python2.5/sip.h:28,                                                                                                 
                 from /var/tmp/portage/kde-base/pykde4-4.1.82/work/pykde4_build/python/pykde4/sip/soprano/sipAPIsoprano.h:11,                         
                 from /var/tmp/portage/kde-base/pykde4-4.1.82/work/pykde4_build/python/pykde4/sip/soprano/sipsopranopart3.cpp:7:                       
/usr/include/python2.5/pyconfig.h:948:1: warning: "_XOPEN_SOURCE" redefined                                                                           
<command line>:1:1: warning: this is the location of the previous definition                                                                           
CMakeFiles/python_module_PyKDE4_plasma.dir/sip/plasma/sipplasmapart0.o: In function `void* qMetaTypeConstructHelper<Plasma::Containment::StyleOption>(Plasma::Containment::StyleOption const*)':                                                                                                             
sipplasmapart0.cpp:(.text._Z24qMetaTypeConstructHelperIN6Plasma11Containment11StyleOptionEEPvPKT_[void* qMetaTypeConstructHelper<Plasma::Containment::StyleOption>(Plasma::Containment::StyleOption const*)]+0x2a): undefined reference to `Plasma::Containment::StyleOption::StyleOption(Plasma::Containment::StyleOption const&)'                                                                                                                                 
sipplasmapart0.cpp:(.text._Z24qMetaTypeConstructHelperIN6Plasma11Containment11StyleOptionEEPvPKT_[void* qMetaTypeConstructHelper<Plasma::Containment::StyleOption>(Plasma::Containment::StyleOption const*)]+0x51): undefined reference to `Plasma::Containment::StyleOption::StyleOption()'                 
CMakeFiles/python_module_PyKDE4_plasma.dir/sip/plasma/sipplasmapart6.o: In function `init_Plasma_Containment_StyleOption':                             
sipplasmapart6.cpp:(.text+0x4934): undefined reference to `Plasma::Containment::StyleOption::StyleOption(QStyleOptionGraphicsItem const&)'             
sipplasmapart6.cpp:(.text+0x495b): undefined reference to `Plasma::Containment::StyleOption::StyleOption()'                                           
sipplasmapart6.cpp:(.text+0x4993): undefined reference to `Plasma::Containment::StyleOption::StyleOption(Plasma::Containment::StyleOption const&)'     
collect2: ld returned 1 exit status                                                                                                                   
make[2]: *** [lib/pykde/plasma.so] Error 1                                                                                                             
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_plasma.dir/all] Error 2                                                                   
make[1]: *** Waiting for unfinished jobs....                                                                                                           
[ 96%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_soprano.dir/sip/soprano/sipsopranopart4.o                                     
In file included from /usr/include/python2.5/Python.h:13,                                                                                             
                 from /usr/include/python2.5/sip.h:28,                                                                                                 
                 from /var/tmp/portage/kde-base/pykde4-4.1.82/work/pykde4_build/python/pykde4/sip/soprano/sipAPIsoprano.h:11,                         
                 from /var/tmp/portage/kde-base/pykde4-4.1.82/work/pykde4_build/python/pykde4/sip/soprano/sipsopranopart4.cpp:7:                       
/usr/include/python2.5/pyconfig.h:948:1: warning: "_XOPEN_SOURCE" redefined                                                                           
<command line>:1:1: warning: this is the location of the previous definition                                                                           
[ 97%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_soprano.dir/sip/soprano/sipsopranopart5.o                                     
[ 97%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_soprano.dir/sip/soprano/sipsopranopart6.o                                     
In file included from /usr/include/python2.5/Python.h:13,                                                                                             
                 from /usr/include/python2.5/sip.h:28,                                                                                                 
                 from /var/tmp/portage/kde-base/pykde4-4.1.82/work/pykde4_build/python/pykde4/sip/soprano/sipAPIsoprano.h:11,                         
                 from /var/tmp/portage/kde-base/pykde4-4.1.82/work/pykde4_build/python/pykde4/sip/soprano/sipsopranopart5.cpp:7:                       
/usr/include/python2.5/pyconfig.h:948:1: warning: "_XOPEN_SOURCE" redefined                                                                           
<command line>:1:1: warning: this is the location of the previous definition                                                                           
In file included from /usr/include/python2.5/Python.h:13,                                                                                             
                 from /usr/include/python2.5/sip.h:28,                                                                                                 
                 from /var/tmp/portage/kde-base/pykde4-4.1.82/work/pykde4_build/python/pykde4/sip/soprano/sipAPIsoprano.h:11,                         
                 from /var/tmp/portage/kde-base/pykde4-4.1.82/work/pykde4_build/python/pykde4/sip/soprano/sipsopranopart6.cpp:7:                       
/usr/include/python2.5/pyconfig.h:948:1: warning: "_XOPEN_SOURCE" redefined                                                                           
<command line>:1:1: warning: this is the location of the previous definition                                                                           
[ 98%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_soprano.dir/sip/soprano/sipsopranopart7.o                                     
In file included from /usr/include/python2.5/Python.h:13,                                                                                             
                 from /usr/include/python2.5/sip.h:28,                                                                                                 
                 from /var/tmp/portage/kde-base/pykde4-4.1.82/work/pykde4_build/python/pykde4/sip/soprano/sipAPIsoprano.h:11,                         
                 from /var/tmp/portage/kde-base/pykde4-4.1.82/work/pykde4_build/python/pykde4/sip/soprano/sipsopranopart7.cpp:7:                       
/usr/include/python2.5/pyconfig.h:948:1: warning: "_XOPEN_SOURCE" redefined                                                                           
<command line>:1:1: warning: this is the location of the previous definition                                                                           
Linking CXX shared library ../../lib/pykde/soprano.so                                                                                                 
[ 98%] Built target python_module_PyKDE4_soprano                                                                                                       
make: *** [all] Error 2                                                                                                                               
 *                                                                                                                                                     
 * ERROR: kde-base/pykde4-4.1.82 failed.                                                                                                               
 * Call stack:                                                                                                                                         
 *               ebuild.sh, line   49:  Called src_compile                                                                                             
 *             environment, line 3751:  Called kde4-meta_src_compile                                                                                   
 *             environment, line 2883:  Called kde4-base_src_make                                                                                     
 *             environment, line 2644:  Called cmake-utils_src_make                                                                                   
 *             environment, line 1018:  Called die                                                                                                     
 * The specific snippet of code:                                                                                                                       
 *           emake "$@" || die "Make failed!";                                                                                                         
 *  The die message:                                                                                                                                   
 *   Make failed!                                                                                                                                     
 *                                                                                                                                                     
 * If you need support, post the topmost build error, and the call stack if relevant.                                                                 
 * A complete build log is located at '/var/tmp/portage/kde-base/pykde4-4.1.82/temp/build.log'.                                                       
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/pykde4-4.1.82/temp/environment'.                                               
 * This ebuild used the following eclasses from overlays:                                                                                             
 *   /usr/portage/local/layman/kde-crazy/eclass/kde4-meta.eclass
 *   /usr/portage/local/layman/kde-crazy/eclass/kde4-base.eclass
 *   /usr/portage/local/layman/kde-crazy/eclass/kde4-functions.eclass
 *

>>> Failed to emerge kde-base/pykde4-4.1.82, Log file:


what to do?
and plus, for me nepomuk/strigi is not functioning
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sat Dec 20, 2008 10:52 am    Post subject: Reply with quote

I'm here just to quickly leave a note for who, like me, needs konq-plugins.

Them are not broken. I just compiled them, the trick is that their CMakeList.txt
is in the upper directory in SVN (them are in ..extragear/base/konq-plugin, but running "cmake ." from
that directory will not success, you have to run "cmake ." from ..extragear/base to see them compiling).

If noone else does, I'll try to ebuild this as soon as I find some spare time (which could mean quite a lot of time, sorry).
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sat Dec 20, 2008 11:27 am    Post subject: Reply with quote

ok, as I hate leaving work to others, here's a quick hack to build konq-plugins with live slot:

/usr/local/portage/kde-misc/konq-plugins/konq-plugins-9999.ebuild:
Code:

# Copyright 1999-2008 Gentoo Foundation                                         
# Distributed under the terms of the GNU General Public License v2             
# $Header: $                                                                   

EAPI="2"

KMNAME="extragear/base"

inherit kde4-base

SLOT="live"

DESCRIPTION="Konqueror plugins."
HOMEPAGE="http://www.kde.org/"
LICENSE="GPL-2 LGPL-2"

KEYWORDS=""
IUSE=""

DEPEND="
        kde-base/konqueror:${SLOT}
        kde-base/libkonq:${SLOT}"
RDEPEND="${DEPEND}"

src_unpack() {
        kde4-base_src_unpack
        mv CMakeLists.txt CMakeList1.txt || die
        cat ${FILESDIR}/CMakeListHead.txt CMakeList1.txt > CMakeLists.txt || die
}


and /usr/local/portage/kde-misc/konq-plugins/files/CMakeListHead.txt:
Code:

project(extragear-base)

# search packages used by KDE
find_package(KDE4 REQUIRED)
include (KDE4Defaults)
include (MacroLibrary)

add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
include_directories (${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${KDE4_INCLUDES})

find_library(KONQ_LIBS NAMES konq
        PATHS
        ${LIB_INSTALL_DIR}
)

feel free to test.

P.S.: Here at pastebin instead my ebuild for kgraphviewer, a diagram/flow chart utility still unstable
but very interesting : http://pastebin.com/f553a2d7f
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/


Last edited by Matteo Azzali on Sun Dec 21, 2008 11:51 am; edited 1 time in total
Back to top
View user's profile Send private message
travlr
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 158
Location: USA

PostPosted: Sat Dec 20, 2008 2:26 pm    Post subject: Reply with quote

Matteo Azzali wrote:
ok, as I hate leaving work to others, here's a quick hack to build konq-plugins with live slot:

/usr/local/portage/kde-misc/kde-plugins/kde-plugins-9999.ebuild:
...
and /usr/local/portage/kde-misc/konq-plugins/files/CMakeListHead.txt:
...

Matteo, hey thanks.

Isn't that supposed to be category/package: kde-base/konq-plugins/ and not kde-misc/kde-plugins/.
Also the ebuild should be konq-plugins-9999.ebuild and not kde-plugins-9999.ebuild


-travlr


Last edited by travlr on Sat Dec 20, 2008 3:40 pm; edited 3 times in total
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat Dec 20, 2008 2:57 pm    Post subject: Reply with quote

Is it possible to make an ebuild for KIPI-plugins 0.2.0 digikam for this program is really good, thanks.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
rolis
n00b
n00b


Joined: 24 Apr 2008
Posts: 12

PostPosted: Sat Dec 20, 2008 7:02 pm    Post subject: Reply with quote

ssmaxss wrote:
After last update marble got some new use flags but it doesn't build again. My USE flags for marble
Code:
[ebuild     U ] kde-base/marble-4.1.85 [4.1.82] USE="htmlhandbook kde kdeprefix python%* -debug -designer-plugin -gps -plasma% -test" 0 kB [1]


it looks like there is a problem with python bindings. if you disable python use flag it builds ok.
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Sat Dec 20, 2008 7:25 pm    Post subject: Reply with quote

After last update marble still doesn't compiles. Maybe it is better to disable python binding in ebuild if they are not working?
Back to top
View user's profile Send private message
travlr
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 158
Location: USA

PostPosted: Sat Dec 20, 2008 7:58 pm    Post subject: Reply with quote

Anybody tried to compile KDE with Qt-4.5 yet?
Is there an ebuild readily available yet?
Back to top
View user's profile Send private message
ComaWhite
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 125

PostPosted: Sat Dec 20, 2008 8:40 pm    Post subject: Reply with quote

no there is no Qt-4.5 ebuild yet
Back to top
View user's profile Send private message
travlr
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 158
Location: USA

PostPosted: Sat Dec 20, 2008 11:02 pm    Post subject: Reply with quote

ComaWhite wrote:
no there is no Qt-4.5 ebuild yet

Yes thats obviously true for the portage tree, but I'm not talking about the portage tree. Thanks though.
.
Back to top
View user's profile Send private message
ComaWhite
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 125

PostPosted: Sat Dec 20, 2008 11:12 pm    Post subject: Reply with quote

travlr wrote:
ComaWhite wrote:
no there is no Qt-4.5 ebuild yet

Yes thats obviously true for the portage tree, but I'm not talking about the portage tree. Thanks though.
.


It's not in the overlays because it was just released like 2 days ago. Give it time.
Back to top
View user's profile Send private message
StringCheesian
l33t
l33t


Joined: 21 Oct 2003
Posts: 887

PostPosted: Sat Dec 20, 2008 11:27 pm    Post subject: Reply with quote

travlr wrote:
Anybody tried to compile KDE with Qt-4.5 yet?
Is there an ebuild readily available yet?


I unmerged qt-4.4 and installed 4.5 beta from source manually, and @kdedeps-live and @kdebase-live both remerged without any problems. However, kdm and plasma both crashed. kwrite ran fine, but I had to run it from Gnome.

Portage's qt ebuild might do something that I didn't.
Back to top
View user's profile Send private message
travlr
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 158
Location: USA

PostPosted: Sun Dec 21, 2008 2:02 am    Post subject: Reply with quote

StringCheesian wrote:

I unmerged qt-4.4 and installed 4.5 beta from source manually, and @kdedeps-live and @kdebase-live both remerged without any problems. However, kdm and plasma both crashed. kwrite ran fine, but I had to run it from Gnome.

Portage's qt ebuild might do something that I didn't.


Thanks. I'll make an ebuild set tomorrow, because I'm curious to see if QtCreator has potential.
Back to top
View user's profile Send private message
ComaWhite
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 125

PostPosted: Sun Dec 21, 2008 3:28 am    Post subject: Reply with quote

travlr wrote:
StringCheesian wrote:

I unmerged qt-4.4 and installed 4.5 beta from source manually, and @kdedeps-live and @kdebase-live both remerged without any problems. However, kdm and plasma both crashed. kwrite ran fine, but I had to run it from Gnome.

Portage's qt ebuild might do something that I didn't.


Thanks. I'll make an ebuild set tomorrow, because I'm curious to see if QtCreator has potential.


I tried it in Windows when it was released and in Gentoo. Works good I like it. But it's useless for me until CMake is released and it required Qt-4.5b1 I couldn't compile it with the current qt-copy 4.4.3
Back to top
View user's profile Send private message
travlr
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 158
Location: USA

PostPosted: Sun Dec 21, 2008 4:14 am    Post subject: Reply with quote

ComaWhite wrote:

I tried it in Windows when it was released and in Gentoo. Works good I like it. But it's useless for me until CMake is released and it required Qt-4.5b1 I couldn't compile it with the current qt-copy 4.4.3


What's this mention about a CMake release; why is it relevant? Thanks.
Back to top
View user's profile Send private message
ComaWhite
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 125

PostPosted: Sun Dec 21, 2008 5:17 am    Post subject: Reply with quote

travlr wrote:
ComaWhite wrote:

I tried it in Windows when it was released and in Gentoo. Works good I like it. But it's useless for me until CMake is released and it required Qt-4.5b1 I couldn't compile it with the current qt-copy 4.4.3


What's this mention about a CMake release; why is it relevant? Thanks.


Its a plugin for qt-creator to be able to build cmake projects instead of crappy qmake
Back to top
View user's profile Send private message
Benni123
Tux's lil' helper
Tux's lil' helper


Joined: 13 Mar 2005
Posts: 110

PostPosted: Sun Dec 21, 2008 8:03 am    Post subject: Reply with quote

I found, that kopete only fails with USE="Jabber" enabled.

While printing-applet-kde has now been added, it seems to explicitely rely on pykde4. However, Pykde4 breaks on my system with:

Quote:
/usr/include/python2.5/pyconfig.h:948:1: Warnung: »_XOPEN_SOURCE« redefiniert
<Kommandozeile>:1:1: Warnung: dies ist die Stelle der vorherigen Definition
[100%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_soprano.dir/sip/soprano/sipsopranopart7.o
In Datei, eingefügt von /usr/include/python2.5/Python.h:13,
von /usr/include/python2.5/sip.h:28,
von /var/tmp/portage/kde-base/pykde4-4.1.85/work/pykde4_build/python/pykde4/sip/soprano/sipAPIsoprano.h:11,
von /var/tmp/portage/kde-base/pykde4-4.1.85/work/pykde4_build/python/pykde4/sip/soprano/sipsopranopart7.cpp:7:
/usr/include/python2.5/pyconfig.h:948:1: Warnung: »_XOPEN_SOURCE« redefiniert
<Kommandozeile>:1:1: Warnung: dies ist die Stelle der vorherigen Definition
Linking CXX shared library ../../lib/pykde/soprano.so
[100%] Built target python_module_PyKDE4_soprano
Linking CXX shared library ../../lib/pykde/plasma.so
CMakeFiles/python_module_PyKDE4_plasma.dir/sip/plasma/sipplasmapart0.o: In function `void* qMetaTypeConstructHelper<Plasma::Containment::StyleOption>(Plasma::Containment::StyleOption const*)':
sipplasmapart0.cpp:(.text._Z24qMetaTypeConstructHelperIN6Plasma11Containment11StyleOptionEEPvPKT_[void* qMetaTypeConstructHelper<Plasma::Containment::StyleOption>(Plasma::Containment::StyleOption const*)]+0x2f): undefined reference to `Plasma::Containment::StyleOption::StyleOption(Plasma::Containment::StyleOption const&)'
sipplasmapart0.cpp:(.text._Z24qMetaTypeConstructHelperIN6Plasma11Containment11StyleOptionEEPvPKT_[void* qMetaTypeConstructHelper<Plasma::Containment::StyleOption>(Plasma::Containment::StyleOption const*)]+0x4e): undefined reference to `Plasma::Containment::StyleOption::StyleOption()'
CMakeFiles/python_module_PyKDE4_plasma.dir/sip/plasma/sipplasmapart6.o: In function `init_Plasma_Containment_StyleOption':
sipplasmapart6.cpp:(.text+0x4c8f): undefined reference to `Plasma::Containment::StyleOption::StyleOption(QStyleOptionGraphicsItem const&)'
sipplasmapart6.cpp:(.text+0x4cbe): undefined reference to `Plasma::Containment::StyleOption::StyleOption()'
sipplasmapart6.cpp:(.text+0x4cfd): undefined reference to `Plasma::Containment::StyleOption::StyleOption(Plasma::Containment::StyleOption const&)'
collect2: ld gab 1 als Ende-Status zurück
make[2]: *** [lib/pykde/plasma.so] Fehler 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_plasma.dir/all] Fehler 2
make: *** [all] Fehler 2
*
* ERROR: kde-base/pykde4-4.1.85 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3678: Called kde4-meta_src_compile
* environment, line 2819: Called kde4-base_src_make
* environment, line 2580: Called cmake-utils_src_make
* environment, line 991: Called die
* The specific snippet of code:
* emake "$@" || die "Make failed!";
* The die message:


Can anyone tell me how to solve this?
my emerge info is
Quote:
Portage 2.2_rc18 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r6-i686-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-glibc2.0
Timestamp of tree: Sun, 21 Dec 2008 06:35:01 +0000
ccache version 2.4 [disabled]
app-shells/bash: 3.2_p33
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python: 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache: 2.4-r7
dev-util/cmake: 2.6.2
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox: 1.2.18.1-r2
sys-devel/autoconf: 2.13, 2.61-r2
sys-devel/automake: 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils: 2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool: 1.5.26
virtual/os-headers: 2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mtune=prescott -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -mtune=prescott -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="de_DE@euro"
LC_ALL="de_DE@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="de en en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/wschlich-testing /usr/portage/local/layman/kde-crazy /usr/portage/local/layman/berkano /usr/portage/local/layman/sunrise /usr/portage/local/layman/science"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X a52 aac acl acpi ads aften alsa amrnb apm arts aspell async automount avahi berkdb bittorrent bzip2 cairo cardbus cdaudio cdparanoia cdr cdrom cern cli consolekit context contrast cpudetection cracklib crypt cups custom-optimization cvs dbus dga disk-partition djvu dri dts dv dvb dvd dvdrdvdread dvi dx dxr2 dxr3-audio-denoise eds em84xx emacs embedded emovix encode excel exif exiv2 extra fam ffmpeg fftw filepicker firefox flac fontconfig foomaticdb fortran fortran95 fpx ftp gadu gamess gd gdbm general ggi gif gimp git glut glw gnome-print gnomecd gnuplot gphoto2 gpm grammar graphics graphviz groupwise gs gstreamer gtk gtk-perl gtkhtml gtkspell gzip hal hdaps hdri html htmlhandbook http humanities iconv ieee1394 imagemagick imlib imlib2 ipv6 ipw4965 isdnlog java jbig joystick jpeg jpeg2k kde kpathsea lapack laptop latex ldap libwww lm_sensors logitech-mouse lyx lzma lzo md5sum mdnsresponder-compat messenger midi mikmod mjpeg mmx mmxext mng motif mp3 mp4 mp4live mpeg mpeg2 mplayer mudflap musepack mysql ncurses network networkmanager nls nptl nptlonly nsplugin nuv octave office ogg ogg123 ogm omega openexr opengl opengl-video openvpn pam parport parted pascal passwdqc pcre pdf perl player plotutils png pop postscript ppds pppd preview-latex ps pstricks publishers python qq qt3 qt3support qt4 quicktime quotas radio rar raw readline realmedia reflection rpm rtc rtf rtsp samba scanner science scv sdl semantic-desktop session smp sms sndfile spell spl sse sse2 ssl ssse3 stream subversion svg svga swat sysfs syslog t1lib tcpd tex4ht theora threads thunderbird tiff tk totem truetype type1 unicode unzip usb v4l v4l2 vcd vcdx vdrvidix vorbis wav wavpack webkit win32codecs winbind wma wmf wxwindows x264 x86 xcomposite xemacs xetex xext xine xml xmlreader xmlwriter xorg xprint xulrunner xv xvid xvmc zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop emptyextplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en en_GB" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa vga apm"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Back to top
View user's profile Send private message
Benni123
Tux's lil' helper
Tux's lil' helper


Joined: 13 Mar 2005
Posts: 110

PostPosted: Sun Dec 21, 2008 10:48 am    Post subject: Reply with quote

I want to add, that pykde4 configure before install made some stange outputs:
Quote:
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Failed
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Phonon Version: 4.2.80
-- Found Phonon: /usr/lib/libphonon.so
-- Found Phonon Includes: /usr/include/KDE;/usr/include
-- Found KDE 4.2 include dir: /usr/include
-- Found KDE 4.2 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Phonon Version: 4.2.80
--
Quote:
cmake package FindOkular.cmake was not found. The package Okular is needed to compile all part of this program.
-- cmake package FindKDevPlatform.cmake was not found. The package KDevPlatform is needed to compile all part of this program.

-- Found PythonInterp: /usr/bin/python2.5
-- Found Python executable: /usr/bin/python2.5
-- Found Python version: 2.5.2
-- Found Python library: /usr/lib/libpython2.5.so
-- Python Libraries: /usr/lib/libpython2.5.so
-- Python Include Path: /usr/include/python2.5
-- Build Kross Python... yes
-- Found SIP version: 4.7.9
-- Found PyQt4 version: 4.4.4
-- Found Python executable: /usr/bin/python2.5
-- Found Python version: 2.5.2
-- Found Python library: /usr/lib/libpython2.5.so
-- Found PyQt4 version: 4.4.4
-- KDEVERSION: 4.1.85
-- KDE4_INCLUDE_DIR: /usr/include
-- KDE4_LIB_DIR: /usr/lib
-- PYTHON_SITE_PACKAGES_DIR: /usr/lib/python2.5/site-packages
-- Build PyKDE4... yes
--
-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
+ Soprano: Soprano Libraries <kdesupport>
Required for Soprano Python bindings.
+ Nepomuk: Nepomuk Libraries <kdesupport>
Required for Nepomuk Python bindings.
+ Kdepimlibs: KDE pim Libraries <kdepimlibs>
Required for Akonadi Python bindings.

-----------------------------------------------------------------------------



regarding to kdepimlibs, emerge says:
Quote:
[ebuild R ] kde-base/kdepimlibs-4.1.85 USE="htmlhandbook ldap sasl -debug -kdeprefix -test" 0 kB [1]
Implying that this package is already there. Why does pykde4 say it would be absent? and what does this here mean?
[quote]--
Quote:
cmake package FindOkular.cmake was not found. The package Okular is needed to compile all part of this program.
-- cmake package FindKDevPlatform.cmake was not found. The package KDevPlatform is needed to compile all part of this program.
Of course, I have okular installed!
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Sun Dec 21, 2008 11:54 am    Post subject: Reply with quote

travlr wrote:

Matteo, hey thanks.

Isn't that supposed to be category/package: kde-base/konq-plugins/ and not kde-misc/kde-plugins/.
Also the ebuild should be konq-plugins-9999.ebuild and not kde-plugins-9999.ebuild

-travlr


Thank you too, konq-plugins is the exact name, corrected. It's just a dirty temp hack, so I choosed kde-misc to
remember that's not the definitive solution, but you can put it in kde-base if you like, will work too.
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7115
Location: Austria

PostPosted: Sun Dec 21, 2008 12:40 pm    Post subject: Reply with quote

heyhey, 4.1.85 just entered kde-testing! :D
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 282

PostPosted: Sun Dec 21, 2008 12:48 pm    Post subject: Reply with quote

Yes, I'm just compiling it (actually I was wondering yesterday, if I should give kde-crazy a try, but since it would have meant some work, I skipped it).
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2334
Location: Konradsreuth (Germany)

PostPosted: Sun Dec 21, 2008 1:07 pm    Post subject: Reply with quote

Anybody out there with a running Akonadi setup? I can both install akonadi and akonadi-server, and the server does also start. But when an application tries to access Akonadi, I get the following error message:
Quote:
Could not create client-side bridge, check if Akonadi KResource bridge is installed

So, where do I get this bridge?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7115
Location: Austria

PostPosted: Sun Dec 21, 2008 1:17 pm    Post subject: Reply with quote

You need to emerge kdepim-kresources
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Sun Dec 21, 2008 3:27 pm    Post subject: Reply with quote

Switched to kde-testing. Marble doesn't build in it too. Is it going to be fixed?
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 282

PostPosted: Sun Dec 21, 2008 3:35 pm    Post subject: Reply with quote

For me, marble compiled fine in kde-testing. But pykde4 failed :(
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 26, 27, 28, 29, 30  Next
Page 27 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum