Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE experimental overlay (genkdesvn) Part 7
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Stefano Crocco
Apprentice
Apprentice


Joined: 28 Sep 2006
Posts: 157

PostPosted: Sun Nov 16, 2008 7:29 pm    Post subject: Reply with quote

beso_1717 wrote:

the problem is that the other ebuilds failing on it should be made dependant on this one. have you already posted a bug on the bugzilla with the new ebuild and the fixed deps on the others?!


I didn't, but someone else has.
_________________
Stefano
Back to top
View user's profile Send private message
NetCutter
n00b
n00b


Joined: 26 Mar 2007
Posts: 25
Location: Bulgaria

PostPosted: Mon Nov 17, 2008 12:57 pm    Post subject: Reply with quote

beso_1717 wrote:
Stefano Crocco wrote:
beso_1717 wrote:
i'm experiencing some errors building kwin, plasma-workspace and some other packages.
the kwin error is the following:

the plasma error is quite strange, since there doesn't seem to be a real error in that file...


is someone else experiencing the same issues?!


The problem is that since yesterday, kwin and plasma (in particular the pager) depend on a new libreary, kephal, which is in the kdebase-workspace module and for which there isn't as yet an ebuild. I tried to make it, basing on the one for kde-base/libplasmaclok, and here's the result:

Code:
KMNAME=kdebase-workspace
KMMODULE=libs/${PN}
inherit gks-svn-meta

DESCRIPTION=""
KEYWORDS=""
IUSE="debug"

It needs to be saved in a kephal/kephal-scm.kdebuild-1 file in a repository (the kde4-experimental one or another one), and needs to be added to /etc/paludis/keywords.conf.

Note that, if you put it in the kde4-experimental repository, you'll need to manually remove it when the official ebuild will be made, otherwise git will complain when you try to sync.

the problem is that the other ebuilds failing on it should be made dependant on this one. have you already posted a bug on the bugzilla with the new ebuild and the fixed deps on the others?!

Where exactly do I have to put this ebuild file? Cuz I tried to save it in:
/var/paludis/repositories/kde/kde-base/kephal/kephal-scm.kdebuild-1
/var/paludis/repositories/kde/kde-base/kdebase-workspace/kephal/kephal-scm.kdebuild-1


But still can't find such a package?

P.S[0]: My kde4-experimental overlay is in /var/paludis/repositories/kde/

edit: Whatever. kephal is now in kde4-experimental ;)
Back to top
View user's profile Send private message
NetCutter
n00b
n00b


Joined: 26 Mar 2007
Posts: 25
Location: Bulgaria

PostPosted: Mon Nov 17, 2008 3:15 pm    Post subject: Reply with quote

And even with kephal I still can't compile kwin and plasma-workspace ;(

plasma-workspace:
Code:
[ 27%] Generating ui_webbrowserconfig.h                                                                                                                                           
Generating webbrowser.moc                                                                                                                                                         
Generating historycombobox.moc                                                                                                                                                     
Generating moc_bookmarksdelegate.cpp                                                                                                                                               
Scanning dependencies of target plasma_applet_webbrowser                                                                                                                           
[ 27%] Building CXX object plasma/applets/webbrowser/CMakeFiles/plasma_applet_webbrowser.dir/plasma_applet_webbrowser_automoc.o                                                   
[ 27%] Building CXX object plasma/applets/webbrowser/CMakeFiles/plasma_applet_webbrowser.dir/historycombobox.o                                                                     
[ 27%] Building CXX object plasma/applets/webbrowser/CMakeFiles/plasma_applet_webbrowser.dir/bookmarksdelegate.o                                                                   
[ 28%] Building CXX object plasma/applets/webbrowser/CMakeFiles/plasma_applet_webbrowser.dir/bookmarkitem.o                                                                       
[ 28%] Building CXX object plasma/applets/webbrowser/CMakeFiles/plasma_applet_webbrowser.dir/webbrowser.o                                                                         
Linking CXX shared module ../../../lib/plasma_applet_webbrowser.so                                                                                                                 
[ 28%] Built target plasma_applet_webbrowser                                                                                                                                       
[ 28%] Generating ui_pagerConfig.h                                                                                                                                                 
Generating pager.moc                                                                                                                                                               
Scanning dependencies of target plasma_applet_pager                                                                                                                               
[ 28%] Building CXX object plasma/applets/pager/CMakeFiles/plasma_applet_pager.dir/plasma_applet_pager_automoc.o                                                                   
[ 29%] Building CXX object plasma/applets/pager/CMakeFiles/plasma_applet_pager.dir/pager.o                                                                                         
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/pager/pager.cpp: In member function 'virtual void Pager::paintInterface(QPainter*, const QStyleOptionGraphicsItem*, const QRect&)':                                                                                                                                               
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/pager/pager.cpp:949: warning: passing 'qreal' for argument 1 to 'void QColor::setAlpha(int)'   
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/pager/pager.cpp: In member function 'void Pager::updateToolTip()':                             
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/pager/pager.cpp:1110: error: 'class Plasma::ToolTipContent' has no member named 'addResource' 
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/pager/pager.cpp:1110: error: 'ImageResource' is not a member of 'Plasma::ToolTipContent'       
make[2]: *** [plasma/applets/pager/CMakeFiles/plasma_applet_pager.dir/pager.o] Error 1                                                                                             
make[1]: *** [plasma/applets/pager/CMakeFiles/plasma_applet_pager.dir/all] Error 2                                                                                                 
make: *** [all] Error 2                                                                                                                                                           
/usr/libexec/paludis/utils/emake: emake returned error 2                                                                                                                           

!!! ERROR in kde-base/plasma-workspace-scm:
!!! In cmake-utils_src_make at line 1308   
!!! Make failed!                           

!!! Call stack:
!!!    * cmake-utils_src_make (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:1308)
!!!    * gks-base_src_make (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:3193)   
!!!    * gks-meta_src_make (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:3492)   
!!!    * gks-meta_src_compile (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:3443)
!!!    * src_compile (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:4648)         
!!!    * ebuild_f_compile (/usr/libexec/paludis/1/src_compile.bash:49)                             
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:477)                                         
!!!    * main (/usr/libexec/paludis/ebuild.bash:492)                                               

diefunc: making ebuild PID 31129 exit with error
die trap: exiting with error.                   

Install error:
  * In program paludis --log-level qa --install --add-to-world-spec kde-base/plasma-workspace --serialised 0.25 package;=kde-base/pykde4-scm:kde-svn::kde4-experimental;installed;has_all_deps;S package;=kde-base/plasma-workspace-scm:kde-svn::kde4-experimental;installed;has_all_deps;P:                                                                         
  * When performing install action from command line:                                                                                                                             
  * When executing install task:                                                                                                                                                   
  * When installing 'kde-base/plasma-workspace-scm:kde-svn::kde4-experimental':                                                                                                   
  * Install error: Install failed for 'kde-base/plasma-workspace-scm:kde-svn::kde4-experimental'                                                                                   



Summary of failures:

* kde-base/plasma-workspace-scm:kde-svn::kde4-experimental: failure


And Kwin:
Code:
Linking CXX shared library ../../lib/libkdecorations.so                                                                                                                           
[  7%] Built target kdecorations                                                                                                                                                   
[  7%] Generating kwinadaptor.cpp, kwinadaptor.h                                                                                                                                   
[  7%] Generating kwinadaptor.moc                                                                                                                                                 
Generating unmanaged.moc                                                                                                                                                           
Generating workspace.moc                                                                                                                                                           
Generating client.moc                                                                                                                                                             
Generating main.moc                                                                                                                                                               
Generating toplevel.moc                                                                                                                                                           
Generating deleted.moc                                                                                                                                                             
Generating geometrytip.moc                                                                                                                                                         
Generating sm.moc                                                                                                                                                                 
Generating popupinfo.moc                                                                                                                                                           
Generating tabbox.moc                                                                                                                                                             
Generating utils.moc                                                                                                                                                               
Scanning dependencies of target kdeinit_kwin                                                                                                                                       
[  7%] Building CXX object kwin/CMakeFiles/kdeinit_kwin.dir/kdeinit_kwin_automoc.o                                                                                                 
[  7%] Building CXX object kwin/CMakeFiles/kdeinit_kwin.dir/workspace.o                                                                                                           
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/toplevel.h: In member function 'pid_t KWin::Toplevel::pid() const':                                                             
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/toplevel.h:402: error: invalid use of undefined type 'struct NETWinInfo2'                                                       
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/toplevel.h:38: error: forward declaration of 'struct NETWinInfo2'                                                               
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/client.h: At global scope:                                                                                                       
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/client.h:89: error: 'NETFullscreenMonitors' has not been declared                                                               
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/client.h:353: error: 'NETFullscreenMonitors' has not been declared                                                               
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/client.h:553: error: invalid use of undefined type 'struct NETWinInfo2'
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/toplevel.h:38: error: forward declaration of 'struct NETWinInfo2'
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/client.h:560: error: 'NETFullscreenMonitors' has not been declared
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/client.h:553: warning: 'class KWin::WinInfo' has virtual functions but non-virtual destructor
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/client.h: In member function 'bool KWin::Client::hasNETSupport() const':
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/client.h:711: error: invalid use of undefined type 'struct NETWinInfo2'
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/toplevel.h:38: error: forward declaration of 'struct NETWinInfo2'
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/client.h: In member function 'bool KWin::Client::hasUserTimeSupport() const':
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/client.h:766: error: invalid use of undefined type 'struct NETWinInfo2'
/var/tmp/paludis/kde-base-kwin-scm/work/kwin/kwin/toplevel.h:38: error: forward declaration of 'struct NETWinInfo2'
make[2]: *** [kwin/CMakeFiles/kdeinit_kwin.dir/workspace.o] Error 1
make[1]: *** [kwin/CMakeFiles/kdeinit_kwin.dir/all] Error 2
make: *** [all] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in kde-base/kwin-scm:
!!! In cmake-utils_src_make at line 1302
!!! Make failed!

!!! Call stack:
!!!    * cmake-utils_src_make (/var/tmp/paludis/kde-base-kwin-scm/temp/loadsaveenv:1302)
!!!    * gks-base_src_make (/var/tmp/paludis/kde-base-kwin-scm/temp/loadsaveenv:3187)
!!!    * gks-meta_src_make (/var/tmp/paludis/kde-base-kwin-scm/temp/loadsaveenv:3486)
!!!    * gks-meta_src_compile (/var/tmp/paludis/kde-base-kwin-scm/temp/loadsaveenv:3437)
!!!    * src_compile (/var/tmp/paludis/kde-base-kwin-scm/temp/loadsaveenv:4644)
!!!    * ebuild_f_compile (/usr/libexec/paludis/1/src_compile.bash:49)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:477)
!!!    * main (/usr/libexec/paludis/ebuild.bash:492)

diefunc: making ebuild PID 11798 exit with error
die trap: exiting with error.

Install error:
  * In program paludis -i kwin plasma-workspace playground-plasma:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'kde-base/kwin-scm:kde-svn::kde4-experimental':
  * Install error: Install failed for 'kde-base/kwin-scm:kde-svn::kde4-experimental'



Summary of failures:

* kde-base/kwin-scm:kde-svn::kde4-experimental: failure
Back to top
View user's profile Send private message
beso_1717
Apprentice
Apprentice


Joined: 19 Jul 2007
Posts: 263

PostPosted: Tue Nov 18, 2008 12:00 pm    Post subject: Reply with quote

i think that these errors are due to kephal, but to other stuff. i've been able to build plasma-workspace and kwin with kephal and they worked. now, though, i'm not able to rebuild them due to these new errors. maybe there's the need for a big rebuild.

anyway, for some days i've been getting this strange error with amarok-scm:

Quote:
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWidget.o
/var/tmp/paludis/media-sound-amarok-scm/work/amarok_build/amarok/src/scriptengine/generator/generator/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QValidator.cpp: In member function 'virtual QValidator::State QtScriptShell_QValidator::validate(QString&, int&) const':
/var/tmp/paludis/media-sound-amarok-scm/work/amarok_build/amarok/src/scriptengine/generator/generator/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QValidator.cpp:122: warning: control reaches end of non-void function
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWidgetAction.o
[ 98%] [ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWidgetItem.o
Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWindowsStyle.o
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWizard.o
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWizardPage.o
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWorkspace.o
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/main.o
/var/tmp/paludis/media-sound-amarok-scm/work/amarok_build/amarok/src/scriptengine/generator/generator/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWindowsStyle.cpp: In member function 'virtual QPixmap QtScriptShell_QWindowsStyle::standardPixmap(QStyle::StandardPixmap, const QStyleOption*, const QWidget*) const':
/var/tmp/paludis/media-sound-amarok-scm/work/amarok_build/amarok/src/scriptengine/generator/generator/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWindowsStyle.cpp:342: warning: control reaches end of non-void function
Linking CXX shared module ../../../../../lib/libqtscript_gui.so
[ 98%] Built target qtscript_gui
make: *** [all] Error 2


is there a way to have it go away?! it's not a new one and i really don't know how to have it fixed. it's true that also pykde4 has failed as a package and i'm not sure is this is related to that.
Back to top
View user's profile Send private message
Stefano Crocco
Apprentice
Apprentice


Joined: 28 Sep 2006
Posts: 157

PostPosted: Tue Nov 18, 2008 1:10 pm    Post subject: Reply with quote

beso_1717 wrote:
i think that these errors are due to kephal, but to other stuff. i've been able to build plasma-workspace and kwin with kephal and they worked. now, though, i'm not able to rebuild them due to these new errors. maybe there's the need for a big rebuild.

anyway, for some days i've been getting this strange error with amarok-scm:

Quote:
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWidget.o
/var/tmp/paludis/media-sound-amarok-scm/work/amarok_build/amarok/src/scriptengine/generator/generator/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QValidator.cpp: In member function 'virtual QValidator::State QtScriptShell_QValidator::validate(QString&, int&) const':
/var/tmp/paludis/media-sound-amarok-scm/work/amarok_build/amarok/src/scriptengine/generator/generator/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QValidator.cpp:122: warning: control reaches end of non-void function
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWidgetAction.o
[ 98%] [ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWidgetItem.o
Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWindowsStyle.o
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWizard.o
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWizardPage.o
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWorkspace.o
[ 98%] Building CXX object amarok/src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/main.o
/var/tmp/paludis/media-sound-amarok-scm/work/amarok_build/amarok/src/scriptengine/generator/generator/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWindowsStyle.cpp: In member function 'virtual QPixmap QtScriptShell_QWindowsStyle::standardPixmap(QStyle::StandardPixmap, const QStyleOption*, const QWidget*) const':
/var/tmp/paludis/media-sound-amarok-scm/work/amarok_build/amarok/src/scriptengine/generator/generator/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWindowsStyle.cpp:342: warning: control reaches end of non-void function
Linking CXX shared module ../../../../../lib/libqtscript_gui.so
[ 98%] Built target qtscript_gui
make: *** [all] Error 2


is there a way to have it go away?! it's not a new one and i really don't know how to have it fixed. it's true that also pykde4 has failed as a package and i'm not sure is this is related to that.


I was able to rebuild kde 4 and amarok (kde 4 about 5 hours ago and amarok right now). Regarding amarok, the output you posted doesn't contain any error (as far as I can see, at least). With cmake, sometimes you need to go back a long way before finding the actual line corresponding to the error. You should look very carefully for a line where the output from gcc (which is easy to see because it's in black) contains the word error.
_________________
Stefano
Back to top
View user's profile Send private message
2dimm
n00b
n00b


Joined: 10 Jun 2005
Posts: 52
Location: Brussels, Belgium

PostPosted: Wed Nov 19, 2008 8:11 am    Post subject: Reply with quote

beso_1717 wrote:
anyway, for some days i've been getting this strange error with amarok-scm:



If you had previously patched mysql.eclass to use -fPIC has it been overwritten by a newer version? It had here. See Gimpel's post from 29/10 on p2 of this thread.
Back to top
View user's profile Send private message
beso_1717
Apprentice
Apprentice


Joined: 19 Jul 2007
Posts: 263

PostPosted: Thu Nov 20, 2008 7:03 pm    Post subject: Reply with quote

2dimm wrote:
beso_1717 wrote:
anyway, for some days i've been getting this strange error with amarok-scm:



If you had previously patched mysql.eclass to use -fPIC has it been overwritten by a newer version? It had here. See Gimpel's post from 29/10 on p2 of this thread.


i though i had -fPIC set globally in my bashrc (i've read somewhere that it's safer on amd64 and gives better performance), but it wasn't the case.
the strange thing is that amarok 1.90-r1 builds against the current mysql and it should have the same problem, but it has only the phonon2 problem that makes amarok crash after you try to play a file. now i'm rebuilding mysql with -DFPIC -fPIC and see if this time amarok would build.


modified 21.11:

why is libkcddb saying that it cannot build against Xine-lib because xine lib or phonon is not compiled with xcb?! i have xine-lib building with xcb since 1.1.10 (now i'm on 1.1.15) and phonon is also build with xcb. also i have everything build with xcb (having it as default use flag). this is the configuration output:

Quote:

Enabling building of HTML handbook
loading initial cache file /var/tmp/paludis/kde-base-libkcddb-scm/temp//gentoo_common_config.cmake
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.4.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found Perl: /usr/bin/perl
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Phonon Version:
-- Found Phonon: /usr/kde/svn/lib64/libphonon.so
-- Found Phonon Includes: /usr/kde/svn/include/KDE;/usr/kde/svn/include
-- Found KDE 4.2 include dir: /usr/kde/svn/include
-- Found KDE 4.2 library dir: /usr/kde/svn/lib64
-- Found the KDE4 kconfig_compiler preprocessor: /usr/kde/svn/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Looking for snd_seq_create_simple_port in asound
-- Looking for snd_seq_create_simple_port in asound - found
-- Found ALSA: /usr/lib64/libasound.so
-- Found MusicBrainz: /usr/include
-- Looking for include files HAVE_SYS_SOUNDCARD_H
-- Looking for include files HAVE_SYS_SOUNDCARD_H - found
-- Looking for include files HAVE_MACHINE_SOUNDCARD_H
-- Looking for include files HAVE_MACHINE_SOUNDCARD_H - not found.
-- Looking for include files HAVE_LINUX_AWE_VOICE_H
-- Looking for include files HAVE_LINUX_AWE_VOICE_H - not found.
-- Looking for include files HAVE_AWE_VOICE_H
-- Looking for include files HAVE_AWE_VOICE_H - not found.
-- Looking for include files HAVE__USR_SRC_SYS_I386_ISA_SOUND_AWE_VOICE_H
-- Looking for include files HAVE__USR_SRC_SYS_I386_ISA_SOUND_AWE_VOICE_H - not found.
-- Looking for include files HAVE__USR_SRC_SYS_GNU_I386_ISA_SOUND_AWE_VOICE_H
-- Looking for include files HAVE__USR_SRC_SYS_GNU_I386_ISA_SOUND_AWE_VOICE_H - not found.
-- Looking for C++ include sys/asoundlib.h
-- Looking for C++ include sys/asoundlib.h - found
-- Looking for C++ include alsa/asoundlib.h
-- Looking for C++ include alsa/asoundlib.h - found
-- Looking for snd_pcm_resume in asound
-- Looking for snd_pcm_resume in asound - found
-- checking for module 'libxine'
-- found libxine, version 1.1.15
-- Found Xine: /usr/include
-- Found taglib: -L/usr/lib64 -ltag
-- Taglib found: -L/usr/lib64 -ltag
-- Looking for vorbis_bitrate_addblock in vorbis
-- Looking for vorbis_bitrate_addblock in vorbis - found
-- Found OggVorbis: /usr/lib64/libogg.so;/usr/lib64/libvorbis.so;/usr/lib64/libvorbisfile.so;/usr/lib64/libvorbisenc.so
-- Looking for include files HAVE_SOUNDCARD_H
-- Looking for include files HAVE_SOUNDCARD_H - not found.
-- Looking for include files HAVE_SYS_STAT_H
-- Looking for include files HAVE_SYS_STAT_H - found
-- Looking for include files HAVE_LINUX_CDROM_H
-- Looking for include files HAVE_LINUX_CDROM_H - found
-- Looking for include files HAVE_LINUX_UCDROM_H
-- Looking for include files HAVE_LINUX_UCDROM_H - not found.
-- Looking for include files HAVE_MACHINE_ENDIAN_H
-- Looking for include files HAVE_MACHINE_ENDIAN_H - not found.
-- Looking for include files HAVE_SYS_AUDIOIO_H
-- Looking for include files HAVE_SYS_AUDIOIO_H - not found.
-- Looking for include files HAVE_ALIB_H
-- Looking for include files HAVE_ALIB_H - not found.
-- Looking for include files HAVE_ALLOCA_H
-- Looking for include files HAVE_ALLOCA_H - found
-- Looking for include files HAVE_ENDIAN_H
-- Looking for include files HAVE_ENDIAN_H - found
-- Looking for include files HAVE_SYS_ENDIAN_H
-- Looking for include files HAVE_SYS_ENDIAN_H - not found.
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for stdint.h
-- Looking for stdint.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of long
-- Check size of long - done
--
-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
+ taglib
+ OggVorbis
+ MusicBrainz
-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
+ Xine XCB: Xine libraries <http://xinehq.de/>
Xine and phonon-xine must be compiled with XCB support.
Back to top
View user's profile Send private message
netshade
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2004
Posts: 84
Location: Sweden

PostPosted: Mon Nov 24, 2008 8:53 pm    Post subject: Reply with quote

I did try to find someone else with this problem, but to no avail. So I'll just post on my own and hope for a solution.

I'm trying to install kdepimlibs-scm from the "kde" overlay (git://www2.mailstation.de/git/genkde4svn.git), but for the last week or weeks it has been broken for me.
Code:


[ 18%] Building CXX object syndication/CMakeFiles/syndication.dir/rss2/document.o
[ 18%] Generating ui_subscriptiondialog.h
[ 18%] Generating ui_controlprogressindicator.h
[ 18%] Generating notificationmanagerinterface.moc
[ 20%] Generating agentmanagerinterface.moc
[ 20%] Generating tracerinterface.moc
[ 20%] Generating resourceadaptor.moc
[ 20%] Generating statusadaptor.moc
[ 21%] Generating controladaptor.moc
Scanning dependencies of target akonadi-kde
[ 21%] Building CXX object syndication/CMakeFiles/syndication.dir/rss2/enclosure.o
[ 21%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/entity.o
[ 21%] Building CXX object syndication/CMakeFiles/syndication.dir/rss2/image.o
[ 21%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agentbase.o
[ 21%] Building CXX object syndication/CMakeFiles/syndication.dir/rss2/item.o
[ 23%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agentfilterproxymodel.o
[ 23%] Building CXX object syndication/CMakeFiles/syndication.dir/rss2/parser.o
[ 23%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agentinstance.o
[ 23%] Building CXX object syndication/CMakeFiles/syndication.dir/rss2/source.o
[ 23%] Building CXX object syndication/CMakeFiles/syndication.dir/rss2/textinput.o
[ 24%] Building CXX object syndication/CMakeFiles/syndication.dir/rss2/tools_p.o
[ 24%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agentinstancecreatejob.o
[ 24%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/parser.o
[ 24%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agentinstancemodel.o
[ 24%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agentinstancewidget.o
[ 24%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/dublincorevocab.o
[ 24%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agentmanager.o
[ 24%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/dublincore.o
[ 24%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/syndicationvocab.o
[ 24%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agenttype.o
[ 26%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agenttypemodel.o
[ 26%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/syndicationinfo.o
[ 26%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agenttypewidget.o
[ 26%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/contentvocab.o
[ 26%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/item.o
[ 26%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agenttypedialog.o
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp:25:36: error: kfilterproxysearchline.h: No such file or directory
[ 27%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/image.o
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp: In constructor 'Akonadi::AgentTypeDialog::AgentTypeDialog(QWidget*)':
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp:43: error: 'KFilterProxySearchLine' was not declared in this scope
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp:43: error: 'searchLine' was not declared in this scope
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp:43: error: expected type-specifier before 'KFilterProxySearchLine'
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp:43: error: expected `;' before 'KFilterProxySearchLine'
make[2]: *** [akonadi/CMakeFiles/akonadi-kde.dir/agenttypedialog.o] Error 1
make[1]: *** [akonadi/CMakeFiles/akonadi-kde.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 27%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/textinput.o
[ 27%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/document.o
[ 27%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/rssvocab.o
[ 27%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/node.o
[ 27%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/property.o
[ 27%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/literal.o
[ 28%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/resource.o
[ 28%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/model.o
[ 28%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/modelmaker.o
[ 28%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/rdfvocab.o
[ 28%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/sequence.o
[ 28%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/statement.o
[ 28%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/resourcewrapper.o
[ 28%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/nodevisitor.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/category.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/constants.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/content.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/document.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/entry.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/generator.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/link.o
[ 30%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/parser.o
[ 31%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/person.o
[ 31%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/source.o
[ 31%] Building CXX object syndication/CMakeFiles/syndication.dir/atom/atomtools.o
[ 31%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/feedrss2impl.o
[ 31%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/itemrss2impl.o
[ 31%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/enclosurerss2impl.o
[ 31%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/categoryrss2impl.o
[ 31%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/imagerss2impl.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/feedrdfimpl.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/itemrdfimpl.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/imagerdfimpl.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/feedatomimpl.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/itematomimpl.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/enclosureatomimpl.o
[ 33%] Building CXX object syndication/CMakeFiles/syndication.dir/mapper/categoryatomimpl.o
[ 34%] Building CXX object syndication/CMakeFiles/syndication.dir/documentsource.o
[ 34%] Building CXX object syndication/CMakeFiles/syndication.dir/documentvisitor.o
[ 34%] Building CXX object syndication/CMakeFiles/syndication.dir/elementwrapper.o
[ 34%] Building CXX object syndication/CMakeFiles/syndication.dir/constants.o
[ 34%] Building CXX object syndication/CMakeFiles/syndication.dir/feed.o
[ 34%] Building CXX object syndication/CMakeFiles/syndication.dir/item.o
[ 34%] Building CXX object syndication/CMakeFiles/syndication.dir/enclosure.o
[ 34%] Building CXX object syndication/CMakeFiles/syndication.dir/category.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/image.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/tools.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/person.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/personimpl.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/loader.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/global.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/dataretriever.o
[ 36%] Building CXX object syndication/CMakeFiles/syndication.dir/specificitemvisitor.o
[ 37%] Building CXX object syndication/CMakeFiles/syndication.dir/specificitem.o
[ 37%] Building CXX object syndication/CMakeFiles/syndication.dir/specificdocument.o
[ 37%] Building CXX object syndication/CMakeFiles/syndication.dir/abstractparser.o
[ 37%] Building CXX object syndication/CMakeFiles/syndication.dir/syndication_automoc.o
Linking CXX shared library ../lib/libsyndication.so
[ 37%] Built target syndication
make: *** [all] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in kde-base/kdepimlibs-scm:
!!! In cmake-utils_src_make at line 1253
!!! Make failed!

!!! Call stack:
!!!    * cmake-utils_src_make (/var/tmp/paludis/kde-base-kdepimlibs-scm/temp/loadsaveenv:1253)
!!!    * gks-base_src_make (/var/tmp/paludis/kde-base-kdepimlibs-scm/temp/loadsaveenv:3138)
!!!    * gks-base_src_compile (/var/tmp/paludis/kde-base-kdepimlibs-scm/temp/loadsaveenv:3107)
!!!    * src_compile (/var/tmp/paludis/kde-base-kdepimlibs-scm/temp/loadsaveenv:4274)
!!!    * ebuild_f_compile (/usr/libexec/paludis/1/src_compile.bash:49)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:477)
!!!    * main (/usr/libexec/paludis/ebuild.bash:492)

diefunc: making ebuild PID 780 exit with error
die trap: exiting with error.




I think it's due to akonadi-server, but I might be wrong. The strange thing about akonadi server is that I have two of them installed.
I have both

Code:

[D] app-office/akonadi-server
     Available versions:  ~1.0.0 {mysql}
     Installed versions:  1.0.0(22.37.26 2008-11-15)(mysql)
     Homepage:            http://pim.kde.org/akonadi
     Description:         The server part of Akonadi



and another one which doesn't show up when inquired by eix

Code:

niefelheim ~ # paludis -q server-pim/akonadi-server
* server-pim/akonadi-server
    installed:               scm* {:0}
    kde4-experimental:       scm {:0}
    Description:             The server part of Akonadi
    Homepage:                http://www.kde.org
    Relevant USE flags:      (mysql)
    License:                 LGPL-2.1
    Installed time:          Mon Nov 24 16:39:36 2008
    From repositories:       kde4-experimental
    Installed using:         paludis-0.30.3



which paludis pulls if I uninstall it.

I'm lost, and my mind is looping.

Please, an answer to this would be really helpful, and if I missed something searching I apologize. I don't get along very well with the phpBB search.
_________________
From where the shadows turn into nightmare, netshade greets you...
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon Nov 24, 2008 8:56 pm    Post subject: Reply with quote

You may want to keep server-pim/akonadi-server and get rid of the other one.

No idea why it is in server-pim/ in this overlay, but at least that one fits to the rest, while app-office/ is the wrong one for this overlay.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Nov 26, 2008 9:59 am    Post subject: Reply with quote

I can't build k3b-scm. Fails at plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp.
The problem seems to be my ffmpeg-version:
media-video/ffmpeg-0.4.9_p20081014

This patch solves the problem:
Code:
--- k3b/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp.org 2008-11-26 10:42:54.000000000 +0100
+++ k3b/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp     2008-11-26 10:43:31.000000000 +0100
@@ -198,7 +198,7 @@
         return i18n("Windows Media v1");
     case CODEC_ID_WMAV2:
         return i18n("Windows Media v2");
-    case CODEC_ID_MP3LAME:
+    case CODEC_ID_MP3:
         return i18n("MPEG 1 Layer III");
     case CODEC_ID_AAC:
         return i18n("Advanced Audio Coding (AAC)");
@@ -291,7 +291,7 @@

         d->outputBufferPos = d->outputBuffer;

-        int len = avcodec_decode_audio(
+        int len = avcodec_decode_audio2(
 #ifdef FFMPEG_BUILD_PRE_4629
             &d->formatContext->streams[0]->codec,
 #else

I don't know when they changed these names, so I don't know when to apply the patch.
Back to top
View user's profile Send private message
individual
n00b
n00b


Joined: 06 Dec 2006
Posts: 61
Location: Wrocław

PostPosted: Fri Dec 05, 2008 2:23 pm    Post subject: Reply with quote

Same problem with kdepimlibs here:

My compile thread:

Code:
Generating ldapstructureproxymodel.moc                                                                                                                                             
[ 26%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agenttypewidget.o                                                                                                     
[ 26%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/document.o                                                                                                   
Scanning dependencies of target kldap                                                                                                                                               
[ 26%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agenttypedialog.o                                                                                                     
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp:25:36: error: kfilterproxysearchline.h: No such file or directory                         
[ 27%] Building CXX object syndication/CMakeFiles/syndication.dir/rdf/rssvocab.o                                                                                                   
[ 27%] Building CXX object kldap/CMakeFiles/kldap.dir/ber.o                                                                                                                         
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp: In constructor 'Akonadi::AgentTypeDialog::AgentTypeDialog(QWidget*)':                     
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp:43: error: 'KFilterProxySearchLine' was not declared in this scope                         
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp:43: error: 'searchLine' was not declared in this scope                                     
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp:43: error: expected type-specifier before 'KFilterProxySearchLine'                         
/var/tmp/paludis/kde-base-kdepimlibs-scm/work/kdepimlibs-scm/akonadi/agenttypedialog.cpp:43: error: expected `;' before 'KFilterProxySearchLine'                                   
make[2]: *** [akonadi/CMakeFiles/akonadi-kde.dir/agenttypedialog.o] Error 1                                                                                                         
make[1]: *** [akonadi/CMakeFiles/akonadi-kde.dir/all] Error 2                                                                                                                       
[ 27%] make[1]: *** Waiting for unfinished jobs....                                                                                                                                 
Building CXX object syndication/CMakeFiles/syndication.dir/rdf/node.o


    * server-pim/akonadi-server
    installed: scm* {:0}
    kde4-experimental: scm {:0}
    Description: The server part of Akonadi
    Homepage: http://www.kde.org
    License: LGPL-2.1
    Installed time: Fri Dec 5 14:06:00 2008
    Use flags: (mysql)
    From repositories: kde4-experimental
    Installed using: paludis-0.32.1


    Quasar dawid # eix akonadi-server
    * app-office/akonadi-server
    Available versions: (~)1.0.0 {mysql}
    Homepage: http://pim.kde.org/akonadi
    Description: The server part of Akonadi


Any ideas?
_________________
HP dv5-1040ew + Gentoo ~amd_64
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Dec 09, 2008 5:36 pm    Post subject: Reply with quote

I had to revert this patch to get behind a cmake error
Code:
INSTALL(EXPORT) given unknown export "kdeworkspaceLibraryTargets"

Not sure if this is an upstream problem or if the kdebuilds/eclass needs fixing. First I thought the qt-4.5 snapshot is guilty, but after reverting that commit everything is fine.

Now.. going to play with WolfenQt. <- wicked! :D
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
netshade
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2004
Posts: 84
Location: Sweden

PostPosted: Wed Dec 10, 2008 5:23 pm    Post subject: Reply with quote

gimpel wrote:
You may want to keep server-pim/akonadi-server and get rid of the other one.

No idea why it is in server-pim/ in this overlay, but at least that one fits to the rest, while app-office/ is the wrong one for this overlay.


Tried that, still the same error... Been looking at it from every imaginable angle (in my world that is, and I'm kind of a n00b when it gets to things like this... :oops: ) and no solution in sight... :(
_________________
From where the shadows turn into nightmare, netshade greets you...
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Wed Dec 10, 2008 5:30 pm    Post subject: Reply with quote

netshade wrote:
gimpel wrote:
You may want to keep server-pim/akonadi-server and get rid of the other one.

No idea why it is in server-pim/ in this overlay, but at least that one fits to the rest, while app-office/ is the wrong one for this overlay.


Tried that, still the same error... Been looking at it from every imaginable angle (in my world that is, and I'm kind of a n00b when it gets to things like this... :oops: ) and no solution in sight... :(

What's the exact problem with this? Just uninstall app-office/akonadi-server and re-install server-pim/akonadi-server.
Or do you have multiple slots of kde4 installed?
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
NetCutter
n00b
n00b


Joined: 26 Mar 2007
Posts: 25
Location: Bulgaria

PostPosted: Wed Dec 10, 2008 7:47 pm    Post subject: Reply with quote

gimpel wrote:
I had to revert this patch to get behind a cmake error
Code:
INSTALL(EXPORT) given unknown export "kdeworkspaceLibraryTargets"

Not sure if this is an upstream problem or if the kdebuilds/eclass needs fixing. First I thought the qt-4.5 snapshot is guilty, but after reverting that commit everything is fine.

It's not working with me.
I've added
Code:
PATHCES="${FILESDIR}/${PN}-targets.patch"
into /var/paludis/repositories/kde/kde-base/plasma-workspace/plasma-workspace-scm.kdebuild-1 [Your patch was named: /var/paludis/repositories/kde/kde-base/plasma-workspace/files/plasma-workspace-targets.patch (by me :D) ]
I've created KDE4WorkspaceConfig.cmake file.
Back to top
View user's profile Send private message
netshade
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2004
Posts: 84
Location: Sweden

PostPosted: Wed Dec 10, 2008 7:54 pm    Post subject: Reply with quote

gimpel wrote:
netshade wrote:
gimpel wrote:
You may want to keep server-pim/akonadi-server and get rid of the other one.

No idea why it is in server-pim/ in this overlay, but at least that one fits to the rest, while app-office/ is the wrong one for this overlay.


Tried that, still the same error... Been looking at it from every imaginable angle (in my world that is, and I'm kind of a n00b when it gets to things like this... :oops: ) and no solution in sight... :(

What's the exact problem with this? Just uninstall app-office/akonadi-server and re-install server-pim/akonadi-server.
Or do you have multiple slots of kde4 installed?


Tried that again (I was uncertain if I really did it last time...)

Paludis wanted to remove 53 packages with app-office/akonadi-server, 250something with "--with-dependencies", so I did it with "--permit-unsafe-uninstalls" just to see what would come from it. kdepimlibs-scm borks at the same point.

I have the portage version of kde-4.1.3 installed slotted and I'm trying to upgrade / reinstall from -9999 to -scm. I still don't get what's breaking kdepimlibs, it seems like it's compiling it's own akonadi... ?

Any help appreciated, and thank's NetCutter for your effort this far!
_________________
From where the shadows turn into nightmare, netshade greets you...
Back to top
View user's profile Send private message
Ceniza
n00b
n00b


Joined: 30 May 2008
Posts: 26

PostPosted: Wed Dec 10, 2008 8:27 pm    Post subject: Reply with quote

gimpel wrote:
I had to revert this patch to get behind a cmake error
Code:
INSTALL(EXPORT) given unknown export "kdeworkspaceLibraryTargets"

Not sure if this is an upstream problem or if the kdebuilds/eclass needs fixing. First I thought the qt-4.5 snapshot is guilty, but after reverting that commit everything is fine.


That's the problem I'm having right now, but it's now too late to try to install KDE 4 again (it takes 2 hours). I'll give it a try tomorrow, but it'd be nice if you can explain better how you proceeded with that patch.

Also, I would like to know if you guys are having any of the following problems:

1. Sometimes when kdm starts the screen starts flickering. Mouse movements and keyboard input feel very slow and leave trails. It doesn't matter if I kill the X server and/or restart kdm through the init scripts. The only way I've found to get the system back to normal is to log in and then log out (even after logging in the strange flickering is still there). I think that problem started even before updating to the latest beta drivers of nvidia.

2. On shutdown, /home cannot be unmounted cleanly. It seems the guilty process is akonadi. When I log out and check in a tty what's running, I find akonadi services and mysql still there running from my user account. If I kill them, the shutdown process goes smoothly. I tried disabling akonadi, but it causes problems with kopete. Also, if I try to start akonadi again using System Settings, it does NOT start, and it reports some errors. I don't recall the errors, neither I can try it right now (no KDE4).

Hopefully, I'll get KDE4 up and running again tomorrow, so I can see again what's going on with akonadi.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Wed Dec 10, 2008 9:50 pm    Post subject: Reply with quote

Ceniza and
NetCutter wrote:
gimpel wrote:
I had to revert this patch to get behind a cmake error
Code:
INSTALL(EXPORT) given unknown export "kdeworkspaceLibraryTargets"

Not sure if this is an upstream problem or if the kdebuilds/eclass needs fixing. First I thought the qt-4.5 snapshot is guilty, but after reverting that commit everything is fine.

It's not working with me.
I've added
Code:
PATHCES="${FILESDIR}/${PN}-targets.patch"
into /var/paludis/repositories/kde/kde-base/plasma-workspace/plasma-workspace-scm.kdebuild-1 [Your patch was named: /var/paludis/repositories/kde/kde-base/plasma-workspace/files/plasma-workspace-targets.patch (by me :D) ]
I've created KDE4WorkspaceConfig.cmake file.

Of course that won't work, as that patch has to be _reverted_ (patch -R). And it's not "my" patch, it's the patch generated by KDE's websvn interface for the commit that "broke it"

But on the long term it's no solution either.
The point is that Alex Neundorf changed the build system in a way that it broke our build system((s).. kde-crazy is also broken).
I tried to look into it, but I must admit that I horribly failed to incorporate those upstream changes into our split-(kd)ebuilds system. I have no idea...

Anyways, as a temporary hack, I just reverted that patch directly in svn-src.. cd /usr/portage/svn-src/KDE/kdebase/kdebase/workspace; patch -p3 -R < CMakeLists.txt.patch
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Wed Dec 10, 2008 10:02 pm    Post subject: Reply with quote

netshade wrote:
I have the portage version of kde-4.1.3 installed slotted and I'm trying to upgrade / reinstall from -9999 to -scm. I still don't get what's breaking kdepimlibs, it seems like it's compiling it's own akonadi... ?

Yeah I thought so... I have no idea why the genkdesvn crew here didn't put akonadi-server in the same category as it is in portage and kde-testing/crazy. Sure, server-pim fits better, but that causes exactly that mess you are experiencing.

So the "solution" is: use _only_ this genkdesvn overlay, or the portage based ones. You can slot the portage based ones.
The real solution would be that the genkdesvn maintainers change the category of akonadi-server, or the portage kde guys change it. But latter one isn't likely to happen, why should they.. that would make one new category with only one package in it, lol.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
NetCutter
n00b
n00b


Joined: 26 Mar 2007
Posts: 25
Location: Bulgaria

PostPosted: Thu Dec 11, 2008 2:28 pm    Post subject: Reply with quote

gimpel wrote:
Ceniza and
NetCutter wrote:
gimpel wrote:
I had to revert this patch to get behind a cmake error
Code:
INSTALL(EXPORT) given unknown export "kdeworkspaceLibraryTargets"

Not sure if this is an upstream problem or if the kdebuilds/eclass needs fixing. First I thought the qt-4.5 snapshot is guilty, but after reverting that commit everything is fine.

It's not working with me.
I've added
Code:
PATHCES="${FILESDIR}/${PN}-targets.patch"
into /var/paludis/repositories/kde/kde-base/plasma-workspace/plasma-workspace-scm.kdebuild-1 [Your patch was named: /var/paludis/repositories/kde/kde-base/plasma-workspace/files/plasma-workspace-targets.patch (by me :D) ]
I've created KDE4WorkspaceConfig.cmake file.

Of course that won't work, as that patch has to be _reverted_ (patch -R). And it's not "my" patch, it's the patch generated by KDE's websvn interface for the commit that "broke it"

But on the long term it's no solution either.
The point is that Alex Neundorf changed the build system in a way that it broke our build system((s).. kde-crazy is also broken).
I tried to look into it, but I must admit that I horribly failed to incorporate those upstream changes into our split-(kd)ebuilds system. I have no idea...

Anyways, as a temporary hack, I just reverted that patch directly in svn-src.. cd /usr/portage/svn-src/KDE/kdebase/kdebase/workspace; patch -p3 -R < CMakeLists.txt.patch


Doh...my bad. Everything is fine now, thanks :oops: :)
Back to top
View user's profile Send private message
Ceniza
n00b
n00b


Joined: 30 May 2008
Posts: 26

PostPosted: Thu Dec 11, 2008 8:09 pm    Post subject: Reply with quote

gimpel wrote:
Ceniza and
...

Anyways, as a temporary hack, I just reverted that patch directly in svn-src.. cd /usr/portage/svn-src/KDE/kdebase/kdebase/workspace; patch -p3 -R < CMakeLists.txt.patch


Thanks a lot! That did the trick!

As usual, some non-so-important packages didn't build, and the flickering is back. It seems to be caused only by KDM 4. I added the option "NoLogo" to xorg.conf just in case. I'll see if that helps next time I reboot.

For comparison purposes, the packages that didn't build are: kdeartwork-kscreensaver, kde-l10n (the reason for this one is clear enough), kitchensync, knewsticker, kpercentage, kscd, kstars, ktux, marble. kdeplasma-addons also failed with message "Could NOT find KDE4Workspace (missing: KDE4Workspace_CONFIG)" and plasma-workspace always fails in the first try, but it builds just fine in the second one. ktorrent also built without problems, and now I'm giving Amarok 2 a try (update: it failed).

Now... Akonadi...

Restart doesn't show any problems, but if I check the resources configuration tab I see an icon that reads "Akonadi not operational". If I click on details, then it shows two errors: "Akonadi control process not registered at D-Bus" and the same one with "server" instead of "control".

Google is not helping me this time :(
Back to top
View user's profile Send private message
Ceniza
n00b
n00b


Joined: 30 May 2008
Posts: 26

PostPosted: Fri Dec 12, 2008 7:50 am    Post subject: Reply with quote

The problem of /home not being cleanly unmounted is still there :(

I searched about the flickering one, and I found that it's caused by the nvidia driver. Actually, it's a problem the driver had a few years ago, and not it's back. I found some workarounds, and there's one of them I tried that seems to be working. What's really strange is that it's been triggered only by KDM 4, not KDM 3. Anyway, you can forget about that one.
Back to top
View user's profile Send private message
NetCutter
n00b
n00b


Joined: 26 Mar 2007
Posts: 25
Location: Bulgaria

PostPosted: Fri Dec 12, 2008 5:36 pm    Post subject: Reply with quote

Bad issue with kdeplasma-addons, even with this patch.
Code:
-- Phonon Version: 4.2.80                                                                                                                                 
-- Found Phonon: /usr/kde/svn/lib/libphonon.so                                                                                                             
-- Found Phonon Includes: /usr/kde/svn/include/KDE;/usr/kde/svn/include
-- Found KDE 4.2 include dir: /usr/kde/svn/include
-- Found KDE 4.2 library dir: /usr/kde/svn/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/kde/svn/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:57 (MESSAGE):
  Could NOT find KDE4Workspace (missing: KDE4Workspace_CONFIG)
Call Stack (most recent call first):
  /usr/kde/svn/share/apps/cmake/modules/FindKDE4Workspace.cmake:68 (find_package_handle_standard_args)
  CMakeLists.txt:9 (find_package)


-- Configuring incomplete, errors occurred!

!!! ERROR in kde-base/kdeplasma-addons-scm:
!!! In cmake-utils_src_configureout at line 1227
!!! Cmake failed

!!! Call stack:
!!!    * cmake-utils_src_configureout (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:1227)
!!!    * cmake-utils_src_configure (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:1208)
!!!    * gks-base_src_configure (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:3127)
!!!    * gks-base_src_compile (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:3106)
!!!    * src_compile (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:4278)
!!!    * ebuild_f_compile (/usr/libexec/paludis/1/src_compile.bash:49)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:482)
!!!    * main (/usr/libexec/paludis/ebuild.bash:498)


KDE Version 4.1.82 (KDE 4.1.82 (KDE 4.2 >= 20081204))
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Fri Dec 12, 2008 5:47 pm    Post subject: Reply with quote

Don't reverse that anymore, as the overlay maintainers have worked around it, it seems.

Thanks! :)
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
NetCutter
n00b
n00b


Joined: 26 Mar 2007
Posts: 25
Location: Bulgaria

PostPosted: Fri Dec 12, 2008 7:23 pm    Post subject: Reply with quote

gimpel wrote:
Don't reverse that anymore, as the overlay maintainers have worked around it, it seems.

Thanks! :)

I did paludis -s kde4-experimental just right now. Then I've recompiled plasma-workspace, but still get this error. :evil:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 4 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum