Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiz-Fusion Dependency Hell
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
nero37
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jun 2007
Posts: 141
Location: Ireland

PostPosted: Wed Oct 01, 2008 6:36 pm    Post subject: Compiz-Fusion Dependency Hell Reply with quote

Went to upgrade compiz-fusion(desktop-effects overlay) to version 0.7.8, tuck a trip down the dependency rabbit hole and got stuck. compiz-0.7.8 requires libXrender-0.9.4 and xorg-server-1.3.0.0-r6 requires libXrender-0.9.2 and due to this bug both want to use the same slot.

emerge error message;
Code:
!!! Multiple versions within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libXrender:0

  ('installed', '/', 'x11-libs/libXrender-0.9.2', 'nomerge') pulled in by
    ('installed', '/', 'x11-base/xorg-server-1.3.0.0-r6', 'nomerge')

  ('ebuild', '/', 'x11-libs/libXrender-0.9.4', 'merge') pulled in by
    ('installed', '/', 'x11-libs/gtk+-2.12.11', 'nomerge')
    ('installed', '/', 'net-libs/xulrunner-1.9.0.3', 'nomerge')
    ('installed', '/', 'media-plugins/libvisual-plugins-0.4.0-r2', 'nomerge')
    (and 14 more)


Upgrading xorg to an unstable version would probably fix this but that's a headache I could do without. So anyone out there got any ideas for the best way to handle this?

Also is requiring an unstable portage for EAPI 2 support really necessary for a minor version bump?
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Thu Oct 02, 2008 7:16 pm    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software.
overlay stuff, so unsupported
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
SeaTiger
l33t
l33t


Joined: 22 Nov 2007
Posts: 603
Location: Toronto, Ontario, Canada

PostPosted: Fri Oct 03, 2008 4:10 am    Post subject: Reply with quote

It is strange that you have xulrunner 1.9.0.3, which is in the ~arch, but still using xorg-server-1.3.0.0-r6.

The ~x86/_64 xorg-server is 1.5.1.

Upgrading it should solve the circular dependency.
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Fri Oct 03, 2008 12:00 pm    Post subject: Re: Compiz-Fusion Dependency Hell Reply with quote

nero37 wrote:
Upgrading xorg to an unstable version would probably fix this but that's a headache I could do without. So anyone out there got any ideas for the best way to handle this?

You already answered your own question: you need to upgrade xorg to its latest ~arch version. Or you could just not update, and wait for stuff to get to stable.

nero37 wrote:
Also is requiring an unstable portage for EAPI 2 support really necessary for a minor version bump?

Really necessary? No. But the maintainer decided to do it this way. And it is only logical that ebuilds in ~arch or overlays would use the new features of the latest portage, because in the end it is in the interest of the users that want these packages. But you are free to adapt the ebuilds to use EAPI 0 or 1 instead.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
nero37
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jun 2007
Posts: 141
Location: Ireland

PostPosted: Sat Oct 04, 2008 2:09 pm    Post subject: Reply with quote

Thanks for all the feedback.
Quote:
It is strange that you have xulrunner 1.9.0.3, which is in the ~arch, but still using xorg-server-1.3.0.0-r6.

Xulrunner-1.9.0.3 is needed by firefox 3 and there was no way I could resist upgrading.

I've been quite hesitant to update xorg considering its such a vital part of the system and bugs in it can be really annoying, leading to I/O freezes and hard restarts. But I think ill give it a shot anyway. xorg-x11 7.3 and 7.4 both use libXrender-0.9.4 so either would work. I have and nvidia geforce 8600 GS with nvidia-drivers and seeing as the nvidia drivers override most of dri/drm, which would give me the best balance of performance/stability.
Back to top
View user's profile Send private message
nero37
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jun 2007
Posts: 141
Location: Ireland

PostPosted: Fri Oct 10, 2008 8:49 am    Post subject: Reply with quote

Went ahead and upgraded xorg and compiz, had a few problems so I reverted back to stable xorg and compiz-0.7.6. Now when I start compiz I get a seg fault. 8O

HELP!
Back to top
View user's profile Send private message
nero37
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jun 2007
Posts: 141
Location: Ireland

PostPosted: Fri Oct 10, 2008 9:25 am    Post subject: Reply with quote

fixed it, remerged libcompizconfig and everything is back to the way it was.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum