Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
skype won't start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
number_nine
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2005
Posts: 136

PostPosted: Thu Oct 02, 2008 12:53 am    Post subject: skype won't start Reply with quote

Whenever I try to run Skype, nothing happens: no text is output, no windows appear, no "phantom" processes are created, etc. The program simply exits with a status of 1.

Code:

$ uname -a
Linux myhostname 2.6.23-gentoo-r9 #1 SMP Mon Mar 10 20:42:49 CDT 2008 x86_64 Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz GenuineIntel GNU/Linux

$ skype
$ echo $?
1
$ emerge -pv skype
[ ... ]
[ebuild   R   ] net-im/skype-2.0.0.68  USE="(qt-static)" 0 kB


This version (2.0.0.68) has been unmasked via ~AMD64 in my /etc/portage/package.keywords file. I had the same result when using the non-masked version, 2.0.0.63.

This was working quite a while ago, i.e. many months---in other words, it's been too long to know what I may have changed since it last worked.

Any thoughts?

Thanks!
Back to top
View user's profile Send private message
Non_E
Apprentice
Apprentice


Joined: 17 Jan 2006
Posts: 160
Location: Czech Republic

PostPosted: Thu Oct 02, 2008 11:14 am    Post subject: Reply with quote

Please run it from some terminal emulator (konsole, xterm etc.)
_________________
Only Sith deals in absolutes.
Back to top
View user's profile Send private message
number_nine
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2005
Posts: 136

PostPosted: Thu Oct 02, 2008 12:29 pm    Post subject: Reply with quote

As opposed to what? In the above code, I was running it in an rxvt (or maybe Eterm) window.

...However! I was trying to start it from within screen, and that screen session had been started remotely (i.e. when I was logged in from another system).

I have noticed that when I don't start screen sessions locally, that X11 apps won't work locally. (But they usually exit with a more useful error message, about not being able to connect to the X server.)

I bet that's it. I'm at work now, I'll try it again when I get home.

Note: just to be clear, I wasn't trying to start Skype remotely; I was physically sitting at the computer on which I was trying to run Skype. However, the screen session had been created remotely.

Anyway, much thanks!
Back to top
View user's profile Send private message
number_nine
Tux's lil' helper
Tux's lil' helper


Joined: 05 May 2005
Posts: 136

PostPosted: Fri Oct 03, 2008 12:38 am    Post subject: Reply with quote

Indeed, that was the problem---trying to run it from a screen session not initiated locally.

Worked fine from another (locally started) screen terminal.

Thanks again.
Back to top
View user's profile Send private message
Non_E
Apprentice
Apprentice


Joined: 17 Jan 2006
Posts: 160
Location: Czech Republic

PostPosted: Fri Oct 03, 2008 8:58 am    Post subject: Reply with quote

Sorry, I did not read your post carefully enough.
_________________
Only Sith deals in absolutes.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum