Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
EVP_whirlpool was not declared in this scope
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
donmartio
Apprentice
Apprentice


Joined: 11 Dec 2004
Posts: 241

PostPosted: Thu Oct 02, 2008 8:01 pm    Post subject: EVP_whirlpool was not declared in this scope Reply with quote

Ho there,

just for everyone struggelin with this!!

When i tried to emerge all the kde-4.1.2 stuff i stumbeled over this error:

Code:
qca-ossl.cpp: In function 'X509_EXTENSION* opensslQCAPlugin::new_subject_key_id(X509*)':
qca-ossl.cpp:330: warning: deprecated conversion from string constant to 'char*'
qca-ossl.cpp: In member function 'virtual QCA::Provider::Context* opensslProvider::createContext(const QString&)':
qca-ossl.cpp:6815: error: 'EVP_whirlpool' was not declared in this scope


After some discussions and research i tried the previous version of openssl an everything works.

So id did:
emerge =dev-libs/openssl-0.9.8h-r1

and in the portage.mask:
=dev-libs/openssl-0.9.8i

May this is the reason for some bugs out there.

Greetings
DonMartio
_________________
Always code as if the person who ends up maintaining your code will be a violent psychopath who knows where you live.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum