Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kchart 1.98 (SOLVED)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Tue Oct 14, 2008 1:34 pm    Post subject: kchart 1.98 (SOLVED) Reply with quote

Hi,

I am using kde-testing overlay and when I try to emerge koffice-meta, the make of kchart looks like this

Quote:

Building CXX object kchart/kdchart/src/CMakeFiles/kdchart.dir/LeveyJennings/KDChartLeveyJenningsGrid.o
[ 62%] Building CXX object kchart/kdchart/src/CMakeFiles/kdchart.dir/LeveyJennings/KDChartLeveyJenningsGridAttributes.o
[ 62%] Building CXX object kchart/kdchart/src/CMakeFiles/kdchart.dir/Scenery/ReverseMapper.o
[ 63%] Building CXX object kchart/kdchart/src/CMakeFiles/kdchart.dir/Scenery/ChartGraphicsItem.o
/home/tmp_portage/portage/app-office/kchart-1.9.98.0/work/kchart-1.9.98.0/kchart/kdchart/src/LeveyJennings/KDChartLeveyJenningsGrid.cpp: In member function 'virtual void KDChart::LeveyJenningsGrid::calculateStepWidth(qreal, qreal, const QList<double>&, Qt::Orientation, qreal&, qreal&, bool, bool) const':
/home/tmp_portage/portage/app-office/kchart-1.9.98.0/work/kchart-1.9.98.0/kchart/kdchart/src/LeveyJennings/KDChartLeveyJenningsGrid.cpp:162: warning: 'distance' may be used uninitialized in this function
[ 64%] Building CXX object kchart/kdchart/src/CMakeFiles/kdchart.dir/kdchart_automoc.o
Linking CXX shared library ../../../lib/libkdchart.so
[ 64%] Built target kdchart
make: *** [all] Error 2
*
* ERROR: app-office/kchart-1.9.98.0 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3170: Called kde4-meta_src_compile
* environment, line 2475: Called kde4-meta_src_make
* environment, line 2579: Called kde4-base_src_make
* environment, line 2209: Called cmake-utils_src_make
* environment, line 767: Called die
* The specific snippet of code:
* emake "$@" || die "Make failed!";
* The die message:
* Make failed!
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/home/tmp_portage/portage/app-office/kchart-1.9.98.0/temp/build.log'.
* The ebuild environment file is located at '/home/tmp_portage/portage/app-office/kchart-1.9.98.0/temp/environment'.
* This ebuild used the following eclasses from overlays:
* /usr/portage/local/layman/kde-testing/eclass/kde4-meta.eclass
* /usr/portage/local/layman/kde-testing/eclass/kde4-functions.eclass
* /usr/portage/local/layman/kde-testing/eclass/kde4-base.eclass
*


here is my emerge --info:

Quote:

Portage 2.2_rc11 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 x86_64)
=================================================================
System uname: Linux-2.6.25-gentoo-r7-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8100_@_2.10GHz-with-glibc2.2.5
Timestamp of tree: Tue, 14 Oct 2008 06:35:02 +0000
app-shells/bash: 3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python: 2.4.4-r13, 2.5.2-r7
dev-util/cmake: 2.6.2
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox: 1.2.18.1-r2
sys-devel/autoconf: 2.13, 2.61-r2
sys-devel/automake: 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils: 2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool: 1.5.26
virtual/os-headers: 2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.lagis.at"
LDFLAGS="-Wl,-O1"
LINGUAS="es ca"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/tmp_portage/"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/kde-testing"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipod ipv6 isdnlog java jpeg kde kdeprefix kerberos ldap libnotify mad midi mikmod mmx mozilla mp3 mp3tunes mp4 mpegmudflap multilib mysql ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype unicode usb visualitzation vorbis wxwindows xcomposite xml xorg xulrunner xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filterheaders include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptic" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es ca" USERLAND="GNU" VIDEO_CARDS="nvidia vesa vga"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Last edited by marcus84 on Sun Oct 19, 2008 5:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sun Oct 19, 2008 5:46 pm    Post subject: Reply with quote

solved in the new version
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum