Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ati 8.543
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
genmich
Apprentice
Apprentice


Joined: 03 Apr 2003
Posts: 196

PostPosted: Wed Oct 15, 2008 11:00 am    Post subject: Ati 8.543 Reply with quote

http://changelogs.ubuntu.com/changelogs/pool/multiverse/f/fglrx-installer/fglrx-installer_8.543-0ubuntu1/changelog
Quote:
fglrx-installer (2:8.543-0ubuntu1) intrepid; urgency=low

* New upstream release. (Closes lp: #247376)
* control: Re-enabled provides of xserver-xorg-video-2 since
this upload works with the current xserver.
* README.Debian: Itemize update procedure

https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/247376


No news on the ATI site or http://www.phoronix.com/ yet. But hopefully it won't take too long. And hopefully it will be a good release :)


Last edited by genmich on Thu Oct 16, 2008 5:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Oct 15, 2008 11:25 am    Post subject: Reply with quote

I hope so too :P
Back to top
View user's profile Send private message
Sensus
n00b
n00b


Joined: 05 Oct 2008
Posts: 12

PostPosted: Wed Oct 15, 2008 2:37 pm    Post subject: Reply with quote

Great. Will it finaly work with the current stable kernel? (Without need to enable unused symbols?)
Back to top
View user's profile Send private message
mirv
n00b
n00b


Joined: 30 Mar 2007
Posts: 13
Location: Germany

PostPosted: Wed Oct 15, 2008 3:27 pm    Post subject: Reply with quote

As far as I'm aware, those drivers are slated for an official november release - I'm guessing they're included with intrepid due to xorg version support. Not sure if ati will "officially" release them until november as such, but the october drivers shouldn't be far away now (although, seeing as intrepid apparently has the november beta, I'm going to assume the october drivers do not support xorg-server 1.5.x).
_________________
the Silly Fish.
Back to top
View user's profile Send private message
genmich
Apprentice
Apprentice


Joined: 03 Apr 2003
Posts: 196

PostPosted: Wed Oct 15, 2008 3:34 pm    Post subject: Reply with quote

Canonical Publishes ATI Catalyst 8.10 Beta
http://www.phoronix.com/scan.php?page=article&item=canonical_catalyst_811&num=1

Quote:
How did Canonical receive this 8.54 driver and permission to upload it early into Ubuntu 8.10? It should not be surprising to assume that Canonical communicates with AMD and participates in their beta driver testing program, and that considering Ubuntu's market-share, they must have allowed them to use this early driver release. AMD though has not commented on the matter.
Back to top
View user's profile Send private message
egon2003
n00b
n00b


Joined: 02 Nov 2004
Posts: 39
Location: Karlstad, Sweden

PostPosted: Wed Oct 15, 2008 7:19 pm    Post subject: Reply with quote

It can be found here https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8-10-x86.x86_64.run
Back to top
View user's profile Send private message
PtitGNU
n00b
n00b


Joined: 16 Feb 2004
Posts: 13
Location: Waterloo, BE

PostPosted: Thu Oct 16, 2008 11:52 am    Post subject: Reply with quote

Hi,

If you want to test the new ati-drivers 8.543 with xorg-server-1.5 , I made some ebuilds this night... There are on my gentoo overlay.

To add the xorg-server and ati-drivers overlay in one line, you can use :

Code:
wget -nH --cut-dirs=1 -r -l inf -P /usr/local/portage ftp://ftp.ptitgnu.be/gentoo-overlay/


It's based on the ubuntu 8.543 source package and it's working for me with a Radeon HD3300 :)

I have more FPS with glxgears too (~3170 with 8.543 vs ~3000 with 8.532)


Troubleshooting :

It seems that there is a problem with 'fglrx_dri.so' (don't forget, this is a beta version)..
This causes a problem with AIGLX :
Code:
(EE) AIGLX error: fglrx exports no extensions (/usr/lib64/dri/fglrx_dri.so: undefined symbol: __driDriverExtensions)

It seems to make 'amdcccle' segfault too..

Does anyone have an idea for that ?
_________________
Gentoo GNU/Linux 2008.0 - Kernel 2.6.26-r2 - KDE 3.5.10


Last edited by PtitGNU on Fri Oct 17, 2008 3:25 am; edited 1 time in total
Back to top
View user's profile Send private message
genmich
Apprentice
Apprentice


Joined: 03 Apr 2003
Posts: 196

PostPosted: Thu Oct 16, 2008 3:10 pm    Post subject: Reply with quote

A bit confusing with the 8.543 (hotfix version ubuntu) and 8.542 (ati released version). I will try out your 8.543 driver now!
Back to top
View user's profile Send private message
egon2003
n00b
n00b


Joined: 02 Nov 2004
Posts: 39
Location: Karlstad, Sweden

PostPosted: Thu Oct 16, 2008 4:47 pm    Post subject: Reply with quote

PtitGNU wrote:
Hi,

If you want to test the new ati-drivers 8.543 with xorg-server-1.5 , I made some ebuilds this night... There are on my gentoo overlay.

To add the xorg-server and ati-drivers overlay in one line, you can use :

Code:
wget -nH --cut-dirs=1 -r -l inf -P /usr/local/portage ftp://ftp.ptitgnu.be/gentoo-overlay/


It's based on the ubuntu 8.543 source package and it's working for me with a Radeon HD3300 :)

Have fun :)



I cant download from the ftp, it gets stuck on 2880 bytes. Thanks for the ebuilds :)
Back to top
View user's profile Send private message
genmich
Apprentice
Apprentice


Joined: 03 Apr 2003
Posts: 196

PostPosted: Thu Oct 16, 2008 5:10 pm    Post subject: Reply with quote

installation went fine but when i'll try to start x i'll get:

Quote:
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
dlopen: /usr/lib/xorg/modules/drivers//fglrx_drv.so: undefined symbol: miZeroLineScreenKey
(EE) Failed to load /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) UnloadModule: "fglrx"
(EE) Failed to load module "fglrx" (loader failed, 7)


How can I fix that?

Edit:
Using Xorg 1.3! It seems they renamed some symbols
Back to top
View user's profile Send private message
genb0y
n00b
n00b


Joined: 10 Apr 2004
Posts: 20

PostPosted: Thu Oct 16, 2008 5:49 pm    Post subject: Reply with quote

Hi, thank you for your ebuilds.

I emerged ati-drivers-8.543 and xorg-server-1.5 from your overlay.

I got only this problem.
Code:
(EE) AIGLX error: fglrx exports no extensions (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driDriverExtensions)
(EE) AIGLX: reverting to software rendering


Other than that, it works.

Can anybody help? I don't want to disable AIGLX.
Back to top
View user's profile Send private message
alxolo
n00b
n00b


Joined: 10 Nov 2008
Posts: 2

PostPosted: Mon Nov 10, 2008 4:41 pm    Post subject: Reply with quote

genb0y wrote:
Hi, thank you for your ebuilds.

I emerged ati-drivers-8.543 and xorg-server-1.5 from your overlay.

I got only this problem.
Code:
(EE) AIGLX error: fglrx exports no extensions (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driDriverExtensions)
(EE) AIGLX: reverting to software rendering


Other than that, it works.

Can anybody help? I don't want to disable AIGLX.


Hi,

unfortunatelly ATI doesn't support AIGLX :( . And I cannot find any information about when they will do.


Last edited by alxolo on Mon Nov 10, 2008 5:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
mirv
n00b
n00b


Joined: 30 Mar 2007
Posts: 13
Location: Germany

PostPosted: Mon Nov 10, 2008 4:59 pm    Post subject: Reply with quote

Actually ATI do support AIGLX, and have done so for a little while now.
ATI have however recently started to use a customised libdri.so - I'm not an expert in such areas, but it may have something to do with that (the gentoo ebuild doesn't copy it over). Try extracting it manually (easy way: run the ati installer, it will extract everything to a temporary folder, copy file, exit installer).
_________________
the Silly Fish.
Back to top
View user's profile Send private message
alxolo
n00b
n00b


Joined: 10 Nov 2008
Posts: 2

PostPosted: Mon Nov 10, 2008 5:45 pm    Post subject: Reply with quote

mirv wrote:
Actually ATI do support AIGLX, and have done so for a little while now.
ATI have however recently started to use a customised libdri.so - I'm not an expert in such areas, but it may have something to do with that (the gentoo ebuild doesn't copy it over). Try extracting it manually (easy way: run the ati installer, it will extract everything to a temporary folder, copy file, exit installer).


Yes, you are quite right ATI support AIGLX starting from 8.42 drivers. But I have the same problem some days ago with installing openSUSE. And I found following information:
http://en.opensuse.org/ATI#AIGLX_error___driCreateNewScreen
Quote:
AIGLX error __driCreateNewScreen

ATI's Driver does not support AIGLX (unless you have an older ATI card pre-r300) at this time so stick to Xorg or Xgl. This will be removed once ATI decides to start supporting it.

If you get a error in Xorg.0.log that looks like

(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering

The solution is to type this in /etc/X11/xorg.conf

Section "ServerFlags"
Option "AIGLX" "off"
EndSection


May be anyone have more clear or additional information?
Back to top
View user's profile Send private message
carlito
n00b
n00b


Joined: 29 May 2003
Posts: 51
Location: Puerto Rico

PostPosted: Fri Nov 14, 2008 4:59 am    Post subject: Reply with quote

I have the same issue and I resolve it doing this:
Code:
cd /usr/lib/opengl/ati/extensions/
mv libglx.so libglx.so.default
cp /usr/X11R6/lib64/modules/extensions/* ./


Then restart X and enjoy AIGLX again, this ebuild needs to be fixed.

Hope it helps :D
_________________
Living la vida Linux
Back to top
View user's profile Send private message
codestation
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2008
Posts: 126
Location: /dev/negi

PostPosted: Fri Nov 14, 2008 2:58 pm    Post subject: Reply with quote

A new version of the driver is out,
https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8-11-x86.x86_64.run
i tried it, but sadly got the same AIGLX error than genb0y
_________________
Just feel the code...
Back to top
View user's profile Send private message
peteblack
n00b
n00b


Joined: 28 Aug 2005
Posts: 26

PostPosted: Fri Nov 14, 2008 3:56 pm    Post subject: Reply with quote

carlito wrote:
I have the same issue and I resolve it doing this:
Code:
cd /usr/lib/opengl/ati/extensions/
mv libglx.so libglx.so.default
cp /usr/X11R6/lib64/modules/extensions/* ./


Then restart X and enjoy AIGLX again, this ebuild needs to be fixed.


Can anyone confirm this. For me it didn't change anything. Also, I have the X11 extensions folder is here:

Code:

/usr/lib/xorg/modules/extensions


Thanks,
Pete
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum