Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
New to Paludis - are these dependencies necessary? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6312
Location: /usr/lib64/lv2

PostPosted: Wed Oct 15, 2008 6:22 pm    Post subject: New to Paludis - are these dependencies necessary? [SOLVED] Reply with quote

I'm trying out Paludis, and using Filezilla as my test, for which an update to my current version is available.

Portage wants to just do the update.

Paludis wants to upgrade 25 or so packages before getting to Filezilla.

Is that the way it's supposed to be? Here's the list of what Paludis wants to do:

Code:

* sys-devel/gnuconfig [U 20080123 -> 20080928]
    Reasons: sys-devel/automake-1.10.1-r1:1.10::installed, sys-devel/libtool-2.2.6a:1.5::installed
    40.17 kBytes to download
* x11-libs/xtrans [U 1.2.1 -> 1.2.2]
    Reasons: x11-libs/libICE-1.0.4:0::installed, x11-libs/libSM-1.1.0:0::installed, 2 more
    -debug
    98.69 kBytes to download
* sys-libs/e2fsprogs-libs [U 1.41.1 -> 1.41.2]
    Reasons: *sys-fs/e2fsprogs-1.41.2:0::gentoo, app-crypt/mit-krb5-1.6.3-r4:0::installed
    nls
    478.11 kBytes to download
* sys-fs/e2fsprogs [U 1.41.1 -> 1.41.2]
    Reasons: sys-apps/util-linux-2.14:0::installed, x11-libs/libSM-1.1.0:0::installed
    nls elibc: (-FreeBSD)
    4.16 MBytes to download
* sys-apps/man-pages [U 3.10 -> 3.11]
    Reasons: sys-apps/diffutils-2.8.7-r2:0::installed
    nls linguas: -cs -da -de -es -fr -it -ja -nl -pl -ro -ru -zh_CN
    964.56 kBytes to download
* dev-libs/openssl [U 0.9.8h-r1 -> 0.9.8i]
    Reasons: app-misc/ca-certificates-20080809:0::installed, dev-lang/python-2.5.2-r8:2.5::installed, 3 more
    -bindist -gmp kerberos -sse2 -test zlib
    3.30 MBytes to download
* dev-libs/libxml2 :2 [U 2.7.1 -> 2.7.2]
    Reasons: app-text/poppler-0.10.0:0::gentoo, dev-libs/dbus-glib-0.76:0::installed, 11 more
    -bootstrap -build -debug -doc -examples ipv6 python readline -test
    4.57 MBytes to download
* sys-libs/timezone-data [U 2008f -> 2008g-r1]
    Reasons: sys-libs/glibc-2.8_p20080602:2.2::installed
    nls elibc: (-FreeBSD) (glibc)
    354.31 kBytes to download
* x11-libs/cairo [U 1.6.4-r1 -> 1.8.0]
    Reasons: *x11-libs/pango-1.22.0:0::gentoo, app-text/ghostscript-gpl-8.63:0::installed, 3 more
    X -debug -directfb -doc -glitz opengl svg -xcb
    5.40 MBytes to download
* dev-libs/libdaemon [U 0.12 -> 0.13-r1]
    Reasons: net-dns/avahi-0.6.23:0::installed
    -doc -examples
    359.49 kBytes to download
* sys-apps/dbus [U 1.2.3 -> 1.2.3-r1]
    Reasons: dev-libs/dbus-glib-0.76:0::installed, dev-python/dbus-python-0.83.0:0::installed, 5 more
    X -debug -doc (-selinux)
* x11-libs/pango [U 1.20.5 -> 1.22.0]
    Reasons: dev-python/pygtk-2.12.1-r2:2::installed, gnome-base/libgnomecanvas-2.20.1.1:0::installed, 2 more
    X -debug -doc
    1.39 MBytes to download
* dev-libs/atk [U 1.22.0 -> 1.24.0]
    Reasons: dev-python/pygtk-2.12.1-r2:2::installed, gnome-base/libglade-2.6.3:2.0::installed, 1 more
    -debug -doc
    685.35 kBytes to download
* media-libs/jasper [U 1.900.1-r1 -> 1.900.1-r2]
    Reasons: app-text/ghostscript-gpl-8.63:0::installed, x11-libs/gtk+-2.14.3-r2:2::installed
    jpeg opengl
    6.04 kBytes to download
* sys-auth/pambase [U 20080801 -> 20080801-r1]
    Reasons: sys-libs/pam-1.0.2:0::installed
    -consolekit cracklib -debug -gnome-keyring -mktemp -passwdqc (-selinux) sha512 -ssh
* app-text/poppler-data [N 0.2.1]
    Reasons: *app-text/poppler-0.10.0:0::gentoo
    "Data files for poppler to support uncommon encodings without xpdfrc"
    3.88 MBytes to download
* app-text/poppler [U 0.8.7 -> 0.10.0]
    Reasons: net-print/cups-1.3.9:0::gentoo
    -doc+
    1.45 MBytes to download
* net-print/cups [U 1.3.8-r1 -> 1.3.9]
    Reasons: app-text/ghostscript-gpl-8.63:0::installed, gnome-base/libgnomeprint-2.18.5:2.2::installed, 6 more
    X -acl avahi dbus gnutls java jpeg kerberos -ldap pam perl -php png ppds python samba slp ssl -static tiff xinetd -zeroconf linguas: -de -en -es -et -fr -he -id -it -ja -pl -sv -zh_TW
    3.81 MBytes to download
* sys-apps/pciutils [U 3.0.0 -> 3.0.2]
    Reasons: media-sound/alsa-utils-1.0.17:0.9::installed, sys-apps/hal-0.5.11-r3:0::installed
    -network-cron zlib
    264.13 kBytes to download
* sys-apps/openrc [U 0.2.5 -> 0.3.0-r1]
    Reasons: media-sound/pulseaudio-0.9.13:0::gentoo, sys-apps/baselayout-2.0.0:0::installed
    -debug ncurses pam unicode kernel: (-FreeBSD) (linux)
    142.19 kBytes to download
* sys-fs/udev [U 128 -> 130-r1]
    Reasons: net-wireless/bluez-utils-3.36:0::installed, sys-apps/hal-0.5.11-r3:0::installed, 1 more
    (-selinux)
    432.47 kBytes to download
    * virtual/dev-manager::virtuals [R 130-r1 (for sys-fs/udev:0::gentoo)]
    Reasons: sys-kernel/gentoo-sources-2.6.27:2.6.27::gentoo
* sys-kernel/gentoo-sources :2.6.27 [S 2.6.27]
    Reasons: *virtual/linux-sources-2.6.27::virtuals (virtual for sys-kernel/gentoo-sources-2.6.27:2.6.27::gentoo)
    -build -symlink
    48.06 MBytes to download
* virtual/linux-sources::virtuals :2.6.27 [R 2.6.27 (for sys-kernel/gentoo-sources:2.6.27::gentoo)]
    Reasons: sys-fs/cryptsetup-1.0.6-r2:0::gentoo
* sys-fs/cryptsetup [U 1.0.6-r1 -> 1.0.6-r2]
    Reasons: sys-apps/hal-0.5.11-r3:0::installed
    -build -dynamic nls (-selinux)
* media-sound/pulseaudio [U 0.9.12 -> 0.9.13]
    Reasons: media-libs/libsdl-1.2.13:0::installed
    X alsa -asyncns avahi bluetooth -caps dbus glib gnome hal jack libsamplerate -lirc nls+ -oss (-policykit) tcpd
    1.25 MBytes to download
* gnome-base/gail [N 1000]
    Reasons: *gnome-base/libgnomecanvas-2.20.1.1:0::installed
    "Dummy gail to handle migration to gtk+"
* x11-themes/gnome-icon-theme [U 2.22.0 -> 2.24.0]
    Reasons: gnome-base/libgnomeprintui-2.18.3:2.2::installed
    3.32 MBytes to download
* x11-libs/wxGTK :2.8 [U 2.8.8.1 -> 2.8.9.1]
    Reasons: net-ftp/filezilla-3.1.4:0::gentoo
    X -debug -doc gnome gstreamer -odbc opengl -pch sdl
    26.67 MBytes to download
* net-ftp/filezilla [U 3.1.3 -> 3.1.4] <target>
    2.52 MBytes to download


Just want to make sure this is not overkill.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.


Last edited by audiodef on Wed Oct 15, 2008 6:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43015
Location: 56N 3W

PostPosted: Wed Oct 15, 2008 6:26 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.

Collected with other Paludis theads
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 432

PostPosted: Wed Oct 15, 2008 6:38 pm    Post subject: Reply with quote

Try with --dl-upgrade as-needed , default is always. I keep this in .bashrc (not paludis bashrc) :

export PALUDIS_OPTIONS="--dl-upgrade as-needed --with-unused-dependencies --log-level warning"

so that when I want to install single package I don't have to upgrade all deps... and --with-unused-dependencies is just one of great paludis features :)
If I am to upgrade world or everything then I use --dl-upgrade always. Also check --continue-on-failure, --uninstall-unused and --report ;) If you want to reinstall all packages (set, world...) use --dl-reinstall-targets
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6312
Location: /usr/lib64/lv2

PostPosted: Wed Oct 15, 2008 6:55 pm    Post subject: Reply with quote

Thanks, M, that works!
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum