Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Open Office Dictionaries Don't Work (SOLVED)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
phunster
n00b
n00b


Joined: 26 Nov 2007
Posts: 7

PostPosted: Sat Oct 18, 2008 5:44 pm    Post subject: Open Office Dictionaries Don't Work (SOLVED) Reply with quote

It seems that every time there is a new release (i.e. from 2 to 3) of Open Office I have to figure out the new way to make the dictionary (spellcheck work) what a pain.

I found the solution to getting it to work in OO-3 and here it is:

First go to: http://www.openoffice.org/issues/show_bug.cgi?id=81365 scroll down to "Sample minimalistic extension dictionaries" and download the attachment.

Then go to Tools - Extension Manager and add the file that you just downloaded.

Make sure to exit OO and restart it - when it restarts your dictionaries will be working (If all else is configured properly as documented elseswhere)

For me this was all I had to do.
Back to top
View user's profile Send private message
gtroland
n00b
n00b


Joined: 09 Jul 2002
Posts: 74

PostPosted: Sun Oct 19, 2008 5:30 pm    Post subject: Reply with quote

Thanks phunster, this procedure worked for me as well.
Back to top
View user's profile Send private message
phunster
n00b
n00b


Joined: 26 Nov 2007
Posts: 7

PostPosted: Tue Nov 18, 2008 4:01 am    Post subject: Follow up to my Post regarding Open Office Dictionaries Reply with quote

I'm in the process of doing an emerge -uDN world, one of the packages being re-emerged is Open Office. This time I noticed the message from portage:


Quote:
openoffice-bin does not provide integration with system spell
* dictionaries. Please install them manually through the Extensions
* Manager (Tools > Extensions Manager) or use the source based
* package instead.
*
* Dictionaries for english, french and spanish are provided in
* /usr/lib64/openoffice/share/extension/install
* Other dictionaries can be found at Suns extension site.
*
* Please note that this release of OpenOffice.org uses a
* new user install dir. As a result you will have to redo
* your settings. Alternatively you might copy the old one
* over from ~/.ooo-2.0 to ~/.ooo3, but be warned that this
* might break stuff.


If you have used the solution in my previous post, be sure to disable the other dictionary because if both are enabled at the same time OO will crash as soon as you hit the space bar after the first word that you type.

I left in the part of the message relating to ~/.ooo-2.0 to ~/.ooo3 for completeness, my settings were intact so I didn't play there.

Best to all...
Back to top
View user's profile Send private message
xmaes
n00b
n00b


Joined: 13 Aug 2008
Posts: 69
Location: Madrid

PostPosted: Tue Nov 25, 2008 5:55 pm    Post subject: Reply with quote

Hello,

I did that as well but i couldnt find the spanish from spain (it wasnt in /usr/lib64/openoffice/share/extension/install ).
I decided to re emerge openoffice and i the end i get a message to emerge myspell-(the language that you want) if i wanted the dictionary installed.
It did installed the correct dictionaries without installing the extension.

Xavier
Back to top
View user's profile Send private message
Hell-Razor
Guru
Guru


Joined: 10 Jun 2004
Posts: 456

PostPosted: Tue Nov 25, 2008 7:39 pm    Post subject: Reply with quote

wow that worked for me...thanks!
_________________
Don't ever tell anybody anything. If you do, you start missing everybody.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum