Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
multilib-overlay
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Wed Oct 28, 2009 9:35 am    Post subject: Reply with quote

An addition to my above post:

I don't have any artifacts in the 32bit glxgears, though I do have some in the 64bit one

edit: Ok, I made the following observations, too:
with mesa-7.5.1, I have about 145fps with a 32bit glxgears and about 170 fps with a 64bit glxgears. With mesa 7.6 (and Desktop Effects disabled, for comparison), I get the same rate with 32bit glxgears and a highly variable framerate ranging from 180 to 240 in 64bit glxgears (probably some regression in the git driver). What is this thing that caused the performance boost from 7.5 to 7.6? was it kms? does it maybe have to do with driver modules that need to be available as 32bit?
Back to top
View user's profile Send private message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Sun Nov 01, 2009 8:52 am    Post subject: Reply with quote

could you guys please update the keywords of the qt packages?
Back to top
View user's profile Send private message
Bogo
Tux's lil' helper
Tux's lil' helper


Joined: 04 May 2002
Posts: 98

PostPosted: Tue Nov 03, 2009 1:42 am    Post subject: Reply with quote

Has db been removed from the overlay? Starting last week after a sync I get this:

Code:
lambda bogo # emerge -uaDN world system

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "sys-libs/db[lib32]".
!!! One of the following packages is required to complete your request:
- sys-libs/db-4.7.25_p4 (Missing IUSE: lib32)
- sys-libs/db-4.6.21_p4 (Missing IUSE: lib32)
- sys-libs/db-4.5.20_p2-r1 (Missing IUSE: lib32)
- sys-libs/db-4.5.20_p2 (Missing IUSE: lib32)
- sys-libs/db-4.3.29_p1-r1 (Missing IUSE: lib32)
- sys-libs/db-4.3.29-r2 (Missing IUSE: lib32)
- sys-libs/db-4.2.52_p5-r1 (Missing IUSE: lib32)
- sys-libs/db-4.2.52_p4-r2 (Missing IUSE: lib32)
- sys-libs/db-3.2.9_p2 (Missing IUSE: lib32)
- sys-libs/db-3.2.9-r11 (Missing IUSE: lib32)
- sys-libs/db-1.85-r3 (Missing IUSE: lib32)
(dependency required by "sys-devel/libperl-5.8.8-r2" [installed])
(dependency required by "dev-lang/perl-5.8.8-r5" [installed])
(dependency required by "app-admin/perl-cleaner-1.05" [installed])

lambda bogo #


There is no db in layman/multilib/sys-libs/db, but the package.use file I was using had sys-libs/db lib32 in it. So it was there... but now it's not. If I remove lib32 from those 3 perl packages, then other things start complaining.
_________________
"I know it's only rock and roll but I like it."
Back to top
View user's profile Send private message
Bogo
Tux's lil' helper
Tux's lil' helper


Joined: 04 May 2002
Posts: 98

PostPosted: Tue Nov 17, 2009 5:20 pm    Post subject: Reply with quote

Anyone? This db thing is kind of a big problem for me. I have a long train of package dependencies that start with db having the lib32 flag.

Edit -
Nevermind. Apparently I screwed something up.

This fixed it for me:

git checkout
git reset --hard
_________________
"I know it's only rock and roll but I like it."
Back to top
View user's profile Send private message
arthurus
n00b
n00b


Joined: 21 Nov 2009
Posts: 1

PostPosted: Sat Nov 21, 2009 9:35 pm    Post subject: qt-core Reply with quote

Hi,

I've got a problem with installing qt-core-4.5.3 because someone coded a die() function in the install-routine.
I'd like to ask why this was done? can I just remove it an it will install fine or are there some problems?

Is it better to use the 4.6.0 version of qt-core even if it is masked?

Thanks for your help
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Tue Nov 24, 2009 11:08 pm    Post subject: Reply with quote

I've installed the overlay multilib.
I've done
Code:
emerge -uDN world

and everythings went ok!

I'm using the profile no-multilib
Code:
cat .config | grep IA32
CONFIG_IA32_EMULATION=y
CONFIG_IA32_AOUT=y


but i'd like to install skype (that is 32bit). So, i did
Code:
autounmask net-im/skype-2.1.0.47


and then i've installed skype and upgraded all the necessary libraries.
Code:
skype
/usr/bin/skype: line 10: /opt/skype/skype: No such file or directory
/usr/bin/skype: line 10: /opt/skype/skype: Success

Code:
ldd /opt/skype/skype
        not a dynamic executable


What did i forget? :roll:
_________________
Darkman
Back to top
View user's profile Send private message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Fri Nov 27, 2009 12:15 am    Post subject: Reply with quote

what happens if you ldd any of the 32bit compiled libraries?
Back to top
View user's profile Send private message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Wed Dec 02, 2009 6:15 pm    Post subject: Reply with quote

Is there any way to solve the performance problem of 32bit 3D apps using mesa? I also have this problem with the latest stable mesa. I don't even know if mesa is causing the problem.
I only need 32bit libs for wine and I only use wine for games and most of these games are old but still use 3D and are unplayable with libs from the multilib-overlay - This whole thing makes the multilib-overlay kind of useless to me. I'd appreciate any hints.
Back to top
View user's profile Send private message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Tue Dec 15, 2009 9:08 am    Post subject: Reply with quote

It's finally working, using mesa-7.7_rc2.
Back to top
View user's profile Send private message
Carnildo
Guru
Guru


Joined: 17 Jun 2004
Posts: 593

PostPosted: Mon Dec 28, 2009 9:19 pm    Post subject: Reply with quote

Trying to build dev-libs/libffi-3.0.8 gives the following error:

Code:
 * ERROR: dev-libs/libffi-3.0.8 failed.
 * Call stack:
 *                ebuild.sh, line   49:  Called pkg_setup
 *                ebuild.sh, line 1273:  Called multilib-native_pkg_setup
 *   multilib-native.eclass, line   86:  Called multilib-native_src_generic 'pkg_setup'
 *   multilib-native.eclass, line  172:  Called multilib-native_src_generic 'pkg_setup'
 *   multilib-native.eclass, line  208:  Called multilib-native_src_generic_sub 'pkg_setup'
 *   multilib-native.eclass, line  244:  Called multilib-native_setup_abi_env 'x86'
 *   multilib-native.eclass, line  388:  Called die
 * The specific snippet of code:
 *              [ "$(readlink /usr/bin/perl)" == "/usr/bin/abi-wrapper" ] || die multilib-native.eclass: please rebuild dev-lang/perl to avoid problems
 *  The die message:
 *   multilib-native.eclass: please rebuild dev-lang/perl to avoid problems


Trying to follow the directions and rebuild dev-lang/perl gives the following:
Code:
 * ERROR: dev-lang/perl-5.8.8-r8 failed.
 * Call stack:
 *                ebuild.sh, line   49:  Called pkg_setup
 *                ebuild.sh, line 1273:  Called multilib-native_pkg_setup
 *   multilib-native.eclass, line   86:  Called multilib-native_src_generic 'pkg_setup'
 *   multilib-native.eclass, line  172:  Called multilib-native_src_generic 'pkg_setup'
 *   multilib-native.eclass, line  208:  Called multilib-native_src_generic_sub 'pkg_setup'
 *   multilib-native.eclass, line  244:  Called multilib-native_setup_abi_env 'x86'
 *   multilib-native.eclass, line  388:  Called die
 * The specific snippet of code:
 *              [ "$(readlink /usr/bin/perl)" == "/usr/bin/abi-wrapper" ] || die multilib-native.eclass: please rebuild dev-lang/perl to avoid problems
 *  The die message:
 *   multilib-native.eclass: please rebuild dev-lang/perl to avoid problems


Any suggestions?
Back to top
View user's profile Send private message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Wed Dec 30, 2009 4:37 pm    Post subject: Reply with quote

I have no Idea what the cause of your problem could be, but you could try to either rebuild perl with USE=-lib32 and then try to rebuild with USE=lib32 and if that does not work, you could try to build a vanilla perl (i.e. by commenting out "source /etc/local/portage/layman/make.conf" in your /etc/make.conf) and then rebuild a multilib perl.
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Wed Dec 30, 2009 6:04 pm    Post subject: Reply with quote

I had the same error, tried to follow your advise, but i got this error when tried to build perl with lib32 already:
* ERROR: dev-lang/perl-5.8.8-r8 failed:
* dev-lang/perl-5.8.8-r8 does not actually support the lib32 USE flag!
...
* multilib-native.eclass, line 244: Called multilib-native_setup_abi_env 'x86'
* multilib-native.eclass, line 388: Called built_with_use 'dev-lang/perl' 'lib32'
* eutils.eclass, line 1826: Called die
* The specific snippet of code:
* die) die "$PKG does not actually support the $1 USE flag!";;
*
Back to top
View user's profile Send private message
Beholders_Eye
Tux's lil' helper
Tux's lil' helper


Joined: 17 Nov 2003
Posts: 116
Location: Brazil

PostPosted: Mon Jan 18, 2010 1:20 pm    Post subject: readline Reply with quote

I'm using this overlay to, and stuck with this same problem. But with version 6.0_p3.

Any ideas??

drescherjm wrote:
I am having trouble with sys-libs/readline

Code:
configure: creating ./config.status
config.status: creating Makefile
config.status: creating config.h
make -j9
x86_64-pc-linux-gnu-gcc -c -I. -I. -D_GNU_SOURCE    -march=core2 -O2 -pipe -m32 rlfe.c
x86_64-pc-linux-gnu-gcc -c -I. -I. -D_GNU_SOURCE    -march=core2 -O2 -pipe -m32 pty.c
rlfe.c: In function 'get_slave_pty':
rlfe.c:210: warning: ignoring return value of 'chown', declared with attribute warn_unused_result
rlfe.c: In function 'maybe_emphasize_input':
rlfe.c:270: warning: format not a string literal and no format arguments
rlfe.c: In function 'line_handler':
rlfe.c:302: warning: ignoring return value of 'write', declared with attribute warn_unused_result
rlfe.c:339: warning: ignoring return value of 'write', declared with attribute warn_unused_result
rlfe.c:342: warning: ignoring return value of 'write', declared with attribute warn_unused_result
rlfe.c:353: warning: ignoring return value of 'write', declared with attribute warn_unused_result
rlfe.c: In function 'main':
rlfe.c:642: warning: ignoring return value of 'write', declared with attribute warn_unused_result
rlfe.c:680: warning: ignoring return value of 'write', declared with attribute warn_unused_result
rlfe.c:724: warning: ignoring return value of 'write', declared with attribute warn_unused_result
x86_64-pc-linux-gnu-gcc -Wl,-O1 -L/lib32 -L/usr/lib32 -m32 -Lreadline -o rlfe rlfe.o pty.o -lreadline -lhistory -lcurses
rlfe.o: In function `main':
rlfe.c:(.text+0xafe): undefined reference to `_rl_echoing_p'
collect2: ld returned 1 exit status
make: *** [rlfe] Error 1
 *
 * ERROR: sys-libs/readline-6.0_p4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3681:  Called multilib-native_src_compile
 *             environment, line 3132:  Called multilib-native_src_generic 'src_compile'
 *             environment, line 3171:  Called multilib-native_src_generic 'src_compile'
 *             environment, line 3191:  Called multilib-native_src_generic_sub 'src_compile'
 *             environment, line 3237:  Called multilib-native_src_compile_internal
 *             environment, line 3143:  Called die
 * The specific snippet of code:
 *           emake || die "make rlfe failed";
 *  The die message:
 *   make rlfe failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/auto/temp_data/var_tmp/portage/sys-libs/readline-6.0_p4/temp/build.log'.
 * The ebuild environment file is located at '/auto/temp_data/var_tmp/portage/sys-libs/readline-6.0_p4/temp/environment'.
 * This ebuild used the following eclasses from overlays:
 *   /auto/portage/local/layman/jmd-multilib/eclass/multilib-native.eclass
 * This ebuild is from a repository named 'multilib'
 *


The 5.2_p13 version installs however

Code:
jmd0 package.keywords # eix sys-libs/readline
[I] sys-libs/readline
     Available versions: 
   (4)   4.3_p5
   (0)   5.0-r2 5.1_p4 5.2_p13 ~6.0 ~6.0_p3
     Installed versions:  5.2_p13[multilib](09:19:09 09/30/09)(lib32)
     Homepage:            http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
     Description:         Another cute console display library
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Mon Jan 18, 2010 2:54 pm    Post subject: Reply with quote

I am sorry. I do not recall what I did to fix that. It is fixed now and I do remember it took manual work but not sure what.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
vlooe
n00b
n00b


Joined: 04 Jun 2005
Posts: 35
Location: Germany

PostPosted: Mon Jan 18, 2010 3:48 pm    Post subject: Reply with quote

the problem is that the -L/lib32 -L/usr/lib32 is before the -Lreadline
because that it uses the old libs of the system instead of the new one in the direcory readline.

i think it sould be solved by emergeing it first without lib32 useflag and then again with the activated useflag
Back to top
View user's profile Send private message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Wed Feb 24, 2010 9:47 pm    Post subject: Reply with quote

update the keywords of media-libs/jpeg-8 please :)
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Tue Mar 09, 2010 3:26 am    Post subject: Reply with quote

I am having lots of problems with ffmpeg:

Code:
>>> Emerging (1 of 1) media-video/ffmpeg-0.5-r1 from multilib
>>> Failed to emerge media-video/ffmpeg-0.5-r1, Log file:   
>>>  '/auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/temp/build.log'
>>> Jobs: 0 of 1 complete, 1 failed                 Load avg: 0.81, 0.54, 0.48
 * CPV:  media-video/ffmpeg-0.5-r1                                             
 * REPO: multilib                                                             
 * USE:  3dnow 3dnowext X alsa amd64 custom-cflags elibc_glibc encode hardcoded-tables ieee1394 kernel_linux lib32 mmx mmxext mp3 multilib oss sdl ssse3 threads userland_GNU v4l v4l2 vdpau video_cards_nvidia vorbis x264 xvid zlib
 * pkg_setup multilib ffmpeg for ABIs: x86 amd64
 * Using return for ABI x86 ...
 * Using return for ABI amd64 ...
>>> Unpacking source...
 * unpack multilib ffmpeg for ABIs: x86 amd64
 * Using base_src_unpack for ABI x86 ...
>>> Unpacking ffmpeg-0.5.tar.bz2 to /auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work
 * Moving source tree from /auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work/ffmpeg-0.5 to /auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work/ffmpeg_build_x86
 * Using base_src_unpack for ABI amd64 ...
>>> Unpacking ffmpeg-0.5.tar.bz2 to /auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work
 * Moving source tree from /auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work/ffmpeg-0.5 to /auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work/ffmpeg_build_amd64
>>> Source unpacked in /auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work
>>> Preparing source in /auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work/ffmpeg_build_amd64 ...
 * prepare multilib ffmpeg for ABIs: x86 amd64
 * Working in /auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work/ffmpeg_build_x86
 * Using base_src_prepare for ABI x86 ...
 * Working in /auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work/ffmpeg_build_amd64
 * Using base_src_prepare for ABI amd64 ...
>>> Source prepared.
>>> Configuring source in /auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work/ffmpeg_build_amd64 ...
 * configure multilib ffmpeg for ABIs: x86 amd64
true
ERROR: libx264 not found
If you think configure made a mistake, make sure you are using the latest
version from SVN.  If the latest version fails, report the problem to the
ffmpeg-user@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.err" produced by configure as this will help
solving the problem.
 * ERROR: media-video/ffmpeg-0.5-r1 failed:
 *   configure failed
 *
 * Call stack:
 *     ebuild.sh, line   48:  Called src_configure
 *   environment, line 3348:  Called multilib-native_src_configure
 *   environment, line 2710:  Called multilib-native_src_generic 'src_configure'
 *   environment, line 2813:  Called multilib-native_src_generic 'src_configure'
 *   environment, line 2833:  Called multilib-native_src_generic_sub 'src_configure'
 *   environment, line 2884:  Called multilib-native_src_configure_internal
 *   environment, line 2794:  Called die
 * The specific snippet of code:
 *       ./configure --prefix=/usr --libdir=/usr/$(get_libdir) --shlibdir=/usr/$(get_libdir) --mandir=/usr/share/man --enable-static --enable-shared --cc="$(tc-getCC)" ${myconf} || die "configure failed"
 *
 * If you need support, post the output of 'emerge --info =media-video/ffmpeg-0.5-r1',
 * the complete build log and the output of 'emerge -pqv =media-video/ffmpeg-0.5-r1'.
 * This ebuild used the following eclasses from overlays:
 *   /auto/portage/local/layman/jmd-multilib/eclass/multilib-native.eclass
 * This ebuild is from a repository named 'multilib'
 * The complete build log is located at '/auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/temp/environment'.
 * S: '/auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/work/ffmpeg_build_x86'
 *
 * The following package has failed to build or install:
 *
 *  ('ebuild', '/', 'media-video/ffmpeg-0.5-r1', 'merge'), Log file:
 *   '/auto/temp_data/var_tmp/portage/media-video/ffmpeg-0.5-r1/temp/build.log'
 *


The issue is that libx264 does exist for both x86 and amd64. I am not sure why it can not find it. I tried newer versions of ffmpeg but then I am getting stuck at vdpau which I need. I guess I could disable the flag for ffmpeg and try again.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Tue Mar 09, 2010 3:39 am    Post subject: Reply with quote

Never mind media-video/ffmpeg-0.5_p20601-r1 worked after disabling the vdpau use flag. That is another issue as I would like that enabled for 64 bit. But it is not essential at the moment.

[ebuild U ] media-video/ffmpeg-0.5_p20601-r1 [0.5-r1] USE="3dnow 3dnowext X alsa cpudetection%* custom-cflags encode hardcoded-tables ieee1394 lib32 mmx mmxext mp3 oss* sdl ssse3 threads v4l v4l2 vorbis x264 xvid zlib (-altivec) -bindist -debug -dirac -doc -faac -faad -gsm -ipv6 -jack% -jpeg2k -network -opencore-amr% -pic% -schroedinger -speex -test -theora -vdpau* (-amr%) (-vhook%)" VIDEO_CARDS="nvidia" 3,031 kB [1]

Total: 1 package (1 upgrade), Size of downloads: 3,031 kB
Portage tree and overlays:
[0] /auto/portage
[1] /auto/portage/local/layman/jmd-multilib

Would you like to merge these packages? [Yes/No] y
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) media-video/ffmpeg-0.5_p20601-r1 from multilib
>>> Installing (1 of 1) media-video/ffmpeg-0.5_p20601-r1
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Sun Mar 21, 2010 11:33 pm    Post subject: Reply with quote

sys-apps/util-linux-2.17.1 will not build for me.

Code:
make[2]: Entering directory `/auto/temp_data/var_tmp/portage/sys-apps/util-linux-2.17.1/work/util-linux_build_x86/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/auto/temp_data/var_tmp/portage/sys-apps/util-linux-2.17.1/work/util-linux_build_x86/po'
Making all in schedutils
make[2]: Entering directory `/auto/temp_data/var_tmp/portage/sys-apps/util-linux-2.17.1/work/util-linux_build_x86/schedutils'
  CC     chrt.o
  CC     taskset.o
  CC     ionice.o
  CCLD   chrt
  CCLD   taskset
  CCLD   ionice
make[2]: Leaving directory `/auto/temp_data/var_tmp/portage/sys-apps/util-linux-2.17.1/work/util-linux_build_x86/schedutils'
Making all in sys-utils
make[2]: Entering directory `/auto/temp_data/var_tmp/portage/sys-apps/util-linux-2.17.1/work/util-linux_build_x86/sys-utils'
  CC     pivot_root.o
  CC     switch_root.o
  CC     dmesg.o
  CC     ctrlaltdel.o
  CC     flock.o
  CC     ipcs.o
  CC     ipcrm.o
  CC     ipcmk.o
  CC     setsid.o
  CC     renice.o
  CC     setarch.o
  CC     cytune.o
  CC     lscpu.o
  CC     fallocate.o
  CC     unshare.o
  CC     readprofile.o
  CC     ldattach.o
  CC     tunelp.o
  CC     rtcwake.o
  CC     rdev.o
echo ".so man8/rdev.8" > ramsize.8
echo ".so man8/rdev.8" > vidmode.8
echo ".so man8/rdev.8" > rootflags.8
echo ".so man8/setarch.8" > linux32.8
echo ".so man8/setarch.8" > linux64.8
echo ".so man8/setarch.8" > i386.8
  CCLD   dmesg
  CCLD   ctrlaltdel
  CCLD   pivot_root
  CCLD   switch_root
  CCLD   ipcrm
  CCLD   flock
  CCLD   ipcs
  CCLD   ipcmk
  CCLD   renice
  CCLD   setsid
  CCLD   cytune
  CCLD   setarch
  CCLD   lscpu
  CCLD   fallocate
  CCLD   unshare
  CCLD   readprofile
  CCLD   ldattach
  CCLD   tunelp
  CCLD   rtcwake
  CCLD   rdev
fallocate.o: In function `main':
fallocate.c:(.text+0x3ad): undefined reference to `fallocate64'
collect2: ld returned 1 exit status
make[2]: *** [fallocate] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/auto/temp_data/var_tmp/portage/sys-apps/util-linux-2.17.1/work/util-linux_build_x86/sys-utils'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/auto/temp_data/var_tmp/portage/sys-apps/util-linux-2.17.1/work/util-linux_build_x86'
make: *** [all] Error 2
 * ERROR: sys-apps/util-linux-2.17.1 failed:
 *   died running emake, base_src_make:make
 *
 * Call stack:
 *     ebuild.sh, line   48:  Called src_compile
 *   environment, line 3282:  Called multilib-native_src_compile
 *   environment, line 2796:  Called multilib-native_src_generic 'src_compile'
 *   environment, line 2827:  Called multilib-native_src_generic 'src_compile'
 *   environment, line 2847:  Called multilib-native_src_generic_sub 'src_compile'
 *   environment, line 2898:  Called multilib-native_src_compile_internal
 *   environment, line 2800:  Called multilib-native_check_inherited_funcs 'src_compile'
 *   environment, line 2671:  Called base_src_compile
 *   environment, line  422:  Called base_src_make
 *   environment, line  460:  Called die
 * The specific snippet of code:
 *           emake $@ || die "died running emake, $FUNCNAME:make";
 *
 * If you need support, post the output of 'emerge --info =sys-apps/util-linux-2.17.1',
 * the complete build log and the output of 'emerge -pqv =sys-apps/util-linux-2.17.1'.
 * This ebuild used the following eclasses from overlays:
 *   /auto/portage/local/layman/jmd-multilib/eclass/multilib-native.eclass
 * This ebuild is from a repository named 'multilib'
 * The complete build log is located at '/auto/temp_data/var_tmp/portage/sys-apps/util-linux-2.17.1/temp/build.log'.
 * The ebuild environment file is located at '/auto/temp_data/var_tmp/portage/sys-apps/util-linux-2.17.1/temp/environment'.
 * S: '/auto/temp_data/var_tmp/portage/sys-apps/util-linux-2.17.1/work/util-linux_build_x86'
 *
 * The following package has failed to build or install:
 *
 *  ('ebuild', '/', 'sys-apps/util-linux-2.17.1', 'merge'), Log file:
 *   '/auto/temp_data/var_tmp/portage/sys-apps/util-linux-2.17.1/temp/build.log'
 *
jmd0 ~ #


[EDIT]

I believe the solution to my problem is here:

https://forums.gentoo.org/viewtopic-t-816003-start-0.html

[/EDIT]
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Tue Mar 23, 2010 4:55 am    Post subject: Reply with quote

The fix from here: https://forums.gentoo.org/viewtopic-t-816003-start-0.html
worked

Code:
jmd0 ~ # ac_cv_func_fallocate=no emerge util-linux
Calculating dependencies... done!
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) sys-apps/util-linux-2.17.1 from multilib
>>> Installing (1 of 1) sys-apps/util-linux-2.17.1
>>> Jobs: 1 of 1 complete                           Load avg: 2.83, 1.14, 0.59
>>> Auto-cleaning packages...

_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Tue Aug 24, 2010 3:16 am    Post subject: Reply with quote

i have problem with some packages, for example media-libs/libcaca, trying to install by both portage and paludis, same failure:

Code:

libtool: link: x86_64-pc-linux-gnu-gcc -march=core2 -mcx16 -msahf -O2 -pipe --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=4096 -fomit-frame-pointer -m32 -I/usr/lib/icedtea6/include -I/usr/lib/icedtea6/include/linux -Wall -Wpointer-arith -Wcast-align -Wcast-qual -Wstrict-prototypes -Wshadow -Waggregate-return -Wmissing-prototypes -Wnested-externs -Wsign-compare -Wl,-O1 -Wl,--sort-common -Wl,--relax -Wl,--enable-new-dtags -Wl,--hash-style=gnu -o .libs/cacaview cacaview-cacaview.o cacaview-common-image.o  -L//usr/lib64 /usr/lib64/libImlib2.so -L/lib64 -L/usr/lib64 -L/usr/X11R6/lib /usr/lib64/libfreetype.so /usr/lib64/libXext.so /usr/lib64/libX11.so /usr/lib64/libxcb.so /usr/lib64/libXau.so /usr/lib64/libXdmcp.so -Wl,--as-needed -L/lib32 -L/usr/lib32 ../caca/.libs/libcaca.so -lslang -lncursesw /usr/lib32/libglut.so -lm -lGL /usr/lib32/libXxf86vm.so /usr/lib32/libXi.so /usr/lib32/libXext.so /usr/lib32/libX11.so /usr/lib32/libxcb.so /usr/lib32/libXau.so /usr/lib32/libXdmcp.so -ldl /usr/lib32/libftgl.so /usr/lib32/libfreetype.so -lGLU -lz
x86_64-pc-linux-gnu-gcc: /usr/lib64/libImlib2.so: No such file or directory
x86_64-pc-linux-gnu-gcc: /usr/lib64/libImlib2.so: No such file or directory
make[2]: *** [img2txt] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: *** [cacaview] Error 1
make[2]: Leaving directory `/var/tmp/paludis/media-libs-libcaca-0.99_beta17/work/libcaca_build_x86/src'
make[1]: Leaving directory `/var/tmp/paludis/media-libs-libcaca-0.99_beta17/work/libcaca_build_x86'
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2


and i have 32bit version of libImlib2.so

Code:
ls /usr/lib32/ |grep libImlib2.so
libImlib2.so
libImlib2.so.1
libImlib2.so.1.4.4


and few more packages with same problem ..., but it blocks pulseaudio or ffmpeg builds for example, this is crytical ).
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Tue Aug 24, 2010 10:13 am    Post subject: Reply with quote

That one looks pretty bad with the mixing of 64 and 32 bit libs.

Are you just starting to use the overlay?

If so you need to rebuild the dependencies.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Tue Aug 24, 2010 3:32 pm    Post subject: Reply with quote

yes, just started, and i tried to rebuild entire system set with "paludis -i system --dl-reinstall always", maybe some other recomendations ?, i am not so good in portage usage because switched to paludis on early stage of using gentoo..., sorry for stupid questions
Back to top
View user's profile Send private message
vlooe
n00b
n00b


Joined: 04 Jun 2005
Posts: 35
Location: Germany

PostPosted: Tue Aug 24, 2010 4:44 pm    Post subject: Reply with quote

I do not use paludis and do not know much about it.
But the overlay should work with it.

Please pastebin the complete output of
Code:

emerge -vt libcaca
emerge --info media-libs/libcaca
emerge --info media-libs/imlib2
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Tue Aug 24, 2010 8:07 pm    Post subject: Reply with quote

http://pastebin.com/EQLQLNbY

i removed 64bit version of library for check if it solve compilation problem, but it don't
_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 5 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum