Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
multilib-overlay
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Tue Aug 24, 2010 8:32 pm    Post subject: Reply with quote

The problem is all of those /usr/lib64 libraries in the 32 bit link.

Code:
libtool: link: x86_64-pc-linux-gnu-gcc -march=core2 -mcx16 -msahf -O2 -pipe --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=4096 -fomit-frame-pointer -m32 -I/usr/lib/icedtea6/include -I/usr/lib/icedtea6/include/linux -Wall -Wpointer-arith -Wcast-align -Wcast-qual -Wstrict-prototypes -Wshadow -Waggregate-return -Wmissing-prototypes -Wnested-externs -Wsign-compare -Wl,-O1 -Wl,--sort-common -Wl,--relax -Wl,--enable-new-dtags -Wl,--hash-style=gnu -o .libs/img2txt img2txt-img2txt.o img2txt-common-image.o  -L//usr/lib64 /usr/lib64/libImlib2.so -L/lib64 -L/usr/lib64 -L/usr/X11R6/lib /usr/lib64/libfreetype.so /usr/lib64/libXext.so /usr/lib64/libX11.so /usr/lib64/libxcb.so /usr/lib64/libXau.so /usr/lib64/libXdmcp.so -Wl,--as-needed -L/lib32 -L/usr/lib32 ../caca/.libs/libcaca.so -lslang -lncursesw /usr/lib32/libglut.so -lm -lGL /usr/lib32/libXxf86vm.so /usr/lib32/libXi.so /usr/lib32/libXext.so /usr/lib32/libX11.so /usr/lib32/libxcb.so /usr/lib32/libXau.so /usr/lib32/libXdmcp.so -ldl /usr/lib32/libftgl.so /usr/lib32/libfreetype.so -lGLU -lz

_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Tue Aug 24, 2010 9:21 pm    Post subject: Reply with quote

how i can fix this ?
_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Tue Aug 24, 2010 9:26 pm    Post subject: Reply with quote

You need to rebuild the system to ensure the dependencies all have 32 bit libs.

The problem you are having is that some of your dependencies only have 64 bit libs and the system will finds the 64 bit library in your library paths but that will not work for a 32 bit build.

For this specific instance you could track down each library that is 64 bit like

/usr/lib64/libImlib2.so

then do an equery belongs /usr/lib64/libImlib2.so

to find the package then rebuild that but this will be a lot of work.

Its far simpler to rebuild the system first. I still caution this will not be easy because of dependencies like this and blockers. Look at the multilib wiki for some advice.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Tue Aug 24, 2010 9:36 pm    Post subject: Reply with quote

thx for info, but first what i tried to do, is rebuild entire system set, which have ~15-20 failed builds (from ~500)
_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Tue Aug 24, 2010 9:44 pm    Post subject: Reply with quote

If you figure out what failed you can try picking off the dependencies for these. Using the equery method I described in the previous post.

The problem will be the same in most cases. You may also have conflicts in the install phase.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
vlooe
n00b
n00b


Joined: 04 Jun 2005
Posts: 35
Location: Germany

PostPosted: Tue Aug 24, 2010 9:52 pm    Post subject: Reply with quote

rebuild the following packages with lib32 activated

media-libs/imlib2
media-libs/freetype
x11-libs/libXext
x11-libs/libX11
x11-libs/libxcb
x11-libs/libXau
x11-libs/libXdmcp

then try to rebuild libcaca

if you still get errors paste the build.log again
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Tue Aug 24, 2010 10:16 pm    Post subject: Reply with quote

please wait some time, i will do.
_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Tue Aug 24, 2010 10:39 pm    Post subject: Reply with quote

http://pastebin.com/eG6fZ10z - after rebuild of packages and trying to build libcaca, i think this problem related to libtool somehow...
_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Tue Aug 24, 2010 10:41 pm    Post subject: Reply with quote

It seems to still want to use /usr/lib64/libImlib2.so

which is part of the

media-libs/imlib2

package.


Edit: Wait a minute it appears not to have changed.

Can you post the output of

Code:
equery files media-libs/imlib2

_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Tue Aug 24, 2010 10:55 pm    Post subject: Reply with quote

Code:
equery files media-libs/imlib2
 * Searching for imlib2 in media-libs ...
!!! Invalid db entry: //var/db/pkg/sys-apps/paludis-scm
 * Contents of media-libs/imlib2-1.4.4:
/usr
/usr/bin
/usr/bin/imlib2-config -> /usr/bin/abi-wrapper
/usr/bin/imlib2-config-amd64
/usr/bin/imlib2-config-x86
/usr/bin/imlib2_bumpmap
/usr/bin/imlib2_colorspace
/usr/bin/imlib2_conv
/usr/bin/imlib2_grab
/usr/bin/imlib2_poly
/usr/bin/imlib2_show
/usr/bin/imlib2_test
/usr/bin/imlib2_view
/usr/include
/usr/include/Imlib2.h
/usr/lib32
/usr/lib32/imlib2
/usr/lib32/imlib2/filters
/usr/lib32/imlib2/filters/bumpmap.la
/usr/lib32/imlib2/filters/bumpmap.so
/usr/lib32/imlib2/filters/colormod.la
/usr/lib32/imlib2/filters/colormod.so
/usr/lib32/imlib2/filters/testfilter.la
/usr/lib32/imlib2/filters/testfilter.so
/usr/lib32/imlib2/loaders
/usr/lib32/imlib2/loaders/argb.la
/usr/lib32/imlib2/loaders/argb.so
/usr/lib32/imlib2/loaders/bmp.la
/usr/lib32/imlib2/loaders/bmp.so
/usr/lib32/imlib2/loaders/bz2.la
/usr/lib32/imlib2/loaders/bz2.so
/usr/lib32/imlib2/loaders/gif.la
/usr/lib32/imlib2/loaders/gif.so
/usr/lib32/imlib2/loaders/id3.la
/usr/lib32/imlib2/loaders/id3.so
/usr/lib32/imlib2/loaders/jpeg.la
/usr/lib32/imlib2/loaders/jpeg.so
/usr/lib32/imlib2/loaders/lbm.la
/usr/lib32/imlib2/loaders/lbm.so
/usr/lib32/imlib2/loaders/png.la
/usr/lib32/imlib2/loaders/png.so
/usr/lib32/imlib2/loaders/pnm.la
/usr/lib32/imlib2/loaders/pnm.so
/usr/lib32/imlib2/loaders/tga.la
/usr/lib32/imlib2/loaders/tga.so
/usr/lib32/imlib2/loaders/tiff.la
/usr/lib32/imlib2/loaders/tiff.so
/usr/lib32/imlib2/loaders/xpm.la
/usr/lib32/imlib2/loaders/xpm.so
/usr/lib32/imlib2/loaders/zlib.la
/usr/lib32/imlib2/loaders/zlib.so
/usr/lib32/libImlib2.a
/usr/lib32/libImlib2.la
/usr/lib32/libImlib2.so -> libImlib2.so.1.4.4
/usr/lib32/libImlib2.so.1 -> libImlib2.so.1.4.4
/usr/lib32/libImlib2.so.1.4.4
/usr/lib32/pkgconfig
/usr/lib32/pkgconfig/imlib2.pc
/usr/lib64
/usr/lib64/imlib2
/usr/lib64/imlib2/filters
/usr/lib64/imlib2/filters/bumpmap.la
/usr/lib64/imlib2/filters/bumpmap.so
/usr/lib64/imlib2/filters/colormod.la
/usr/lib64/imlib2/filters/colormod.so
/usr/lib64/imlib2/filters/testfilter.la
/usr/lib64/imlib2/filters/testfilter.so
/usr/lib64/imlib2/loaders
/usr/lib64/imlib2/loaders/argb.la
/usr/lib64/imlib2/loaders/argb.so
/usr/lib64/imlib2/loaders/bmp.la
/usr/lib64/imlib2/loaders/bmp.so
/usr/lib64/imlib2/loaders/bz2.la
/usr/lib64/imlib2/loaders/bz2.so
/usr/lib64/imlib2/loaders/gif.la
/usr/lib64/imlib2/loaders/gif.so
/usr/lib64/imlib2/loaders/id3.la
/usr/lib64/imlib2/loaders/id3.so
/usr/lib64/imlib2/loaders/jpeg.la
/usr/lib64/imlib2/loaders/jpeg.so
/usr/lib64/imlib2/loaders/lbm.la
/usr/lib64/imlib2/loaders/lbm.so
/usr/lib64/imlib2/loaders/png.la
/usr/lib64/imlib2/loaders/png.so
/usr/lib64/imlib2/loaders/pnm.la
/usr/lib64/imlib2/loaders/pnm.so
/usr/lib64/imlib2/loaders/tga.la
/usr/lib64/imlib2/loaders/tga.so
/usr/lib64/imlib2/loaders/tiff.la
/usr/lib64/imlib2/loaders/tiff.so
/usr/lib64/imlib2/loaders/xpm.la
/usr/lib64/imlib2/loaders/xpm.so
/usr/lib64/imlib2/loaders/zlib.la
/usr/lib64/imlib2/loaders/zlib.so
/usr/lib64/libImlib2.a
/usr/lib64/libImlib2.la
/usr/lib64/libImlib2.so -> libImlib2.so.1.4.4
/usr/lib64/libImlib2.so.1 -> libImlib2.so.1.4.4
/usr/lib64/libImlib2.so.1.4.4
/usr/lib64/pkgconfig
/usr/lib64/pkgconfig/imlib2.pc
/usr/share
/usr/share/doc
/usr/share/doc/imlib2-1.4.4
/usr/share/doc/imlib2-1.4.4/AUTHORS
/usr/share/doc/imlib2-1.4.4/ChangeLog
/usr/share/doc/imlib2-1.4.4/README
/usr/share/doc/imlib2-1.4.4/TODO
/usr/share/imlib2
/usr/share/imlib2/data
/usr/share/imlib2/data/fonts
/usr/share/imlib2/data/fonts/cinema.ttf
/usr/share/imlib2/data/fonts/grunge.ttf
/usr/share/imlib2/data/fonts/morpheus.ttf
/usr/share/imlib2/data/fonts/notepad.ttf
/usr/share/imlib2/data/images
/usr/share/imlib2/data/images/audio.png
/usr/share/imlib2/data/images/bg.png
/usr/share/imlib2/data/images/bulb.png
/usr/share/imlib2/data/images/cal.png
/usr/share/imlib2/data/images/calc.png
/usr/share/imlib2/data/images/folder.png
/usr/share/imlib2/data/images/globe.png
/usr/share/imlib2/data/images/imlib2.png
/usr/share/imlib2/data/images/lock.png
/usr/share/imlib2/data/images/mail.png
/usr/share/imlib2/data/images/menu.png
/usr/share/imlib2/data/images/mush.png
/usr/share/imlib2/data/images/paper.png
/usr/share/imlib2/data/images/sh1.png
/usr/share/imlib2/data/images/sh2.png
/usr/share/imlib2/data/images/sh3.png
/usr/share/imlib2/data/images/stop.png
/usr/share/imlib2/data/images/tnt.png

_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Wed Aug 25, 2010 10:14 am    Post subject: Reply with quote

any ideas ?
_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Wed Aug 25, 2010 1:32 pm    Post subject: Reply with quote

Try uninstalling/reinstalling media-libs/imlib2 using these steps.

quickpkg media-libs/imlib2

emerge -C media-libs/imlib2

emerge media-libs/imlib2

The build will still fail but I am curious if that fixes the one dependency.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Wed Aug 25, 2010 6:05 pm    Post subject: Reply with quote

nothing changes, problem still here...
_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
vlooe
n00b
n00b


Joined: 04 Jun 2005
Posts: 35
Location: Germany

PostPosted: Thu Aug 26, 2010 12:02 pm    Post subject: Reply with quote

does /usr/lib32/libImlib2.la contain anything about lib64 in it?

If yes then there is a problem with imlib2.
If not then there is a problem with libcaca.

I hope i have some time this eventing to try to reproduce your problem
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Thu Aug 26, 2010 12:33 pm    Post subject: Reply with quote

how can i check it ?
_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Thu Aug 26, 2010 12:48 pm    Post subject: Reply with quote

Code:
cat  /usr/lib32/libImlib2.la
# libImlib2.la - a libtool library file
# Generated by ltmain.sh (GNU libtool) 2.2.6b
#
# Please DO NOT delete this file!
# It is necessary for linking the library.

# The name that we can dlopen(3).
dlname='libImlib2.so.1'

# Names of this library.
library_names='libImlib2.so.1.4.4 libImlib2.so.1 libImlib2.so'

# The name of the static archive.
old_library='libImlib2.a'

# Linker flags that can not go in dependency_libs.
inherited_linker_flags=''

# Libraries that this one depends upon.
dependency_libs=' -L/lib32 -L/usr/lib32 /usr/lib32/libfreetype.la -lz -L/usr/X11R6/lib -L//usr/lib64 /usr/lib32/libXext.la /usr/lib32/libX11.la /usr/lib32/libxcb.la /usr/lib32/libXau.la /usr/lib32/libXdmcp.la -ldl -lm'

# Names of additional weak libraries provided by this library
weak_library_names=''

# Version information for libImlib2.
current=5
age=4
revision=4

# Is this an already installed library?
installed=yes

# Should we warn about portability when linking against -modules?
shouldnotlink=no

# Files to dlopen/dlpreopen
dlopen=''
dlpreopen=''

# Directory that this library needs to be installed in:
libdir='/usr/lib32'

_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Fri Aug 27, 2010 9:50 pm    Post subject: Reply with quote

nothing about lib64 ....
_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Sat Aug 28, 2010 9:11 am    Post subject: Reply with quote

sss123NEXT: are you currently using paludis? I have some trouble with abi-wrapper on some packages. Not sure if libcaca uses pkgconfig or the -config binary.

Please post the output of those 2 commands:
Code:
/usr/bin/imlib2-config-x86 --libs --cflags
cat /usr/lib32/pkgconfig/imlib2.pc

_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Sun Aug 29, 2010 4:39 am    Post subject: Reply with quote

Code:
/usr/bin/imlib2-config-x86 --libs --cflags
-L/usr/lib32 -lImlib2 -L/usr/lib32 -lfreetype -lz -L/usr/X11R6/lib -lX11 -lXext -ldl -lm


Code:
cat /usr/lib32/pkgconfig/imlib2.pc
prefix=/usr
exec_prefix=${prefix}
libdir=/usr/lib32
includedir=${prefix}/include

Name: imlib2
Description: Powerful image loading and rendering library
Version: 1.4.4
Libs: -L${libdir} -lImlib2
Cflags: -I${includedir}


_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Sun Aug 29, 2010 4:40 am    Post subject: Reply with quote

gimpel wrote:
sss123NEXT: are you currently using paludis? I have some trouble with abi-wrapper on some packages. Not sure if libcaca uses pkgconfig or the -config binary.


both paludis and portage give same result
_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43015
Location: 56N 3W

PostPosted: Sun Aug 29, 2010 12:50 pm    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software. Its an overlay
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sss123NEXT
n00b
n00b


Joined: 23 Sep 2007
Posts: 32
Location: Ukraine\Crimea\Alushta

PostPosted: Mon Aug 30, 2010 2:03 pm    Post subject: Reply with quote

is anybody else have same problem ?, if this is overlay bug how i can help to fix it ?
_________________
am i evil ?

Gentoo repo
Back to top
View user's profile Send private message
Styrsven
n00b
n00b


Joined: 30 Aug 2009
Posts: 5

PostPosted: Tue Aug 31, 2010 9:05 am    Post subject: For the record: problem building python-2.6 with paludis Reply with quote

I used to receive this error all the time:
Code:

 * Using python_src_compile for ABI x86 ...

!!! ERROR in dev-lang/python-2.6.5-r3::multilib:
!!! In python_src_compile at line 7434
!!! python_src_compile() cannot be used in ebuilds of packages not supporting in stallation for multiple Python ABIs


until I copied this
Code:

multilib-native_src_compile_internal() {
   LC_ALL="C" default
}


from the 3.1 ebuild. I think it should be added to the 2.6 ebuilds.
Back to top
View user's profile Send private message
vlooe
n00b
n00b


Joined: 04 Jun 2005
Posts: 35
Location: Germany

PostPosted: Wed Sep 01, 2010 8:53 am    Post subject: Reply with quote

@sss123NEXT:
I am not able to reproduce your problem.
Try to delete the *.la files of imlib2

@gimpl:
I does neither use pkgconfig nor *-config. It uses the .la files if they are there.

@Styrsven:
I will look into this issue as soon as possible.
Back to top
View user's profile Send private message
vlooe
n00b
n00b


Joined: 04 Jun 2005
Posts: 35
Location: Germany

PostPosted: Fri Sep 03, 2010 11:27 pm    Post subject: Reply with quote

@Styrsven:
I can not reproduce your error.

Please set MULTILIB_DEBUG=1, build python again and pastebin every line here.

@sss123NEXT:
Do you still have trouble?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 6 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum