Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gimp 2.6
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
sdubois92
n00b
n00b


Joined: 14 Jul 2008
Posts: 8

PostPosted: Sat Oct 25, 2008 2:05 pm    Post subject: Gimp 2.6 Reply with quote

I would like to upgrade to Gimp 2.6

When i try to emerge gimp i get the following:

Code:
[ebuild     U ] dev-libs/glib-2.18.1 [2.16.3-r1] USE="doc*"
[ebuild     U ] dev-util/intltool-0.40.5 [0.37.1]
[ebuild  N    ] media-libs/gd-2.0.35  USE="jpeg png -fontconfig -truetype -xpm"
[ebuild     U ] media-video/ffmpeg-0.4.9_p20080326 [0.4.9_p20070616] USE="doc* ipv6%* mp3%* -bindist% -hardcoded-tables%"
[ebuild  N    ] app-text/asciidoc-7.0.4 
[ebuild  N    ] media-libs/babl-0.0.22  USE="(-mmx) (-sse)"
[ebuild  N    ] dev-lang/lua-5.1.3-r3  USE="deprecated readline -static"
[ebuild  N    ] app-text/enscript-1.6.4-r3  USE="nls -ruby"
[ebuild     U ] x11-libs/gtk+-2.14.3-r2 [2.12.10-r1] USE="doc* -jpeg2k%"
[ebuild  N    ] media-gfx/graphviz-2.20.3  USE="doc gtk java jpeg nls perl png python -cairo -cgraph -examples -gnome -ruby -tcl"
[ebuild  N    ] media-libs/gegl-0.0.20  USE="doc ffmpeg jpeg png svg -cairo -debug (-mmx) -openexr -raw -sdl (-sse) -v4l"
[ebuild     U ] media-gfx/gimp-2.6.0 [2.4.2] USE="doc* exif%* -hal%"
[blocks B     ] <gnome-base/gail-1000 (is blocking x11-libs/gtk+-2.14.3-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


I looked up to see if there was a bug report and apparantly If i add "gnome-base/gail x86 ~x86" (or in my case, ppc ~ppc) it should work. but it doesn't. Trying to emerge -avu gail gives the following

Code:
Calculating dependencies... done!
[ebuild     U ] dev-libs/glib-2.18.1 [2.16.3-r1] USE="doc* -debug -fam -hardened (-selinux) -xattr" 4,615 kB
[ebuild     U ] gnome-base/gail-1000 [1.20.2] USE="(-debug%) (-doc%)" 0 kB
[ebuild     U ] x11-libs/gtk+-2.14.3-r2 [2.12.10-r1] USE="X cups doc* jpeg tiff -debug -jpeg2k% -vim-syntax -xinerama" 16,748 kB
[blocks B     ] <gnome-base/gail-1000 (is blocking x11-libs/gtk+-2.14.3-r2)

Total: 3 packages (3 upgrades, 1 block), Size of downloads: 21,362 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.


Am I doing something wrong here?
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5021
Location: Dark side of the mood

PostPosted: Sat Oct 25, 2008 2:35 pm    Post subject: Reply with quote

Upgrade gail first then upgrade gimp afterwards:
Code:
emerge -avq1 gail     # note the lack of option 'u'
emerge -avqu gimp

And if it still doesn't work, uninstall gail (emerge -avqC gail) and upgrade gimp. Gail should then come along with version number 1000.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum