Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HPLIP] error: Unable to load dbus
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
vieuxmike
n00b
n00b


Joined: 27 Jun 2008
Posts: 27

PostPosted: Sun Oct 26, 2008 4:32 pm    Post subject: [HPLIP] error: Unable to load dbus Reply with quote

Bonjour,

Pour gérer mon imprimante, j'ai installé un paquet qui s'appelle hplip et qui est très bien. Ce qui était génial, avant, c'est que quand je lançais le programme, une petite icône 'hp' apparaissait dans la zone de notification. C'était le bon temps. C'était bien. C'était avant...

Maintenant, quand je lance hplip j'ai plus d'icône en zone de notification. Quand je tape 'hp-toolbox' dans la console, j'ai un message tout pourri relatif à dbus, et qui varie d'ailleurs en fonction des paquets installés...

Code:
 ~ $ hp-toolbox

HP Linux Imaging and Printing System (ver. 2.8.7)
HP Device Manager ver. 14.0

Copyright (c) 2001-8 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Unable to load dbus - Automatic status updates in HPLIP Device Manager will be disabled.


Quand je dis que le message varie, c'est parce que j'ai trifouillé sur les dépendances de hplip. En particuliers celle ci :

Code:

 ~ $ eix dbus-python
[I] dev-python/dbus-python
     Available versions:  0.71 0.80.2 [m]0.82.4 [m]~0.83.0 {test}
     Installed versions:  0.80.2(09:53:13 26.10.2008)(-test)
     Homepage:            http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/
     Description:         Python bindings for the D-Bus messagebus.


Vous pouvez constater que la version 0.82.4 est masquée : n'étant pas en instable, c'était la version initialement installée. Le plus drôle, c'est que j'avait un message d'erreur au lancement qui me disait... qu'il me fallait une version de dbus-pytho > 0.80 Oo
Du coup j'ai installé la version 0.80, bien que le message d'erreur n suggère pas cette solution, je ne sais plus très bien à quel saint me vouer...

je sais pas si ça peut servir, mais je vais laisser à tous hasard les paquets dbus installés...

Code:

 ~ $ eix -I dbus
[I] dev-libs/dbus-glib
     Available versions:  0.73 0.74 ~0.74-r1 ~0.76 {debug doc selinux}
     Installed versions:  0.74(16:39:10 17.06.2008)(-debug -doc -selinux)
     Homepage:            http://dbus.freedesktop.org/
     Description:         D-Bus bindings for glib

[I] dev-libs/dbus-qt3-old
     Available versions:  0.70 {debug}
     Installed versions:  0.70(17:00:15 26.10.2008)(-debug)
     Homepage:            http://freedesktop.org/wiki/Software/dbus
     Description:         D-BUS Qt3 bindings compatible with old application API and new dbus

[I] dev-python/dbus-python
     Available versions:  0.71 0.80.2 [m]0.82.4 [m]~0.83.0 {test}
     Installed versions:  0.80.2(09:53:13 26.10.2008)(-test)
     Homepage:            http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/
     Description:         Python bindings for the D-Bus messagebus.

[I] sys-apps/dbus
     Available versions:  1.0.2-r2 ~1.1.4 1.1.20 ~1.2.1 ~1.2.3 1.2.3-r1 {X debug doc kernel_FreeBSD kernel_linux selinux}
     Installed versions:  1.2.3-r1(16:39:39 11.10.2008)(X -debug -doc -selinux)
     Homepage:            http://dbus.freedesktop.org/
     Description:         A message bus system, a simple way for applications to talk to each other

Found 4 matches.


Parmi ces paquets, le paquet dbus-qt3-old que j'ai pris l'initiative d'installer (ce qui n'a servi à rien). En Effet,

Code:

 ~ $ eix hplip
[I] net-print/hplip
     Available versions:  (~)2.8.5[1] 2.8.6b (~)2.8.7 {X cupsddk dbus doc fax gtk minimal parport ppds qt3 qt4 scanner snmp}
     Installed versions:  2.8.7(09:45:05 26.10.2008)(dbus gtk ppds qt3 scanner -cupsddk -doc -fax -minimal -parport -qt4 -snmp)
     Homepage:            http://hplip.sourceforge.net/
     Description:         HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools.


J'ai qt3 et -qt4 en useflag, au départ c'était plutôt qt4 et -qt3 (avec le use qt3support lors de la compilation de la lib qt4), ce qui n'a (encore) servi à rien.

Je me demande bien quel est le beans avec dbus, j'ai un soucis avec mumble également et je soupçonne aussi dbus (enfin ici c'est hors-sujet).

sauriez-vous m'éclairer quant à cette erreur, afin de faire en sorte d'avoir de nouveau l'icône en zone de notification (et au passage faire disparaitre le message d'erreur...)?

Merci pour vos réponses :)

PS : hplip est installé avec les uses gtk et qt3 :/ . On pourrait penser qu'il y a conflit?? Eh bien non : la version 2.8.6 ne propose pas de use gtk (donc juste le use qt3). Et là c'est la même : le lancement du programme provoque le message d'erreur, pas d'icone dans le tray...
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1699
Location: 127.0.0.1

PostPosted: Mon Oct 27, 2008 10:01 am    Post subject: Reply with quote

Salut,

Que donne hp-check ?
J'ai les versions suivantes installées, çà fonctionne.
Code:

$ short-eix -I 'hplip|dbus'
dbus-glib       0.74
dbus-qt3-old    0.70
dbus-python     0.82.4
hplip      2.8.6b
dbus       1.2.3-r1
Back to top
View user's profile Send private message
vieuxmike
n00b
n00b


Joined: 27 Jun 2008
Posts: 27

PostPosted: Mon Oct 27, 2008 3:03 pm    Post subject: Reply with quote

hp-check me donne ceci

Code:
$ hp-check

HP Linux Imaging and Printing System (ver. 2.8.6b)
Dependency/Version Check Utility ver. 14.0

Copyright (c) 2001-8 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                   
2. Run-time check mode (-r or --run): Use this mode to determine if a distro   
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                     
3. Both compile- and run-time check mode (-b or --both) (Default): This mode   
will check both of the above cases (both compile- and run-time dependencies).   

Saving output in log file: hp-check.log

Initializing. Please wait...
warning: Invalid ppd_dir value: None

---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux gentoo 2.6.25-gentoo-r7 #15 SMP Sun Sep 28 02:13:25 CEST 2008 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3600+ AuthenticAMD GNU/Linux

Distribution:
gentoo 0.0

HPOJ running?
No, HPOJ is not running (OK).

Checking Python version...
OK, version 2.5.2 installed

Checking PyQt version...
OK, version 3.17 installed.

Checking SIP version...
OK, Version 4.7.3 installed

Checking for CUPS...
Status: l’ordonnanceur tourne
Version: 1.3.8
error_log is set to level: info
note: For troubleshooting printing issues, it is best to have the CUPS 'LogLevel'
note: set to 'debug'. To set the LogLevel to debug, edit the file /etc/cups/cupsd.conf (as root),
note: and change the line near the top of the file that begins with 'LogLevel' to read:
note: LogLevel debug
note: Save the file and then restart CUPS (see your OS/distro docs on how to restart CUPS).
note: Now, when you print, helpful debug information will be saved to the file:
note: /var/log/cups/error_log
note: You can monitor this file by running this command in a console/shell:
note: tail -f /var/log/cups/error_log

Checking for dbus/python-dbus...
dbus daemon is running.
python-dbus version: 0.80.2


------------------------------------
| COMPILE AND RUNTIME DEPENDENCIES |
------------------------------------

note: To check for compile-time only dependencies, re-run hp-check with the -c parameter (ie, hp-check -c).
note: To check for run-time only dependencies, re-run hp-check with the -r parameter (ie, hp-check -r).

Checking for dependency: cups - Common Unix Printing System...
OK, found.

Checking for dependency: cups-ddk - CUPS driver development kit...
warning: NOT FOUND! This is an OPTIONAL/RUNTIME ONLY dependency. Some HPLIP functionality may not function properly.

Checking for dependency: cups-devel- Common Unix Printing System development files...
OK, found.

Checking for dependency: dbus - Message bus system...
OK, found.

Checking for dependency: gcc - GNU Project C and C++ Compiler...
OK, found.

Checking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...
OK, found.

Checking for dependency: libcrypto - OpenSSL cryptographic library...
OK, found.

Checking for dependency: libjpeg - JPEG library...
OK, found.

Checking for dependency: libnetsnmp-devel - SNMP networking library development files...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libpthread - POSIX threads library...
OK, found.

Checking for dependency: libtool - Library building support services...
OK, found.

Checking for dependency: libusb - USB library...
OK, found.

Checking for dependency: make - GNU make utility to maintain groups of programs...
OK, found.

Checking for dependency: PIL - Python Imaging Library (required for commandline scanning with hp-scan)...
OK, found.

Checking for dependency: ppdev - Parallel port support kernel module....
error: NOT FOUND! This is a REQUIRED/RUNTIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: PyQt - Qt interface for Python...
OK, found.

Checking for dependency: python-ctypes - A foreign function library for Python...
OK, found.

Checking for dependency: python-dbus - Python bindings for dbus...
OK, found.

Checking for dependency: python-devel - Python development files...
OK, found.

Checking for dependency: Python 2.3 or greater - Required for fax functionality...
OK, found.

Checking for dependency: Python 2.2 or greater - Python programming language...
OK, found.

Checking for dependency: Reportlab - PDF library for Python...
warning: NOT FOUND! This is an OPTIONAL/RUNTIME ONLY dependency. Some HPLIP functionality may not function properly.

Checking for dependency: SANE - Scanning library...
OK, found.

Checking for dependency: SANE - Scanning library development files...
OK, found.

Checking for dependency: scanimage - Shell scanning program...
OK, found.

Checking for dependency: xsane - Graphical scanner frontend for SANE...
OK, found.


----------------------
| HPLIP INSTALLATION |
----------------------


Currently installed HPLIP version...
HPLIP 2.8.6b currently installed in '/usr/share/hplip'.

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=2.8.6b

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-2.8.6b
icon=/usr/share/applications
cupsbackend=/usr/libexec/cups/backend
cupsfilter=/usr/libexec/cups/filter
drv=/usr/share/cups/drv/hp

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=no
dbus-build=yes
cups11-build=no
doc-build=no
shadow-build=no
foomatic-drv-install=no
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
internal-tag=2.8.6.20b


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                        Model             
  --------------------------------  ------------------
  hp:/usb/PSC_1400_series?serial=C  HP PSC 1400 series
  N615D62B804DZ                                       

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
warning: No queues found.

----------------------
| SANE CONFIGURATION |
----------------------

'hpaio' in '/etc/sane.d/dll.conf'...
OK, found. SANE backend 'hpaio' is properly set up.

Checking output of 'scanimage -L'...
device `hpaio:/usb/PSC_1400_series?serial=CN615D62B804DZ' is a Hewlett-Packard PSC_1400_series all-in-one


---------------------
| PYTHON EXTENSIONS |
---------------------

Checking 'cupsext' CUPS extension...
OK, found.

Checking 'pcardext' Photocard extension...
OK, found.

Checking 'hpmudext' I/O extension...
OK, found.

Checking 'scanext' SANE scanning extension...
error: NOT FOUND OR FAILED TO LOAD! Please reinstall HPLIP and check for the proper installation of scanext.

-----------------
| USB I/O SETUP |
-----------------


Checking for permissions of USB attached printers...
 
HP Device 0x4d11 at 002:003:
    Device URI: hp:/usb/PSC_1400_series?serial=CN615D62B804DZ
    Device node: /dev/bus/usb/002/003
    Mode: 0664
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/002/003
# owner: root
# group: lp
user::rw-
group::rw-
other::r--



-----------
| SUMMARY |
-----------

error: 5 errors and/or warnings.

Please refer to the installation instructions at:
http://hplip.sourceforge.net/install/index.html


Done.


5 errors or warnings...

L'une concerne un module de kernel pour faire tourner les imprimantes sur port parallele, et dont je n'ai en fait pas besoin (c'est une imprimante usb).
Une autre concerne une dépendance appelée libnetsnmp-devel, relative à la gestion de l'imprimante via le protocole Snmp, que je ne connais pas (http://fr.wikipedia.org/wiki/Simple_network_management_protocol). Je ne sais pas si cette dépendance a à voir avec le problème lié au tray, mais à-priori je ne vois pas le rapport.

D'ailleurs ces messages d'"erreurs" sembleraient logiques : les USEs sont mis sur -parport et -snmp...

Un message d'erreur relatif au scanner sinon. Là je trouve ça bizarre parce que le USE scanner est activé, d'ailleurs il fonctionne avec xsane.

En fait j'ai le mesage d'erreur relatif à dbus en lançant hp-systray :

Code:

$ hp-systray

HP Linux Imaging and Printing System (ver. 2.8.6b)
System Tray Status Service ver. 0.1

Copyright (c) 2001-8 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: dbus failed to load (python-dbus ver. 0.80+ required). Exiting...
Processus arrêté
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1699
Location: 127.0.0.1

PostPosted: Mon Oct 27, 2008 4:11 pm    Post subject: Reply with quote

Quote:
5 errors or warnings...

L'une concerne un module de kernel pour faire tourner les imprimantes sur port parallele, et dont je n'ai en fait pas besoin (c'est une imprimante usb).
Une autre concerne une dépendance appelée libnetsnmp-devel, relative à la gestion de l'imprimante via le protocole Snmp, que je ne connais pas (http://fr.wikipedia.org/wiki/Simple_network_management_protocol). Je ne sais pas si cette dépendance a à voir avec le problème lié au tray, mais à-priori je ne vois pas le rapport.

D'ailleurs ces messages d'"erreurs" sembleraient logiques : les USEs sont mis sur -parport et -snmp...

Un message d'erreur relatif au scanner sinon. Là je trouve ça bizarre parce que le USE scanner est activé, d'ailleurs il fonctionne avec xsane.

J'ai exactement les mêmes erreurs/warning avec hp-check, et tout fonctionne correctement.
hplip 2.8.6b est installé avec ces useflags : cupsddk dbus ppds qt3 scanner
Une histoire de droits / groupes peut être ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum