Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GCC 4.4.0 testing
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 14, 15, 16  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Tue Apr 28, 2009 5:04 pm    Post subject: Reply with quote

Is there any way to get gcc-4.4.0 ? I know where i can find live ebuilds or snapshots, but i prefer to install the "official" version. ;)

Thank you. :)
Back to top
View user's profile Send private message
justinkb
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 160

PostPosted: Tue Apr 28, 2009 5:06 pm    Post subject: Reply with quote

posted ebuild two pages ago...
_________________
~amd64 | gcc 4.4.2 | linux 2.6.33-git w/ alsa 1.0.22.1 and drm-radeon-testing | gnome(-light) 2.28.2 | xorg-x11 and xf86-video-ati from git
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Tue Apr 28, 2009 6:16 pm    Post subject: Reply with quote

Tom_ wrote:
Is there any way to get gcc-4.4.0 ? I know where i can find live ebuilds or snapshots, but i prefer to install the "official" version. ;)

Thank you. :)


"official" is hard as there as far as I know has not been any released patchset from gentoo yet.
_________________
If I edit a post without commenting it mostly is spelling-errors.
And if I sounds rude I am sorry, that is just my personality speaking and has most of the time nothing to do with you personally.
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Wed Apr 29, 2009 8:21 am    Post subject: Reply with quote

I know that is hard to find something "official" .. thaht's why i asked. I was wondering : which version are they all using here ? :o I think i'm going to get an ebuild from the toolchain overlay, and then rename it.
Back to top
View user's profile Send private message
scary
n00b
n00b


Joined: 17 Apr 2004
Posts: 47

PostPosted: Wed Apr 29, 2009 9:20 am    Post subject: Reply with quote

I'm currently using the 4.4.1_pre9999 ebuild from gcc-porting overlay, built two or three days after 4.4.0 release so I guess it is substantially 4.4.0 .... no particular problems so far, fresh install on ext4 using the various new -floop-whatever flags. A couple (non-critical) packages failed to build but I found fixes on bugzilla for all of them :) ~amd64 on core2
Back to top
View user's profile Send private message
mbar
Veteran
Veteran


Joined: 19 Jan 2005
Posts: 1979
Location: Poland

PostPosted: Wed Apr 29, 2009 1:58 pm    Post subject: Reply with quote

Somebody got glibc to compile with gcc 4.4.0 (final)?

Code:
x86_64-pc-linux-gnu-gcc libc-start.c -c -std=gnu99 -fgnu89-inline -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -fno-strict-aliasing -Wstrict-prototypes -mpreferred-stack-boundary=4  -fPIC -g0 -O99 -fomit-frame-pointer -D__USE_STRING_INLINES    -I../include -I/var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/csu -I/var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl -I../sysdeps/i386/elf -I../nptl/sysdeps/unix/sysv/linux/i386/i686 -I../nptl/sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pth
ibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-version.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-profile.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-conflict.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-tls.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-origin.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-execstack.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-caller.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-open.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-close.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-trampoline.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-sysdep.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-environ.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-minimal.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-brk.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-sbrk.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/tlsdesc.os /var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-tlsdesc.os
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: Relocatable linking with relocations from format elf64-x86-64 (/var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-init.os) to format elf32-i386 (/var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-allobjs.os) is not supported
collect2: ld returned 1 exit status
distcc[8382] ERROR: compile (null) on localhost failed
make[2]: *** [/var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/build-x86-x86_64-pc-linux-gnu-nptl/elf/dl-allobjs.os] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/glibc-2.9-20081201/elf'
make[1]: *** [elf/subdir_lib] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/work/glibc-2.9-20081201'
make: *** [all] Error 2
 *
 * ERROR: sys-libs/glibc-2.9_p20081201-r2 failed.
 * Call stack:
 *               ebuild.sh, line   48:  Called src_compile
 *             environment, line 3603:  Called eblit-run 'src_compile'
 *             environment, line 1216:  Called eblit-glibc-src_compile
 *       src_compile.eblit, line  179:  Called src_compile
 *             environment, line 3603:  Called eblit-run 'src_compile'
 *             environment, line 1216:  Called eblit-glibc-src_compile
 *       src_compile.eblit, line  187:  Called toolchain-glibc_src_compile
 *       src_compile.eblit, line  122:  Called die
 * The specific snippet of code:
 *              make PARALLELMFLAGS="${MAKEOPTS}" || die "make for ${ABI} failed"
 *  The die message:
 *   make for x86 failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/glibc-2.9_p20081201-r2/temp/environment'.
 *


Code:
Portage 2.1.6.11 (default/linux/amd64/2008.0/desktop, gcc-4.4.0, glibc-2.9_p20081201-r2, 2.6.29-zen2 x86_64)
=================================================================
System uname: Linux-2.6.29-zen2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8300_@_2.40GHz-with-gentoo-2.0.0
Timestamp of tree: Wed, 29 Apr 2009 06:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:     4.0_p17-r1
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.2
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -mfpmath=sse -ftree-vectorize -msse4.1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -mfpmath=sse -ftree-vectorize -msse4.1"
DISTDIR="/usr/portage/distfiles"
FEATURES="distcc distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.po.opole.pl"
LANG="pl_PL.utf8"
LC_ALL="pl_PL.utf8"
LDFLAGS="-Wl,-O1 -Wl,-s -Wl,--hash-style=gnu"
LINGUAS="pl en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/gentoo-china /usr/local/portage/layman/zen-overlay /usr/local/portage/layman/vmware /usr/local/portage/layman/wschlich-testing /usr/local/portage/layman/toolchain /usr/local/portage/layman/gnome /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi alsa amd64 artworkextra aspell autoipd automount avahi bluetooth branding bzip2 cairo cdda cddb cdr cleartype cli consolekit cracklib crypt cups custom-optimization dbus dell dhcpcd dri dvd dvdr dvdread emboss emerald encode epiphany evo exif fam fbcon fbcondecor ffmpeg firefox flac fontconfig fuse gcdmaster gdbm gif git glibc-omitfp glitz gmp gnome gnomecd gphoto2 gpm gstreamer gtk hal iconv id3tag isdnlog ithreads java java6 jbig jpeg jpeg2k justify laptop libnotify libsamplerate lzma lzo mad mdnsresponder-compat midi mikmod mmx moznopango mp3 mpeg multilib nautilus ncurses networkmanager nls nntp nptl nptlonly nsplugin ntp offensive ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support quicktime readline reflection session spell spl sqlite sse sse2 ssl startup-notification subversion svg symlink sysfs threads tiff truetype ubuntu unicode unsupported usb vorbis x264 xcb xml xorg xprint xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl en" USERLAND="GNU" VIDEO_CARDS="vesa nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Apr 29, 2009 4:27 pm    Post subject: Reply with quote

try to disable distcc and update gcc on your other distcc hosts :idea:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Wed Apr 29, 2009 4:51 pm    Post subject: Reply with quote

mbar wrote:
Somebody got glibc to compile with gcc 4.4.0 (final)?


Code:
FEATURES="-distcc -ccache" MAKEOPTS="-j1" emerge -1 glibc


Then repost any errormessages.
_________________
If I edit a post without commenting it mostly is spelling-errors.
And if I sounds rude I am sorry, that is just my personality speaking and has most of the time nothing to do with you personally.
Back to top
View user's profile Send private message
ComaWhite
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 125

PostPosted: Wed Apr 29, 2009 6:59 pm    Post subject: Reply with quote

I was able to compile glibc-2.9_p20081201-r2 with GCC-4.4.0
Back to top
View user's profile Send private message
mbar
Veteran
Veteran


Joined: 19 Jan 2005
Posts: 1979
Location: Poland

PostPosted: Wed Apr 29, 2009 7:44 pm    Post subject: Reply with quote

thanks, -distcc helped. I forgot that I had older gcc 4.4 snapshot on my other distcc host.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Wed Apr 29, 2009 11:31 pm    Post subject: Reply with quote

Can we now get through an emerge -e system with gcc-4.4.0, and then build a pretty basic kde-svn/gnome/xfce4 environment?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
bob_111
Apprentice
Apprentice


Joined: 12 Oct 2004
Posts: 155

PostPosted: Thu Apr 30, 2009 6:28 am    Post subject: Reply with quote

I just upgraded from i486 GCC 4.1.2 to i686 4.4.1_9999.

Everything worked smoothly. Upgraded world and system. Only one package didn't want to compile. Some science maths package so i just masked it and was on my way.
Back to top
View user's profile Send private message
ComaWhite
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 125

PostPosted: Thu Apr 30, 2009 6:57 am    Post subject: Reply with quote

mozilla finally compiles but you need mozilla-firefox-4.5_beta4 from mozilla overlay for the 9999 version. Yeah I can compile all of KDE-live with GCC-4.4.0
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Sun May 03, 2009 1:12 pm    Post subject: Reply with quote

Thanks for the feedback! :D I'm giving it a try (9999 version). However, some slight confusion here.
The ebuild has graphite in IUSE, but I get - graphite when I do this:
Code:
kdesvn wrc # USE="multislot" emerge -pv =sys-devel/gcc-4.4.1_pre9999

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   ] sys-devel/gcc-4.4.1_pre9999 [3.3.6-r1, 4.1.2, 4.3.3-r2] USE="fortran gtk mudflap multislot nls openmp (-altivec) -bootstrap -build -debug -doc (-fixed-point) -gcj -graphite (-hardened) -ip28 -ip32r10k -libffi (-multilib) (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -offline -profiledbootstrap -test -vanilla" 0 kB [1] 

However, when I do:
Code:
kdesvn wrc # USE="multislot graphite" emerge -pv =sys-devel/gcc-4.4.1_pre9999

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=dev-libs/cloog-ppl-0.15" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/cloog-ppl-0.15.3 (masked by: missing keyword)
I'm wondering if graphite is absolutely supposed to be disabled, or to go ahead and unmask cloog-ppl?
Why is it in the current sys-devel/gcc-4.4.1_pre9999 ebuild, and NOT being picked up by emerge?
Quote:
IUSE="offline profiledbootstrap debug graphite"


EDIT: I seem to have a problem unmasking/keywording cloog-ppl, so I didn't do USE="multilslot graphite", just multislot. Also did a quickpkg gcc, just in case things go wrong.
Why wasn't multislot enabled in the ebuild?
Now compiling gcc-4.4.1_pre9999.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Sun May 03, 2009 5:00 pm    Post subject: Reply with quote

OK- sucessfully installed and switched the compiler to gcc-4.4.1_pre9999, and rebuilt the toolchain. Now attempting an emerge -e system, I curiously get:
Code:
emerge -epv @system
These are the packages that would be merged, in order:
Calculating dependencies... done!
SNIPPED
Total: 331 packages (10 upgrades, 1 downgrade, 1 new, 319 reinstalls), Size of downloads: 10,788 kB
Portage tree and overlays:                                                                         
 [0] /usr/portage                                                                                 
 [1] /usr/local/portage/layman/zen-overlay                                                         
 [2] /usr/local/portage/layman/gcc-porting                                                         
 [3] /usr/local/portage/layman/kde-testing
However,
Code:
kdesvn wrc # emerge -pv @system

These are the packages that would be merged, in order:
Calculating dependencies... done!
SNIPPED
Total: 51 packages (51 reinstalls), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage/layman/gcc-porting

For years, emerge -ep system has listed only about 100 pure base system packages, and now 331?

And, with gcc-4.4.1_pre9999 selected as the compiler, is it now reporting 331 packages as "system included" packages because all the selections need to be rebuilt due to gcc-4.4.1_pre9999? This never happened with all the myriad gcc updates/version changes I've made before.

Is this the correct explanation? Obviously x11,qt,kde-svn, and lots of other packages aren't base system packages. :wink:
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental


Last edited by wrc1944 on Sun May 03, 2009 11:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
mbar
Veteran
Veteran


Joined: 19 Jan 2005
Posts: 1979
Location: Poland

PostPosted: Sun May 03, 2009 7:29 pm    Post subject: Reply with quote

I recompiled world (over 800 packages) with gcc 4.4 final with graphite enabled and these are packages thad failed:
dev-libs/icu
dev-libs/boost
media-libs/musicbrainz (but this one is trivial to repair)
xulrunner 1.8.x version
an of course, much anticipated openoffice also failed.


Last edited by mbar on Mon May 04, 2009 10:48 am; edited 1 time in total
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Sun May 03, 2009 11:02 pm    Post subject: Reply with quote

Just finished up my big 331 package emerge -epv @system with gcc-4.4.1_pre9999 (r147075), which included kdelibs-9999. All went without a problem. I was in xfce4 at the time, and all seems to be working normally except the known Firefox problem (which I read about here). Haven't rebooted the system, or to kde-svn, so that's the big test. Must say my first experience with this has gone perfect, so far. 8)

I guess if the reboot goes OK a full emerge -e @world is in order, correct? Or are the 331 packages already compiled with gcc-4.4.1 adequate, and I can just get the rest done in time as they are addressed in regular emerge -uD world sessions?

BTW- how can I get around the graphite USE flag and the cloog-ppl problem I have (can't seem to keyword or unmask cloog. :?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
mbar
Veteran
Veteran


Joined: 19 Jan 2005
Posts: 1979
Location: Poland

PostPosted: Mon May 04, 2009 8:49 am    Post subject: Reply with quote

evolution-2.26.1.1 from gnome overlay also fails:

Code:
libtool: link: x86_64-pc-linux-gnu-gcc -shared  .libs/google-source.o .libs/google-contacts-source.o   /usr/lib64/libecal-1.2.so -L/usr/lib64 -L/usr/lib64/nspr -L/usr/lib64/lib /usr/lib64/libicalss.so /usr/lib64/libicalvcal.so /usr/lib64/libical.so /usr/lib64/libedataserverui-1.2.so -L/usr/lib64/nss /usr/lib64/libebook-1.2.so /usr/lib64/libcamel-1.2.so -lssl3 -lsmime3 -lnssutil3 -lnss3 /usr/lib64/libsqlite3.so /usr/lib64/libebackend-1.2.so /usr/lib64/libedataserver-1.2.so -lplds4 -lplc4 -lnspr4 -ldb /usr/lib64/libhal.so /usr/lib64/libnotify.so /usr/lib64/libgtkhtml-editor.so /usr/lib64/libgtkhtml-3.14.so /usr/lib64/libgnomeui-2.so /usr/lib64/libgnome-keyring.so /usr/lib64/libglade-2.0.so /usr/lib64/libenchant.so /usr/lib64/libbonoboui-2.so /usr/lib64/libgnomecanvas-2.so /usr/lib64/libgailutil.so /usr/lib64/libXrandr.so /usr/lib64/libXcursor.so /usr/lib64/libXcomposite.so /usr/lib64/libXdamage.so /usr/lib64/libXfixes.so /usr/lib64/libgnome-2.so /usr/lib64/libgnomevfs-2.so -lssl -lcrypto /usr/lib64/libavahi-glib.so /usr/lib64/libavahi-client.so /usr/lib64/libavahi-common.so -lresolv -lutil /usr/lib64/libpopt.so /usr/lib64/libbonobo-2.so /usr/lib64/libbonobo-activation.so /usr/lib64/libORBitCosNaming-2.so /usr/lib64/libart_lgpl_2.so /usr/lib64/libgconf-2.so /usr/lib64/libORBit-2.so /usr/lib64/libdbus-glib-1.so /usr/lib64/libdbus-1.so /usr/lib64/libgtk-x11-2.0.so /usr/lib64/libgdk-x11-2.0.so /usr/lib64/libatk-1.0.so /usr/lib64/libgdk_pixbuf-2.0.so /usr/lib64/libpangocairo-1.0.so /usr/lib64/libpangoft2-1.0.so /usr/lib64/libcairo.so /usr/lib64/libpixman-1.so /usr/lib64/libglitz-glx.so /usr/lib64/libXmu.so /usr/lib64/libXt.so /usr/lib64/libSM.so -luuid /usr/lib64/libICE.so /usr/lib64/libXi.so /usr/lib64/libGL.so /usr/lib64/libXext.so /usr/lib64/libglitz.so /usr/lib64/libpng12.so /usr/lib64/libxcb-render-util.so /usr/lib64/libxcb-render.so /usr/lib64/libXrender.so /usr/lib64/libX11.so /usr/lib64/libxcb-xlib.so /usr/lib64/libxcb.so /usr/lib64/libXau.so /usr/lib64/libXdmcp.so /usr/lib64/libpango-1.0.so /usr/lib64/libfontconfig.so /usr/lib64/libfreetype.so /usr/lib64/libexpat.so /usr/lib64/libgdata-google-1.2.so /usr/lib64/libgdata-1.2.so /usr/lib64/libsoup-2.4.so /usr/lib64/libgthread-2.0.so -lpthread -lrt /usr/lib64/libxml2.so -lm /usr/lib64/libgnutls.so /usr/lib64/libtasn1.so -lz /usr/lib64/libgcrypt.so /usr/lib64/libgpg-error.so /usr/lib64/libgio-2.0.s
exchange-operations.c:28:32: error: exchange-hierarchy.h: No such file or directory
exchange-operations.c:31: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
exchange-operations.c: In function ‘free_exchange_listener’:
exchange-operations.c:55: error: ‘exchange_global_config_listener’ undeclared (first use in this function)
exchange-operations.c:55: error: (Each undeclared identifier is reported only once
exchange-operations.c:55: error: for each function it appears in.)
exchange-operations.c: In function ‘e_plugin_lib_enable’:
exchange-operations.c:61: error: ‘exchange_global_config_listener’ undeclared (first use in this function)
exchange-operations.c:62: warning: implicit declaration of function ‘exchange_config_listener_new’
exchange-operations.c: In function ‘exchange_is_offline’:
exchange-operations.c:71: warning: implicit declaration of function ‘exchange_config_listener_get_offline_status’
exchange-operations.c:71: error: ‘exchange_global_config_listener’ undeclared (first use in this function)
exchange-operations.c: At top level:
exchange-operations.c:188: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
exchange-operations.c:225: error: expected ‘)’ before ‘*’ token
exchange-operations.c:289: error: expected ‘)’ before ‘*’ token
make[4]: *** [exchange-operations.lo] Error 1
make[4]: Leaving directory `/var/tmp/portage/mail-client/evolution-2.26.1.1/work/evolution-2.26.1.1/plugins/exchange-operations'
make[3]: *** [all] Error 2
rm org-gnome-exchange-operations.eplug.in
make[3]: Leaving directory `/var/tmp/portage/mail-client/evolution-2.26.1.1/work/evolution-2.26.1.1/plugins/exchange-operations'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/mail-client/evolution-2.26.1.1/work/evolution-2.26.1.1/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/mail-client/evolution-2.26.1.1/work/evolution-2.26.1.1'
make: *** [all] Error 2
 *
 * ERROR: mail-client/evolution-2.26.1.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3503:  Called gnome2_src_compile
 *             environment, line 2530:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
Back to top
View user's profile Send private message
robnotts
Guru
Guru


Joined: 15 Mar 2004
Posts: 405
Location: Nottingham, UK

PostPosted: Mon May 04, 2009 8:50 am    Post subject: Reply with quote

Done an emerge -ve @system, closely followed by an emerge -ve @world, with a few problems, attempting to use the graphite flags for all packages (just felt suicidally insane :o )... results...

had to downgrade flags for libstdc++-v3, but nothing unexpected there
had to use the packages from the gcc-porting overlay (although not got boost compiled yet)

still have these problems...

dev-java/jaxme-0.3.1-r4
sci-libs/cln-1.2.2
dev-libs/boost-1.35.0-r2
dev-java/rhino-1.5.5-r4
media-gfx/exiv2-0.17
net-libs/xulrunner-1.8.1.19
dev-java/gnu-classpath-0.97-r1
x11-libs/qtscriptgenerator-0.1.0
media-tv/mythtv-0.22_alpha20308
kde-base/libkleo-4.2.2
kde-base/kleopatra-4.2.2

did have a problem with qtscriptgenerator, and a few others, but looking around on bugs.gentoo.org allowed me to find the patches/clues to solve those as well...

Seems stable, and not noticeably quicker/faster/worse, and this is with a gcc-4.4.0 compiled kernel as well!

(x86 laptop, not the amd64 one as that one I do need to be stable!)
_________________
---

Gentoo Phenom][ X4 955 on AMD790 + Geforce 220GT 8GB/1.75TB (Desktop)
+ MythTV (3xFreeview,1xFreesat HD) on 1080p
Gentoo Turion64 X2 Geforce 6150 2GB/120GB (Laptop)
Back to top
View user's profile Send private message
justinkb
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 160

PostPosted: Mon May 04, 2009 11:31 am    Post subject: Reply with quote

wrc1944 wrote:

And, with gcc-4.4.1_pre9999 selected as the compiler, is it now reporting 331 packages as "system included" packages because all the selections need to be rebuilt due to gcc-4.4.1_pre9999? This never happened with all the myriad gcc updates/version changes I've made before.

Is this the correct explanation? Obviously x11,qt,kde-svn, and lots of other packages aren't base system packages. :wink:
did you maybe build ppl with prolog use flag and swi-prolog with X/java flags or something? i'm guessing those new packages are getting pulled into system because of ppl[prolog]. of course i'm not sure :)
_________________
~amd64 | gcc 4.4.2 | linux 2.6.33-git w/ alsa 1.0.22.1 and drm-radeon-testing | gnome(-light) 2.28.2 | xorg-x11 and xf86-video-ati from git
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Mon May 04, 2009 12:26 pm    Post subject: Reply with quote

Thanks justinkb,
I'll investigate what you mentioned. I was about to post this right as I saw your post:

OK- finally got cloog-ppl unmasked, and am trying to enable graphite. Put the flags in make.conf, and thought I was on the way, but got this: Anyone got a fix, or possible reason about C compiler not being able to create executables?
Code:
Calculating dependencies... done!
[ebuild  N    ] dev-libs/ppl-0.10.2  USE="-doc -pch -prolog -test -watchdog" 9,590 kB [0]
[ebuild  N    ] dev-libs/cloog-ppl-0.15.3  788 kB [0]
[ebuild   R   ] sys-devel/gcc-4.4.1_pre9999  USE="fortran graphite* gtk mudflap nls openmp (-altivec) -bootstrap -build -debug -doc (-fixed-point) -gcj (-hardened) -ip28 -ip32r10k -libffi (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -offline -profiledbootstrap -test -vanilla" 0 kB [1]

Total: 3 packages (2 new, 1 reinstall), Size of downloads: 10,378 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage/layman/gcc-porting
>>> Unpacking source...
>>> Unpacking ppl-0.10.2.tar.bz2 to /var/tmp/portage/dev-libs/ppl-0.10.2/work
>>> Source unpacked in /var/tmp/portage/dev-libs/ppl-0.10.2/work
>>> Preparing source in /var/tmp/portage/dev-libs/ppl-0.10.2/work/ppl-0.10.2 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-libs/ppl-0.10.2/work/ppl-0.10.2 ...
 * econf: updating ppl-0.10.2/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating ppl-0.10.2/Watchdog/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating ppl-0.10.2/Watchdog/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating ppl-0.10.2/config.guess with /usr/share/gnuconfig/config.guess
./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --docdir=/usr/share/doc/ppl-0.10.2 --disable-debugging --disable-optimization --disable-pch --disable-watchdog --enable-interfaces=c cxx
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output file name...
configure: error: in `/var/tmp/portage/dev-libs/ppl-0.10.2/work/ppl-0.10.2':
configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-libs/ppl-0.10.2/work/ppl-0.10.2/config.log
 *
 * ERROR: dev-libs/ppl-0.10.2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_configure
 *             environment, line 2146:  Called econf '--docdir=/usr/share/doc/ppl-0.10.2' '--disable-debugging' '--disable-optimization' '--disable-pch' '--disable-watchdog' '--enable-interfaces=c cxx '
 *               ebuild.sh, line  526:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *  The die message:
 *   econf failed


EDIT: Hmm. ppl does have the -prolog USE flag, but I don't have swi-prolog even installed? Is that the problem?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Mon May 04, 2009 12:33 pm    Post subject: Reply with quote

wrc1944 wrote:
Anyone got a fix, or possible reason about C compiler not being able to create executables?
That is what I normally call a faulty CFLAG.
Look inside your config.log for info about which it is.
_________________
If I edit a post without commenting it mostly is spelling-errors.
And if I sounds rude I am sorry, that is just my personality speaking and has most of the time nothing to do with you personally.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon May 04, 2009 12:53 pm    Post subject: Reply with quote

Xake wrote:
wrc1944 wrote:
Anyone got a fix, or possible reason about C compiler not being able to create executables?
That is what I normally call a faulty CFLAG.
Look inside your config.log for info about which it is.


++

or a faulty ldflag

or a faulty program check

or faulty/bad binutils
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Xake
Guru
Guru


Joined: 11 Feb 2004
Posts: 588
Location: Göteborg, the rainy part of scandinavia

PostPosted: Mon May 04, 2009 1:09 pm    Post subject: Reply with quote

wrc1944 wrote:
Code:

checking for C compiler default output file name...
configure: error: in `/var/tmp/portage/dev-libs/ppl-0.10.2/work/ppl-0.10.2':
configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-libs/ppl-0.10.2/work/ppl-0.10.2/config.log

As a second note: are you sure gcc-4.4 are the stuff for you if you cannot even read the errormessage? As it says: read that file and it will tell you exactly why it cannot compile things. As kernelOfTruth pointed out I missed some points of what can be wrong the last time around.:-P
_________________
If I edit a post without commenting it mostly is spelling-errors.
And if I sounds rude I am sorry, that is just my personality speaking and has most of the time nothing to do with you personally.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Mon May 04, 2009 2:39 pm    Post subject: Reply with quote

Xake,
:oops: I read the build.log instead, and somehow forgot about checking the config.log. :roll: Trying to do too many things at the same time- big mistake with stuff like this. :lol:
Anyway, I disabled graphite and am halfway through an emerge -e world. I'll try sorting graphite and ppl cloog problems later.

Thanks to all for the quick feedback- much appreciated! Perhaps my gcc-4.3.3 cflags and the --as-needed LDFLAG won't work well with gcc-4.4.1_pre9999, although I did get those 331 system packages done yesterday without a hitch. Maybe it's just that ppl and/or cloog-ppl doesn't like --as-needed- I'll figure it out later- no time to work on it right now.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 14, 15, 16  Next
Page 9 of 16

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum