Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sup?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Beetle B.
Guru
Guru


Joined: 01 Mar 2003
Posts: 517

PostPosted: Sun Nov 02, 2008 8:09 pm    Post subject: Sup? Reply with quote

Anyone have an ebuild for Sup? It's kind of hard to search for that term.
_________________
Beetle B.

Please update the table of equivalents.
A Firefox guide.
Back to top
View user's profile Send private message
Stupendoussteve
n00b
n00b


Joined: 06 Sep 2005
Posts: 72
Location: US West

PostPosted: Sun Nov 02, 2008 8:43 pm    Post subject: Reply with quote

I'm working on writing one up now to put in bugzilla. Trollop (one of the depends) does not have an ebuild so I'll be making one there as well.

EDIT: Trollop is in the Sunrise overlay. I'll still put up the ebuild for it and request an official package.


Last edited by Stupendoussteve on Sun Nov 02, 2008 9:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
Beetle B.
Guru
Guru


Joined: 01 Mar 2003
Posts: 517

PostPosted: Sun Nov 02, 2008 8:52 pm    Post subject: Reply with quote

Thanks. Do post the bugzilla link here (searching for sup doesn't help...).
_________________
Beetle B.

Please update the table of equivalents.
A Firefox guide.
Back to top
View user's profile Send private message
ocin
Guru
Guru


Joined: 01 Jan 2006
Posts: 500

PostPosted: Sun Nov 02, 2008 9:53 pm    Post subject: Reply with quote

Yeah link to ebuild would be cool, I wanna test sup too :p
Back to top
View user's profile Send private message
Stupendoussteve
n00b
n00b


Joined: 06 Sep 2005
Posts: 72
Location: US West

PostPosted: Sun Nov 02, 2008 11:14 pm    Post subject: Reply with quote

mail-client/sup ebuild is available as an attachment to https://bugs.gentoo.org/show_bug.cgi?id=245330

Requires a few more packages that aren't in portage:
dev-ruby/trollop at https://bugs.gentoo.org/show_bug.cgi?id=232644
dev-ruby/ruby-lockfile at https://bugs.gentoo.org/show_bug.cgi?id=245336
dev-ruby/ruby-rmail at https://bugs.gentoo.org/show_bug.cgi?id=245337

Due to bug 196036, sup will FAIL to merge on the first attempt. After it fails, run "gem install ncurses" and wait for gem to install the gem version of the library. This is because the tar.gz version of ncurses-ruby installed by Gentoo does not make its existance known to the gem install system.

After installing the ruby ncurses through gem, sup should merge fine. I tested on x86 with no problems.
Back to top
View user's profile Send private message
Beetle B.
Guru
Guru


Joined: 01 Mar 2003
Posts: 517

PostPosted: Sun Nov 02, 2008 11:29 pm    Post subject: Reply with quote

Thanks!
_________________
Beetle B.

Please update the table of equivalents.
A Firefox guide.
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2152

PostPosted: Thu Feb 05, 2009 9:10 pm    Post subject: Reply with quote

Thank you very much, works for me on ~amd64.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum