Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
seq24 fails to build
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
musicman
n00b
n00b


Joined: 13 Jun 2004
Posts: 66

PostPosted: Tue Nov 11, 2008 11:44 pm    Post subject: seq24 fails to build Reply with quote

I recently tried to re-merge seq24 with lash support from the pro-audio layman overlay, and I got this:

Code:
config.status: creating src/Makefile
config.status: creating src/config.h
config.status: src/config.h is unchanged
config.status: executing depfiles commands
/var/tmp/portage/media-sound/seq24-0.8.7/temp/environment: line 2080: --disable-alsatest: command not found
 *
 * ERROR: media-sound/seq24-0.8.7 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2080:  Called die
 * The specific snippet of code:
 *       --disable-alsatest || die;
 *  The die message:
 *   (no error message)


Here's the corresponding part of the temp/environment file:

Code:
src_compile ()
{
    export WANT_AUTOCONF=2.5;
    if use devel-patches; then
        autoconf || die "autoconf failed";
        autoreconf;
    fi;
    econf $(use_enable jack jack-support) $(use_enable lash);
    --disable-alsatest || die;
    emake || die
}


Now I'm just merging the version of it in the main portage tree using the ebuild command. Any suggestions?
Back to top
View user's profile Send private message
cyrillic
Watchman
Watchman


Joined: 19 Feb 2003
Posts: 7313
Location: Groton, Massachusetts USA

PostPosted: Wed Nov 12, 2008 4:43 am    Post subject: Re: seq24 fails to build Reply with quote

I am just guessing here, but it looks like a typo in the ebuild.

Try changing this part
Code:
    econf $(use_enable jack jack-support) $(use_enable lash);
    --disable-alsatest || die;

into 1 line, like this
Code:
    econf $(use_enable jack jack-support) $(use_enable lash) \
    --disable-alsatest || die;
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Wed Nov 12, 2008 10:29 am    Post subject: Reply with quote

Indeed... a typo.. bad evermind! :)

Fixed. Thanks!
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum