Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiz-fusion and Gnome 2.24
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
EgonVLC
n00b
n00b


Joined: 13 Jun 2005
Posts: 14

PostPosted: Sun Nov 16, 2008 10:21 pm    Post subject: Compiz-fusion and Gnome 2.24 Reply with quote

I'm trying to install compiz-fusion 0.7.8 on a fresh mixed amd64/~amd64 gentoo install. I emerged compiz and nothing happened. Well, it was downloaded with a handful of dependences, compiled without errors and installed. If I run manually "compiz --replace & emerald --replace &" I got no effects and no window border/decoration, but neither compiz nor emerald print any error. My versions:

NVIDIA GeForce 8800GT, Intel Core2Quad Q6600

Xorg-X11 7.4 (~amd64)
nvidia-drivers 177.80 (~amd64)
Gnome 2.24 (~amd64 and gnome overlay)
Compiz 0.7.8 (~amd64 and desktop-effects overlay)

"glxinfo | grep direct" -> direct rendering: Yes
"glxgears" works, and outputs ~10.000 FPS.

relevant parts of xorg.conf:

In section module:

# This loads the GLX module
# Load "glx"
# This loads the DRI module
# Load "dri"
# (since I use nvidia-drivers)

Section "Device"
Identifier "GForce8800Gt"
Driver "nvidia"
Option "NoLogo" "true"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
# Insert Clocks lines here if appropriate
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Compiz works out-of-the-box with Ubuntu (I've just switched from Ubuntu to Gentoo), but it seems I can't make it work in gentoo :(

Any idea? Thanks in advance!
Back to top
View user's profile Send private message
EgonVLC
n00b
n00b


Joined: 13 Jun 2005
Posts: 14

PostPosted: Sun Nov 16, 2008 10:35 pm    Post subject: Reply with quote

I solved it!!

I had to pass "ccp" as parameter when lauching compiz... ¿Any way to do it automaticaly?
Back to top
View user's profile Send private message
jcat
Veteran
Veteran


Joined: 26 May 2006
Posts: 1337

PostPosted: Mon Nov 17, 2008 12:38 pm    Post subject: Reply with quote

I use "fusion-icon" to launch and manage Compiz. You can get it from the Desktop-Effects overlay.



Cheers,
jcat
Back to top
View user's profile Send private message
EgonVLC
n00b
n00b


Joined: 13 Jun 2005
Posts: 14

PostPosted: Mon Nov 17, 2008 2:54 pm    Post subject: Reply with quote

I don't use to play on linux, so I'd like to have compiz on all time. That's how it was on my previous Ubuntu. I've edited /gnome/session/required/windowmanager with gconfeditor, changing metacity for compiz, but it doesn't work: I've edited directly /usr/bin/gnome-wm adding "ccp" param too but still no luck. The only way I've succeded has being adding a entry in "sessions" under gnome adminstrator: "compiz --replace ccp", and it works, but it loads metacity first and then compiz, and gnome load time is thus longer. I'd like to load only compiz... ¿Any clue?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum