Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't see the x11 overlay
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
XrateR
Apprentice
Apprentice


Joined: 18 Nov 2005
Posts: 164
Location: Sweden

PostPosted: Wed Nov 19, 2008 6:23 pm    Post subject: Can't see the x11 overlay Reply with quote

Hello,
I have just installed layman but when I run layman -L I don't get the x11 overlay.
First I only got one layer but after emerge subversion I got some more. But not x11.

Is there some more then subversion to emerge to get all available overlay:s?
(my list is 56 layers long atm)

\\ xrater
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Wed Nov 19, 2008 6:33 pm    Post subject: Reply with quote

x11 is using git not svn so you must also emerge git - this took me a while to ;]
Back to top
View user's profile Send private message
XrateR
Apprentice
Apprentice


Joined: 18 Nov 2005
Posts: 164
Location: Sweden

PostPosted: Wed Nov 19, 2008 6:39 pm    Post subject: Reply with quote

szczerb wrote:
x11 is using git not svn so you must also emerge git - this took me a while to ;]

Thanks! Yeah I understand that, but what is Gentoo. You must work for it in order to deserve it.
:P

Edit: Now I can see x11 but when I try to "add" it I get this:
Code:
exie ~ # layman -a x11
* Running command "/usr/bin/git clone "git://git.overlays.gentoo.org/proj/x11/" "/usr/portage/local/layman/x11""...
/usr/bin/git: warning: invalid extra options ignored

GNU Interactive Tools 4.3.20 (i686-pc-linux-gnu), 19:42:41 Nov 19 2008
GIT is free software; you can redistribute it and/or modify it under the
terms of the GNU General Public License as published by the Free Software
Foundation; either version 2, or (at your option) any later version.
Copyright (C) 1993-1999 Free Software Foundation, Inc.
Written by Tudor Hulubei and Andrei Pitis, Bucharest, Romania

/usr/bin/git: fatal error: `chdir' failed: permission denied.
* Failed to add overlay "x11".
* Error was: Directory /usr/portage/local/layman/x11 does not exist. Cannot remove the overlay!

I emerge app-misc/git and not dev-util/git, was that wrong? It looks like dev-util/git needs a lot of deps.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum