Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with adding a repository to layman [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
sts
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jul 2007
Posts: 97

PostPosted: Thu Nov 20, 2008 2:29 am    Post subject: Problem with adding a repository to layman [solved] Reply with quote

I'm trying to manage steev's e repository with laymen. It is located here:
git://github.com/steev/e.git

I can manually pull it using git.

However, when I do 'layman -s e' I get an error:
Quote:
* Running command "cd "/usr/portage/local/layman/e" && /usr/bin/git pull"...
fatal: Not a git repository
*
* Errors:
* ------
*
* Failed to sync overlay "e".
* Error was: Syncing overlay "e" returned status 32768!


Which is odd, since it is demonstrably a git repository.

Here's the overlay file I am using:
my-overlays.xml
Code:
<?xml version="1.0" ?>
<layman>
  <overlay
    type = "git"
    src  = "git://github.com/steev/e.git"
    contact = "steev@gentoo.org"
    status = "official"
    name = "e">

    <description>
        Experimental overlay for up to date e packages.
    </description>
  </overlay>

</layman>


Last edited by sts on Thu Nov 20, 2008 1:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Thu Nov 20, 2008 12:41 pm    Post subject: Reply with quote

Try removing and re-adding the overlay.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
sts
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jul 2007
Posts: 97

PostPosted: Thu Nov 20, 2008 1:24 pm    Post subject: Reply with quote

That worked, thanks. Does that mean I had something mis-configured when I added it the first time?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum