Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UPDATE] Getting higher refresh rates using vesafb driver
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 12, 13, 14  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
neenee
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1786

PostPosted: Tue Dec 23, 2003 12:50 pm    Post subject: Reply with quote

love-sources had this patch in place, and i
have suggested adding it again in the love1
thread, but so far no dice it seems.

time shall tell :wink:

*update* it's back in.. and there was much rejoicing :wink:
Back to top
View user's profile Send private message
d3vlin
Tux's lil' helper
Tux's lil' helper


Joined: 02 Apr 2003
Posts: 134
Location: The Hague

PostPosted: Fri Jan 16, 2004 2:11 pm    Post subject: Reply with quote

hello all, I am trying to get my linux-2.6.1-r1 (gentoo-dev-sources) 1280x1024@60Hz framebuffer/bootsplash to run at a higher refresh rate. I installed the patch according to the howto and that went just fine.

I am running a Geforce3Ti500 on a iiyama A901HT (19') monitor.
According to the specs it can do:
hsync: 27-115 kHz
vrefresh: 50-160 kHz
bandwith: 230
The ergonomic resolution of this monitor is 1280 x 1024 @ 107Hz, according to the manual. This would be a very nice framebuffer res. I think :)

I have been trying around with the script to set these values, but somehow it always messes up and comes up with inapropriate monitor settings.
I am booting the patched kernel with vga=0x51A in lilo.

I run my Xfree (kde powered) in 1600x1200@85 Hz (fH=106KHz, fV=85kHz).
I tried to run xvidtune, but when I run 1280x1024 in Xfree, I have a screen that is not aligned with the borders of the physical screen, i.e. the desktop scrolls (because it is larger than the physical area). According to the OSD menu of the monitor it then runs 1280x1024@86Hz.

I wonder if someone has the same config or problem, after rebooting about 40 times, any help is appreciated. Thanks.
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Fri Jan 16, 2004 3:08 pm    Post subject: Reply with quote

try this modeline for your 1280x1024@85Hz Xfree setting.
Code:
Modeline "1280x1024"  159.36  1280 1376 1512 1744  1024 1025 1028 1075  -HSync +Vsync


this for 1600x1200@85:
Code:

 Modeline "1600x1200"  234.76  1600 1720 1896 2192  1200 1201 1204 1260  -HSync +Vsync



For your vesafb_modes.h file put this one:

Code:

# 1280x1024 @ 100.00Hz
        .word   1760, 1376, 1520
        .word   1085, 1025, 1028
        .byte   0
        .long   190960000
        .word   10000
        .space  40


make bzImage and try again.

Btw, is these patches working again on =>2.6.1 again ?
Last time i tried was on 2.6.0 and there it didnt work anymore.
:roll:
Hope it Helps-
_________________
linux: #232767
Back to top
View user's profile Send private message
d3vlin
Tux's lil' helper
Tux's lil' helper


Joined: 02 Apr 2003
Posts: 134
Location: The Hague

PostPosted: Fri Jan 16, 2004 5:19 pm    Post subject: Reply with quote

flawless!!! :)

running 1280x1024@100Hz SXGA now
(fH=108 kHz fV=100 kHz)
on a (gentoo-dev-sources) 2.6.1-gentoo-r1 kernel

looks awesome. I wonder how you got these values.

Is it also possible to stretch the display to 1600x1200 as mentioned in a post somewhere earlier? (i.e. override 1280x1024 as a 1600x1200 mode)
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Fri Jan 16, 2004 5:37 pm    Post subject: Reply with quote

Ive tried 1600x1200 but didnt work out so well.
Now I havent been using framebufer because it stop working some time ago, but since you say it works on 2.6.1 i might try again at some time... dont fell like rebooting now .
maybe i wait until 2.6.2 :)

I just made those lines using that xvidconfig tool , used 1280x1024 @ 100hz on the X server and then made my own vesa_rates.h file.
_________________
linux: #232767
Back to top
View user's profile Send private message
d3vlin
Tux's lil' helper
Tux's lil' helper


Joined: 02 Apr 2003
Posts: 134
Location: The Hague

PostPosted: Fri Jan 16, 2004 5:52 pm    Post subject: Reply with quote

thanks a lot.
actually I saw that there are config files and images provided for 1600x1200 already in /etc/bootsplash/gentoo.
quite strange if there's no default 1600x1200 vesa framebuffer mode?
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Fri Jan 16, 2004 5:56 pm    Post subject: Reply with quote

I think thats because, like someone else pointed out somewhere in this tread, that 1600x1200 isnt a vesa standard resolution.

But you can try to trick it, just delete the 1280x1024 block and insert a 1600x1200 one.

then it might work.. that was what I was trying to do.
_________________
linux: #232767
Back to top
View user's profile Send private message
d3vlin
Tux's lil' helper
Tux's lil' helper


Joined: 02 Apr 2003
Posts: 134
Location: The Hague

PostPosted: Sat Jan 17, 2004 3:37 am    Post subject: Reply with quote

btw, I had some very strange results on my 15" UXGA (1600x1200 capable, radeon M9000 driven) laptop screen when using bootsplash. While framebuffer has always worked there (1280x1024), the screen turns all white and blurry when using bootsplash. Could it be that that's todo with the bootsplash refresh rate opposed to just framebuffer or something? Looking for solutions here.
Back to top
View user's profile Send private message
danone
Guru
Guru


Joined: 18 Jan 2004
Posts: 398
Location: Germany

PostPosted: Mon Jan 19, 2004 6:05 pm    Post subject: XDM and Gnome Reply with quote

The patch also works at my 2.6.1 kernel gentoo-dev-sources-r1
i use 1280x1024 @ 85hz

My monitor specs are
Hsync max:42~97khz
Vsync:max 40-160hz
Bandwith: 156.50Mhz

and use the GeForce T4200@64MB

so far it works fine but when i start xdm i must go of OSD an must correct position and gemometrie and if i do so i must do it on boot again my video_modes.h settinge are:
Code:
# 800x600 @ 150Hz
        .word   1128, 848, 1048
        .word   640, 614, 614
        .byte   0
        .long   108288000
        .word   15000
        .space  40

# 1024x768 @ 118.81Hz
        .word   1416, 1080, 1320
        .word   808, 782, 782
        .byte   0
        .long   135936000
        .word   11881
        .space  40

# 1280x1024 @ 85.26Hz
        .word   1736, 1344, 1624
        .word   1064, 1038, 1038
        .byte   0
        .long   157500000
        .word   8526
        .space  40

Also when i set to grub.conf vga=0x51B does not work but why? 0x51 works
well will try now this on X11
"1280x1024" 157.50 1280 1344 1504 1728 1024 1025 1028 1072 +hsync +vsync
Back to top
View user's profile Send private message
Cossins
Veteran
Veteran


Joined: 21 Mar 2003
Posts: 1136
Location: Copenhagen, Denmark

PostPosted: Wed Jan 21, 2004 7:54 pm    Post subject: Reply with quote

How do I figure out the proper numbers for vesafb_modes.h if I want 1600x1200@85Hz?

- Simon
_________________
who cares
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Wed Jan 21, 2004 8:08 pm    Post subject: Reply with quote

Hejza.
Thats described somewhere in this tread or one of the others treads about framebuffer.

i cant remember off hand, let me see if i can find it before you do.
_________________
linux: #232767
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Wed Jan 21, 2004 8:10 pm    Post subject: Reply with quote

[edit]
nevermind ....
didnt pay attention you mean 1600x1200 .. Good Luck , let me know when you did it.
I want also .
_________________
linux: #232767
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Wed Jan 21, 2004 8:32 pm    Post subject: Reply with quote

well .. try the following.

:twisted:
Code:

# 800x600 @ 170Hz
        .word   1128, 848, 1048
        .word   640, 614, 614
        .byte   0
        .long   122726400
        .word   17000
        .space  40

# 1024x768 @ 136.13Hz
        .word   1416, 1080, 1320
        .word   808, 782, 782
        .byte   0
        .long   155760000
        .word   13613
        .space  40

# 1600 x 1200 @ 85.00Hz
        .word   2160, 1664, 1856
        .word   1250, 1201, 1204
        .byte   0
        .long   22950000
        .word   8500
        .space  40



template:

From Xvidtune you get a Modeline like this:
Code:
"1600x1200"   229.50   1600 1664 1856 2160   1200 1201 1204 1250 +hsync +vsync

That translates to:
Code:

"1600x1200" Clock 1 2 3 4   5 6 7 8 +hsync +vsync

so
Code:

# 1600X1200 @ XX.00Hz
        .word   4, 2, 3  <-  replace each char with the numbers from the modeline.
        .word   8, 6, 7 <- same thing here
        .byte   0
        .long   229500000  <--Pixel clock
        .word   85000   <--- Refresh rate
        .space  40


Thats it.
_________________
linux: #232767
Back to top
View user's profile Send private message
Cossins
Veteran
Veteran


Joined: 21 Mar 2003
Posts: 1136
Location: Copenhagen, Denmark

PostPosted: Wed Jan 21, 2004 8:50 pm    Post subject: Reply with quote

ikaro: Thanks!
Actually, my output from xvidtune is exactly the same as yours...

So am I just supposed to set the vga-argument in grub.conf to the 1280x1024 setting?

- Simon
_________________
who cares
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Wed Jan 21, 2004 9:26 pm    Post subject: Reply with quote

no . the 1600x1200 one.
_________________
linux: #232767
Back to top
View user's profile Send private message
Cossins
Veteran
Veteran


Joined: 21 Mar 2003
Posts: 1136
Location: Copenhagen, Denmark

PostPosted: Wed Jan 21, 2004 9:33 pm    Post subject: Reply with quote

ikaro wrote:
no . the 1600x1200 one.

...yes, which would be on 0x51B, where 1280x1024 used to be, right?

- Simon
_________________
who cares
Back to top
View user's profile Send private message
Cossins
Veteran
Veteran


Joined: 21 Mar 2003
Posts: 1136
Location: Copenhagen, Denmark

PostPosted: Wed Jan 21, 2004 9:45 pm    Post subject: Reply with quote

Argh, I'm having problems.
I can't set vga=0x51B, because then the kernel complains that that setting isn't supported. The I tried replacing the 800x600 values with the 1600x1200 values in video.S - when I boot the kernel (after of course recompiling), I get a black screen. The kernel boots, and I can log in to X and fetch this dmesg output:
Code:
vesafb: framebuffer at 0xd0000000, mapped to 0xf0807000, size 16384k
vesafb: mode is 800x600x32, linelength=3200, pages=1
vesafb: protected mode interface info at c000:f290
vesafb: scrolling: redraw
vesafb: directcolor: size=8:8:8:8, shift=24:16:8:0
fb0: VESA VGA frame buffer device


My graphics card is a GeForce4 MX440 with 64 Mb RAM - maybe it isn't VESA (or whatsitcalled) 3.0 compatible?

- Simon
_________________
who cares
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Wed Jan 21, 2004 11:08 pm    Post subject: Reply with quote

should be, mine is Gforce 2GTS.
But 1600x1200 isn't a VESA standard Resolution ( someone else mentioned this before )
_________________
linux: #232767
Back to top
View user's profile Send private message
neenee
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1786

PostPosted: Fri Jan 23, 2004 12:54 pm    Post subject: Reply with quote

though i do get 1024x768 resolution, my refresh rate
is back to 60Hz, even though i did not modify my mode-
file for this hack.

perhaps someone can tell me what i am doing wrong?

my modeline, as provided by xvidtune:

Code:
"1024x768"     98.97   1024 1072 1312 1408    768  770  782  808


what i have in my vesafb_modes.h file:

Code:
# 1024x768 @ 86.99Hz
       .word   1408, 1072, 1312
       .word   808, 770, 782
       .byte   0
       .long   98970000
       .word   86990
       .space  40


thanks in advance.
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Fri Jan 23, 2004 2:49 pm    Post subject: Reply with quote

neenee wrote:
though i do get 1024x768 resolution, my refresh rate
is back to 60Hz, even though i did not modify my mode-
file for this hack.

perhaps someone can tell me what i am doing wrong?

my modeline, as provided by xvidtune:

Code:
"1024x768"     98.97   1024 1072 1312 1408    768  770  782  808


what i have in my vesafb_modes.h file:

Code:
# 1024x768 @ 86.99Hz
       .word   1408, 1072, 1312
       .word   808, 770, 782
       .byte   0
       .long   98970000
       .word   86990
       .space  40


thanks in advance.



try this:
Code:
# 1024x768 @ 86.99Hz
       .word   1408, 1072, 1312
       .word   808, 770, 782
       .byte   0
       .long   989700000  <- was missing a 0
       .word   86990
       .space  40


if it doesnt work, you can try setting the clock a bit down, and roudup the refresh rate to 85.00 ( .word 85000 )
_________________
linux: #232767
Back to top
View user's profile Send private message
neenee
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1786

PostPosted: Fri Jan 23, 2004 4:53 pm    Post subject: Reply with quote

i tried lowering the pixel clock and
lowering the refresh rate to 85Hz.
i also tried loweing the bitdepth
using the kernel line option.

my framebuffer stays at 60Hz :|

suggestions are welcome.
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Fri Jan 23, 2004 5:25 pm    Post subject: Reply with quote

which kernel ?
and I assume you have patched the kernel with the bootsplash and the his-res patches and everything applied clean.

and that you configured your kernel to use framebuffer using the VESA driver and not using any RIVA and not using 16 bit Frammebuffer.

some more details please.
_________________
linux: #232767
Back to top
View user's profile Send private message
neenee
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1786

PostPosted: Fri Jan 23, 2004 8:53 pm    Post subject: Reply with quote

i use love-sources which includes the vesafb patch.
i do not use bootsplash, even though i can enable
it in love-sources.

i have my kernel configured properly, as described
at the start of this thread.

i have used this configuration with previous kernels,
and somewhere along the line i had and lost a proper
refresh rate with the framebuffer.

i have added "video=ywrap,mttr vga=0x517" to
my kernel line in grub.conf
Back to top
View user's profile Send private message
neenee
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1786

PostPosted: Mon Feb 09, 2004 2:51 pm    Post subject: Reply with quote

*shameless bump*
Back to top
View user's profile Send private message
Proton
Apprentice
Apprentice


Joined: 16 Mar 2003
Posts: 195
Location: Estoril, Portugal

PostPosted: Tue Feb 10, 2004 1:21 pm    Post subject: Reply with quote

I can't seem to get it working :(

My xvidtune reports the same exact settings as Borisdigital back one page, I use the exact same settings as him in the .h file and nothing...

I'm using love-sources, so it should work...
_________________
Sérgio @ Portugal
IST - LEIC
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 12, 13, 14  Next
Page 7 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum