Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UPDATE] Getting higher refresh rates using vesafb driver
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 12, 13, 14  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
linP
n00b
n00b


Joined: 12 Apr 2004
Posts: 18

PostPosted: Fri May 07, 2004 1:37 pm    Post subject: Reply with quote

EMac

I to :(

I have a Gentoo, with gentoo-dev-sources ( kernel 2.6.6-rc1 & LILO),Nvidia GeForce 2 MX 100/200 32 MB , Samsung 765 MB khz 30-85; hz 50-160 !
My Monitor can do a 1024*786*110HZ , but i have a trouble with :

Code:
 

* chmod u+x /usr/src/linux/scripts/vesa_modeline_gen.pl
* /usr/src/linux/scripts/vesa_modeline_gen.pl
* Syntax errrot at  /usr/src/linux/scripts/vesa_modeline_gen.pl line 152 near "print"
* execution  /usr/src/linux/scripts/vesa_modeline_gen.pl  aborted due to  compiliaton errors !

Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Sat May 08, 2004 5:52 pm    Post subject: Reply with quote

linP wrote:

Code:
 
* chmod u+x /usr/src/linux/scripts/vesa_modeline_gen.pl
* /usr/src/linux/scripts/vesa_modeline_gen.pl
* Syntax errrot at  /usr/src/linux/scripts/vesa_modeline_gen.pl line 152 near "print"
* execution  /usr/src/linux/scripts/vesa_modeline_gen.pl  aborted due to  compiliaton errors !


Right, there was a syntax error in the Perl script. I'm sorry I wasn't able to fix it earlier, but I was away from home for two weeks. I've just uploaded an updated version of the patch, just redownload the tar.bz2 file and everything should be fine :)
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
blue.sca
l33t
l33t


Joined: 28 Aug 2003
Posts: 680
Location: Mainz, Germany

PostPosted: Wed May 12, 2004 6:51 am    Post subject: Reply with quote

weird, getting a non-vesa 1600x1200 fb to work perfectly, but changing to vesa, the display is a little darker than normal and the whole screen is a little shifted, so i cant see the command prompt (nothing to do with my monitor settings, i can move them along, but no prompt).
im using iiyama provision 454, the same xvidtune-output as ikaro and and same result with any setting in vesa_modelines.h...

did anybody get a 1600x1200 vesafb to work with this settings, or does anybody know a solution? thx in advance...
_________________
geek by nature, linux by choice
i want my avatar back... thank you
:wq
Back to top
View user's profile Send private message
Ard Righ
Guru
Guru


Joined: 24 Jun 2002
Posts: 337
Location: Wellington, NZ

PostPosted: Fri May 14, 2004 1:14 am    Post subject: Reply with quote

linP wrote:
Code:
* chmod u+x /usr/src/linux/scripts/vesa_modeline_gen.pl
* /usr/src/linux/scripts/vesa_modeline_gen.pl
* Syntax errrot at  /usr/src/linux/scripts/vesa_modeline_gen.pl line 152 near "print"
* execution  /usr/src/linux/scripts/vesa_modeline_gen.pl  aborted due to  compiliaton errors !


Ard Righ wrote:
First, I got an "execution error" due to a typo in the patch I downloaded today. The 2nd to last line where is has
Code:
`ln -s $path/arch/i386/boot/vesafb_modes.h $path/arch/x86_64/boot/vesagb_modes.h`

Needs a semi-colon at the end of it :)


I hate quoting myself, but that the error you ran into is fixed by my note above.
Back to top
View user's profile Send private message
Assgier
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2003
Posts: 127
Location: Europe -> Netherlands -> Utrecht -> Amersfoort

PostPosted: Thu May 20, 2004 6:27 am    Post subject: Reply with quote

thanks for this nice howto, at first i had some trouble getting the good modes (i wanted to put the monitor on 100Hz @ 1280x1024, because it can handle that, but X will not go any further as 85Hz (85.02 to be exact))...

Well anyways, at some time i decided to let the 100Hz thing go for now and just try to get this "hack" running on 85Hz... It worked out great, i now have bootsplash running together with this "hack" :D

Before i start explaining what steps i have run trough, i will list my hardware:

Screen: IIyama HM903DT (Vision Master Pro 454)
Videocard: Asus V8440 (GeForce 4 Ti4400, 128 MB)

Should anyone have a good ModeLine for X (for getting the monitor to run @ 100Hz on 1280x1024) or a good vesafb_modes.h entry, please let me know, thanks in advance :D

Ok so here's what i have done to make it work, all this on vanilla kernel 2.6.6 (ACCEPT_KEYWORDS="~x86" emerge development-sources).

After making bootsplash to work, i toke a look into xvidtune:

http://members1.chello.nl/~p.pieters6/pics/xvidtune.png

After that i used the red circled information with the perl script provided by the patch where this topic is all about so that i would get the exact same refreshrate as i have in X so that the monitor doesn't have to recalibrate each time i switch from X to a tty.

Then i checked if it worked, and it did :)

Quote:

# 1280x1024 @ 85.02Hz
.word 1736, 1344, 1624
.word 1064, 1038, 1038
.byte 0
.long 157040782.08
.word 8502
.space 40

as you can see, exactly 85.02Hz, just like X ;)

After that i compiled the kernel (make), which gave a few errors (ignored lines in the vesafb_modes.h file), i decided to ignore them for now, "i'll have a look on those should it not work as it is now"... Put the bzImage file in it's correct place, and editted grub.conf as following:

Quote:

title=Linux Gentoo 2.6.6 met vesahack
root (hd0,1)
kernel=(hd0,1)/Gentoo266_vesa root=/dev/hda4 video=vesafb:ywrap,mtrr vga=0x51A splash=silent
initrd=/boot/gentoo.initrd


I rebooted and... voila, it just worked, a nice bootsplash at 85.02Hz :D

Thanks once again for this great patch 8)
_________________
8)


Last edited by Assgier on Fri May 21, 2004 8:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
garo
Bodhisattva
Bodhisattva


Joined: 15 Jul 2002
Posts: 860
Location: Edegem,BELGIUM

PostPosted: Fri May 21, 2004 2:40 pm    Post subject: Reply with quote

spock_ wrote:
Unmount /boot, reboot and enjoy your framebuffer console at a high refresh rate. Mine is running perfectly in 1024x756 @ 85Hz


756 ? strange resolution... :wink:

Btw, i have a problem.I tried the patch and used the xvidtune output:
Code:
"1024x768"     94.50   1024 1072 1168 1376    768  769  772  808 +hsync +vsync

to make this "/usr/src/linux/arch/i386/boot/vesafb_modes.h":
Code:
#define VIDEO_VESAFB_CRTC_DATA

# 1024x768 @ 85.00Hz
        .word   1376, 1072, 1168
        .word   808, 769, 772
        .byte   0
        .long   94500000
        .word   8500
        .space  40


I work in X with 1024x768 at 85hz. But if i recompile my kernel and reboot (i changed the grub settings from 0x317 to 0x517) then i get 1024x768 at 83 and a bit hertz in the framebuffer and a very narrow screen.
_________________
My favorite links this month:
- Surf Random
- Web-based SSH
- Stop Spam
Back to top
View user's profile Send private message
`VL
n00b
n00b


Joined: 30 Apr 2004
Posts: 71
Location: Russia

PostPosted: Sun May 23, 2004 8:03 am    Post subject: vesa_modeline_gen.pl script loops forever Reply with quote

I have ViewSonic PF775 monitor with such capabilities:

VertRefresh 50-180Hz
HorizSync 30-97kHz
Bandwidth 200MHz

When entering this parameters to script,it loops forever and so doesn`t generate file with modelines..

i tested with 2.4 kernels and 2.6,result is the same..
Back to top
View user's profile Send private message
Assgier
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2003
Posts: 127
Location: Europe -> Netherlands -> Utrecht -> Amersfoort

PostPosted: Tue May 25, 2004 12:57 pm    Post subject: Reply with quote

garo wrote:
spock_ wrote:
Unmount /boot, reboot and enjoy your framebuffer console at a high refresh rate. Mine is running perfectly in 1024x756 @ 85Hz


756 ? strange resolution... :wink:

Btw, i have a problem.I tried the patch and used the xvidtune output:
Code:
"1024x768"     94.50   1024 1072 1168 1376    768  769  772  808 +hsync +vsync

to make this "/usr/src/linux/arch/i386/boot/vesafb_modes.h":
Code:
#define VIDEO_VESAFB_CRTC_DATA

# 1024x768 @ 85.00Hz
        .word   1376, 1072, 1168
        .word   808, 769, 772
        .byte   0
        .long   94500000
        .word   8500
        .space  40


I work in X with 1024x768 at 85hz. But if i recompile my kernel and reboot (i changed the grub settings from 0x317 to 0x517) then i get 1024x768 at 83 and a bit hertz in the framebuffer and a very narrow screen.

try your xvidtune output on the perl script coming with this patch, i couldn't use the xvidtune output directly with the vesafb_modes.h file as well, but when i used it with the perl script, it worked fine :)
_________________
8)
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Sun Jun 13, 2004 2:38 pm    Post subject: Reply with quote

Ok people, vesafb-tng has just been released! :) Forget the modeline_gen script, forget the recompilations and forget manual editing of the the code!

I encourage all of you who had problems with the vesafb-rrc patch to try vesafb-tng (more info on http://dev.gentoo.org/~spock/#vesafb-tng).
Even if you didn't have any problems with the old patch - please test the new one, as the old one has just become obsolete and as the new one has a lot more features and is much easier to use.

I've tested the code on my system and it works fine. Other than that - it's untested. Your help in finding the bugs and making it better will be greatly appreciated.
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
dec
n00b
n00b


Joined: 18 Jul 2003
Posts: 63

PostPosted: Tue Jun 15, 2004 9:47 am    Post subject: Reply with quote

Any reports on how this new code works? :)

-dec
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Tue Jun 15, 2004 1:30 pm    Post subject: Reply with quote

dec wrote:
Any reports on how this new code works? :)

So far I've heard from about 10 happy users and from 1 user for whom vesafb-tng doesn't work (he has a Voodoo 3 gfx board). The problem he experiences is being worked on now and it'll hopefully be gone in a few days. All in all, it seems it's pretty safe to use vesafb-tng. Please remember to let me know about your results if you decide to give it a try :)
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
Zaqh
n00b
n00b


Joined: 28 Jan 2004
Posts: 17

PostPosted: Tue Jun 15, 2004 3:01 pm    Post subject: Reply with quote

Working nice here. I have some problems with patch because of bootsplash patch, but i could solve it. Runing at 1024x768-16@70 (bootsplash doesn't work with 24 or 32 :? )
Back to top
View user's profile Send private message
boris64
Veteran
Veteran


Joined: 04 Oct 2003
Posts: 1770
Location: vechelde / peine

PostPosted: Tue Jun 15, 2004 3:24 pm    Post subject: Reply with quote

seems to work nice here.

just one thing, that looks kind of funny.
when the kernel boots and loads the vesafb-driver,
everything before the vesafb driver output lines
Code:
...
vesafb: NVIDIA Corporation, NV28 Board, Chip Rev A0 (OEM: NVIDIA)
...
fb0: VESA VGA frame buffer device

is shown as white blocks and the text becomes unreadable
(is anyone here able to read white text on white background :))

i wish i had a digicam, so i could take a picture ;P
_________________
boris64.net 200x / visit my desktop / try these tiny kernel patches ;)
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Tue Jun 15, 2004 7:18 pm    Post subject: Reply with quote

borisdigital wrote:
when the kernel boots and loads the vesafb-driver,
everything before the vesafb driver output lines
is shown as white blocks and the text becomes unreadable
(is anyone here able to read white text on white background :))


Quote from my page:
NOTE: The white rectangle that appears after loading the driver is not a vesafb bug. Please do not report it to me. This is a known bug in the fbcon code, a fix for it already exists and it will hopefully be included in the future versions of the Linux kernel.

borisdigital wrote:
i wish i had a digicam, so i could take a picture ;P

No need to, everyone will be able to see it when they install vesafb-tng ;)

Anyway, thanks for the it-works report :)
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
boris64
Veteran
Veteran


Joined: 04 Oct 2003
Posts: 1770
Location: vechelde / peine

PostPosted: Tue Jun 15, 2004 9:11 pm    Post subject: Reply with quote

lol, :P
sorry for not reading your manual hard enough :oops:

of course your patch works fine here :)
_________________
boris64.net 200x / visit my desktop / try these tiny kernel patches ;)
Back to top
View user's profile Send private message
Brazil
Tux's lil' helper
Tux's lil' helper


Joined: 08 Apr 2003
Posts: 117
Location: Los Angeles, California

PostPosted: Tue Jun 15, 2004 10:51 pm    Post subject: Reply with quote

Can I finnaly put 1920x1200@85Hz for my nvidia card, or is this just probing and preparing the modes available for the fb driver?

I want my widescreen monitor to work in vesa damnit!

-Brazil
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Wed Jun 16, 2004 5:54 pm    Post subject: Reply with quote

Brazil wrote:
Can I finnaly put 1920x1200@85Hz for my nvidia card, or is this just probing and preparing the modes available for the fb driver?
I want my widescreen monitor to work in vesa damnit!

The driver gets a mode list (you can then see a list of all available modes in /proc/fb0/modes) from the VESA BIOS. If your BIOS provides a 1920x1200 mode - then sure, you can. If it doesn't - well, there's not much that can be done with vesa. It might be better to switch to a driver made specifically for your type of graphic board (rivafb for example, if you're using a nVidia board).
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
Pubare
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2003
Posts: 81
Location: Lafayette, LA

PostPosted: Sat Jun 19, 2004 8:34 pm    Post subject: Reply with quote

Vesafb-tng doesn't seem to be working for me... I'm using ck-sources 2.6.7-r1 on a Via MVP3 motherboard with a Geforce2MX-200. Same basic kernel config as used with the vesafb-rrc patch on kernel 2.6.4-ck2, which works wonderfully (thanks for the great patches) - agpgart is built as module with no other fb devices. Kernel command line in grub is:

kernel /kernel-2.6.7-ck1 root=/dev/ram0 init=/linuxrc real_root=/dev/hdg3 theme=NewTux splash=silent video=vesa:ywrap,mtrr,1280x1024-16@85 reboot=w

This is the same mode I use (via the vga=0x51A parameter) with the -rrc without issue. I've tried stepping it down to 1024x768-16@60 and even eliminating the modeline all together without luck. It displays the following, then the boot process stops:

vesafb: NVidia Corporation, NV11 Board, Chip Rev B2
vesafb: VBE version: 3.0
vesafb: pmi: set display start = c00cc355, set palette = c00cc3da
vesafb: pmi: ports = [long range of ports I didn't feel like writing down]
vesafb: hardware supports DCC2 transfers

At this point I have to powercycle the PC, as it just stays there indefinitely. Thoughts, suggestions, or fixes?

...and thanks for the great work on the patches. I _like_ having a readable console without eye-strain.
Back to top
View user's profile Send private message
bobby p rajan
n00b
n00b


Joined: 19 Nov 2003
Posts: 2
Location: India

PostPosted: Sun Jun 20, 2004 4:52 am    Post subject: Reply with quote

Quote:

Vesafb-tng doesn't seem to be working for me... I'm using ck-sources 2.6.7-r1 on a Via MVP3 motherboard with a Geforce2MX-200. Same basic kernel config as used with the vesafb-rrc patch on kernel 2.6.4-ck2, which works wonderfully (thanks for the great patches)


i am having exactly the same problem, the rrc patch is working fine with 2.6.7-rc3-mm1 on my pc. i am using mm-sources-2.6.7-rc3-mm2. the card is a ge-force-4 mx-440 with 64 mb.

i am willing to do any testing to make this work

bobby
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Sun Jun 20, 2004 11:16 am    Post subject: Reply with quote

Pubare wrote:

vesafb: NVidia Corporation, NV11 Board, Chip Rev B2
vesafb: VBE version: 3.0
vesafb: pmi: set display start = c00cc355, set palette = c00cc3da
vesafb: pmi: ports = [long range of ports I didn't feel like writing down]
vesafb: hardware supports DCC2 transfers

At this point I have to powercycle the PC, as it just stays there indefinitely. Thoughts, suggestions, or fixes?

It seems it hangs while trying to get EDID data. You can try the 'noedid' option - edit your kernel param line to:
Code:
kernel /kernel-2.6.7-ck1 root=/dev/ram0 init=/linuxrc real_root=/dev/hdg3 theme=NewTux splash=silent video=vesa:ywrap,mtrr,noedid,1280x1024-16@85  reboot=w
and see if this changes anything.

BTW, it would be best to test vesafb-tng on vanilla kernel sources (ie. sys-kernel/development-sources) - one can never be sure if there isn't something in -ck or -mm that affects how vesafb-tng works.
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
rc
Apprentice
Apprentice


Joined: 16 Dec 2003
Posts: 234

PostPosted: Sun Jun 20, 2004 12:21 pm    Post subject: Reply with quote

Hi,
this maybe kinda OT but i want to give some feedback.
Im running Archlinux rightnow and your patch is working well with selfcompiled 2.6.4 and 2.6.7 Kernels.
Im using 1024x768@85Hz for my console.
To calculate apropriate settings with the script i used my regular monitor timings, but for the horizontal frequence i used 68khz.
Why 68khz ?
My X resolution is 1280x1024@85Hz wich results in 91khz horizontal frequency (i can check this in my monitors osd).
So i divided 91khz by 1024 and multiplied the result with 768. The result was 68250Hz.
I rounded this down to 68khz.
And with these settings my console runs fine at the desired resolution.
Maybe a bit complicated, but for me it was the easiest solution (didn't want to edit some files).

greetings,
rc
Back to top
View user's profile Send private message
zidour
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 103

PostPosted: Sun Jun 20, 2004 5:41 pm    Post subject: problems with vesa-tng Reply with quote

I run gentoo with framebuffer console support. Recently I upgraded kernel to version 2.6.7 and tried to patch kernel with vesafb-tng patch.

Here is the code:
Code:

[19:13 root@fagot /usr/src/linux]# bzip2 -dc /usr/src/linux/vesafb-tng-0.9-rc1-2.6.7.patch.bz2 | patch -p1
patching file arch/i386/boot/video.S
patching file Documentation/fb/vesafb.txt
patching file drivers/video/fbmem.c
patching file drivers/video/Kconfig
patching file drivers/video/Makefile
Hunk #1 succeeded at 44 (offset 1 line).
patching file drivers/video/vesafb.c
Hunk #6 FAILED at 245.
Hunk #7 succeeded at 471 (offset 3 lines).
Hunk #8 succeeded at 498 (offset 3 lines).
Hunk #9 succeeded at 519 (offset 3 lines).
Hunk #10 succeeded at 813 (offset 3 lines).
Hunk #11 succeeded at 852 (offset 3 lines).
Hunk #12 succeeded at 882 (offset 3 lines).
Hunk #13 succeeded at 1122 (offset 3 lines).
1 out of 13 hunks FAILED -- saving rejects to file drivers/video/vesafb.c.rej
patching file drivers/video/vesafb-thread.c
patching file include/video/vesa.h


It means that patching the vesafb.c file failed, resulting in kernel that I cannot compile.

Code:

  CC      drivers/video/vesafb.o
drivers/video/vesafb.c:260: error: `vesafb_check_var' undeclared here (not in a function)
drivers/video/vesafb.c:260: error: initializer element is not constant
drivers/video/vesafb.c:260: error: (near initialization for `vesafb_ops.fb_check_var')
drivers/video/vesafb.c:263: error: `vesafb_set_par' undeclared here (not in a function)
drivers/video/vesafb.c:263: error: initializer element is not constant
drivers/video/vesafb.c:263: error: (near initialization for `vesafb_ops.fb_set_par')
drivers/video/vesafb.c:268: error: `vesafb_probe' undeclared here (not in a function)
drivers/video/vesafb.c:268: error: initializer element is not constant
drivers/video/vesafb.c:268: error: (near initialization for `vesafb_driver.probe')
drivers/video/vesafb.c:274: error: `vesafb_platform_release' undeclared here (not in a function)
drivers/video/vesafb.c:274: error: initializer element is not constant
drivers/video/vesafb.c:274: error: (near initialization for `vesafb_device.dev.release')
drivers/video/vesafb.c:275: error: initializer element is not constant
drivers/video/vesafb.c:275: error: (near initialization for `vesafb_device.dev')
drivers/video/vesafb.c: In function `vesafb_probe':
drivers/video/vesafb.c:754: warning: implicit declaration of function `vesafb_find_vbe_mode'
drivers/video/vesafb.c:772: warning: implicit declaration of function `vesafb_setup_var'
drivers/video/vesafb.c: At top level:
drivers/video/vesafb.c:558: warning: `vesafb_probe' defined but not used
make[2]: *** [drivers/video/vesafb.o] Error 1
make[1]: *** [drivers/video] Error 2
make: *** [drivers] Error 2


I'm not a linux expert, may be I am doing something completely wrong.
Can anybody help?
Back to top
View user's profile Send private message
Mr_Maniac
Guru
Guru


Joined: 10 Jun 2004
Posts: 538

PostPosted: Sun Jun 20, 2004 5:51 pm    Post subject: Reply with quote

I cannot use the vesafb_tng-Patch, too...
But the vesavb-rrc Patch works fine for the kernel 2.6.7!
_________________
Intel Core i7 6700
ASUS Z170 PRO GAMING
32 GB DDR4 RAM
GeForce GTX 1070
Gentoo Linux (most recent stable kernel - amd64)
Windows 10 x64
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Sun Jun 20, 2004 6:02 pm    Post subject: Re: problems with vesa-tng Reply with quote

zidour wrote:
I run gentoo with framebuffer console support. Recently I upgraded kernel to version 2.6.7 and tried to patch kernel with vesafb-tng patch.

Please send me drivers/video/vesafb.c.rej and I'll tell you what to do :)
Are you experiencing this problem with a vanilla (ie. development-sources) kernel?
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
rc
Apprentice
Apprentice


Joined: 16 Dec 2003
Posts: 234

PostPosted: Sun Jun 20, 2004 6:18 pm    Post subject: Reply with quote

Hi again,
tried the tng patch now and it works fine for me.
It even solved some minor problems i had.
For example it seems like i dont need that
Code:
Option      "IgnoreDisplayDevices" "TV"
in my X config file.
I installed the patch by running
Code:
bzip2 -dc vesafb-tng-0.9-rc1-2.6.7.patch.bz2 | patch -p1
in /usr/src/linux. I also copied the patch file to this position.

greetings,
rc
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 12, 13, 14  Next
Page 9 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum