Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UPDATE] Getting higher refresh rates using vesafb driver
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 9, 10, 11, 12, 13, 14  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
danone
Guru
Guru


Joined: 18 Jan 2004
Posts: 398
Location: Germany

PostPosted: Sun Jun 20, 2004 7:37 pm    Post subject: Reply with quote

Well the vesafb_tng also does not work here have a Leadtek NVidia GeforceFX 5900 and it only goes in 320x320 video mode and that at a 19"..my kernelboot params are video=vesa:ywrap,mtrr,1280x1024-16@85
tried with ypan and also no success
VGA BIOS is VBE 2/3 compatible
_________________
[:: Processor: Intel Core 2 Duo E6300 ]::[ Mainboard: ASUS P5B Deluxe ]::[ GPU: nVidia 7900GTO ::]
[:: RAM: HyperX DDR2 800 ]::[ Samsung SH-183A SATA:: CREATiVE X-Fi XtremeMusic :: ]
Back to top
View user's profile Send private message
zidour
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 103

PostPosted: Sun Jun 20, 2004 9:02 pm    Post subject: Re: problems with vesa-tng Reply with quote

spock_ wrote:

Please send me drivers/video/vesafb.c.rej and I'll tell you what to do :)
Are you experiencing this problem with a vanilla (ie. development-sources) kernel?


I am sorry, I can't send you the file at the moment. May be tomorrow.

I am experiencing this problem with gentoo-dev-sources.
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Sun Jun 20, 2004 10:00 pm    Post subject: Re: problems with vesa-tng Reply with quote

zidour wrote:
I am experiencing this problem with gentoo-dev-sources.

That explains everything. For all of you, who want to test vesafb-tng on g-d-s I've just made a special patch: http://dev.gentoo.org/~spock/projects/vesafb-tng/vesafb-tng-0.9-rc1-r1-2.6.7-gentoo.patch.bz2.
Have fun :)
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Sun Jun 20, 2004 10:32 pm    Post subject: Re: problems with vesa-tng Reply with quote

For those of you, for whom vesafb-tng doesn't work at all (you get some weird errors and a kernel hand during boot-up) - please use http://dev.gentoo.org/~spock/projects/vesafb-tng/vesafb-tng-test-20040620.patch.bz2.
This patch will increase vesafb-tng's verbosity. Please save your dmesg if possible and send it to me. I'll try to find out what's wrong and fix it.
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
s4n
n00b
n00b


Joined: 21 Jun 2004
Posts: 13

PostPosted: Mon Jun 21, 2004 3:50 pm    Post subject: Re: problems with vesa-tng Reply with quote

spock_ wrote:
zidour wrote:
I am experiencing this problem with gentoo-dev-sources.

That explains everything. For all of you, who want to test vesafb-tng on g-d-s I've just made a special patch: http://dev.gentoo.org/~spock/projects/vesafb-tng/vesafb-tng-0.9-rc1-r1-2.6.7-gentoo.patch.bz2.
Have fun :)

i applied the patch and compiled kernel without errors, system rebooted but i have still 60hz

dmesg seems fine:
vesafb: NVIDIA Corporation, NV35 Board - p177h-1n, Chip Rev (OEM:NVIDIA)
vesafb: VBE version: 3.0
vesafb: protected mode interface info at c000:f510
vesafb: pmi: set display start = c00cf546, set palette = c00cf5b0
vesafb: pmi: ports = 3b4 3b5 3ba 3c0 3c1 3c2 3c3 3c4 3c5 3c6 3c7 3c8 3c9 3cc 3ce 3cf 3d0 3d1 3d2 3d3 3d4 3d5 3da
vesafb: hardware supports DCC2 transfers
vesafb: EDID vendor sign: GSM
vesafb: monitor limits: vf = 200 Hz, hf = 107 Khz, clk = 230 Mhz
vesafb: total memory: 134217728
vesafb: scrolling: wrap using protected mode interface, yres_virtual=52428
vesafb: framebuffer at 0xf0000000, mapped to 0xe0808000, size 131072k
fb0: VESA VGA frame buffer device

while grub.conf is like this:

kernel /kernel-2.6.7-gentoo root=/dev/hda6 video=vesafb:ywrap,mtrr,1280x1024-16@85 splash=silent

i tried some other combinations but result didn't change

any ideas?
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Mon Jun 21, 2004 4:09 pm    Post subject: Re: problems with vesa-tng Reply with quote

Did vesafb-rrc work for you in the past (if you used it)? Have you tried adding 'gtf' to kernel parameters? Have you tried other modes (eg. 800x600-16@85)? Have you tried to set a mode with a higher refresh using fbset (instructions on how to do it can be found in the first post in this topic)?
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
s4n
n00b
n00b


Joined: 21 Jun 2004
Posts: 13

PostPosted: Mon Jun 21, 2004 5:26 pm    Post subject: Re: problems with vesa-tng Reply with quote

spock_ wrote:
Did vesafb-rrc work for you in the past (if you used it)? Have you tried adding 'gtf' to kernel parameters? Have you tried other modes (eg. 800x600-16@85)? Have you tried to set a mode with a higher refresh using fbset (instructions on how to do it can be found in the first post in this topic)?

yes i tried first the vesafb-rrc but it gava errors while patching :(
yes i have tried 800 and 1024 modes without any result
fbset tell me that mode is 1280x1024-85, when i start X it goes effectively to 85hz
didn't try the 'gtf' option, where do i have to put it exactly?

thx :D
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Mon Jun 21, 2004 6:01 pm    Post subject: Re: problems with vesa-tng Reply with quote

s4n wrote:
yes i tried first the vesafb-rrc but it gava errors while patching :(
yes i have tried 800 and 1024 modes without any result
fbset tell me that mode is 1280x1024-85, when i start X it goes effectively to 85hz
didn't try the 'gtf' option, where do i have to put it exactly?

You have to change your kernel parameters line to:
Code:
kernel /kernel-2.6.7-gentoo root=/dev/hda6 video=vesafb:ywrap,mtrr,gtf,1280x1024-16@85 splash=silent


As for fbset, you can try to get a framebuffer console @ 85Hz in the following way:
- boot and get a console @ 60Hz
- start X and switch to the mode you'd like to have on console
- do xvidtune -show | ./modeline2fb.pl >> /etc/fb.modes
- then, on console, execute fbset 1280x1024 - this should switch framebuffer to 1280x1024 with a higher refresh rate.

This is described in detail in the first post in this thread.
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
s4n
n00b
n00b


Joined: 21 Jun 2004
Posts: 13

PostPosted: Mon Jun 21, 2004 6:27 pm    Post subject: Re: problems with vesa-tng Reply with quote

spock_ wrote:
You have to change your kernel parameters line to:
Code:
kernel /kernel-2.6.7-gentoo root=/dev/hda6 video=vesafb:ywrap,mtrr,gtf,1280x1024-16@85 splash=silent

i did the change but no improvement in refresh rate :(

spock_ wrote:
As for fbset, you can try to get a framebuffer console @ 85Hz in the following way:
- boot and get a console @ 60Hz
- start X and switch to the mode you'd like to have on console
- do xvidtune -show | ./modeline2fb.pl >> /etc/fb.modes
- then, on console, execute fbset 1280x1024 - this should switch framebuffer to 1280x1024 with a higher refresh rate.

i tried 1280 and 1024, in both cases the screen becomes a mixture of colors, i must use 'clear' to clean the console (still 60hz btw)
Back to top
View user's profile Send private message
ixogn
n00b
n00b


Joined: 22 Jun 2004
Posts: 2

PostPosted: Tue Jun 22, 2004 4:11 am    Post subject: Reply with quote

Quote:
# Run a script to set the CRTC data (this an equivalent of XFree86 Modelines).
Code:
chmod u+x /usr/src/linux/scripts/vesa_modeline_gen.pl
/usr/src/linux/scripts/vesa_modeline_gen.pl


i've got no vesa_modeline_gen.pl in /usr/src/linux/scripts/ :oops:
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Tue Jun 22, 2004 5:46 am    Post subject: Reply with quote

ixogn wrote:
i've got no vesa_modeline_gen.pl in /usr/src/linux/scripts/ :oops:

This script is only necessary if you're using vesafb-rrc. With vesafb-tng it's not longer needed. In case you're using vesafb-tng, please follow the instructions on http://dev.gentoo.org/~spock/#vesafb-tng.
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
s4n
n00b
n00b


Joined: 21 Jun 2004
Posts: 13

PostPosted: Tue Jun 22, 2004 2:04 pm    Post subject: Re: problems with vesa-tng Reply with quote

spock_ wrote:
Did vesafb-rrc work for you in the past (if you used it)?

i retried and i successfully patched the kernel, but i still get 60hz... :(
Back to top
View user's profile Send private message
zidour
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2004
Posts: 103

PostPosted: Tue Jun 22, 2004 9:56 pm    Post subject: Re: problems with vesa-tng Reply with quote

spock_ wrote:

That explains everything. For all of you, who want to test vesafb-tng on g-d-s I've just made a special patch: http://dev.gentoo.org/~spock/projects/vesafb-tng/vesafb-tng-0.9-rc1-r1-2.6.7-gentoo.patch.bz2.
Have fun :)


Thank you. Now everything works fine.
Back to top
View user's profile Send private message
SuSEQ
n00b
n00b


Joined: 27 Jun 2003
Posts: 17
Location: The Boeshes

PostPosted: Thu Jun 24, 2004 10:04 pm    Post subject: Reply with quote

I'm trying to get vesafb-tng to work, but as of now, I'm not very succesful... It hangs just after the VBE detection. The verbosity patch fails when applying hunk #6; the other patch, however, apllied successfully

I have the 2.6.7-r5 gentoo-dev sources, and an nVidia Ti 4600-core quadro. The used append line in lilo: "video=vesafb:124x768-24@85,mtrr,ywwrap,vram:16". The specification of vram:16 doesn't do much to the problem; also, the kernel complains about an incorrect videomode...

Gr, SuSEQ
_________________
Dwelling in the past is dying in the present (Atrus)
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Thu Jun 24, 2004 10:05 pm    Post subject: Reply with quote

runs cool here at 1600x1200@85 :)
thanks for the update
_________________
linux: #232767
Back to top
View user's profile Send private message
deNniZ
n00b
n00b


Joined: 25 Jun 2004
Posts: 5
Location: Kerpen

PostPosted: Fri Jun 25, 2004 4:20 am    Post subject: Reply with quote

Works nice on my box with gentoo-dev-sources at 1280x1024-16@85!

I have only a small problem with my splashscreen, vesafb semms to get loaded too late so there's some white gfx error on a grey bootsplash looks weird, but goes away after scrolling!

any help would be appreciatet!

keep up the nice work!
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Fri Jun 25, 2004 2:25 pm    Post subject: Reply with quote

spock:

little problem with the screen geometry.
I get the framebuffer about 10 mm outside of the screen to the left.
so when i get back to X the image is 10mm ouside the screen to the right.

1600x1200@85 both Fb and X
_________________
linux: #232767
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Fri Jun 25, 2004 8:13 pm    Post subject: Reply with quote

Quote:
I have only a small problem with my splashscreen, vesafb semms to get loaded too late so there's some white gfx error on a grey bootsplash looks weird, but goes away after scrolling!

This sounds like the white rectangle problem, a known bug in fbcon code, which will hopefully be fixed soon. It hasn't really anything to do with vesafb-tng. You will get it when using other non-vesafb drivers (rivafb for example), too.

ikaro wrote:
spock:
little problem with the screen geometry.
I get the framebuffer about 10 mm outside of the screen to the left.
so when i get back to X the image is 10mm ouside the screen to the right.
1600x1200@85 both Fb and X

You can use fbset to correct it (have your X modeline converted to fb.modes format) or you can try the 'gtf' kernel parameter, but I doubt the results of the latter one will be as good as you expect of it. Still, it might be worth a try :)
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
nojon
n00b
n00b


Joined: 25 Jun 2004
Posts: 3

PostPosted: Fri Jun 25, 2004 8:20 pm    Post subject: Reply with quote

I have also tried your vesafb-tng patch - I have not ever tried the previous one. However it does not seem to work here ( nVidia GeForce 4 MX 440 SE ). I've sent the output to you per eMail. Reading threw the thread I have a feeling that the patch does not work for (m)any nVidia graphics cards. If I can help you debug it please tell me how.
Back to top
View user's profile Send private message
Pubare
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2003
Posts: 81
Location: Lafayette, LA

PostPosted: Fri Jun 25, 2004 10:34 pm    Post subject: Reply with quote

Sorry I didn't post back sooner, been a hectic week... The noedid option did the trick for me (suspected it was something along these lines), works just fine. Thanks for the patch and the fix.
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Sat Jun 26, 2004 3:17 am    Post subject: Reply with quote

[quote="spock_"]
Quote:

You can use fbset to correct it (have your X modeline converted to fb.modes format) or you can try the 'gtf' kernel parameter, but I doubt the results of the latter one will be as good as you expect of it. Still, it might be worth a try :)



right. but then it kinda defeats the pourpose of using this new patch instead of the 'old one' where it just worked.

oh well ....
_________________
linux: #232767
Back to top
View user's profile Send private message
ennservogt
n00b
n00b


Joined: 27 May 2004
Posts: 32

PostPosted: Sat Jun 26, 2004 12:38 pm    Post subject: Radeon 9500 does't seem to work with vesafb rcc/tng fix :-( Reply with quote

I just can't believe that my Radeon 9500 does not support the
required VBE standard... :-( But I just can't get the framebuffer device to work at the desired refresh rates and resolutions.

I have tried the vanilla sources, the gentoo development sources, the rcc version and the latest tng version of the patch. Neither of them worked :-(

So is anyone out there who can confirm that the Radeon 9500 does not or does work with the rcc or tng refresh rate fix?

PS: It would help a lot if anybody posting a report in the future also writes which video card he uses.


Thanks in advance...
EnnserVogt
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Sun Jun 27, 2004 10:15 pm    Post subject: Re: Radeon 9500 does't seem to work with vesafb rcc/tng fix Reply with quote

I'm happy to announce the availability of a new version of vesa-tng (0.9-rc2). If the previous versions didn't work for you, please give this one a try and let me know about your results. Links to the new patch can be found on my devsite http://dev.gentoo.org/~spock/.

ennservogt wrote:
I just can't believe that my Radeon 9500 does not support the required VBE standard... :-( But I just can't get the framebuffer device to work at the desired refresh rates and resolutions.

As strange as it seems, AFAIK Radeons only support VBE2.0, which is not enough to change the refresh rate. You can check you board's VBE version in /proc/fb0/vbe_info or in dmesg.

ikaro wrote:
right. but then it kinda defeats the purpose of using this new patch instead of the 'old one' where it just worked.

Well, it's for users to decide which one to use. vesafb-tng is far more advanced than vesafb-rrc and it gives you options you'd never have with the old patch (like setting/adjusting mode after bootup is complete). The modes you get with vesafb-tng may not be perfect, but they should be good enough. Even board-specific drivers like rivafb don't always give you the perfect mode you'd want. Sometimes things just have to be adjusted manually ;)
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
nojon
n00b
n00b


Joined: 25 Jun 2004
Posts: 3

PostPosted: Mon Jun 28, 2004 2:25 pm    Post subject: Reply with quote

Hurray - with rc2 it works for my GeFroce 4 MX 440, too - thanks for a great patch.
Back to top
View user's profile Send private message
SuSEQ
n00b
n00b


Joined: 27 Jun 2003
Posts: 17
Location: The Boeshes

PostPosted: Mon Jun 28, 2004 10:26 pm    Post subject: Reply with quote

I'm having trouble patching the gentoo-dev-2.6.7-rc6 sources; the previous patch patched OK, but it didn't work like it should.

Code:
patching file drivers/video/vesafb.c
Hunk #6 FAILED at 246.
Hunk #7 succeeded at 474 (offset 3 lines).
Hunk #8 succeeded at 501 (offset 3 lines).
Hunk #9 succeeded at 522 (offset 3 lines).
Hunk #10 succeeded at 824 (offset 3 lines).
Hunk #11 succeeded at 863 (offset 3 lines).
Hunk #12 succeeded at 893 (offset 3 lines).
Hunk #13 succeeded at 1159 (offset 3 lines).
1 out of 13 hunks FAILED -- saving rejects to file drivers/video/vesafb.c.rej


As I'm no C guru, I'm not exactly confident to patch the file by hand...

//edit: but I did it - new kernel is now compiling... Fingers crosed!

Greets, SuSEQ
_________________
Dwelling in the past is dying in the present (Atrus)


Last edited by SuSEQ on Mon Jun 28, 2004 11:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 9, 10, 11, 12, 13, 14  Next
Page 10 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum