Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Probblem with layman
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
XrateR
Apprentice
Apprentice


Joined: 18 Nov 2005
Posts: 164
Location: Sweden

PostPosted: Tue Nov 25, 2008 9:03 pm    Post subject: Probblem with layman Reply with quote

Hello,
I hade just emerge layman (for my first time) and did a #layman -a x11
when I got this message:
Code:
exie ~ # layman -a x11
* Running command "/usr/bin/git clone "git://git.overlays.gentoo.org/proj/x11/" "/usr/portage/local/layman/x11""...
/usr/bin/git: warning: invalid extra options ignored

GNU Interactive Tools 4.3.20 (i686-pc-linux-gnu), 19:42:41 Nov 19 2008
GIT is free software; you can redistribute it and/or modify it under the
terms of the GNU General Public License as published by the Free Software
Foundation; either version 2, or (at your option) any later version.
Copyright (C) 1993-1999 Free Software Foundation, Inc.
Written by Tudor Hulubei and Andrei Pitis, Bucharest, Romania

/usr/bin/git: fatal error: `chdir' failed: permission denied.
* Failed to add overlay "x11".
* Error was: Directory /usr/portage/local/layman/x11 does not exist. Cannot remove the overlay!
exie ~ #

Can some one help me out on this one? Because I tried to create the folders
and the make.conf but nothing helps.

\\ xrater
Back to top
View user's profile Send private message
mtjm
n00b
n00b


Joined: 25 Nov 2008
Posts: 40
Location: Katowice, Poland

PostPosted: Tue Nov 25, 2008 9:41 pm    Post subject: Reply with quote

Try removing app-misc/git and installing dev-util/git. It is needed to checkout the x11-overlay.
Back to top
View user's profile Send private message
shickapooka800
Guru
Guru


Joined: 05 Dec 2004
Posts: 304
Location: no

PostPosted: Tue Nov 25, 2008 9:43 pm    Post subject: Reply with quote

did you run layman -f to get the latest list?

I just ran layman -a x11 and it worked just fine. I didn't have the layman/x11 directory before. the git pull creates this.

what do you have in /usr/portage/local/layman?
Back to top
View user's profile Send private message
XrateR
Apprentice
Apprentice


Joined: 18 Nov 2005
Posts: 164
Location: Sweden

PostPosted: Tue Nov 25, 2008 10:01 pm    Post subject: Reply with quote

mtjm wrote:
Try removing app-misc/git and installing dev-util/git. It is needed to checkout the x11-overlay.

I will try that, thanks.
:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum