Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo and plymouth
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Siker
n00b
n00b


Joined: 22 Sep 2004
Posts: 72

PostPosted: Tue Dec 02, 2008 12:28 am    Post subject: Gentoo and plymouth Reply with quote

Hi guys, take a look to this article on phoronix... do you know if someone is working at this cool app for gentoo? It should be a replacement for the current gensplash...

http://www.phoronix.com/scan.php?page=news_item&px=Njg3Nw
_________________
[img]http://www.rapmaniacz.com/rap.jpg[/img]
Back to top
View user's profile Send private message
roidelapluie
n00b
n00b


Joined: 07 Dec 2008
Posts: 2

PostPosted: Sun Dec 07, 2008 11:43 am    Post subject: Reply with quote

I am interrested in this too.
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5617
Location: Removed by Neddy

PostPosted: Sun Dec 07, 2008 1:05 pm    Post subject: Reply with quote

I commented abt it in here
https://forums.gentoo.org/viewtopic-t-716945-highlight-.html
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
hook
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1398
Location: Ljubljana, Slovenia

PostPosted: Sun Jun 21, 2009 5:17 pm    Post subject: Reply with quote

I've already submitted a bug for its inclusion.

There's also a short thread on FreeDesktop on how to (theoretically) get Plymouth working on Gentoo.
_________________
tea+free software+law=hook

(deep inside i'm still a tux's little helper)
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Sun Jun 21, 2009 7:19 pm    Post subject: Reply with quote

hook wrote:
I've already submitted a bug for its inclusion.

There's also a short thread on FreeDesktop on how to (theoretically) get Plymouth working on Gentoo.


I will get an ebuild going for this soon...
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
hook
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1398
Location: Ljubljana, Slovenia

PostPosted: Sun Jun 21, 2009 7:53 pm    Post subject: Reply with quote

rmh3093 wrote:

I will get an ebuild going for this soon...


Niiiiiiiiiiiiiiiiiiceeeeeeeeeeeeeee :D
_________________
tea+free software+law=hook

(deep inside i'm still a tux's little helper)
Back to top
View user's profile Send private message
patrikh
n00b
n00b


Joined: 25 Jul 2006
Posts: 23

PostPosted: Sat Jun 27, 2009 7:42 am    Post subject: Reply with quote

I can't wait for this. This would be so great :D
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 376
Location: Ekaterinburg, Russia

PostPosted: Tue Sep 29, 2009 6:30 pm    Post subject: Reply with quote

still no ebuilds?

oh. maybe i'll write one..
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
Drone4four
Apprentice
Apprentice


Joined: 09 May 2006
Posts: 247

PostPosted: Wed Feb 24, 2010 2:47 am    Post subject: Reply with quote

There are still no search results for Plymouth on gentoo-portage.com. Bullocks!
_________________
My rig:
IBM Personal System/2 Model 30-286 - - Intel 80286 (16 bit) 10 Mhz - - 1MB DRAM - - Integrated VGA Display adapter
1.44MB capacity Floppy Disk - - PS/2 keyboard (no mouse)
Back to top
View user's profile Send private message
Kingoftherings
Guru
Guru


Joined: 04 May 2008
Posts: 328

PostPosted: Wed Feb 24, 2010 8:34 pm    Post subject: Reply with quote

Drone4four wrote:
There are still no search results for Plymouth on gentoo-portage.com. Bullocks!


There is one on Bugzilla if you're interested.

https://bugs.gentoo.org/show_bug.cgi?id=274065
Back to top
View user's profile Send private message
kotakotakota
n00b
n00b


Joined: 01 Feb 2010
Posts: 12

PostPosted: Thu Feb 25, 2010 12:02 am    Post subject: Reply with quote

Drone4four wrote:
There are still no search results for Plymouth on gentoo-portage.com. Bullocks!


Even better, http://gpo.zugaina.org/sys-boot/plymouth
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Tue Jun 15, 2010 10:17 am    Post subject: Reply with quote

I was wondering if anyone here uses Plymouth? Is there any howto available out there for Gentoo ?

Thank you!
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2803
Location: Richmond, BC, Canada

PostPosted: Tue Jun 15, 2010 10:38 pm    Post subject: Reply with quote

Sorry, I don't know of anyone using it in gentoo. I do know that we almost had a GSOC student that was going to port it to gentoo properly. But we lost him to another project for another organization.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
MetalGod
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 816
Location: Portugal

PostPosted: Wed Jun 16, 2010 12:50 pm    Post subject: Reply with quote

dol-sen wrote:
Sorry, I don't know of anyone using it in gentoo. I do know that we almost had a GSOC student that was going to port it to gentoo properly. But we lost him to another project for another organization.


I think Gentoo have a student working on dracut and plymouth check his reports on planet gentoo
_________________
ex: Gentoo Linux Developer: amd64 media-optical sound gnome
ex: Portuguese Moderator
------------------------------------------------------------------------------
God Doesn't Play Dice
Back to top
View user's profile Send private message
Benson
Apprentice
Apprentice


Joined: 23 Feb 2004
Posts: 156
Location: Switzerland

PostPosted: Fri Jul 09, 2010 4:40 pm    Post subject: Reply with quote

I tried to get plymouth 0.8.3 working, modified ebuild and patch. Now i get the following error when booting:
Code:
/pre-trigger/10plymouth-pretrigger.sh: 20: /lib/udev/console_init: not found

In fedora there's a console_init by udev, in gentoo not. The code looks like that:
Code:
/lib/udev/console_init tty0

How is this done with gentoo?

Thanks,
Benson
_________________
If it compiles, commit to CVS.
If it links, ship to customer.
If it runs without bugs, ..., nah, never had that case.
Back to top
View user's profile Send private message
Satoshi
Apprentice
Apprentice


Joined: 06 Nov 2006
Posts: 180
Location: Brazil

PostPosted: Sat Jul 10, 2010 1:38 pm    Post subject: Reply with quote

I really hope this gets more attention soon.
Back to top
View user's profile Send private message
Drone4four
Apprentice
Apprentice


Joined: 09 May 2006
Posts: 247

PostPosted: Fri Jul 23, 2010 12:23 am    Post subject: Reply with quote

Satoshi wrote:
I really hope this gets more attention soon.

Ditto. It's a bit disconcerting to see #plymouth on FreeNode have only 8 idlers. I wish this project was more popular.
_________________
My rig:
IBM Personal System/2 Model 30-286 - - Intel 80286 (16 bit) 10 Mhz - - 1MB DRAM - - Integrated VGA Display adapter
1.44MB capacity Floppy Disk - - PS/2 keyboard (no mouse)
Back to top
View user's profile Send private message
Benson
Apprentice
Apprentice


Joined: 23 Feb 2004
Posts: 156
Location: Switzerland

PostPosted: Fri Aug 06, 2010 12:31 pm    Post subject: Reply with quote

As reported in the bug, plymouth is hanging on the boot process. Further, with nvidia-drivers it's not working, you only get a blue bar at the bottom. Nouveau is making me mad, wasn't able to test with it. With Arch Linux, i got it working with nouveau and nvidia-drivers (using fesafb or uvesafb)! I'll try to investigate what's different with gentoo...

If anyone else is trying to get it working please report your progress here!

Thanks,
Benson
_________________
If it compiles, commit to CVS.
If it links, ship to customer.
If it runs without bugs, ..., nah, never had that case.
Back to top
View user's profile Send private message
francescofavero
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2005
Posts: 130
Location: Kongens Lyngby

PostPosted: Sun Jan 16, 2011 9:53 pm    Post subject: Reply with quote

Look at this bug, there is a live ebuild of plymouth. It works smoothly on intel with 2.6.37.
I also did an attempt to put gentoo logo on the splash, it works with solar theme, it's really cool.
I'm not an ebuild and int script expert, so any improvement is welcome, but it just works like this.
Hope it helps

F.
_________________
Play old NES on Facebook!!
Back to top
View user's profile Send private message
^marcs
Apprentice
Apprentice


Joined: 09 Mar 2005
Posts: 169

PostPosted: Fri Jan 21, 2011 9:15 pm    Post subject: Reply with quote

hi,
all this stuff look great, but anyone know is it possible to get flickerless transition from fb console to X on current nouveau driver?
like in this vid http://www.youtube.com/watch?v=ogzsX2b42fU&feature=related
Back to top
View user's profile Send private message
niick
Tux's lil' helper
Tux's lil' helper


Joined: 09 Mar 2006
Posts: 88

PostPosted: Sat Jan 22, 2011 12:27 am    Post subject: Reply with quote

I was wondering the same thing. I found this by one of the red hat guys who develops plymouth. It seems that patches are required for drivers, X and gnome bits. I have no idea whether any or all of these have been applied upstream or what the current status is for any of them. However, it is something to go on.

Also, has anyone found a way to build plymouth without having all the drm drivers built? I only want it for nouveau and I tried adding DRM_LIBS and DRM_CFLAGS to make.conf but to no avail.
_________________
"Give me control of a nation's money and I care not who makes the laws."
Mayer Amschel Rothschild
Back to top
View user's profile Send private message
Etal
Veteran
Veteran


Joined: 15 Jul 2005
Posts: 1682

PostPosted: Sat Jan 22, 2011 1:16 am    Post subject: Reply with quote

I didn't try installing Plymouth, but I noticed that on Fedora, the X session starts in vt1 instead of the usual vt7. In the proposed init script on bugzilla, he's switching to vt7, so I'm wondering if starting the DM in vt1 and not switching right after plymouth quits would achieve flickerlessness.
_________________
“And even in authoritarian countries, information networks are helping people discover new facts and making governments more accountable.”– Hillary Clinton, Jan. 21, 2010
Back to top
View user's profile Send private message
niick
Tux's lil' helper
Tux's lil' helper


Joined: 09 Mar 2006
Posts: 88

PostPosted: Sat Feb 26, 2011 1:48 pm    Post subject: Reply with quote

Just want to let people know that plymouth is now in portage! I guess this means that this thread might not belong in unsupported anymore.

Edit: Also it now respects which video card you're using, so you don't need libdrm complied with all the drivers.
_________________
"Give me control of a nation's money and I care not who makes the laws."
Mayer Amschel Rothschild
Back to top
View user's profile Send private message
perplx
n00b
n00b


Joined: 17 Apr 2006
Posts: 26
Location: Montréal, QC

PostPosted: Thu Mar 10, 2011 1:13 am    Post subject: Reply with quote

I've been using plymouth for a few days, and, well, wow. 8O

The solar theme beats anything I've seen from splash-utils, fbcondecor, etc. hands down.

I'd been trying to get it to work ever since aidecoe started work on dracut last summer, but it had been painful. No documentation, incomplete support, and my nVidia card meant I had to go through nouveau + KMS, which is pretty painful in terms of random crashes all the time, and not being able to suspend.

Now that plymouth works with UvesaFB, I can keep the nvidia-driver and enjoy a luxurious graphical booting experience :D

It's still not perfect. I sort of miss having console decorations for the VTs, and plymouth just disappears after a bit, so the end of booting is a black screen. Also, pressing F2 while booting to go into verbose mode has caused some funny graphics behavior once X started up - I'm not sure why that would be. And I wish plymouth came up during suspend/resume.

Still, overall, it's awesome, I encourage people to try it. Once you see plymouth, it's hard to go back!
_________________
Gentoo: keep it real.
Back to top
View user's profile Send private message
shedyed
n00b
n00b


Joined: 10 Mar 2011
Posts: 1

PostPosted: Thu Mar 10, 2011 4:25 am    Post subject: I miss my VT backgrounds Reply with quote

...that were available with bootsplash (before plymouth and usplash and splashy). I hope there is an equivalent with plymouth. In plymouth, I think if you were able to match the gdm login background with the plymouth bg, the switch to graphical would appear seamless, but it's not easily user-configurable (hardly might be a better suited word). Heck even gdm is becoming hard to change.
I have a bias towards bootsplash because 1) we get a pretty boot sequence 2) we get graphical wallpaper for our framebuffer VTs. I have to mess with fbterm, which has a wrapper of some sort to place a background. And unfortunately, I can't port my animated themes there http://kde-look.org/content/show.php/Raiders?content=46890 and its sequel. I can't wait till plymouth makes the jump to userland, or else I am stuck with fedora's blue splashes.
_________________
Third prize is you're fired.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum