Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
yet another nvidia beta driver release, 180.11
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Dec 08, 2008 2:43 pm    Post subject: Reply with quote

albright wrote:
I guess these drivers are OK, but I don't like the way
X crashes suddenly and unpredictably. Last time I
found these messages:

in dmesg:
Code:
NVRM: Xid (0001:00): 6, PE0000 01b4 00949dac 00402770 00909cab 00909cab
NVRM: Xid (0001:00): 13, 0000 80016100 0000008a 00000404 00acb7c4 00004000
NVRM: Xid (0001:00): 6, PE0000 0100 80010200 0000bf90 00000000 006286a9
NVRM: Xid (0001:00): 3, C 00000000 SC 00000006 M 00000194 Data 00000000


Anyone know what these mean (GeForce 6600)?


take a look at nvnews.net:

http://www.google.com/search?hl=en&q=site%3Awww.nvnews.net+NVRM%3A+Xid&btnG=Google-Suche&meta=

you're not alone - (un)fortunately I don't get this so I can't tell what's actually going wrong ...

good luck :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Mon Dec 08, 2008 4:42 pm    Post subject: Reply with quote

I also haven't got such problems (yet). Without vdpau flag here.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
kmare
l33t
l33t


Joined: 20 Nov 2004
Posts: 619
Location: Thessaloniki, Greece

PostPosted: Sat Dec 13, 2008 11:10 am    Post subject: Reply with quote

new beta release again 180.16.. should fix most problems with VDPAU (wish it was supported on my card..):

http://www.nvnews.net/vbulletin/showthread.php?t=124599
_________________
Never argue with an idiot. They will only pull you down to their level, then beat you with experience.
Back to top
View user's profile Send private message
hvengel
Guru
Guru


Joined: 19 Sep 2004
Posts: 515

PostPosted: Mon Dec 22, 2008 12:21 am    Post subject: Reply with quote

kmare wrote:
new beta release again 180.16.. should fix most problems with VDPAU (wish it was supported on my card..):

http://www.nvnews.net/vbulletin/showthread.php?t=124599


Is there an ebuild available for this yet?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Mon Dec 22, 2008 12:51 am    Post subject: Reply with quote

I believe there's one in berkano overlay.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1312
Location: Netherlands

PostPosted: Tue Dec 23, 2008 11:45 am    Post subject: Reply with quote

It certainly is in the devnull overlay ...
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5673
Location: Removed by Neddy

PostPosted: Tue Dec 23, 2008 1:33 pm    Post subject: Reply with quote

new drivers nvidia-drivers-180.18

I copied the berkano ebuild to 180.18 but it wont emerge

Code:

>>> Emerging (1 of 9) x11-drivers/nvidia-drivers-180.18
 * NVIDIA-Linux-x86_64-180.18-pkg2.run RMD160 SHA1 SHA256 size ;-) ...                                          [ ok ]
 * checking ebuild checksums ;-) ...                                                                            [ ok ]
 * checking auxfile checksums ;-) ...                                                                           [ ok ]
 * checking miscfile checksums ;-) ...                                                                          [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/2.6.26-gentoo-r1/build
 * Found sources for kernel version:
 *     2.6.26-gentoo-r1
 * Checking for MTRR support ...                                                                                 [ !! ]
 * Please enable MTRR support in your kernel config, found at:
 *
 *   Processor type and features
 *     [*] MTRR (Memory Type Range Register) support
 *
 * and recompile your kernel ...
 *
 * ERROR: x11-drivers/nvidia-drivers-180.18 failed.
 * Call stack:
 *                      ebuild.sh, line   49:  Called pkg_setup
 *   nvidia-drivers-180.18.ebuild, line  150:  Called mtrr_check
 *   nvidia-drivers-180.18.ebuild, line  114:  Called die
 * The specific snippet of code:
 *         die "MTRR support not detected!"
 *  The die message:
 *   MTRR support not detected!


YET...

Code:

zgrep MTRR /proc/config.gz
CONFIG_MTRR=y

_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
P.Kosunen
Guru
Guru


Joined: 21 Nov 2005
Posts: 309
Location: Finland

PostPosted: Wed Dec 24, 2008 1:15 pm    Post subject: Reply with quote

swimmer wrote:
It certainly is in the devnull overlay ...


That doesn't install the vdpau files.
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1312
Location: Netherlands

PostPosted: Wed Dec 24, 2008 5:50 pm    Post subject: Reply with quote

Ouch! My apologies :-/
Back to top
View user's profile Send private message
Gef
Apprentice
Apprentice


Joined: 17 May 2008
Posts: 180
Location: France

PostPosted: Thu Dec 25, 2008 2:52 am    Post subject: Reply with quote

@Naib : works for me, with a 2.6.27-gentoo-r7 kernel, MTRR support enabled.

Not really sure where this ebuild comes from, has I bumped new versions with it for ages. Anyhow: http://pastebin.com/m203cf2ee
_________________
Laptop : Gentoo ~amd64
(remote) Server : Gentoo amd64
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum