Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Qq
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 534

PostPosted: Mon Dec 08, 2008 2:40 am    Post subject: Qq Reply with quote

I searched the forums, both English and Chinese, and found not a single mention of QQ. This IM protocol is not very popular in the U.S.A., but it's ubiquitous in China. I recently switched from Gnome 2.22 to KDE 4.13, which of course involved switching from Pidgin to Kopete. Everything seems to work well in Kopete, except for my webcam (which I don't really care about) and QQ, which I do care about.

I could, if I wanted, reinstall Pidgin, along with a slew of Gnome packages, but I don't want to do that. I tried installing Pidgin without the GTK use flag and using finch, the text client, but that just isn't suitable, except maybe on my PIII :) I found a Linux QQ client here:

http://im.qq.com/qq/linux/

But it's all in Chinese, and I know very, very little Chinese, and I have no idea how secure/unsecure it is. I ran it (it comes with a binary, and no source code, apparently) connected successfully to the network, so it seems. The QQ mascot is even a cute penguin wearing a scarf -- how suitable for Linux. Of course, for all I know, the program could be filled with security holes.

Anyway, my main point here is that I would like to begin a dialog about QQ in English for Linux, and Gentoo more specifically, and I'm wondering if anyone knows how to connect to QQ using Kopete. It's not a problem with my firewall, because I can connect to it using the actual QQ client in Gentoo and Windows, and I could connect using Pidgin. So perhaps it's a problem with the plugin; either the plugin is faulty/outdated, or I need to enter the correct server information. Does anyone know?
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon Dec 08, 2008 10:55 am    Post subject: Reply with quote

Just compile kopete with USE="qq"

(at least looking at /usr/portage/kde-base/kopete/kopete-4.1.3.ebuild shows qq in IUSE..)
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 534

PostPosted: Mon Dec 08, 2008 5:17 pm    Post subject: Reply with quote

Sorry, I wasn't specific enough. I have the qq use flag enabled, and Kopete is installed with QQ support. However, it never seems to connect, or to know whether it's connected to the network or not. It just displays a yellow triangle with an exclamation mark inside as my connection status.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Dec 08, 2008 6:23 pm    Post subject: Reply with quote

Seems to be a known bug.

http://bugs.kde.org/show_bug.cgi?id=163939
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum