Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mozilla-firefox 3.1 beta2 ebuild?
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
bbee
n00b
n00b


Joined: 16 Jun 2007
Posts: 26

PostPosted: Sun Dec 14, 2008 9:57 pm    Post subject: Reply with quote

Be happy you can get it to display at all.. Mine still just hangs at 100% cpu.. I guess beta really means beta, I just wish I didn't need it to fix a nasty bug I'm having with 3.0.4. Did anyone get this to work on amd64? If so I'd like to see:
- your CFLAGS
- USE flags for nss, xulrunner, mozilla-firefox
If I can't get it working with a confirmed set of those I'm gonna start blaming the compiler..
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Mon Dec 15, 2008 12:04 am    Post subject: Reply with quote

my system is amd64, completely ~.
Code:
# emerge --info
Portage 2.2_rc17 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r0, 2.6.28-rc8-tip-blackbit-01080-g89280db x86_64)
=================================================================
System uname: Linux-2.6.28-rc8-tip-blackbit-01080-g89280db-x86_64-Intel-R-_Xeon-R-_CPU_E5420_@_2.50GHz-with-glibc2.2.5
Timestamp of tree: Sun, 14 Dec 2008 02:30:01 +0000
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=nocona"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /e
tc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev
/rules.d"
CXXFLAGS="-O2 -pipe -march=nocona"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch
"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS=""
LINGUAS="en de"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=18
0 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/mozilla /usr/portage/local/layman/sunrise /usr/portage/local/blackbit"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amd64 amrnb amrwb bash-completion berkdb bl bzip2 cairo cddb cdio cdr cli cracklib crypt cscope
 css cups dbus dga directfb dri dts dv dvb dvd dvdr dvi enca encode fbcon ffmpeg flac fortran ftp fuse gcj gdbm ggi gif gnome gnut
ls gpm gs gstreamer gtk guile hal hdri iconv isdnlog java java6 jbig jpeg jpeg2k lapack lcms libcaca live lzo mad md5sum midi mmx
mmxext mozdevelop mp2 mp3 mpeg mudflap multilib musepack nautilus ncurses nemesi networking nls nptl nptlonly nsplugin objc objc++
 objc-gc ogg openal openct openexr opengl openmp pam pcre perl png pnm pppd python qt3support qt4 quicktime radio rar readline ref
lection rtc session spl sse sse2 ssl ssse3 svg sysfs tcpd theora tiff truetype type1 unicode v4l v4l2 vim-syntax vorbis wma wmf x2
64 xcb xml xorg xulrunner xv xvid xvmc zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci em
u10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" A
LSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_em
ul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm
authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_
lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_mag
ic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboar
d mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en
de" USERLAND="GNU" VIDEO_CARDS="xgi vesa radeon radeonhd"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORT
AGE_RSYNC_EXTRA_OPTS

#

no special flags set in /etc/portage/package.use.
i hope that helps.
Back to top
View user's profile Send private message
Gef
Apprentice
Apprentice


Joined: 17 May 2008
Posts: 180
Location: France

PostPosted: Mon Dec 15, 2008 12:30 am    Post subject: Reply with quote

No problem with this system :
Code:

zetabox usr # emerge --info
Portage 2.2_rc17 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r0, 2.6.27-gentoo-r5-low-tickless-hrt i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r5-low-tickless-hrt-i686-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-glibc2.0
Timestamp of tree: Sun, 14 Dec 2008 02:15:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks fixpackages parallel-fetch preserve-libs preserved-rebuild protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.free.fr/mirrors/ftp.gentoo.org/ http://mirror.ovh.net/gentoo-distfiles/"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="fr fr_FR"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/zeta-overlay /usr/portage/local/layman/desktop-effects /usr/portage/local/layman/mozilla /usr/portage/local/layman/wschlich-testing /usr/portage/local/layman/initng"
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa apm berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt dbus dri dvd dvdr dvdread emboss encode ffmpeg fortran gdbm gif gnutls gpm gstreamer gtk hal hda-intel iconv id3tag isdnlog jpeg lame laptop libnotify mad midi mikmod mmx mp3 mpeg mudflap ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl ssse3 svg sysfs tcpd threads tiff truetype unicode usb vorbis win32codecs x264 x86 xinerama xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" ELIBC="glibc" INITNG_PLUGINS="also bash_launcher chdir chroot conflict cpout critical ctrlaltdel daemon_clean debug_commands envparser find fmon fstat history idleprobe initctl interactive iparser last limit lockfile logfile netdev netprobe ngc4 ngcs nge pause provide reload renice rlparser simple_launcher stcmd stdout suid syncron syslog sysreq unneeded usplash" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Nothing related to FF/Xul/NSS in package.use.

edit : talked too fast ;
"eix -Il mozilla-firefox" :
Code:

Installed versions:  3.1_beta2-r1[1](02:27:00 14/12/2008)(custom-optimization dbus java linguas_fr xulrunner ...)

"eix -Il xulrunner"
Code:

Installed versions:  1.9.1_beta2(1.9)[1](23:15:41 12/12/2008)(custom-optimization dbus

_________________
Laptop : Gentoo ~amd64
(remote) Server : Gentoo amd64
Back to top
View user's profile Send private message
bbee
n00b
n00b


Joined: 16 Jun 2007
Posts: 26

PostPosted: Mon Dec 15, 2008 3:14 am    Post subject: Reply with quote

Hmm OK I've tried with more conservative flags, different USE flags etc.. I gave up after recompiling serveral times and resorted to strace :(

After initial shared library setup, etc., this is what 3.0.4 does:
access("/usr/lib64/mozilla-firefox/xulrunner/libxpcom.so", R_OK) = -1 ENOENT (No such file or directory)
It then sets off looking for the correct library location in conf files, reading ~/.gre.d and other locations until it finally finds the correct one:
open("/etc/gre.d/1.9.0.4.system.conf", O_RDONLY) = 4
And a bit later:
access("/usr/lib64/xulrunner-1.9/libxpcom.so", R_OK) = 0

This behavior seems to have completely failed in 3.1_beta2. Instead after failing to find libxpcom, it reads /proc/cpuinfo (?!), tries to read /etc/malloc.conf for some reason, then goes into an endless mmap()/munmap() loop:
Code:
access("/usr/lib64/mozilla-firefox/xulrunner/libxpcom.so", R_OK) = -1 ENOENT (No such file or directory)
open("/proc/cpuinfo", O_RDONLY)         = 3
read(3, "processor\t: 0\nvendor_id\t: Authent"..., 1024) = 577
read(3, ""..., 1024)                    = 0
close(3)                                = 0
readlink("/etc/malloc.conf", 0x7e17cebf16d0, 4096) = -1 ENOENT (No such file or directory)
mmap(NULL, 1048576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x6f2ec8f73000
mmap(NULL, 2097152, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x6f2ec7883000
munmap(0x6f2ec7883000, 2097152)         = 0
mmap(0x6f2ec7a00000, 2097152, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x6f2ec7883000
munmap(0x6f2ec7883000, 2097152)         = 0
mmap(NULL, 3145728, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x6f2ec7783000
munmap(0x6f2ec7783000, 3145728)         = 0
mmap(0x6f2ec7800000, 2097152, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x6f2ec7883000
munmap(0x6f2ec7883000, 2097152)         = 0
mmap(NULL, 3145728, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x6f2ec7783000
munmap(0x6f2ec7783000, 3145728)         = 0
mmap(0x6f2ec7800000, 2097152, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x6f2ec7883000
munmap(0x6f2ec7883000, 2097152)         = 0

This continues forever. I'm no expert on kernel calls, but if I'm reading it correctly, it tries to mmap a fixed address with size 2097152, the kernel instead returns a mapping at a different address (page boundary?) which it destroys, then it requests a larger mapping of 3145728 at any address, which it gets but doesn't like either, destroys it, rinse, repeat.

Before I start diffing code trees, does anyone have the slightest idea what might be causing this?
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 376
Location: Ekaterinburg, Russia

PostPosted: Mon Dec 15, 2008 5:17 am    Post subject: Reply with quote

chjiang wrote:
Sorry, I found that didn't really fix the problem because I hit this really old bug, http://forums.opensuse.org/archives/sf-archives/archives-opensuse-beta/330083-qtcurve-messing-firefox.html

So I tried the workaround, comment out the qtcurve line and make userChrome.css read-only. Then the preference page back. Hope this time, this really could solve the problem.
thanks. that works :-)
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
laplata
n00b
n00b


Joined: 25 Nov 2008
Posts: 19

PostPosted: Mon Dec 15, 2008 9:09 pm    Post subject: Reply with quote

Rion wrote:
chjiang wrote:
Sorry, I found that didn't really fix the problem because I hit this really old bug, http://forums.opensuse.org/archives/sf-archives/archives-opensuse-beta/330083-qtcurve-messing-firefox.html

So I tried the workaround, comment out the qtcurve line and make userChrome.css read-only. Then the preference page back. Hope this time, this really could solve the problem.
thanks. that works :-)

Yeah, that's it, baby!

I just deleted /usr/share/themes/QtCurve/mozilla/QtCurve.css

Thank you!
Back to top
View user's profile Send private message
bbee
n00b
n00b


Joined: 16 Jun 2007
Posts: 26

PostPosted: Thu Dec 18, 2008 3:06 pm    Post subject: Reply with quote

If anyone is interested (the other person that complained?), I've traced the 100% cpu usage to a loop in memory/jemalloc/jemalloc.c in the firefox sources, it's a bug in firefox that only occurs if you have pax enabled (hardened-sources) and configured to randomize the mmap() base.
I filed Mozilla bug #470217

Edit: "emerge paxctl && paxctl -r /usr/lib64/mozilla-firefox/firefox" is a temporary solution, without disabling it for the entire system.
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Thu Dec 18, 2008 9:08 pm    Post subject: Reply with quote

laplata wrote:
Rion wrote:
chjiang wrote:
Sorry, I found that didn't really fix the problem because I hit this really old bug, http://forums.opensuse.org/archives/sf-archives/archives-opensuse-beta/330083-qtcurve-messing-firefox.html

So I tried the workaround, comment out the qtcurve line and make userChrome.css read-only. Then the preference page back.
thanks. that works :-)

I just deleted /usr/share/themes/QtCurve/mozilla/QtCurve.css

Or you could just disable the firefox3 and mozilla useflags of x11-themes/gtk-engines-qtcurve... :wink:
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Dec 30, 2008 12:25 am    Post subject: Reply with quote

so what's the exact step-by-step guide to get an xulrunner-enabled firefox 3.1 beta2 install running ?

many thanks in advance :P
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
unK
l33t
l33t


Joined: 06 Feb 2007
Posts: 769

PostPosted: Tue Dec 30, 2008 5:16 pm    Post subject: Reply with quote

Just download mozilla overlay and update world ;) I did so and it worked out of the box.

Btw did anyone experience random segfaults in free() (that's lol) in firefox 3.1 beta2 with glibc 2.9? I had to downgrade to 3.0.5 because of it ~~
_________________
ncmpcpp - featureful ncurses based MPD client inspired by ncmpc
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Tue Dec 30, 2008 7:16 pm    Post subject: Reply with quote

no segfaults here.
Back to top
View user's profile Send private message
lonex
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2004
Posts: 105
Location: Karlsruhe, Germany

PostPosted: Tue Dec 30, 2008 9:58 pm    Post subject: Reply with quote

unK wrote:
Just download mozilla overlay and update world ;) I did so and it worked out of the box.

Btw did anyone experience random segfaults in free() (that's lol) in firefox 3.1 beta2 with glibc 2.9? I had to downgrade to 3.0.5 because of it ~~


See https://bugs.gentoo.org/show_bug.cgi?id=252302 about those segfaults.
_________________
There are no dumb questions, just dumb answers. So please help users that are new to linux/gentoo by answering unanswered questions.
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2843

PostPosted: Tue Dec 30, 2008 10:44 pm    Post subject: Reply with quote

unK wrote:
Btw did anyone experience random segfaults in free() (that's lol) in firefox 3.1 beta2 with glibc 2.9? I had to downgrade to 3.0.5 because of it ~~

+1, I downgraded to net-libs/xulrunner-1.9.0.5 and www-client/mozilla-firefox-3.0.5.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
Tonglebeak
Guru
Guru


Joined: 23 Mar 2006
Posts: 362

PostPosted: Tue Dec 30, 2008 11:02 pm    Post subject: Reply with quote

Doesn't this version of firefox have QT support?

https://wiki.ubuntu.com/MozillaTeam/QT
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Dec 31, 2008 12:46 pm    Post subject: Reply with quote

unK wrote:
Just download mozilla overlay and update world ;) I did so and it worked out of the box.

Btw did anyone experience random segfaults in free() (that's lol) in firefox 3.1 beta2 with glibc 2.9? I had to downgrade to 3.0.5 because of it ~~


unfortunately 999_sqlite-version.patch fails :(

omitted that by commenting out ...

edit:

Quote:

* Failed Patch: 999_minefield_against_xulrunner-v2.patch !
* ( /usr/portage/packages/overlays/mozilla/www-client/minefield/files/999_minefield_against_xulrunner-v2.patch )
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/www-client/minefield-9999-r5/temp/999_minefield_against_xulrunner-v2.patch-31800.out

*
* ERROR: www-client/minefield-9999-r5 failed.
* Call stack:
* ebuild.sh, line 49: Called src_unpack
* environment, line 4453: Called epatch '/usr/portage/packages/overlays/mozilla/www-client/minefield/files/999_minefield_against_xulrunner-v2.patch'
* environment, line 2460: Called die
* The specific snippet of code:
* die "Failed Patch: ${patchname}!";
* The die message:
* Failed Patch: 999_minefield_against_xulrunner-v2.patch!
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/log/portage/www-client:minefield-9999-r5:20081231-141819.log'.
* The ebuild environment file is located at '/var/tmp/portage/www-client/minefield-9999-r5/temp/environment'.

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
armin76
Retired Dev
Retired Dev


Joined: 24 Apr 2006
Posts: 174

PostPosted: Wed Dec 31, 2008 5:21 pm    Post subject: Reply with quote

kernelOfTruth wrote:
unK wrote:
Just download mozilla overlay and update world ;) I did so and it worked out of the box.

Btw did anyone experience random segfaults in free() (that's lol) in firefox 3.1 beta2 with glibc 2.9? I had to downgrade to 3.0.5 because of it ~~


unfortunately 999_sqlite-version.patch fails :(

omitted that by commenting out ...

edit:

Quote:

* Failed Patch: 999_minefield_against_xulrunner-v2.patch !
* ( /usr/portage/packages/overlays/mozilla/www-client/minefield/files/999_minefield_against_xulrunner-v2.patch )
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/www-client/minefield-9999-r5/temp/999_minefield_against_xulrunner-v2.patch-31800.out

*
* ERROR: www-client/minefield-9999-r5 failed.
* Call stack:
* ebuild.sh, line 49: Called src_unpack
* environment, line 4453: Called epatch '/usr/portage/packages/overlays/mozilla/www-client/minefield/files/999_minefield_against_xulrunner-v2.patch'
* environment, line 2460: Called die
* The specific snippet of code:
* die "Failed Patch: ${patchname}!";
* The die message:
* Failed Patch: 999_minefield_against_xulrunner-v2.patch!
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/log/portage/www-client:minefield-9999-r5:20081231-141819.log'.
* The ebuild environment file is located at '/var/tmp/portage/www-client/minefield-9999-r5/temp/environment'.


layman -a mozilla
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Dec 31, 2008 5:58 pm    Post subject: Reply with quote

armin76 wrote:
kernelOfTruth wrote:
unK wrote:
Just download mozilla overlay and update world ;) I did so and it worked out of the box.

Btw did anyone experience random segfaults in free() (that's lol) in firefox 3.1 beta2 with glibc 2.9? I had to downgrade to 3.0.5 because of it ~~


unfortunately 999_sqlite-version.patch fails :(

omitted that by commenting out ...

edit:

Quote:

* Failed Patch: 999_minefield_against_xulrunner-v2.patch !
* ( /usr/portage/packages/overlays/mozilla/www-client/minefield/files/999_minefield_against_xulrunner-v2.patch )
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/www-client/minefield-9999-r5/temp/999_minefield_against_xulrunner-v2.patch-31800.out

*
* ERROR: www-client/minefield-9999-r5 failed.
* Call stack:
* ebuild.sh, line 49: Called src_unpack
* environment, line 4453: Called epatch '/usr/portage/packages/overlays/mozilla/www-client/minefield/files/999_minefield_against_xulrunner-v2.patch'
* environment, line 2460: Called die
* The specific snippet of code:
* die "Failed Patch: ${patchname}!";
* The die message:
* Failed Patch: 999_minefield_against_xulrunner-v2.patch!
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/log/portage/www-client:minefield-9999-r5:20081231-141819.log'.
* The ebuild environment file is located at '/var/tmp/portage/www-client/minefield-9999-r5/temp/environment'.


layman -a mozilla


this is supposed to do what ?

I'm already using that overlay

I justed synced it and it's still happening :?

thanks

and Happy New Year :P (it's still a few hours but it seems at least for you guys in the US it's already 2009 -> all Zunes not working anymore :lol: )
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
goffrie
n00b
n00b


Joined: 14 Mar 2007
Posts: 67

PostPosted: Thu Jan 01, 2009 12:13 am    Post subject: Reply with quote

kernelOfTruth wrote:

I'm already using that overlay

I justed synced it and it's still happening :?

You probably need to do a `layman -d mozilla && layman -a mozilla`, as the overlay that I have has only xulrunner, mozilla-firefox and mozilla-thunderbird packages.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Jan 01, 2009 1:02 pm    Post subject: Reply with quote

goffrie wrote:
kernelOfTruth wrote:

I'm already using that overlay

I justed synced it and it's still happening :?

You probably need to do a `layman -d mozilla && layman -a mozilla`, as the overlay that I have has only xulrunner, mozilla-firefox and mozilla-thunderbird packages.


and you were right,

I was running a really ancient version of the mozilla-overlay (with a different address),

since I don't sync them with layman but with paludis I didn't notice the server-change for a long time :lol:

thanks again
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2860
Location: Bay Area, CA

PostPosted: Fri Jan 02, 2009 7:00 am    Post subject: Reply with quote

Is anyone else seeing no contents in the Edit->Preferences window?

PS: never mind. yngwin already answered this.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jan 02, 2009 12:06 pm    Post subject: Reply with quote

laplata wrote:
Rion wrote:
chjiang wrote:
Sorry, I found that didn't really fix the problem because I hit this really old bug, http://forums.opensuse.org/archives/sf-archives/archives-opensuse-beta/330083-qtcurve-messing-firefox.html

So I tried the workaround, comment out the qtcurve line and make userChrome.css read-only. Then the preference page back. Hope this time, this really could solve the problem.
thanks. that works :-)

Yeah, that's it, baby!

I just deleted /usr/share/themes/QtCurve/mozilla/QtCurve.css

Thank you!


++

thanks !

finally I can delete private stuff (cookies, history, etc.) again

before commenting out that line the 2 buttons for cancel and accept were not displayed :idea:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum