Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pykde4 version already defined (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
valczir
n00b
n00b


Joined: 23 Nov 2005
Posts: 35
Location: Minnesota

PostPosted: Tue Dec 09, 2008 3:10 pm    Post subject: pykde4 version already defined (solved) Reply with quote

[solution]
Turns out the solution is to just not install pykde4. If you set "kde-base/plasma-workspace -python" in /etc/portage/package.use, then pykde4 is no longer a dependency when installing kde 4.2 (thanks much to Dont Panic for this bit of help).
[/solution]

Well, here's the tail end of my emerge output. Turns out it was completely useless, but I'm leaving it here in case other people come here looking for solutions, so that they can compare the tail end of their output to the tail end of mine (assuming they don't bother to scroll all the way back to 4% to see the errors).

Code:

[  9%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_kdecore
.dir/sip/kdecore/sipkdecorepart7.o
In file included from /usr/include/python2.5/Python.h:13,
                 from /usr/include/python2.5/sip.h:28,
                 from /var/tmp/portage/kde-base/pykde4-4.1.80/work/pykde4_build/
python/pykde4/sip/kdecore/sipAPIkdecore.h:11,
                 from /var/tmp/portage/kde-base/pykde4-4.1.80/work/pykde4_build/
python/pykde4/sip/kdecore/sipkdecorepart7.cpp:7:
/usr/include/python2.5/pyconfig.h:976:1: warning: "_XOPEN_SOURCE" redefined
<command-line>: warning: this is the location of the previous definition
/usr/kde/4.2/include/kconfiggroup.h:564: warning: ‘virtual const KConfigGroup KC
onfigGroup::groupImpl(const QByteArray&) const’ was hidden
sipkdecorepart7.cpp:4216: warning:   by ‘virtual KConfigGroup sipKConfigGroup::g
roupImpl(const QByteArray&)’
sipkdecorepart7.cpp: In function ‘PyObject* meth_KConfigGroup_changeGroup(PyObje
ct*, PyObject*)’:
sipkdecorepart7.cpp:4633: warning: ‘changeGroup’ is deprecated (declared at /usr
/kde/4.2/include/kconfiggroup.h:130)
sipkdecorepart7.cpp:4650: warning: ‘changeGroup’ is deprecated (declared at /usr
/kde/4.2/include/kconfiggroup.h:131)
/usr/kde/4.2/include/kconfig.h: At global scope:
/usr/kde/4.2/include/kconfig.h:255: warning: ‘virtual const KConfigGroup KConfig
::groupImpl(const QByteArray&) const’ was hidden
sipkdecorepart7.cpp:8076: warning:   by ‘virtual KConfigGroup sipKConfig::groupI
mpl(const QByteArray&)’
sipkdecorepart7.cpp: In function ‘PyObject* meth_KConfig_setForceGlobal(PyObject
*, PyObject*)’:
sipkdecorepart7.cpp:8717: warning: ‘setForceGlobal’ is deprecated (declared at /
usr/kde/4.2/include/kconfig.h:227)
sipkdecorepart7.cpp: In function ‘PyObject* meth_KConfig_forceGlobal(PyObject*,
PyObject*)’:
sipkdecorepart7.cpp:8745: warning: ‘forceGlobal’ is deprecated (declared at /usr
/kde/4.2/include/kconfig.h:234)
Linking CXX shared library ../../lib/pykde/kdecore.so
[  9%] Built target python_module_PyKDE4_kdecore
make: *** [all] Error 2
 *
 * ERROR: kde-base/pykde4-4.1.80 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3506:  Called kde4-meta_src_compile
 *             environment, line 2679:  Called kde4-meta_src_make
 *             environment, line 2772:  Called kde4-base_src_make
 *             environment, line 2410:  Called cmake-utils_src_make
 *             environment, line  889:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *  The die message:
 *   Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/lib/entropy/logs/kde-base:pykde4-4.1.80:20081209-145306.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/pykde4-4.1.80/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/layman/kde-crazy/'
 *


Last edited by valczir on Wed Dec 10, 2008 8:46 am; edited 3 times in total
Back to top
View user's profile Send private message
valczir
n00b
n00b


Joined: 23 Nov 2005
Posts: 35
Location: Minnesota

PostPosted: Wed Dec 10, 2008 7:30 am    Post subject: Reply with quote

*bump*

I updated the kde-crazy overlay and tried installing the 4.1.82 version of pykde4. It fails at a different percentage marker, but during the same sequence (compiling sip stuff):

[edit] That emerge output was useless, actually. [/edit]

I also tried doing an emerge -uD @kde, but it looks like the dependencies are all up to date. Or, if they weren't before, they are now. I'm about to try emerge -uND python pykde4, to see if use flags might be the problem. It looks like python was compiled without expat support, so I suppose that could be it.

Anyone have any ideas? Would more information help? Also, is there any type of tag that I can use to get a scroll bar for my emerge output and other stuff like that? I don't wanna make a mile long post, if I can help it.

[edit]
BWAHA! I found the error lines! I have no idea what they mean, nor do I understand why they were way back up at the beginning of the compile process, but they are errors!

Code:

[  4%] Built target compile_python_files
[  4%] Generating sip/kio/sipkiopart0.cpp, sip/kio/sipkiopart1.cpp, sip/kio/sipkiopart2.cpp, sip/kio/sipkiopart3.cpp, sip/kio/sipkiopart4.cpp, sip/kio/sipkiopart5.cpp, sip/kio/sipkiopart6.cpp, sip/kio/sipkiopart7.cpp                       
                                                                               
sip: /usr/share/sip/qt/versions.sip:34: Version is already defined             
make[2]: *** [python/pykde4/sip/dnssd/sipdnssdpart0.cpp] Error 1               
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_dnssd.dir/all] Error 2                                                                             
make[1]: *** Waiting for unfinished jobs....                                   
sip: /usr/share/sip/qt/versions.sip:34: Version is already defined             
make[2]: *** [python/pykde4/sip/kdeui/sipkdeuipart0.cpp] Error 1               
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_kdeui.dir/all] Error 2                                                                             
sip: /usr/share/sip/qt/versions.sip:34: Version is already defined             
make[2]: *** [python/pykde4/sip/khtml/sipkhtmlpart0.cpp] Error 1               
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_khtml.dir/all] Error 2                                                                             
sip: /usr/share/sip/qt/versions.sip:34: Version is already defined             
make[2]: *** [python/pykde4/sip/kio/sipkiopart0.cpp] Error 1                   
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_kio.dir/all] Error 2
Scanning dependencies of target python_module_PyKDE4_kdecore     


[/edit]
[edit again]
Alright, I found an answer on the russian gentoo site (translated for me by google). I ran equery b /usr/share/sip/qt/versions.sip and found that PyQt 3.17.4 was the culprit. I'm attempting to emerge pykde4 soon, here (just have to let entropy update its database of installed packages), and we'll see if that fixes it...

...

.......

Now it says it's unable to find qtmod.sip. However, the error I posted for is fixed. Attempting to rebuild PyQt4 to see if that brings back qtmod.sip.
[/edit]
[edit final]
I figured I'd post the qtmod.sip problems elsewhere, mostly just because I made a huge mess of things in this thread. Here's the link:
link to the thread for the qtmod.sip problems
[/edit
Back to top
View user's profile Send private message
deStilaDo
n00b
n00b


Joined: 26 Jan 2006
Posts: 20

PostPosted: Tue Jan 27, 2009 5:00 am    Post subject: Reply with quote

I don't think you should change the subject to solved, as this is not a solution, but a workarround, as the problem still exists.

A package that cannot be compiled is certainly a bug, even if it's a upstream bug, as in this case. IIt's was already fixed [1] [2]. As the fix appears to be just one line, I think should be easy to make a patch that permits package to compile. Any gentoo dev?

See:
[1] http://bugs.kde.org/show_bug.cgi?id=178354#c13
[2] http://websvn.kde.org/trunk/KDE/kdelibs/plasma/containment.h?r1=906246&r2=906245&pathrev=906246
Back to top
View user's profile Send private message
nielsd
n00b
n00b


Joined: 20 Aug 2009
Posts: 8
Location: Heilbad Heiligenstadt

PostPosted: Thu Aug 20, 2009 7:15 pm    Post subject: not solved Reply with quote

daer all,

i have the same problems with pykde4:4.3 while building kde-meta:4.3, since i switched to -kdeprefix. For this is unmerged all KDE 4.x packages as described in the Gentoo kde4 howto.

Superkaramba and plasma is -python. Then i tried -python globally, unmerging and reemerging PyQt and/or PyQt4 - even the tip from the russian Gentoo forum brought no solution for me.

If i have PyQt installed beside PyQt4 i get the version conflict error you described:
Code:
versions.sip:34 version already defined

- without PyQt (PyQt4 only) i get the not found error:
Code:
unable to find file: qt/qtmod.sip


i'm not very familiar with sip - otherwise i had tried to solve this byself in the sources / ebuilds. Im wondering if no other one then me has this problem too?

Any tip or solutions is welcome...

best regards,

Niels.
Back to top
View user's profile Send private message
drbergie
n00b
n00b


Joined: 22 Nov 2007
Posts: 34

PostPosted: Sun Jun 20, 2010 8:26 pm    Post subject: Reply with quote

Hi
I am still getting this problem. Did anyone find a solution to this?

my build log says
Code:
sip: /usr/share/sip/qt/versions.sip:34: Version is already defined

Lines 33 and 34 of my versions.sip follows:
Code:
// Specify the platforms.
%Platforms      {WS_X11 WS_WIN WS_QWS WS_MACX}


Unfortunately according to
Code:
equery b /usr/share/sip/qt/versions.sip


none owns it. (I saw someone has said that an old kde3.5 version of pyqt interfered with the new one.) Any one can help with perhaps rebuilding the sip version files?
Thanks

Code:

 emerge --info
Portage 2.1.8.3 (default/linux/x86/10.0/desktop, gcc-4.3.2, glibc-2.10.1-r1, 2.6.30-tuxonice-r4 i686)
=================================================================                                   
System uname: Linux-2.6.30-tuxonice-r4-i686-Intel-R-_Core-TM-2_Duo_CPU_E6550_@_2.33GHz-with-gentoo-1.12.13
Timestamp of tree: Sat, 19 Jun 2010 04:45:01 +0000                                                       
app-shells/bash:     4.0_p28                                                                             
dev-java/java-config: 2.1.9-r1                                                                           
dev-lang/python:     2.6.4-r1                                                                             
dev-util/cmake:      2.6.4-r3                                                                             
sys-apps/baselayout: 1.12.13                                                                             
sys-apps/sandbox:    1.6-r2                                                                               
sys-devel/autoconf:  2.13, 2.63-r1                                                                       
sys-devel/automake:  1.9.6-r2, 1.10.2                                                                     
sys-devel/binutils:  2.18-r3                                                                             
sys-devel/gcc:       4.4.3-r2                                                                             
sys-devel/gcc-config: 1.4.1                                                                               
sys-devel/libtool:   2.2.6b                                                                               
virtual/os-headers:  2.6.30-r1                                                                           
ACCEPT_KEYWORDS="x86"                                                                                     
ACCEPT_LICENSE="* -@EULA"                                                                                 
CBUILD="i686-pc-linux-gnu"                                                                               
CFLAGS="-Os -march=i686 -pipe"                                                                           
CHOST="i686-pc-linux-gnu"                                                                                 
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"                                                                                               
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"                                                                                 
CXXFLAGS="-Os -march=i686 -pipe"                                                                                     
DISTDIR="/usr/portage/distfiles"                                                                                     
FEATURES="assume-digests distlocks fixpackages metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"                                                                         
GENTOO_MIRRORS="http://gentoo.mirror.ac.za/"
LDFLAGS="-Wl,-O1"
LINGUAS="en af"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/desktop-effects /usr/portage/local/layman/jyujin"
SYNC="rsync://rsync.is.co.za/gentoo-portage/"
USE="X a52 aac acl acpi alsa arts berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gnome gpm gtk hal iconv ipv6 jpeg kde lame lcms ldap libnotify mad mikmod mmx mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly offensive ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3 qt3support qt4 readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype type1 unicode usb vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en af" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
drbergie
n00b
n00b


Joined: 22 Nov 2007
Posts: 34

PostPosted: Mon Jun 21, 2010 8:34 pm    Post subject: Reply with quote

Hallo again.
I think what is happening here, is that there are still files hanging around from a previous, broken dev-python/pykde package. But like I said, the pykde package is not installed on my system.
Code:
# emerge -s pykde
Searching...
[ Results for search key : pykde ]
[ Applications found : 1 ]

*  kde-base/pykde4
      Latest version available: 4.3.5-r1
      Latest version installed: [ Not Installed ]
      Size of files: 4,766 kB
      Homepage:      http://www.kde.org/
      Description:   Python bindings for KDE4
      License:       GPL-2

Anyone know how I can clean this mess up?

I have been trying to read the old pykde ebuilds at http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/kde-base/pykde/?hideattic=0 , but not getting far.

Also, have read at the new pykde4 ebuild http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/kde-base/pykde4/pykde4-4.3.3-r1.ebuild?view=markup that it has an explicit block with pykde.

Could this also be a sip problem?
Any help would be appreciated.
Back to top
View user's profile Send private message
drbergie
n00b
n00b


Joined: 22 Nov 2007
Posts: 34

PostPosted: Mon Jun 21, 2010 8:46 pm    Post subject: Reply with quote

This is strange:
I went to my build dir for pykde4, and ran make. It failed obviously. But then , I ran make again, and I noticed, the progress increased. So I ran make about 7 times, and now it seems to have compile happily. (it goes up to 100%, and it seems to have compiled everything.) Should I try: make install?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum