Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pykde4 qtmod.sip problems (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
valczir
n00b
n00b


Joined: 23 Nov 2005
Posts: 35
Location: Minnesota

PostPosted: Wed Dec 10, 2008 8:24 am    Post subject: pykde4 qtmod.sip problems (solved) Reply with quote

[solution]
Turns out the solution is to just not install pykde4. If you set "kde-base/plasma-workspace -python" in /etc/portage/package.use, then pykde4 is no longer a dependency when installing kde 4.2 (thanks much to Dont Panic for this bit of help).
[/solution]

So, I was having the "Version is already defined" error while emerging pykde4, earlier. I fixed that by unmerging PyQt 3.17.4. However, that created a new error - pykde4 started to complain that "qt/qtmod.sip" was missing.

I managed to figure out that I had a /usr/share/sip/Qt/Qtmod.sip, but no /usr/share/sip/qt/qtmod.sip. So I created the qt directory and linked /usr/share/sip/qt/qtmod.sip to /usr/share/sip/Qt/Qtmod.sip, and it partially worked, in that the file was loaded when trying to emerge pykde4.

However, these are the errors I'm getting now:

Code:

[  4%] Generating sip/kio/sipkiopart0.cpp, sip/kio/sipkiopart1.cpp, sip/kio/sipkiopart2.cpp, sip/kio/sipkiopart3.cpp, sip/kio/sipkiopart4.cpp, sip/kio/sipkiopart5.cpp, sip/kio/sipkiopart6.cpp, sip/kio/sipkiopart7.cpp

sip: /usr/share/sip/qt/qtmod.sip:1: A %CompositeModule cannot be %Imported
make[2]: *** [python/pykde4/sip/dnssd/sipdnssdpart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_dnssd.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
sip: /usr/share/sip/qt/qtmod.sip:1: A %CompositeModule cannot be %Imported
make[2]: *** [python/pykde4/sip/khtml/sipkhtmlpart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_khtml.dir/all] Error 2
sip: /usr/share/sip/qt/qtmod.sip:1: A %CompositeModule cannot be %Imported
make[2]: *** [python/pykde4/sip/kdeui/sipkdeuipart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_kdeui.dir/all] Error 2
sip: /usr/share/sip/qt/qtmod.sip:1: A %CompositeModule cannot be %Imported
make[2]: *** [python/pykde4/sip/kio/sipkiopart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_kio.dir/all] Error 2


I'm going to delete my link and directory, then try to emerge PyQt, again. Maybe it won't screw with the versions, this time.

Anyone have suggestions other than that?
Back to top
View user's profile Send private message
deStilaDo
n00b
n00b


Joined: 26 Jan 2006
Posts: 20

PostPosted: Tue Jan 27, 2009 4:59 am    Post subject: Reply with quote

I don't think you should change the subject to solved, as this is not a solution, but a workarround, as the problem still exists.

A package that cannot be compiled is certainly a bug, even if it's a upstream bug, as in this case. IIt's was already fixed [1] [2]. As the fix appears to be just one line, I think should be easy to make a patch that permits package to compile. Any gentoo dev?

See:
[1] http://bugs.kde.org/show_bug.cgi?id=178354#c13
[2] http://websvn.kde.org/trunk/KDE/kdelibs/plasma/containment.h?r1=906246&r2=906245&pathrev=906246
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum