Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Consolefont] problème d'encodage (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat Dec 13, 2008 6:13 am    Post subject: [Consolefont] problème d'encodage (résolu) Reply with quote

Bonjour, j'ai un petit soucis avec mon clavier et l'encodage français, je m'explique.
Dans les consoles tty je ne peux pas taper les lettres accentuées de mon clavier et si par hasard il y en a une dans un message système elle est traduite à l'écran par du charabia.
Le retour de la commande locale
Code:
# locale
LANG=fr_CH.UTF-8
LC_CTYPE="fr_CH.UTF-8"
LC_NUMERIC="fr_CH.UTF-8"
LC_TIME="fr_CH.UTF-8"
LC_COLLATE="fr_CH.UTF-8"
LC_MONETARY="fr_CH.UTF-8"
LC_MESSAGES="fr_CH.UTF-8"
LC_PAPER="fr_CH.UTF-8"
LC_NAME="fr_CH.UTF-8"
LC_ADDRESS="fr_CH.UTF-8"
LC_TELEPHONE="fr_CH.UTF-8"
LC_MEASUREMENT="fr_CH.UTF-8"
LC_IDENTIFICATION="fr_CH.UTF-8"
LC_ALL=fr_CH.UTF-8
et aussi le fichier consolefont
Code:
cat /etc/conf.d/consolefont
# consolefont specifies the default font that you'd like Linux to use on the
# console.  You can find a good selection of fonts in /usr/share/consolefonts;
# you shouldn't specify the trailing ".psf.gz", just the font name below.
# To use the default console font, comment out the CONSOLEFONT setting below.
# This setting is used by the /etc/init.d/consolefont script (NOTE: if you do
# not want to use it, run "rc-update del consolefont" as root).
consolefont="lat9w-10"

# consoletranslation is the charset map file to use.  Leave commented to use
# the default one.  Have a look in /usr/share/consoletrans for a selection of
# map files you can use.
consoletranslation="8859-1_to_uni"

# unicodemap is the unicode map file to use. Leave commented to use the
# default one. Have a look in /usr/share/unimaps for a selection of map files
# you can use.
#unicodemap="iso01"
Merci d'avance pour votre aide.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)


Last edited by titoucha on Mon Dec 15, 2008 3:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Mon Dec 15, 2008 7:54 am    Post subject: Reply with quote

Un up, personne n'a une petite idée ou un début de piste?
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1699
Location: 127.0.0.1

PostPosted: Mon Dec 15, 2008 8:38 am    Post subject: Reply with quote

Salut,

Quelle est ta keymap ?
Code:

$ grep ^keymap /etc/conf.d/keymaps
keymap="fr-latin9"

Je viens de faire l'expérience : même configuration que toi en consolefont, avec fr en keymap, aucun éàè etc... en console.
Avec fr-latin9, pas de problème.
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Mon Dec 15, 2008 9:22 am    Post subject: Reply with quote

Merci pour ta réponse, voici mon keymap.
Code:
grep KEYMAP /etc/conf.d/keymaps
KEYMAP="fr_CH"
EXTENDED_KEYMAPS=""
#EXTENDED_KEYMAPS="backspace keypad euro"
contrairement à toi j'ai un clavier suisse romand et pas français.

EDIT: je viens de changer le mapping en "fr_CH-latin1" et maintenant j'ai les lettres accentuées.
C'était la bonne solution, un grand merci.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Tony Clifton
l33t
l33t


Joined: 07 Jul 2004
Posts: 686
Location: Rennes

PostPosted: Sat Dec 20, 2008 11:46 am    Post subject: Reply with quote

Tu as essayé de remettre la consolefont à sa valeur par défaut (CONSOLEFONT="default8x16") et de désactiver la consoletranslation ?
Quand j'étais passé à l'utf8 je m'étais dis que ces options ne m'étaient plus utiles et visiblement ça ne marche pas trop mal (enfin suf pour le € et le ø et peut-être d'autre mais le principal marche)
_________________
La seule certitude que j'ai, c'est d'être dans le doute ! P. Desproges
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat Dec 20, 2008 2:29 pm    Post subject: Reply with quote

J'ai mis la configuration comme tu me le suggères et je vais tester.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Tony Clifton
l33t
l33t


Joined: 07 Jul 2004
Posts: 686
Location: Rennes

PostPosted: Sun Dec 21, 2008 10:21 am    Post subject: Reply with quote

Tony Clifton wrote:
Tu as essayé de remettre la consolefont à sa valeur par défaut (CONSOLEFONT="default8x16") et de désactiver la consoletranslation ?
Quand j'étais passé à l'utf8 je m'étais dis que ces options ne m'étaient plus utiles et visiblement ça ne marche pas trop mal (enfin suf pour le € et le ø et peut-être d'autre mais le principal marche)


Eh non, en fait ce n'est pas la bonne solution : je viens de faire un p'tit tour dans le keymap fr-latin9 et il est en iso8859-15. J'ai bien essayé de le convertir en utf8 (avec iconv et en modifiant la ligne charset du keymap) mais du coup il ne fonctionne pas :oops: .
_________________
La seule certitude que j'ai, c'est d'être dans le doute ! P. Desproges
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sun Dec 21, 2008 10:44 am    Post subject: Reply with quote

Et tu as trouvé où la définition du charset du keymap?
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Tony Clifton
l33t
l33t


Joined: 07 Jul 2004
Posts: 686
Location: Rennes

PostPosted: Sun Dec 21, 2008 11:07 am    Post subject: Reply with quote

Code:
$ zgrep charset /usr/share/keymaps/i386/azerty/fr-latin9.map.gz
charset "iso-8859-15"

_________________
La seule certitude que j'ai, c'est d'être dans le doute ! P. Desproges
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum