Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Song Vaio PCG-GRT170 - Working!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
somazero
n00b
n00b


Joined: 03 Jul 2002
Posts: 7
Location: Geilenkirchen, Germany

PostPosted: Sat Aug 02, 2003 9:54 am    Post subject: Song Vaio PCG-GRT170 - Working! Reply with quote

Greetings! I just thought I'd share my experience eith my new laptop and Gentoo.

1. In order to get sound to work and for the usb 2 modules to atleast load, I had to use kernel version 2.6.0-test2...other development kernels may work, but that's the first that I tried. Sound works very well, but since I don't have any usb 2 hardware - I can't confirm that it's functional.

2. Networking was a little unique as well. I had to patch (well, I just changed the actual file...I didn't patch it) orinoco_pci.c. Here's the patch file that I used to change the code in the file...

Code:


--- linux-2.4.20/drivers/net/wireless/orinoco_pci.c.orig        2003-05-21 11:40:59.000000000 -0400
+++ linux-2.4.20/drivers/net/wireless/orinoco_pci.c     2003-05-21 11:41:52.000000000 -0400
@@ -359,6 +359,7 @@
 }
 
 static struct pci_device_id orinoco_pci_pci_id_table[] __devinitdata = {
+       {0x1260, 0x3872, PCI_ANY_ID, PCI_ANY_ID,},
        {0x1260, 0x3873, PCI_ANY_ID, PCI_ANY_ID,},
        {0,},
 }



I didn't write the patch, and I don't remember the author. I apologize to whom ever it is! I found it after quite a while of google'ing

Basically, you just add that extra line to the struct and wireless works great! I did have to place orinoco_pci in the modules.autoload file though. The same with sis900, which get's ethernet going.

I haven't testing dvd burning yet...Not really a big thing right now...however, I will post my results/solutions when available.

Hope this is somewhat helpful...:D [/code]
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7692
Location: Pelotas, BR

PostPosted: Sat Aug 02, 2003 5:09 pm    Post subject: Reply with quote

Moved to Documentation, Tips & Tricks.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
somazero
n00b
n00b


Joined: 03 Jul 2002
Posts: 7
Location: Geilenkirchen, Germany

PostPosted: Sun Aug 03, 2003 11:44 am    Post subject: Reply with quote

Okay, I'm on crack... :D

I was messing around with some other kernels...2.4.22-pre10. I enabled ACPI and everything worked as it had in 2.6.0-test2.

Sound and usb2 work just as they had in the development kernel.

I seems that the ACPI was the key kernel option.

As for the wireless patch, that is still needed.

Steve
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum